Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • AtlonXP1800
  • Registratie: augustus 2001
  • Laatst online: 22-07 11:57
Onlangs heb ik mijn thuis netwerk flink op de schop genomen door alle hardware te vervangen door ubiqiti apparatuur. Een laatste hobbel die ik nog moet nemen is het vervangen van de Telfort experiabox v8 door de USG PRO 4, om het \[Ubiquiti-apparatuur] Ervaringen & Discussie - Deel 2 niet te veel te vervuilen start ik even dit aparte topic.

In mijn huidige situatie zit mijn hele netwerk op de 192.168.2.x range, dat wil ik ook graag zo houden. De Experiabox zit op 192.168.2.254 en fungeert momenteel nog als DHCP server. De lan poort van de USG zit al aangesloten op het netwerk en zit nu op ip 192.168.2.1 (Op aanraden van QempZoR, eerst zat hij op 60, midden in de DHCP range ;) ) en draait op firmware versie 4.4.22.5086057

Naast de usg heb ik ook een cloud key die zit op ip 192.168.2.47

@QempZoR had in het Ubiquiti-apparatuur topic al een config.gateway.json configuratie file gepost waarmee het mogelijk zou moeten zijn om de boel aan de praat te krijgen. Deze heb ik enigszins aangepast om te kunnen gebruiken met de USG pro, het verschil zou enkel moeten zitten in de eth poortnamen:

eth0 = LAN1
eth1 = LAN2
eth2 = WAN1
eth3 = WAN2

In mijn experiabox heb ik de MAC adressen opgezocht die volgens mij nodig zijn voor de configuratie:



Vervolgens zag mijn config.gateway.json er zo uit:
JSON:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
{
    "firewall": {
        "source-validation": "disable"
    },
    "interfaces": {
        "ethernet": {
            "eth2": {
                "description": "eth2 - FTTH",
                "duplex": "auto",
                "speed": "auto",
                "vif": {
                    "4": {
                        "mac": 4C-09-D4-98-F3-XX,
                        "address": [
                            "dhcp"
                        ],
                        "description": "eth2.4 - IPTV",
                        "dhcp-options": {
                            "client-option": [
                                "send vendor-class-identifier "IPTV_RG";",
                                "request subnet-mask, routers, rfc3442-classless-static-routes;"
                            ],
                            "default-route": "no-update",
                            "default-route-distance": "210",
                            "name-server": "update"
                        }
                    },
                    "34": {
                        "mac": 4C-09-D4-98-F3-XX,
                        "description": "eth2.34 - Internet",
                        "firewall": {
                            "in": {
                                "name": "WAN_IN"
                            },
                            "local": {
                                "name": "WAN_LOCAL"
                            },
                            "out": {
                                "name": "WAN_OUT"
                            }
                        },
                        "address": [
                            "dhcp"
                        ],
                        "dhcp-options": {
                            "default-route": "update",
                            "name-server": "update",
                            "default-route-distance": "1"
                        }
                    }
                }
            },
            "eth0": {
                "description": "eth0 - LAN",
                "address": [
                    "192.168.2.1/24"
                ],
                "duplex": "auto",
                "firewall": {
                    "in": {
                        "name": "LAN_IN"
                    },
                    "local": {
                        "name": "LAN_LOCAL"
                    },
                    "out": {
                        "name": "LAN_OUT"
                    }
                },
                "speed": "auto"
            },
            "eth4": {
                "disable": "''",
                "duplex": "auto",
                "speed": "auto"
            }
        },
        "loopback": {
            "lo": "''"
        }
    },
    "protocols": {
        "igmp-proxy": {
            "interface": {
                "eth2": {
                    "role": "disabled",
                    "threshold": "1"
                },
                "eth2.4": {
                    "alt-subnet": [
                        "0.0.0.0/0"
                    ],
                    "role": "upstream",
                    "threshold": "1"
                },
                "eth0": {
                    "role": "downstream",
                    "threshold": "1"
                }
            }
        },
        "static": {
            "interface-route": {
                "0.0.0.0/0": {
                    "next-hop-interface": {
                        "eth2.34": {
                            "distance": "1"
                        }
                    }
                }
            },
            "route": {
                "213.75.112.0/21": {
                    "next-hop": {
                        "10.88.36.1": "''"
                    }
                }
            }
        }
    },
    "port-forward": {
        "auto-firewall": "enable",
        "hairpin-nat": "enable",
        "lan-interface": [
            "eth0"
        ],
        "wan-interface": "eth2.34"
    },
    "service": {
        "nat": {
            "rule": {
                "5000": {
                    "description": "MASQ corporate_network to IPTV network",
                    "destination": {
                        "address": "213.75.112.0/21"
                    },
                    "log": "disable",
                    "outbound-interface": "eth2.4",
                    "protocol": "all",
                    "type": "masquerade"
                },
                "6001": {
                    "description": "MASQ corporate_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth2.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "corporate_network"
                        }
                    },
                    "type": "masquerade"
                },
                "6002": {
                    "description": "MASQ remote_user_vpn_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth2.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "remote_user_vpn_network"
                        }
                    },
                    "type": "masquerade"
                },
                "6003": {
                    "description": "MASQ guest_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth2.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "guest_network"
                        }
                    },
                    "type": "masquerade"
                }
            }
        }
    }
}


In de controller had ik al een WAN en een LAN:



In de lan heb ik vervolgens DHCP aangezet en de USG laten provisionen:



En toen de kabel van het glasvezelkastje naar de experiabox er uit gehaald en in de WAN1 poort van de USG gestopt. Vervolgens de Experiabox helemaal uitgezet zodat deze geen DHCP adressen meer kon verstrekken.

Het eerste wat mij opviel in de controller is dat er geen WAN adres verschijnt, ook is er niets terug te zien van de settings in de json file.



Vervolgens lijkt het er op dat er geen dhcp adressen worden verstrekt, en dan houd het natuurlijk al snel op.
Ongetwijfeld mis ik ergens een punt, ik moet zeggen dat mijn netwerk kennis niet enorm groot is. Iemand die mij de juiste kant op kan sturen?

Alle reacties


  • GrasshopperNL
  • Registratie: april 2013
  • Laatst online: 21:07
Moet je niet ergens een VLAN id opgeven in je wan interface? VLAN 6?
Ik weet dat dit wel moet bij bijvoorbeeld KPN glasvezel verbindingen.

  • HKLM_
  • Registratie: februari 2009
  • Laatst online: 22:09

HKLM_

www.cloud23.nl

Moet je de ETH namen niet goed zetten in " ETH0 description = "WAN"

cloud23.nl


  • bd-casemod
  • Registratie: januari 2005
  • Laatst online: 29-07 15:32
Glasvezel van telfort (kpn) is idd Tagged vlan6, daarop een PPP sessie laten opbouwen met fictieve gegevens

Was in de verwarring met xs4all |:(

[Voor 21% gewijzigd door bd-casemod op 17-08-2018 10:40]


  • Step
  • Registratie: januari 2004
  • Laatst online: 15:46

Step

step@tweakers.net#

bd-casemod schreef op donderdag 16 augustus 2018 @ 16:40:
Glasvezel van telfort (kpn) is idd Tagged vlan6, daarop een PPP sessie laten opbouwen met fictieve gegevens
Zelfde als KPN dus. Werkt inderdaad prima. :)

[Voor 4% gewijzigd door Step op 16-08-2018 17:29]

~Step @ Mac Mini 2011, MacBook Pro 2012 & PC (zie inventaris)


  • MisteRMeesteR
  • Registratie: december 2001
  • Nu online

MisteRMeesteR

Moderator Internet & Netwerken

Is Gek op... :)

bd-casemod schreef op donderdag 16 augustus 2018 @ 16:40:
Glasvezel van telfort (kpn) is idd Tagged vlan6, daarop een PPP sessie laten opbouwen met fictieve gegevens
:/ 8)7

Telfort werkt op VLAN34 en niet met PPPoE maar met IPoE (DHCP).

www.google.nl


  • AtlonXP1800
  • Registratie: augustus 2001
  • Laatst online: 22-07 11:57
MisteRMeesteR schreef op donderdag 16 augustus 2018 @ 18:43:
[...]

:/ 8)7

Telfort werkt op VLAN34 en niet met PPPoE maar met IPoE (DHCP).
Precies, 34 voor internet, 4 voor TV, en die zitten in de config file. DHCP staat ook aan op de WAN interface:


Ik kan ook Vlans met de hand aanmaken, maar ik kan daar verder bar weinig aan configureren:

  • bd-casemod
  • Registratie: januari 2005
  • Laatst online: 29-07 15:32
MisteRMeesteR schreef op donderdag 16 augustus 2018 @ 18:43:
[...]

:/ 8)7

Telfort werkt op VLAN34 en niet met PPPoE maar met IPoE (DHCP).
Je hebt helemaal gelijk, ik was even in de verwarring met xs4all.

  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
Werkt dit ook op " het nieuwe" glasvezel netwerk van Telfort (na migratie) ?

  • MisteRMeesteR
  • Registratie: december 2001
  • Nu online

MisteRMeesteR

Moderator Internet & Netwerken

Is Gek op... :)

killer2 schreef op vrijdag 27 september 2019 @ 10:39:
Werkt dit ook op " het nieuwe" glasvezel netwerk van Telfort (na migratie) ?
Ja.

Internet = VLAN34
IPTV = VLAN4.

Edit; Waar je bij Telfort even moet opletten is dat je DHCP requests voor beide services vanaf verschillende MAC adressen wordt gedaan. Als je op beide VLAN's met hetzelfde MAC adres een DHCP request doet vindt de BRAS van Telfort dat niet zo leuk en krijg je nooit beide in de lucht.

Been there :P :o

[Voor 40% gewijzigd door MisteRMeesteR op 27-09-2019 10:51]

www.google.nl


  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
ok thx!
bedoel je dit en dan stap 5 : ?
https://debeerict.nl/kenn...-met-ubiquity-apparatuur/

ps: werkt ook op een usg pro ?
MisteRMeesteR schreef op vrijdag 27 september 2019 @ 10:48:
[...]

Ja.

Internet = VLAN34
IPTV = VLAN4.

Edit; Waar je bij Telfort even moet opletten is dat je DHCP requests voor beide services vanaf verschillende MAC adressen wordt gedaan. Als je op beide VLAN's met hetzelfde MAC adres een DHCP request doet vindt de BRAS van Telfort dat niet zo leuk en krijg je nooit beide in de lucht.

Been there :P :o

  • MisteRMeesteR
  • Registratie: december 2001
  • Nu online

MisteRMeesteR

Moderator Internet & Netwerken

Is Gek op... :)

killer2 schreef op vrijdag 27 september 2019 @ 11:15:
ok thx!
bedoel je dit en dan stap 5 : ?
https://debeerict.nl/kenn...-met-ubiquity-apparatuur/

ps: werkt ook op een usg pro ?


[...]
Exact hetgeen ik bedoel.

Op een USG Pro werkt het ook, al moet je even opletten hoe de interfaces daar heten.

[Voor 12% gewijzigd door MisteRMeesteR op 27-09-2019 12:43]

www.google.nl


  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
Ok thx, heb jij toevallig een actuele json zonder " &quot genezuel ?

  • Gman
  • Registratie: januari 2000
  • Laatst online: 19:40
Ah het topic is alive.
Mooi want ik ben hetzelfde aan het doen maar ik krijg het next hop adres voor de iptv maar niet te pakken.
Ik ben met SSH ingelogd op de USG, ben root, en voer het volgende uit:
3 Bepaal het next-hop adres voor IPTV

Log in op de USG (als admin) via een terminal en voer het volgende commando uit:

cat /config/config.boot | grep 213.75.112.0/21 -A1 | grep next-hop | awk ‘{ print $2}’

Resultaat is het next-hop IP adres wat je later nodig hebt (voorbeeld: 10.240.34.1)
Bron Tutorial

Maar no comprende, er gebeurt helemaal niets.
Nog eens helemaal overgetyped, want ik zie dat paste niet goed gaat maar helaas krijg ik dit:
root@USG:~# cat /config/config.boot | grep 213.75.112.0/21 -A1 | grep next-hop | awk`{print $2}`
bash: {print: command not found
Commando niet goed, maar ik moet helaas afhaken, hier komt mijn linux kennis te kort.
Wie weet hoe ik dat achterhaal?

[Voor 15% gewijzigd door Gman op 27-09-2019 20:19]


  • Jeroen_ae92
  • Registratie: april 2012
  • Laatst online: 05-08 16:15
Zoiets?
code:
1
cat /var/run/dhclient_eth0.4_lease | grep new_routers | grep -E -o "([0-9]{1,3}[\.]){3}[0-9]{1,3}" | awk '{ print }'

[Voor 3% gewijzigd door Jeroen_ae92 op 27-09-2019 20:21]

U+


  • Gman
  • Registratie: januari 2000
  • Laatst online: 19:40
Ik zie het al, vlan 4 is nog niet aangemaakt, maar daar wordt ook nog aan gewerkt in de tutorial dus ik ben ff de weg kwijt :?
wordt vervolgd.

iig bedankt @Jeroen_ae92 dat was al een stap vooruit.

[Voor 18% gewijzigd door Gman op 27-09-2019 20:28]


  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
ah je bedoeld aanmaken via de controller .... check ik kon hem ook al niet vinden.

Netwerk new VLAN only VLAN 4 ?
Gman schreef op vrijdag 27 september 2019 @ 20:26:
Ik zie het al, vlan 4 is nog niet aangemaakt, maar daar wordt ook nog aan gewerkt in de tutorial dus ik ben ff de weg kwijt :?
wordt vervolgd.

iig bedankt @Jeroen_ae92 dat was al een stap vooruit.

  • Gman
  • Registratie: januari 2000
  • Laatst online: 19:40
Ja "only vlan" (andere optie had ik niet eens).

Ik ben door drukte thuis helaas niet verder gegaan.
Internet wel werkend gekregen maar IPTV nog niet kunnen opzetten.

[Voor 24% gewijzigd door Gman op 07-10-2019 13:10]


  • Bartjuh!
  • Registratie: maart 2009
  • Laatst online: 20-05 22:31
Ik ben op dit moment ook met hetzelfde bezig en wellicht dat iemand mij hier verder mee kan helpen.

Met opstelling is NT kastje > USG > tp link tl-sg1024d managed switch > access points, tv's, etc (poorten 2 - 17). En stb (poorten 18 - 24).

Instellingen USG:
WAN met vlan 34 (internet werkt)
LAN 192.168.1.0/24
VLAN only (vlan 4) igmp snooping aan. --> Echter staat in de UI dat dit alleen mogelijk is met een Ubiquiti switch? Is dat zo écht zo of is dit marketing en kan elke managed switch dit aan?

Instellingen switch
Enkel iets ingesteld voor poorten 18 - 24 (vlan 4 (tagged))

Echter krijg ik geen beeld, maar foutmelding 561 (verkeerd ip adres).

Ook als ik het eerder genoemde comando ingeeft om next-hop adres te achterhalen krijg ik geen respons. Iemand een idee? Mijn aanname is dat ik in ieder geval respons moet krijgen voordat ik met de json aan de slag moet? Of moet dit eerst?

  • Gman
  • Registratie: januari 2000
  • Laatst online: 19:40
Nou die igmp snooping kan op veel apparaten dus dat is wel een tikje marketing.

Verder heb ik dus hetzelfde probleem.

Tussen USG en je TP Link heb je een werkende trunk link? (dus meerdere vlan's over 1 kabel).

  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
Hi momenteel heb ik het werkend, TV + Internet VLAN 4 hoef je niet aan te maken op de USG.
IGMP staat uit :)


Tevens staat er een nieuw voorbeeld (json config_ op de site plus oplossing voor de next hop.

[Voor 31% gewijzigd door killer2 op 11-10-2019 16:06]


  • Gman
  • Registratie: januari 2000
  • Laatst online: 19:40
ok nice.
Maar waar is "de site" ? https://debeerict.nl/ ?

  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
https://debeerict.nl/kenn...-met-ubiquity-apparatuur/

Ik heb de boel weer terug moeten zetten, IPTV werd instabiel, freeze na ca 3 seconden bij ieder kanaal...
herstarten USG hielp niet echt.. Iemand suggesties? IMGP snooping ding? alleen maar unifi producten nodig ?

  • Gman
  • Registratie: januari 2000
  • Laatst online: 19:40
Thanks.
Ik denk dat je echt IMGP snooping aan moet hebben, dat staat in alle handleidingen.

  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
Behalve in die van de beer ict dus...
Gman schreef op dinsdag 15 oktober 2019 @ 11:55:
Thanks.
Ik denk dat je echt IMGP snooping aan moet hebben, dat staat in alle handleidingen.

  • Bartjuh!
  • Registratie: maart 2009
  • Laatst online: 20-05 22:31
Hi @killer2 kun je vertellen hoe je het 'next-hop' adres achterhaald heb? Ik heb inmiddels geprobeerd het voorgestelde config.gateway.json van beer ict toe te voegen (met aangepaste mac adressen) wat resulteert in werkend internet, maar nog steeds geen iptv nog steeds een verkeerd ip-adres. Als ik het next-hop adres opzoek na het plaatsen van het config.gateway bestand, dan krijg het het adres dat hierin is opgegeven (dus waarschijnlijk niet mijn next-hop adres).

Ik heb het macadres van mijn experiabox ingegeven en bij iptv daar het laatste nummer van veranderd (van 9 naar 0), maar nog steeds geen succes.

Iemand een idee?

  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
voor de next hop gebruik je eerst het vorobeeld ip zoals in de config, daarna de usg provision + herstart, dan command voor next hop, en dan krijg je volgens mij de werkelijke ip :

" JSON bestand aanmaken met tijdelijk next-hop IP adres (10.240.34.1) – USG herstarten – via USG next-hop IP adres bepalen en juiste IP adres wijzigen in JSON configuratie – USG en decoder herstarten – klaar: "

  • Bartjuh!
  • Registratie: maart 2009
  • Laatst online: 20-05 22:31
Ja dat dacht ik dus ook, echter krijg ik dan het 10.240.34.1 adres terug en heb geen iptv.. Vanavond nog maar eens een poging wagen.

UPDATE:
Ik heb het werkend gekregen. Ik heb het next-hop adres vastgesteld door het commando: show dhcp client leases interface eth0.4 Het adres dat bij router staat is dan het next-hop adres.

IGMP snooping moet inderdaad aanstaan. Hopelijk blijft het werken.

[Voor 53% gewijzigd door Bartjuh! op 05-11-2019 22:37]


  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
top nu bijna 2 weken later, werkt het nog ?
Bartjuh! schreef op vrijdag 1 november 2019 @ 15:11:
Ja dat dacht ik dus ook, echter krijg ik dan het 10.240.34.1 adres terug en heb geen iptv.. Vanavond nog maar eens een poging wagen.

UPDATE:
Ik heb het werkend gekregen. Ik heb het next-hop adres vastgesteld door het commando: show dhcp client leases interface eth0.4 Het adres dat bij router staat is dan het next-hop adres.

IGMP snooping moet inderdaad aanstaan. Hopelijk blijft het werken.

  • Bartjuh!
  • Registratie: maart 2009
  • Laatst online: 20-05 22:31
Ja het werkt hier nog steeds goed. Één keer gehad dat het beeld 'bevroor' na 3 seconde (dit was nadat alles opnieuw was opgestart na een korte stroomuitval). Toen heb ik de igmp-proxy moeten restarten (restart igmp-proxy) en sindsdien (nu ruim een week) nergens meer last van gehad. De experiabox is inmiddels naar de zolder in een doos.. :P En waarschijnlijk blijft hij daar... 8)

  • killer2
  • Registratie: september 2002
  • Laatst online: 01-08 20:02
Wow dat fijn!

Zie je kans je hele json config eens te sturen ?

ps: usg pro toch of de 3 P ?
gr Lars
Bartjuh! schreef op woensdag 13 november 2019 @ 21:28:
Ja het werkt hier nog steeds goed. Één keer gehad dat het beeld 'bevroor' na 3 seconde (dit was nadat alles opnieuw was opgestart na een korte stroomuitval). Toen heb ik de igmp-proxy moeten restarten (restart igmp-proxy) en sindsdien (nu ruim een week) nergens meer last van gehad. De experiabox is inmiddels naar de zolder in een doos.. :P En waarschijnlijk blijft hij daar... 8)

  • Bartjuh!
  • Registratie: maart 2009
  • Laatst online: 20-05 22:31
Nee niet de pro, de 3p heb ik. Daarom heb ik 'gewoon' de json van de site op de beer ICT gebruikt en daar de mac adressen en next hop adres in veranderd.

Wat ik daar wel in gemerkt heb is dat bij sommige andere topics het eerste regeltje over source validation ter discussie wordt gesteld. Echter toen ik deze regel weghaalde werkte mijn IPTV niet. Ik heb het daarna er weer terug in gezet en toen werkte het weer wel. Misschien dat dat je helpt?

  • vanputten80
  • Registratie: september 2008
  • Laatst online: 19:37
Dank voor dit topic. Het is mij gelukt om Telfort Tv en internet werkende te krijgen op mijn Unifi netwerk.


https://debeerict.nl/kenn...-met-ubiquity-apparatuur/

  • ptjuh
  • Registratie: november 2005
  • Laatst online: 16:33

ptjuh

New day, same old shit

iemand misschien een idee ?

ik heb alles gevolgd van de beer ict website, maar krijg na alle instellingen een error 561.

Hieronder mijn Json file :
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
{
    "firewall": {
        "source-validation": "disable"
    },
    "interfaces": {
        "ethernet": {
            "eth0": {
                "description": "eth0 - WAN",
                "duplex": "auto",
                "speed": "auto",
                "vif": {
                    "4": {
                        "mac": "4C:09:D4:C9:F3:XX",
                        "address": [
                            "dhcp"
                        ],
                        "description": "eth0.4 - IPTV",
                        "dhcp-options": {
                            "client-option": [
                                "send vendor-class-identifier "IPTV_RG";"
                            ],
                            "default-route": "no-update",
                            "default-route-distance": "210",
                            "name-server": "update"
                        }
                    },
                    "34": {
                        "mac": "4C:09:D4:C9:F3:XX",
                        "description": "eth0.34 - Internet",
                        "firewall": {
                            "in": {
                                "name": "WAN_IN"
                            },
                            "local": {
                                "name": "WAN_LOCAL"
                            },
                            "out": {
                                "name": "WAN_OUT"
                            }
                        },
                        "address": [
                            "dhcp"
                        ],
                        "dhcp-options": {
                            "default-route": "update",
                            "name-server": "update",
                            "default-route-distance": "1"
                        }
                    }
                }
            },
            "eth1": {
                "description": "eth1 - LAN",
                "address": [
                    "192.168.1.1/24"
                ],
                "duplex": "auto",
                "firewall": {
                    "in": {
                        "name": "LAN_IN"
                    },
                    "local": {
                        "name": "LAN_LOCAL"
                    },
                    "out": {
                        "name": "LAN_OUT"
                    }
                },
                "speed": "auto"
            },
            "eth2": {
                "disable": "''",
                "duplex": "auto",
                "speed": "auto"
            }
        },
        "loopback": {
            "lo": "''"
        }
    },
    "protocols": {
        "igmp-proxy": {
            "interface": {
                "eth0": {
                    "role": "disabled",
                    "threshold": "1"
                },
                "eth0.4": {
                    "alt-subnet": [
                        "0.0.0.0/0"
                    ],
                    "role": "upstream",
                    "threshold": "1"
                },
                "eth1": {
                    "alt-subnet": [
                        "0.0.0.0/0"
                    ],
                    "role": "downstream",
                    "threshold": "1"
                }
            }
        },
        "static": {
            "interface-route": {
                "0.0.0.0/0": {
                    "next-hop-interface": {
                        "eth0.34": {
                            "distance": "1"
                        }
                    }
                }
            },
            "route": {
                "213.75.112.0/21": {
                    "next-hop": {
                        "145.129.247.1": "''"
                    }
                }
            }
        }
    },
    "port-forward": {
        "auto-firewall": "enable",
        "hairpin-nat": "enable",
        "lan-interface": [
            "eth1"
        ],
        "wan-interface": "eth0.34"
    },
    "service": {
        "nat": {
            "rule": {
                "5000": {
                    "description": "MASQ corporate_network to IPTV network",
                    "destination": {
                        "address": "213.75.112.0/21"
                    },
                    "log": "disable",
                    "outbound-interface": "eth0.4",
                    "protocol": "all",
                    "type": "masquerade"
                },
                "6001": {
                    "description": "MASQ corporate_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth0.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "corporate_network"
                        }
                    },
                    "type": "masquerade"
                },
                "6002": {
                    "description": "MASQ remote_user_vpn_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth0.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "remote_user_vpn_network"
                        }
                    },
                    "type": "masquerade"
                },
                "6003": {
                    "description": "MASQ guest_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth0.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "guest_network"
                        }
                    },
                    "type": "masquerade"
                }
            }
        }
    }
}


Tevens krijg ik geen next hop adres te zien bij het commando:
cat /config/config.boot | grep 213.75.112.0/21 -A1 | grep next-hop | awk ‘{ print $2}’

of bij deze
admin@ubnt:~$ show dhcp client leases eth0.4
Invalid command

wel het router adres bij deze. maar daar stond bij eth0.34
admin@ubnt:~$ show dhcp client leases

Iemand misschien een idee? of tip?

[Voor 0% gewijzigd door MisteRMeesteR op 28-04-2020 00:14. Reden: Code tags geplaatst.]

Its all in the little things that people do..


  • ptjuh
  • Registratie: november 2005
  • Laatst online: 16:33

ptjuh

New day, same old shit

Kickje,

Niemand een idee?
Heb alles op telfort en ben in contact met die kerel van beet ict...

Its all in the little things that people do..


  • Mitt3nz
  • Registratie: maart 2002
  • Laatst online: 23-07 08:40
@ptjuh ik had hetzelfde probleem met de next-hop. Heb toen eerst next-hop 10.240.34.1 gebruikt (die dus standaard in de json staat), daarna de USG geprovisioned en gereboot, en daarna de correcte next-hop bepaald en ingevuld met het volgende commando: show dhcp client leases interface eth0.4. Het juiste next-hop IP staat dan na router vermeldt. Vervolgens weer geprovisioned en gereboot.

[Voor 7% gewijzigd door Mitt3nz op 27-04-2020 21:37]


  • ik222
  • Registratie: maart 2007
  • Niet online
ptjuh schreef op maandag 27 april 2020 @ 14:54:
Kickje,

Niemand een idee?
Heb alles op telfort en ben in contact met die kerel van beet ict...
Dat 145.x.x.x adres is in elk geval niet de correcte nexthop voor de /21 IPTV route, dat moet een 10.x.x.x adres zijn. Dus dat verklaart je probleem.

Je moet het correcte gateway adres op je ITV interface vinden en daar invullen.

Acties:
  • 0Henk 'm!

  • ptjuh
  • Registratie: november 2005
  • Laatst online: 16:33

ptjuh

New day, same old shit

@Mitt3nz dank je wel..

dit werkte inderdaad! ik heb wel geteld uur TV kunnen kijken. Hierna was mijn decoder de weg kwijt.
Ik denk dat de TvRoute nogmaals moet uitvoeren na het opnieuw vervangen van de json file.

Ik heb nog wel wat instellingen te gaan ook om mijn IPtelefoon aan de gang te krijgen!

Its all in the little things that people do..


Acties:
  • 0Henk 'm!

  • Mitt3nz
  • Registratie: maart 2002
  • Laatst online: 23-07 08:40
ptjuh schreef op maandag 4 mei 2020 @ 15:27:
@Mitt3nz dank je wel..

dit werkte inderdaad! ik heb wel geteld uur TV kunnen kijken. Hierna was mijn decoder de weg kwijt.
Ik denk dat de TvRoute nogmaals moet uitvoeren na het opnieuw vervangen van de json file.

Ik heb nog wel wat instellingen te gaan ook om mijn IPtelefoon aan de gang te krijgen!
Je kunt daarvoor het script gebruiken van De Beer ICT: https://debeerict.nl/wp-c...s/2019/01/tvroute.sh_.txt. Ik heb de task schedulur config toegevoegd aan de gateway.config.json, en nu wordt dat ook automatisch uitgevoerd na iedere provisie.

Acties:
  • 0Henk 'm!

  • ptjuh
  • Registratie: november 2005
  • Laatst online: 16:33

ptjuh

New day, same old shit

@Mitt3nz

zou je dat stukje config is willen delen?

Ik heb sinds gisteren het probleem dat me usg keer uit is gevallen en gelijk hapert me tv :(.
Het is niet dat ik een foutmelding krijg op de digitale kast. Maar dat ik iedere keer een melding krijg dat ik naar een andere zend moet zappen of de digitale kast moet herstarten.

of dat het beeld hapert en blijft hangen.Nog vager is dat NPO1 het wel goed doet de andere zenders alleen niet. on-demand werkt wel normaal

iemand ideen?

[Voor 54% gewijzigd door ptjuh op 24-05-2020 08:39]

Its all in the little things that people do..


Acties:
  • 0Henk 'm!

  • daenny
  • Registratie: augustus 2013
  • Laatst online: 28-07 00:41
Ik heb sinds vandaag ook eindelijk routed IPTV met telfort :) . De IPTV receiver zit in eigen VLAN zodat er minder overlap met de 'gewone' traffic is.
Helaas met:
code:
1
2
3
"firewall": {
        "source-validation": "disable"
    },


Heeft iemand IPTV zonder de `source-validation: disable` voor elkaar gekregen? Bij KPN lijkt dat te werken.

@ptjuh : Hieronder het stukje voor de scheduler:
code:
1
2
3
4
5
6
7
8
9
10
11
12
    "system": {
        "task-scheduler": {
            "task": {
                "iptv": {
                    "executable": {
                        "path": "/config/scripts/post-config.d/tvroute.sh"
                    },
                    "interval": "15m"
                }
            }
        }
    },


Voor de geinteresserden, mijn volledige config:
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
{
    "firewall": {
        "source-validation": "disable"
    },
    "interfaces": {
        "ethernet": {
            "eth0": {
                "description": "eth0 - WAN",
                "duplex": "auto",
                "speed": "auto",
                "vif": {
                    "4": {
                        "mac": "BC:30:D9:1E:XXXX",
                        "address": [
                            "dhcp"
                        ],
                        "description": "eth0.4 - IPTV",
                        "dhcp-options": {
                            "client-option": [
                                "send vendor-class-identifier "IPTV_RG";",
                                "request subnet-mask, routers, rfc3442-classless-static-routes;"
                            ],
                            "default-route": "no-update",
                            "default-route-distance": "210",
                            "name-server": "update"
                        },
                        "ip": {
                            "source-validation": "loose"
                        }
                    },
                    "34": {
                        "mac": "BC:30:D9:1E:XXXX",
                        "description": "eth0.34 - Internet",
                        "firewall": {
                            "in": {
                                "name": "WAN_IN"
                            },
                            "local": {
                                "name": "WAN_LOCAL"
                            },
                            "out": {
                                "name": "WAN_OUT"
                            }
                        },
                        "address": [
                            "dhcp"
                        ],
                        "dhcp-options": {
                            "default-route": "update",
                            "name-server": "update",
                            "default-route-distance": "1"
                        }
                    }
                }
            },
            "eth1": {
                "description": "eth1 - LAN",
                "address": [
                    "192.168.2.1/24"
                ],
                "duplex": "auto",
                "firewall": {
                    "in": {
                        "name": "LAN_IN"
                    },
                    "local": {
                        "name": "LAN_LOCAL"
                    },
                    "out": {
                        "name": "LAN_OUT"
                    }
                },
                "speed": "auto"
            },
            "eth2": {
                "disable": "''",
                "duplex": "auto",
                "speed": "auto"
            }
    },
        "loopback": {
        "lo": "''"
        }
    },
    "protocols": {
        "igmp-proxy": {
        "disable-quickleave": "''",
            "interface": {
                "eth0": {
                    "role": "disabled",
                    "threshold": "1"
                },
                "eth0.4": {
                    "alt-subnet": [
                        "0.0.0.0/0"
                    ],
                    "role": "upstream",
                    "threshold": "1"
                },
        "eth0.34": {
                    "role": "disabled",
                    "threshold": "1"
                },
        "eth1.40": {
                    "alt-subnet": [
                        "0.0.0.0/0"
                    ],
                    "role": "downstream",
                    "threshold": "1"
                },

                "eth1": {
                    "role": "disabled",
                    "threshold": "1"
                }
            }
        },
        "static": {
        "arp": {
                "192.168.2.254": {
                    "hwaddr": "ff:ff:ff:ff:ff:ff"
                }
             },
            "interface-route": {
                "0.0.0.0/0": {
                    "next-hop-interface": {
                        "eth0.34": {
                            "distance": "1"
                        }
                    }
                }
            },
            "route": {
                "213.75.112.0/21": {
                    "next-hop": {
                        "10.214.180.1": "''"
                    }
                }
            }
        }
    },
    "port-forward": {
        "auto-firewall": "enable",
        "hairpin-nat": "enable",
        "lan-interface": [
            "eth1"
        ],
        "wan-interface": "eth0.34"
    },
    "system": {
        "task-scheduler": {
            "task": {
                "iptv": {
                    "executable": {
                        "path": "/config/scripts/post-config.d/tvroute.sh"
                    },
                    "interval": "15m"
                }
            }
        }
    },
    "service": {
        "nat": {
            "rule": {
                "5000": {
                    "description": "MASQ corporate_network to IPTV network",
                    "destination": {
                        "address": "213.75.112.0/21"
                    },
                    "log": "disable",
                    "outbound-interface": "eth0.4",
                    "protocol": "all",
                    "type": "masquerade"
                },
        "5001": {
                    "description": "MASQ corporate_network to IPTV network",
                    "destination": {
                        "address": "10.16.0.0/16"
                    },
                    "log": "disable",
                    "outbound-interface": "eth0.4",
                    "protocol": "all",
                    "type": "masquerade"
                },

                "6001": {
                    "description": "MASQ corporate_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth0.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "corporate_network"
                        }
                    },
                    "type": "masquerade"
                },
                "6002": {
                    "description": "MASQ remote_user_vpn_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth0.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "remote_user_vpn_network"
                        }
                    },
                    "type": "masquerade"
                },
                "6003": {
                    "description": "MASQ guest_network to WAN",
                    "log": "disable",
                    "outbound-interface": "eth0.34",
                    "protocol": "all",
                    "source": {
                        "group": {
                            "network-group": "guest_network"
                        }
                    },
                    "type": "masquerade"
                }
            }
        }
    }
}


Verder heb ik een Unifi Switch 8 PoE direct aan de USG3 en nog een Netgear Managed Switch, waar ik het IPTV VLAN en gewone VLAN via een enkele kabel naar de woonkamer stuur en daar weer split.

Acties:
  • 0Henk 'm!

  • ptjuh
  • Registratie: november 2005
  • Laatst online: 16:33

ptjuh

New day, same old shit

@daenny ; dank je voor de code!!


probleem wat ik beschreef: Opgelost. Schijnbaar nadat mijn USG3 is uitgevallen had ik een nieuwe nexthop adres moeten opzoeken. Opnieuw in de json geladen en it works like a charm

Its all in the little things that people do..


Acties:
  • 0Henk 'm!

  • The Killer36
  • Registratie: december 2014
  • Laatst online: 04-08 10:38
Sinds 2 weken ben ik in het bezig van de USG (3P). De USG heeft mijn Telfort Experiabox v8 ondertussen vervangen. :) Dit ging totaal niet zonder slag of stoot. Omdat ik hier issues voorbij zie komen die ik ondertussen getackeld heb hoop ik, met mijn (1e *O*) reactie op het Tweakers forum, wat verduidelijking te geven.

Wat ik tot nu toe werkend heb: Internet & TV. Telefonie neem ik ook af, echter hier nog niet verder naar gekeken(hiervoor zal de Experiabox er weer tussen moeten om dat ik geen VOIP telefoons heb.. :( )

@daenny Bij mij werkt de setup zonder:

code:
1
2
3
"firewall": {
        "source-validation": "disable"
    },


Toen kon ik opnames terugkijken maar live-tv deed het telkens voor 2 seconden en daarna moest ik van zender wisselen(werd aangegeven). Eigenlijk precies de situatie die @ptjuh omschreef. Na een beste tijd debuggen kwam ik erachter dat het te maken had met de "source-validation". Deze heb ik toegevoegd aan vlan 4, echter niet met de optie 'disable' maar met 'loose':

code:
1
2
3
"ip": {
              "source-validation": "loose"
            }


Verder heb ik op het LAN IGMP Snooping aan gezet. Daarna werkte alles naar behoren. :*)

@ptjuh Ik zag je opmerking dat je geen 'next-hop' adres te zien kreeg met dit commando:
cat /config/config.boot | grep 213.75.112.0/21 -A1 | grep next-hop | awk ‘{ print $2}’
Dit houdt in dat je nog geen next-hop adres hebt geset in je config. Het next-hop adres kun je in je dhcp leases vinden. Dat kan door te kijken bij 'eth0.4' als je het volgende typt:
show dhcp client leases
of als je een specifieke interface wil zien gebruik je:
show dhcp client leases interface eth0.4
Ter verduidelijking; het 'config.gateway.json' bestand zijn toevoegen/aanpassingen aan het uiteindelijke config bestand van de USG. Mocht je het resultaat willen zien van je geprovisioned USG, log dan in op de USG via ssh. Word vervolgens super user door het volgende te typen:
sudo su
en type vervolgens dit om het totale config bestand te tonen:
cat /config/config.boot
Wat ik misschien nog moet toevoegen is het automatisch updaten(scheduler) van het next-hop adres. Ben nog niet zeker of dit nodig is, heb nog geen ander adres gekregen. Wat ik wel opmerkte is dat het script van Bas Meerman(https://github.com/basmee...ster/update_iptv_route.sh) constant je static route verwijderd en opnieuw aanmaakt. Mijn gevoel zegt dat het niet wenselijk is dat dit telkens verwijderd en toegevoegd word. Het script van www.debeerict.nl(https://debeerict.nl/wp-c...s/2019/01/tvroute.sh_.txt) ziet er dan beter uit. Deze update alleen de static route wanneer deze daadwerkelijk gewijzigd is.

In mijn config.gateway.json heb ik onderdelen weggelaten. Voorbeeld hiervan zijn:

code:
1
2
3
"loopback": {
            "lo": "''"
        }
(dit staat in veel andere configs na 'ethernet')

code:
1
2
3
4
5
"eth2": {
                "disable": "''",
                "duplex": "auto",
                "speed": "auto"
            }
(dit staat in veel andere configs achterin in 'ethernet')

De reden hiervoor is dat de USG dit zelf aanvult omdat dit blijkbaar ergens in de basis config staat(?!). Waar die precies staat heb ik nog niet gevonden.

Mocht iemand er baat bij hebben, dit is de config die ik op dit moment gebruik (dus zonder scheduler!!!!) en werkt naar behoren (MAC adressen & next-hop wel even invullen):

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
{
  "interfaces": {
    "ethernet": {
      "eth0": {
        "description": "eth0 - WAN",
        "duplex": "auto",
        "speed": "auto",
        "vif": {
          "4": {
            "mac": "XX:XX:XX:XX:XX:XX",
            "description": "eth0.4 - IPTV",
            "address": [
              "dhcp"
            ],
            "dhcp-options": {
              "client-option": [
                "send vendor-class-identifier "IPTV_RG";",
                "request subnet-mask, routers, rfc3442-classless-static-routes;"
              ],
              "default-route": "no-update",
              "default-route-distance": "210",
              "name-server": "update"
            },
            "ip": {
              "source-validation": "loose"
            }
          },
          "34": {
            "mac": "XX:XX:XX:XX:XX:XX",
            "description": "eth0.34 - Internet",
            "address": [
              "dhcp"
            ],
            "dhcp-options": {
              "default-route": "update",
              "name-server": "update",
              "default-route-distance": "1"
            }
          }
        }
      },
      "eth1": {
        "description": "eth1 - LAN",
        "address": [
          "192.168.2.254/24"
        ]
      }
    }
  },
  "protocols": {
    "igmp-proxy": {
      "disable-quickleave": "''",
      "interface": {
        "eth0": {
          "role": "disabled",
          "threshold": "1"
        },
        "eth0.4": {
          "alt-subnet": [
            "0.0.0.0/0"
          ],
          "role": "upstream",
          "threshold": "1"
        },
        "eth0.34": {
          "role": "disabled",
          "threshold": "1"
        },
        "eth1": {
          "alt-subnet": [
            "0.0.0.0/0"
          ],
          "role": "downstream",
          "threshold": "1"
        }
      }
    },
    "static": {
      "interface-route": {
        "0.0.0.0/0": {
          "next-hop-interface": {
            "eth0.34": {
              "distance": "1"
            }
          }
        }
      },
      "route": {
        "213.75.112.0/21": {
          "next-hop": {
            "XX.XX.XX.X": "''"
          }
        }
      }
    }
  },
  "service": {
    "nat": {
      "rule": {
        "5000": {
          "description": "MASQ corporate_network to IPTV network",
          "destination": {
            "address": "213.75.112.0/21"
          },
          "log": "disable",
          "outbound-interface": "eth0.4",
          "protocol": "all",
          "type": "masquerade"
        },
        "6001": {
          "description": "MASQ corporate_network to WAN",
          "log": "disable",
          "outbound-interface": "eth0.34",
          "protocol": "all",
          "source": {
            "group": {
              "network-group": "corporate_network"
            }
          },
          "type": "masquerade"
        },
        "6002": {
          "description": "MASQ remote_user_vpn_network to WAN",
          "log": "disable",
          "outbound-interface": "eth0.34",
          "protocol": "all",
          "source": {
            "group": {
              "network-group": "remote_user_vpn_network"
            }
          },
          "type": "masquerade"
        },
        "6003": {
          "description": "MASQ guest_network to WAN",
          "log": "disable",
          "outbound-interface": "eth0.34",
          "protocol": "all",
          "source": {
            "group": {
              "network-group": "guest_network"
            }
          },
          "type": "masquerade"
        }
      }
    }
  }
}

  • valkhyr
  • Registratie: augustus 2003
  • Laatst online: 17:03
Sinds twee weken krijg ik zeer regelmatig ( 1 a 2 keer per uur) de melding zender niet beschikbaar, hebben meer mensen hier last van met een USG 3P?
Daarvoor had ik alleen dat het beeld soms even stil stond.

  • ptjuh
  • Registratie: november 2005
  • Laatst online: 16:33

ptjuh

New day, same old shit

@valkhyr Nee, sinds ik de scripts heb aangepast met de scheduler heb ik nergens meer last van!

Its all in the little things that people do..


  • valkhyr
  • Registratie: augustus 2003
  • Laatst online: 17:03
Het lijkt erop dat telfort de boel aan het aanpassen is geweest.
Sinds vrijdavond draait alles weer zonder haperingen, mijn herstart van de IGMP-proxy is ook niet meer nodig.

  • ptjuh
  • Registratie: november 2005
  • Laatst online: 16:33

ptjuh

New day, same old shit

ja, alles wordt natuurlijk langzaam omgezet naar KPN onderdelen.

ik ga vandaag eens bellen voor nieuw contract.. Kijken of er nog wat verschil in zit :)

Its all in the little things that people do..

Pagina: 1


Apple iPhone SE (2020) Microsoft Xbox Series X LG CX Google Pixel 4a CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True