Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Vraag


Acties:
  • 0Henk 'm!
Goedendag,

Ik lees al een tijdje via een P1 Smart Meter USB kabel mijn slimme meter uit en stuur deze data door naar een raspberry pi met domoticz erop.

Nu zie ik dat dit sinds een paar dagen niet meer werkt, als ik via de terminal het probeer te verbinden krijg ik wel een connected bericht, maar daarna niets meer:

cu -l /dev/ttyUSB0 -s 9600 --parity=none
Connected.
cu -l /dev/ttyUSB0 -s 115200 --parity=none
Connected.

cu -l /dev/ttyAMA0 -s 9600 --parity=none
Connected.
cu -l /dev/ttyAMA0 -s 115200 --parity=none
Connected.

Heeft iemand een idee wat hier mis kan zijn?
Kan zo'n USB kabel opeens stuk zijn?

Bus 001 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

die FT232 USB-Serial is denk ik de p1 kabel

Ik heb al gebeld met Stedin en die zegt dat er niks mis mee is en dat ze niet zomaar de p1 poort uit hebben
gezet

Hebben meer mensen zo iets eerder gezien?

Madcat wijzigde deze reactie 06-07-2018 22:21 (20%)

Alle reacties


Acties:
  • 0Henk 'm!

  • UTMachine
  • Registratie: juli 2000
  • Laatst online: 14:33
Hier zegt 'connected' niet zoveel.

Als je meerdere P1 kabels hebt getest, dan zou het alleen aan de slimme meter kunnen liggen. 3 maanden geleden stopte mijn slimme meter (merk: Iskra) ook met data sturen over de P1 poort en die heeft Stedin zonder problemen vervangen (door merk: Landis+Gyr).

Acties:
  • 0Henk 'm!

  • Kek
  • Registratie: maart 2007
  • Laatst online: 18-10 22:02

Kek

3flix

Al eens aan de kabel/connector gefriemeld? bij mij klikt hij er wel in maar de rj11 moet nog wat extra druk krijgen voordat er goed signaal door komt...

Acties:
  • 0Henk 'm!

  • TommyboyNL
  • Registratie: januari 2006
  • Niet online
Trek je kabels eens los uit je meter, sluit de Tx en Rx van je kabel kort, open een terminal sessie, en mep op wat toetsen. Zie je output? Kabel is OK. Geen output: Kabel is dood.

Acties:
  • 0Henk 'm!
Ik heb pin 2 en 5 (de beide uiterste connectors met elkaar verbonden) en dan het commando "screen /dev/ttyUSB0 9600" gedraaid. (heb de andere opties ook geprobeerd)

Zou ik dan wat moeten zien op het scherm als ik wat intype?

wat bizar dat zo'n simpele kabel al na een jaartje kapot gaat

Madcat wijzigde deze reactie 06-07-2018 22:35 (22%)



Apple iPhone XS Red Dead Redemption 2 LG W7 Google Pixel 3 XL OnePlus 6T FIFA 19 Samsung Galaxy S10 Google Pixel 3

Tweakers vormt samen met Tweakers Elect, Hardware.Info, Autotrack, Nationale Vacaturebank en Intermediair de Persgroep Online Services B.V.
Alle rechten voorbehouden © 1998 - 2018 Hosting door True