Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Hoe IGMP snooping enablen in LEDE?

Pagina: 1
Acties:

Vraag


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Mijn vraag:

Hoe krijg ik IGMP snooping goed werkend op LEDE?
...

Even de probleemstelling:
Ik deel de internetverbinding met de buren (schoonouders). Daar hebben ze een KPN glasvezelverbinding met bijbehorende Experiabox v10.

1 van de LAN porten van de experiabox is aangesloten op de WAN-port van mijn ASUS RT-N56U met LEDE (laatste versie).

De router met LEDE is dan verbonden met een ASUS RT-N66U die als AP functioneert. Op de NT-66U AP is dan een motorola kastje aangesloten voor de TV.

Eerder had ik een andere router dan degene met LEDE, en toen werkte TV e.d. gewoon goed als ik IGMP snooping aanzette. Echter, in LEDE krijg ik het maar niet werkend, met als gevolg dat na 3 seconden het beeld van de TV hangt en ik een melding krijg dat het kanaal niet beschikbaar is.


Wat ik al gevonden of geprobeerd heb:
Ik heb al geprobeerd om de volgende packages te installeren:
kmod-bridge
igmpproxy

En vervolgens de guide te volgen van:
https://wiki.openwrt.org/doc/howto/udp_multicast

Ik heb ook wat andere packages geprobeerd (omcproxy, mcproxy) maar daar kon ik minder informatie over vinden. Ik heb nog wat geprobeerd met VLAN netwerken, maar volgens mij zit de oplossing daar niet: het werkte met de oude router makkelijk met IGMP snooping aan. Het lijkt dus met de "handleiding" IGMP snooping gewoon niet aan gaat. Mis ik iets als ik dat uitvoer ? Iemand nog tips?

Beste antwoord (via rens-br op 07-01-2019 20:51)


  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 12:33:
Dan is er ook geen optie meer tot IGMP snooping aan te ztten op het AP, maar werkt het wel.

Dus ik denk dat het dan zo OK is. Bedankt voor de hulp! :)
Wireless -> Professional -> Disable IGMP snooping for both 2,4GHz and 5GHz niet aangevinkt.
Je zou het daarna kunnen testen door even zo veel mogelijk wireless clients aan te zetten vlakbij je AP en op eentje een speedtest draaien met de IPTV box 5 minuten uit. Dan draai een speedtest met de IPTV box aan terwijl je even over 5 kanalen zapt. Zou nauwelijks verschil in de speedtest moeten zijn.

Wil je nog weten wat een betere architectuur zou zijn voor jouw use case?

[Voor 22% gewijzigd door |sWORDs| op 26-12-2017 12:39]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset

Alle reacties


  • boyette
  • Registratie: november 2009
  • Laatst online: 05:38
wacht eens even.. je gebruikt gewoon een tv kastje van kpn?

  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Ja, een Motorola VIP1853

  • boyette
  • Registratie: november 2009
  • Laatst online: 05:38
Voor zover ik weet kan dit normaal gesproken niet.

Het verkeer voor TV gaat alleen op 2 dedicated poorten van de Experiabox.
Het internetverkeer moet ook gescheiden zijn.

Je hebt dat nu door elkaar liggen dat werkt niet.

Ik heb dat ook eens opgelost maar door er een switch tussen te zetten die dat verkeer van elkaar gescheiden hield.

Dat dit bij jou voorheen wel heeft gewerkt verbaast mij dan ook.

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

Een N66U is een managed switch (BCM53125) met aan poort 8 van de switch de NIC van de CPU (BCM4706).
Of je nu routed IPTV (igmpproxy) of bridged (VLAN) gebruikt, IGMP Snooping is sowieso aanbevolen.

Werkt TV wel voor 5 minuten als je het kanaal direct op pause en play zet?

Draai je wel een igmpproxy op de N56? Wat zijn de instellingen daarvan en wat zijn de ranges op de V10 en N56?

Maar er zijn echt beter manieren dan hoe je het nu gedaan hebt, als ik het goed begrijp is het nu als volgt:
V10 (router) -> RT-N56U (router) -> RT-N66U (ap) -> Motorola

[Voor 56% gewijzigd door |sWORDs| op 26-12-2017 11:32]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • boyette
  • Registratie: november 2009
  • Laatst online: 05:38
Ik denk dat hij de verkeerde lan poort op de xperia gebruikt

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
boyette schreef op dinsdag 26 december 2017 @ 11:21:
Ik denk dat hij de verkeerde lan poort op de xperia gebruikt
Tegenwoordig heb je op alle poorten van een V10 routed IPTV.

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • boyette
  • Registratie: november 2009
  • Laatst online: 05:38
aah.. en daar mag dan ook ander verkeer op?
voor zover ik weet blokkeert de tv als er ook ander verkeer op de zelfde poort binnen komt..

of zijn dat allemaal verouderde opvattingen?

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
boyette schreef op dinsdag 26 december 2017 @ 11:24:
aah.. en daar mag dan ook ander verkeer op?
voor zover ik weet blokkeert de tv als er ook ander verkeer op de zelfde poort binnen komt..

of zijn dat allemaal verouderde opvattingen?
Allemaal oud.

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • boyette
  • Registratie: november 2009
  • Laatst online: 05:38
excuses..
knijp maar een oogje dicht voor mij reacties

dan kan ik ook wat switches gaan ophalen her en der :P

  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Ja, binnen 3 seconden pauzeren en dan weer aan werkt wel

/etc/config/igmpproxy
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
config igmpproxy
        option quickleave 1
        option verbose 1

config phyint wan
        option network wan
        option direction upstream
        list altnet 192.168.1.0/24
        list altnet  213.75.167.0/24

config phyint lan
        option network lan
        option direction downstream

deel van /etc/config/network
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '8.8.8.8 8.8.4.4'
        option ipaddr '192.168.0.1'
        option igmp_snooping '1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '0a:60:6e:e9:4b:3d'

config interface 'wan'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.2.202'
        option netmask '255.255.255.0'
        option gateway '192.168.2.254'
        option dns '8.8.4.4 192.168.2.254'

V10 geeft adressen binnen 192.168.2.1-192.168.2.100 (gateway .254)
N56u binnen 192.168.0.100-192.168.0.180

Het tvkastje heeft een assigned IP op 192.168.0.10

En ja, de opzet die je beschreef klopte

[Voor 92% gewijzigd door Yaldair op 26-12-2017 11:42]


  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 11:33:
Ja, binnen 3 seconden pauzeren en dan weer aan werkt wel
Ok, dan zit het probleem in de igmpproxy op jouw router of multicast wordt gedropped in een van de managed switches. Heb je een 'domme' switch? Kun je jouw AP daar eens mee vervangen en alleen de kabel van je router en IPTV kastje daarin stoppen?

[Voor 18% gewijzigd door |sWORDs| op 26-12-2017 11:43]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Ik zie net dat ik de verkeerde range in igmpproxy heb staan. Even kijken of dat het oplost...

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 11:44:
Ik zie net dat ik de verkeerde range in igmpproxy heb staan. Even kijken of dat het oplost...
Kan het bijna niet zijn, list altnet 192.168.1.0/24 hoef je niet als upstream op te geven. Downstream heb je leeg en zou dus voor alle netwerken (dus ook list altnet 192.168.0.1/24) gelden.

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Als ik de RT-N66U (AP) er helemaal uit haal werkt het wel. Heb helaas geen domme switch voor handen.

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 11:49:
Als ik de RT-N66U (AP) er helemaal uit haal werkt het wel. Heb helaas geen domme switch voor handen.
Dan lijkt het alsof die multicast dropped. Ik zou er Merlin opzetten, dan kun je IMGP Snooping inschakelen, zou multicast niet gedropped moeten worden en heb je betere WIFI.

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Hmm, maar heb Merlin daar op staan. Sorry was ik vergeten te vermelden. Met IGMP snooping ook op die aan.

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 11:51:
Hmm, maar heb Merlin daar op staan. Sorry was ik vergeten te vermelden. Met IGMP snooping ook op die aan.
En je weet zeker dat als je er nu om heen gaat dat IPTV werkt?
En als je er niet omheen gaat krijg je IPTV kast een IP in de 192.168.0.x range?
Wat is je robocfg op je AP (robocfg show)?

[Voor 16% gewijzigd door |sWORDs| op 26-12-2017 11:55]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Ja:

LEDE-> Merlin via LAN->LAN-ports. LAN kabel die normaal gesproken naar Merlin gaat eruitgehaald en in motorola gestoken. Toen werkte het meteen. RT-N66U met Merlin had dan ook geen internet meer.

Settings van de RT_N66U:
Lan->IPTV:
Select ISP profile: None
Choose IPTV STB port: None
Use DHCP routes: RFC3442 & Microsoft
Enable multicast routing (IGMP proxy) : Enable
Enable efficient multicast forwarding (IGMP snooping)
UDP proxy : 0

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 11:58:
Ja:

LEDE-> Merlin via LAN->LAN-ports. LAN kabel die normaal gesproken naar Merlin gaat eruitgehaald en in motorola gestoken. Toen werkte het meteen. RT-N66U met Merlin had dan ook geen internet meer.

Settings van de RT_N66U:
Lan->IPTV:
Select ISP profile: None
Choose IPTV STB port: None
Use DHCP routes: RFC3442 & Microsoft
Enable multicast routing (IGMP proxy) : Enable
Enable efficient multicast forwarding (IGMP snooping)
UDP proxy : 0
Je hoeft geen IGMP proxy op je AP te draaien, mag het probleem niet zijn, maar is niet correct.

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Haha, ja, zet dat net uit (Zowel IGMP proxy als IGMP snooping) en dan werkt het :)

Edit;

Alleen IGMP proxy uit werkt niet. Dus moet ook IGMP snooping uit zetten op de AP. Kan dat kloppen?

[Voor 40% gewijzigd door Yaldair op 26-12-2017 12:01]


  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 12:00:
Haha, ja, zet dat net uit (Zowel IGMP proxy als IGMP snooping) en dan werkt het :)
Maar IGMP Snooping moet eigenlijk wel aan. Anders krijg je IPTV traffic op je wireless en gaat de WIFI performance er gigantisch onder lijden.
Als je IGMP Snooping aan zet moet je wel even zappen naar een kanaal wat je de laatste paar minuten niet hebt gehad, je moet wel een join doen voor de traffic allowed is.

[Voor 21% gewijzigd door |sWORDs| op 26-12-2017 12:07]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Als ik zap naar een kanaal dat ik nog niet aangehad heb, met IGMP snooping aan, hangt hij weer.

Kan ik dit oplossen door alles beter aan elkaar te hangen (,indien mogelijk)?

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 12:12:
Als ik zap naar een kanaal dat ik nog niet aangehad heb, met IGMP snooping aan, hangt hij weer.

Kan ik dit oplossen door alles beter aan elkaar te hangen (,indien mogelijk)?
Er zijn betere oplossingen dan wat je nu hebt, maar ik zie niet waarom het met IGMP Snooping aan niet werkt met je huidige oplossing. Moet even nadenken...

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

Je woont niet toevallig in de buurt van Zutphen? Je mag wel even een managed switch met IGMP Snooping lenen om het een en ander uit te kunnen sluiten. Hoe lang ik ook nadenk, ik kom niet verder dan dat IGMP Snooping niet goed werkt op jouw 66U.

Laten we je 66U even zien als een switch, want met wat we nu aan het testen zijn gebruik je alleen de built-in managed switch.
IPTV box doet een join (je zapt naar een kanaal), maar krijgt geen traffic (foutmelding). Met IGMP Snooping uit krijgt hij wel traffic. Unicast werkt wel (pause/play).

Je zou nog even een reboot van de router en AP (met Snooping aan) kunnen proberen. Misschien is er iets mis met de multicast tables en quick leave.

[Voor 58% gewijzigd door |sWORDs| op 26-12-2017 12:24]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Nee, helaas niet. Zit in de buurt van Weert.

Ik kan later vanmiddag misschien wel de andere router in AP mode zetten en die er tussen zetten. Dat is een TP-link AC-750, en had een optie voor IGMP snooping.

Maar, ik zie net dat ik de 66U als "wireless router mode" heb, maar dan DHCP etc uit. Misschien dat hij op deze manier dan conflicteert?

Weet even niet meer waarom ik niet voor AP mode heb gekozen...

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 12:26:
Nee, helaas niet. Zit in de buurt van Weert.

Ik kan later vanmiddag misschien wel de andere router in AP mode zetten en die er tussen zetten. Dat is een TP-link AC-750, en had een optie voor IGMP snooping.

Maar, ik zie net dat ik de 66U als "wireless router mode" heb, maar dan DHCP etc uit. Misschien dat hij op deze manier dan conflicteert?

Weet even niet meer waarom ik niet voor AP mode heb gekozen...
Hij moet echt als AP, met NAT en firewall gaat het echt niet goed werken of je moet nog een IGMP proxy draaien.

[Voor 6% gewijzigd door |sWORDs| op 26-12-2017 12:32]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Dan is er ook geen optie meer tot IGMP snooping aan te ztten op het AP, maar werkt het wel.

Dus ik denk dat het dan zo OK is. Bedankt voor de hulp! :)

Acties:
  • Beste antwoord
  • 0Henk 'm!

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 12:33:
Dan is er ook geen optie meer tot IGMP snooping aan te ztten op het AP, maar werkt het wel.

Dus ik denk dat het dan zo OK is. Bedankt voor de hulp! :)
Wireless -> Professional -> Disable IGMP snooping for both 2,4GHz and 5GHz niet aangevinkt.
Je zou het daarna kunnen testen door even zo veel mogelijk wireless clients aan te zetten vlakbij je AP en op eentje een speedtest draaien met de IPTV box 5 minuten uit. Dan draai een speedtest met de IPTV box aan terwijl je even over 5 kanalen zapt. Zou nauwelijks verschil in de speedtest moeten zijn.

Wil je nog weten wat een betere architectuur zou zijn voor jouw use case?

[Voor 22% gewijzigd door |sWORDs| op 26-12-2017 12:39]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Ah gevonden, nu IGMP snooping enabled in wireless daar, en werkt alles.

Ja, zou graag de betere architectuur horen :)

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 12:42:
Ah gevonden, nu IGMP snooping enabled in wireless daar, en werkt alles.

Ja, zou graag de betere architectuur horen :)
Als je na de NTU een router gewoon twee netwerken (of vier met guest WIFI) laat maken heb je geen dubbel NAT en geen tweede IGMP Proxy. Je kunt dan ook daar een betere firewall draaien en geeft beide huizen een poort op de router (mochten je schoonouders ook telefonie hebben dan twee poorten, op eentje bridge je VLAN7 naar de Experiabox). Alles er achter in de woningen zijn dan gewoon switches (met IGMP Snooping) of AP's.
Beide netwerken zijn dan wel volledig geïsoleerd (op dit moment kun jij bij het netwerk van je schoonouders, maar niet andersom), al zou je natuurlijk in de router ook bepaalde traffic toe kunnen staan.

[Voor 5% gewijzigd door |sWORDs| op 26-12-2017 12:56]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • Yaldair
  • Registratie: april 2012
  • Laatst online: 05-04 17:03
Ah, duidelijk. Ja, ga eens kijken of ik dat misschien voor elkaar kan krijgen :)

  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

quote:
Yaldair schreef op dinsdag 26 december 2017 @ 13:00:
Ah, duidelijk. Ja, ga eens kijken of ik dat misschien voor elkaar kan krijgen :)
pfSense is een goede kandidaat, met bijvoorbeeld zoiets:
https://nl.aliexpress.com...bit-lans/32821041344.html

Dan kun je ook SNORT of Suricata als inline intrusion prevention gebruiken. 2.4.2-RELEASE-p1 werkt perfect met igmpproxy en VLANs.

Dan krijg je zoiets met een extra netwerk en extra downstream in de IGMP Proxy:
|sWORDs| in "[XS4all Glasvezel] Ervaringen en Discussie"

Voor de interface config zie:
|sWORDs| in "[KPN Glasvezel] Ervaringen & Discussie - Deel 2"

[Voor 21% gewijzigd door |sWORDs| op 26-12-2017 13:09]

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset


  • |sWORDs|
  • Registratie: maart 2000
  • Laatst online: 05-04 22:03

|sWORDs|

vSphere/ESXi

Ik zie dat je in Nov '13 ook naar virtualisatie hebt gekeken. pfSense kan natuurlijk ook prima virtueel, dan zou je of de NTU/'Schoonouders LAN' kunnen trunken of de server in de meterkast van de schoonouders kunnen plaatsen.

V&A:24 Core Xeon E5 v4, 256GB ECC met dual 10Gbit upgradeset

Pagina: 1


Apple iPhone 11 Microsoft Xbox Series X LG OLED C9 Google Pixel 4 CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True