Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
sluiten

Onderzoek Tweakers

Om beter te begrijpen wat jij waardevol vindt aan Tweakers en andere online content of features, voeren we een onderzoek uit. Wil jij ons helpen door de bijbehorende vragenlijst in te vullen? Het invullen neemt ongeveer 15 minuten in beslag en onder alle deelnemers verloten we drie Tweakers-goodiebags.

Naar het onderzoek

Toon posts:

Manage Hyper-V server remotely

Pagina: 1
Acties:

  • JoWannes
  • Registratie: juni 2007
  • Laatst online: 30-03 19:27
Als test- / leeropstelling heb ik Hyper-V server 2016 op mijn NUC geïnstalleerd. Na wat gepruts om de Intel LAN driver werkende krijgen (1,2) heb ik het meeste op orde. Ik kan de server remote beheren via Server Manager, kan eraan via RDP, en kan remote Powershell'en.

Echter, ik kan de server niet toevoegen binnen Hyper-V manager, dan krijg ik deze fout:

https://tweakers.net/ext/f/Vos1xFDePydZKbcAfAoGCXsN/thumb.jpg

Het is Nederlands (of toch grotendeels), maar voor mij kon het even goed Chinees zijn.

Ik heb reeds gedaan:

Op de server:
  • Netwerk instellingen via sconfig
  • Enable-PSRemoting
  • WinRM quickconfig
  • Enable-WSManCredSSP -Role server
  • Set-NetFirewallRule -DisplayGroup "*Remote*" -Enabled True
  • Set-NetFirewallRule -DisplayGroup "*Hyper-V*" -Enabled True
Op de client:
  • Set-Item WSMan:\localhost\Client\TrustedHosts -Value "SRV-HPV01"
  • Enable-WSManCredSSP -Role client -DelegateComputer "SRV-HPV01"
En via GPedit de onderstaande aanpassingen doorgevoerd (eenzelfde voor de 5 rules):
https://tweakers.net/ext/f/ym7PBQVDBd329ykP29tY18TX/thumb.jpg

Heeft iemand voor mij een zetje in de goede richting?

[Voor 6% gewijzigd door JoWannes op 11-12-2017 20:36]

AMD R7 3700X, Crucial 16GB 3600MHz CL16, MSI B450 Tomahawk Max, KFA2 RTX 2070 Super, SM951 256GB NVMe, MX500 500GB, 2x 3TB WD Black, SoundBlaster Z, Corsair RM650i & Carbide 400R & Vengeance K60, Logitech G502, Acer XB270HU


  • KerberosX
  • Registratie: december 2003
  • Laatst online: 30-03 13:51
Ik denk dat je het meeste reeds gedaan hebt. Connecteer je effectief naar de Hyper-V server met "SRV-HPV01"? Indien niet, aanpassen en eventueel eens met IP configureren en connecteren.
Verder, welke client gebruik je? Indien Windows 8.1/10, controleer eens welke soort netwerk profiel je client NIC heeft? Indien dit niet Private is, kan dat wel eens problemen opleveren.

Verder kan je ook proberen om de credentials voor de Hyper-V server eerst op de slaan op de client voor je de Hyper-V manager opent. Kan met cmdkey.exe:
code:
1
cmdkey /add:SRV-HPV01 /user: /pass:

Bij user en pass vul je de credentials van je Hyper-V server in.

[Voor 26% gewijzigd door KerberosX op 12-12-2017 11:42]


  • Dennism
  • Registratie: september 1999
  • Laatst online: 08:51
Enigzins offtopic:

Ik zou als ik jou was nu je nog niet al te ver bent met je opstelling een reinstall doen in het engels. Dit zal trouble shooting in de toekomst vele malen makkelijker maken. Ook zul je in het "wild" vrijwel nooit servers / beheerstations tegenkomen in de Nederlandse taal mocht je laten een carrière in de IT ambiëren

Chronia Lvl 110 Warlock Diablo 3


  • HKLM_
  • Registratie: februari 2009
  • Laatst online: 08:11

HKLM_

www.cloud23.nl

@JoWannes Ik heb het vorig jaar via deze handleiding gefixt:
MSDN: Configuring Remote Management of Hyper-V Server – in a workgroup ...

Daarnaast ben ik het wel met @Dennism eens dat je de server beter kan herinstalleren naar een engelse versie. Dit omdat je dan beter kan troubleshooten op problemen.

[Voor 17% gewijzigd door HKLM_ op 12-12-2017 12:56]

Ubiquiti • Unifi USG 3P • Unifi Switch 16 ports 150w •Unifi Switch 8 Ports• Unifi AC-LR • Unifi AC-Lite • Unifi CloudKey


  • nelizmastr
  • Registratie: maart 2010
  • Laatst online: 09:09

nelizmastr

Goed wies kapot

Je moet als je geen AD hebt draaien op zowel server als je lokale PC een identieke gebruiker (lees: lokale administrator) hebben qua naam en wachtwoord. Anders blijft-ie weigeren.

[Voor 8% gewijzigd door nelizmastr op 12-12-2017 13:50]

I reject your reality and substitute my own


  • JoWannes
  • Registratie: juni 2007
  • Laatst online: 30-03 19:27
quote:
KerberosX schreef op dinsdag 12 december 2017 @ 11:38:
Connecteer je effectief naar de Hyper-V server met "SRV-HPV01"?
Ik connecteer idd op hostname.
quote:
Verder, welke client gebruik je? Indien Windows 8.1/10, controleer eens welke soort netwerk profiel je client NIC heeft? Indien dit niet Private is, kan dat wel eens problemen opleveren.
Win 10 idd. Heb RSAT geinstalleerd, maar daar zit Hyper-V Manager niet in blijkbaar. Heb die dan manueel toegevoegd via Windows onderdelen toevoegen/verwijderen.
quote:
Verder kan je ook proberen om de credentials voor de Hyper-V server eerst op de slaan op de client voor je de Hyper-V manager opent. Kan met cmdkey.exe:
code:
1
cmdkey /add:SRV-HPV01 /user: /pass:

Bij user en pass vul je de credentials van je Hyper-V server in.
En dat werkt! _/-\o_
Ergens raar, want ik gaf dezelfde credentials op in de GUI, maar dat nam ie dan niet.
Ik neem aan dat dergelijke truckjes in een 'normale' omgeving (= domain, Hyper-V server domain joined) niet nodig zijn?
quote:
Dennism schreef op dinsdag 12 december 2017 @ 12:45:
Ik zou als ik jou was nu je nog niet al te ver bent met je opstelling een reinstall doen in het engels. Dit zal trouble shooting in de toekomst vele malen makkelijker maken. Ook zul je in het "wild" vrijwel nooit servers / beheerstations tegenkomen in de Nederlandse taal mocht je laten een carrière in de IT ambiëren
De Hyper-V Core server is wel degelijk in het Engels geïnstalleerd. Het is vanaf mijn client (mijn dagdagelijkse PC, in het NL) dat ik wou connecteren en die melding kreeg.
quote:
Die neem ik nog even door, dankjewel.

AMD R7 3700X, Crucial 16GB 3600MHz CL16, MSI B450 Tomahawk Max, KFA2 RTX 2070 Super, SM951 256GB NVMe, MX500 500GB, 2x 3TB WD Black, SoundBlaster Z, Corsair RM650i & Carbide 400R & Vengeance K60, Logitech G502, Acer XB270HU


  • Dennism
  • Registratie: september 1999
  • Laatst online: 08:51
quote:
JoWannes schreef op dinsdag 12 december 2017 @ 16:36:


De Hyper-V Core server is wel degelijk in het Engels geïnstalleerd. Het is vanaf mijn client (mijn dagdagelijkse PC, in het NL) dat ik wou connecteren en die melding kreeg.
Vandaar dat ik ook zei server / beheerstation ;) je wil namelijk je foutmeldingen e.d. maar ook bijv. GPO's het liefst in het engels hebben voor zaken als troubleshooting, maar ook bijv. consistentie in naamgeving. Uit ervaring wil het configuren van bijv. GPO's in het nederlands nog wel eens een drama zijn ;)

Chronia Lvl 110 Warlock Diablo 3

Pagina: 1


Apple iPhone 11 Microsoft Xbox Series X LG OLED C9 Google Pixel 4 CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True