Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Synology folders in Linux Mint bestandbeheer

Pagina: 1
Acties:

Vraag


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Ik ben nogal newbie met Linux. Tot nu toe gaat het best aardig.
Maar wat ik niet snap / niet voor elkaar krijg is het standaard zichtbaar maken van de folders op mijn Synology NAS in bestandbeheer.

Als ik onder "NETWERK" klik op "Blader door het netwerk" dan zie ik:
DiskStation
DISKSTATION
Windows Network

Klik ik op "DiskStation" (NFS denk ik) dan moet ik me aanmelden (prima), maar bij elke onderliggende map in de root moet ik me opnieuw aanmelden. Bovendien gaat het nogal traag.

Klik ik op "DISKSTATION" (Windows FS) dan moet ik me aanmelden (prima), maar moet ik me voor elke map in de root me opnieuw aanmelden.

Klik ik op "Windows Netwerk" dan krijg ik de foutmelding: "Kon 'Windows Network' niet openen.".

Tevens krijg ik pop ups met "gegevens naar apparaat schrijven" (o.i.d.).

=> de vraag is: hoe kan ik structureel, probleemloos de mappen van mijn Synology NAS benaderen in Linux Mint?

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800

Alle reacties


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Door op je NAS de boel degelijk in te stellen. Wat je daar doet is direct te vertalen naar wat je op Linux ziet. Als je NAS nfs aan kan, en het toch altijd aan staat, kan je net zo goed de locatie standaard laten mounten bij het opstarten van je computer.

Ga dus eerst even goed kijken hoe je NAS is ingesteld en meld dat dan ook hier. Vergeet ook niet om te melden hoe je de share opent. Er is namelijk een login optie waarbij je voor elke map opnieuw moet aanmelden, de credentials worden namelijk na het gebruik weer vergeten. Dit staat ook duidelijk in beeld.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op donderdag 15 december 2016 @ 21:47:
Door op je NAS de boel degelijk in te stellen.
Wat bedoel je met degelijk instellen?
Wat je daar doet is direct te vertalen naar wat je op Linux ziet. Als je NAS nfs aan kan
Dat kan mijn NAS.
, en het toch altijd aan staat,
Dat staat hij.
kan je net zo goed de locatie standaard laten mounten bij het opstarten van je computer.
Prima. Wil ik best doen, al weet ik niet welke commando's dat zijn of hoe dat ik bestandbeheer moet.
Ik snap nog niet waarom het zo onhandig gaat in bestandbeheer.
Ga dus eerst even goed kijken hoe je NAS is ingesteld en meld dat dan ook hier. Vergeet ook niet om te melden hoe je de share opent. Er is namelijk een login optie waarbij je voor elke map opnieuw moet aanmelden, de credentials worden namelijk na het gebruik weer vergeten. Dit staat ook duidelijk in beeld.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Videopac schreef op donderdag 15 december 2016 @ 22:02:
[...]

Wat bedoel je met degelijk instellen?
Nou, veel mensen gooien zo'n ding neer en laten alles op standaard staan. Het werkt, maar is niet optimaal. Er kan veel verbeterd worden door wat dieper in 't systeem te duiken. Als je bijvoorbeeld geen Windows machines hebt en de NAS alleen maar met je computer gebruikt, zou je bijvoorbeeld Samba uit kunnen schakelen en puur op NFS werken. Maar er kunnen ook andere instellingen gedaan worden. Kijk hiervoor even in Opslagtechnologie bij de Synology topics. Ik heb zelf geen NAS, dus kan er niet veel meer over zeggen.
[...]

Dat kan mijn NAS.

[...]

Dat staat hij.

[...]

Prima. Wil ik best doen, al weet ik niet welke commando's dat zijn of hoe dat ik bestandbeheer moet.
Ik snap nog niet waarom het zo onhandig gaat in bestandbeheer.
Het is niet echt onhandig. Je moet het alleen even doorhebben hoe het werkt. Alles wat je met netwerk doet via "bestandbeheer", is tijdelijk. Als je het standaard beschikbaar wilt hebben, zodat je er ook via een terminal bij kan, dan moet je de locatie mounten. Dit maak je permanent (automatisch bij opstarten) in /etc/fstab. Het vergt echter wel wat kennis, want een fout in dit bestand zou kunnen betekenen dat je systeem geen schijven meer kan koppelen en daarbij dus niet verder kan opstarten totdat het is opgelost. Lees je dus goed in.

Nadat je je hebt ingelezen hoe je fstab bewerkt en de Synology toevoegd als NFS, zou het iets als dit moeten zijn wat je toevoegd (doe ik even uit m'n hoofd, verifieer dus of dit echt klopt!):
code:
1
//ip.van.je.nas/nfssharenaam    /locatie/waar/je/het/wilt/hebben    nfs    defaults    0  0

Als je dit hebt toegevoegd, kan je vanuit een terminal het commando 'mount -a' uitvoeren, of 'mount /locatie/in/fstab'. Is er een fout gemaakt, dan krijg je daar melding over. Gaat het goed, dan zie je niets veranderen maar zou je wel alle bestanden moeten kunnen zien op de locatie die je hebt opgegeven.

Commandline FTW | Tweakt met mate


  • DJMaze
  • Registratie: juni 2002
  • Niet online
smb://192.168.1.???/

/net/192.168.1.???/volume1/ (zie autofs)

Bij een login scherm kan je toch gewoon de gegevens "onthouden"?

Maak je niet druk, dat doet de compressor maar


  • bolkmans
  • Registratie: november 2014
  • Laatst online: 12-08 18:47
Ik heb een QNAP, dus specifieke Synology-zaken kan ik je niet mee helpen. Op mijn QNAP heb ik een map met symbolic links gemaakt naar alle mappen die ik wil benaderen via mijn Linux-computer.
(bron: http://www.tweaking4all.c...bine-qnap-shared-folders/)

Vervolgens voer ik de volgende stappen uit op mijn linux-pc (ubuntu):

sudo apt-get install cifs-utils
sudo mkdir -p /media/allshares

#### --->>>
gksudo gedit /etc/fstab
//NASNAAM/AllShares /media/allshares cifs defaults,rw,credentials=/root/.naslogon,dir_mode=0777,file_mode=0777,iocharset=utf8 0 0
#### <<<---

#### --->>>
gksudo gedit /root/.naslogon
username=mijngebruikersnaam
password=mijnwachtwoord
#### <<<---

sudo chmod 600 /root/.naslogon
sudo mount -a

Succes er mee!

  • nelizmastr
  • Registratie: maart 2010
  • Laatst online: 07:32

nelizmastr

Goed wies kapot

In de webinterface van je NAS kan je de rechten automatisch doorgeven voor onderliggende mappen. Dan hoef je maar 1x aan te melden. Even naar je gesharede map gaan en de NFS machtigingen checken.

I reject your reality and substitute my own


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

De regel die bolkmans toevoegt aan z'n fstab is niet helemaal goed. Beter wordt er file_mode 666 gebruikt ipv 777, zodat je niet spontaan alles gaat uitvoeren. Het is in principe al gevaarlijk om iets world read/writable te hebben, maar ook nog eens uitvoerbaar door iedereen is niet verstandig. Zelfs als het op je interne netwerk is. Als je wilt dat een bepaalde gebruiker er bij kan, dan laat je die mode opties achterwege en geef je 'uid=<jouw uid>' mee. Desnoods ook met je group id.

Commandline FTW | Tweakt met mate


  • JPBTEW
  • Registratie: december 2016
  • Laatst online: 14-05-2019
Ik krijg de root mappen ook niet zichtbaar. Ook niet via sftp...(inloggen lukt prima..) ik wil floorplans toevoegen aan Domoticz maar ik krijg de mappen van Domoticz niet zichtbaar....


HELP....

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

JPBTEW schreef op vrijdag 30 december 2016 @ 20:06:
Ik krijg de root mappen ook niet zichtbaar. Ook niet via sftp...(inloggen lukt prima..) ik wil floorplans toevoegen aan Domoticz maar ik krijg de mappen van Domoticz niet zichtbaar....


HELP....
Eigen topic maken met alle relevante informatie. Niet dit topic kapen om je eigen irrelevante problemen te dumpen en hopen op een antwoord.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Dus als ik het goed begrijp moet ik voor een simpel, veel gevraagd iets, wat onder windows gewoon kan door in de verkenner "reconnect at logon" of met 1 enkele regel op de command prompt, in Linux eerst een fstab commando uit gaan pluizen of minimaal 10 regels gaan "programmeren"?

Dit kan gewoon niet kloppen.
(sorry: ik ben nogal gefrustreerd dat zoiets simpels gewoon niet kan).

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Je kan er als het goed is ook een bookmark van maken zodat je het snel kan openen via de snelkoppelingen aan de linker kant. Echter heb je bookmarks of mappen daar, niet beide, afhankelijk van de filemanager die je gebruikt.
Waar je met deze methode rekening moet houden is dat niet elk programma direct van een gvfs locatie (smb://[server]/map/bestand.txt) bestanden kan openen. Daarom is een regel toevoegen aan fstab het beste.

Ik vond het eerst ook omslachtig om daarmee schijven en shares direct beschikbaar te maken, maar het wendt uiteindelijk en het heeft ook wel een zekere logica. Bij Windows wordt als in het register opgeslagen en kan je een keer zitten dat een schrijfletter in gebruik is terwijl je niet kan zien waardoor.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Inmiddels een nieuwe NAS en een nieuwe Linux Mint installatie (van dual-boot W10 / Linux naar Linux alleen).

Echter: wederom geen enkele manier om de NAS-folders zichtbaar te krijgen in de "file manager" van Linux Mint. Er lijken ook totaal geen opties te zijn in de menu's bovenaan of met de rechtermuisknop.

Is het echt niet mogelijk om basale functionaliteit als het zichtbaar maken van server folders voor elkaar te krijgen zonder cursus programmeren en netwerkprotocollen? Ik snap niet waarom dit zo moeilijk gemaakt is.

Ik zou het jammer vinden als ik zou moeten stoppen met Linux puur en alleen omdat het weigert mijn NAS bereikbaar te maken.

[Voor 10% gewijzigd door Videopac op 12-12-2017 11:34]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op vrijdag 30 december 2016 @ 23:28:
Je kan er als het goed is ook een bookmark van maken zodat je het snel kan openen via de snelkoppelingen aan de linker kant. Echter heb je bookmarks of mappen daar, niet beide, afhankelijk van de filemanager die je gebruikt.
Waar je met deze methode rekening moet houden is dat niet elk programma direct van een gvfs locatie (smb://[server]/map/bestand.txt) bestanden kan openen. Daarom is een regel toevoegen aan fstab het beste.

Ik vond het eerst ook omslachtig om daarmee schijven en shares direct beschikbaar te maken, maar het wendt uiteindelijk en het heeft ook wel een zekere logica. Bij Windows wordt als in het register opgeslagen en kan je een keer zitten dat een schrijfletter in gebruik is terwijl je niet kan zien waardoor.
Eeh: dank je, denk ik. Ik snap het alleen niet.
- Hoe maak je dan zo'n boekmark?
- Wat is gvfs?
- Wat is fstab?

Edit: uiteindelijk opgelost door \etc\fstab met gedit te editen.
Dus:
1. Command prompt.
2. cd ..
3. cd ..
4. cd etc
5. sudo -s
(voor het als root uitvoeren van commando's).
6. gedit fstab
7. file aanpassen, per folder een regel toevoegen:

//[IP-adresNAS]/[folder_op_NAS] [folder_op_Linux_Mint] cifs username=<username>,password=<password>,noperm,dir_mode=0666,file_mode=0666,iocharset=utf8,_netdev 0 0

Ik heb in mijn documentenfolder een folder "NAS" aangemaakt en daaronder mappen die overeenkomen met de mappen op de NAS die ik bereikbaar wil maken.

Herstarten en het werkt!

[Voor 23% gewijzigd door Videopac op 12-12-2017 16:14]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Leuk, maar je dirmode=0666 is niet echt handig, zo kan je niet door mappen bladeren. ;) Beter is 755 of 775. Bestanden met 0666 kan, maar 0664 of 0644 doet 't ook, jij bent immers de enige die erbij hoeft. Sterker nog, die twee opties hoeven niet eens. Dit zou genoeg moeten zijn:
code:
1
//ip.synology/nasshare    /media/nas    cifs    username=<user>,password=<pass>,uid=1000,gid=1000    0 0

Die uid= en gid= opties zorgen voor de gebruiker en groep die je lokaal ziet, ik neem even aan dat het ID van je gebruiker 1000 is, de standaard voor de eerste gebruiker op je Linux systeem.

Voor je commando's, je kan ook gelijk 'cd /etc' doen, of nog makkelijker, 'sudo gedit /etc/fstab'. Let echter wel op, bij sommige desktop omgevingen kan je de text editor niet als root uitvoeren. Kate van KDE bijvoorbeeld geeft daar een melding over en sluit dan weer. ;)

Commandline FTW | Tweakt met mate


  • hcQd
  • Registratie: september 2009
  • Nu online
Misschien ook handig om een x-systemd.device-timout=30 op te nemen in de opties, anders boot het zo lastig als je NAS het niet doet.

  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Na een (kernel?)update zijn al mijn mappings weer verdwenen.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Dat zou niets met Samba te maken moeten hebben en de share zelf. Kijk je logs na wat er nou gebeurt als het systeem de share probeert te mounten. Gebruik desnoods 'mount -vvv /media/nas' om te achterhalen wat er nou gebeurt.

Commandline FTW | Tweakt met mate


  • Corrigan
  • Registratie: juni 2016
  • Niet online
Herkenbaar, dit heeft mij ooit in het begin ook hoofdbrekens gekost. Zelfs zoveel dat ik er een screenshot van heb bewaard van de instellingen op de Synology. Dit werkt altijd perfect.

Gebruik NFS in plaats van Samba.

- Installeer in Mint nfs-common: sudo apt install nfs-common
- maak een map om je nas te mounten: sudo mkdir /mnt/nas

Stel je nas heeft ip adres 192.168.2.10, al je devices zitten in 192.168.* en je volumenaam van je Synology is volume1:

- zet als 1 regel in /etc/fstab:

192.168.2.10:/volume1 /mnt/nas nfs noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0

Dan op je Synology onder configuratiescherm:

- Bestandservice, activeer NFS
- Gedeelde map, Bewerken, NFS-machtigingen. En zet de instellingen in zoals de screenshot.
- Herhaal dit voor alle mappen die je wilt delen. Eventueel kun je rechten later nog beperken.

- reboot je pc.

En bewaar dit plaatje. :)

[Voor 7% gewijzigd door Corrigan op 13-01-2018 11:24]


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Corrigan schreef op zaterdag 13 januari 2018 @ 11:17:
Herkenbaar, dit heeft mij ooit in het begin ook hoofdbrekens gekost. Zelfs zoveel dat ik er een screenshot van heb bewaard van de instellingen op de Synology. Dit werkt altijd perfect.

Gebruik NFS in plaats van Samba.

- Installeer in Mint nfs-common: sudo apt install nfs-common
- maak een map om je nas te mounten: sudo mkdir /mnt/nas

Stel je nas heeft ip adres 192.168.2.10, al je devices zitten in 192.168.* en je volumenaam van je Synology is volume1:

- zet als 1 regel in /etc/fstab:

192.168.2.10:/volume1 /mnt/nas nfs noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0

Dan op je Synology onder configuratiescherm:

- Bestandservice, activeer NFS
- Gedeelde map, Bewerken, NFS-machtigingen. En zet de instellingen in zoals de screenshot.
- Herhaal dit voor alle mappen die je wilt delen. Eventueel kun je rechten later nog beperken.

- reboot je pc.

En bewaar dit plaatje. :)

[afbeelding]
Dank voor je hulp. Ik zie nu de hoofdmappen van de NAS wel, maar niet de inhoud als ik er op klik.
Ik blijf nog even door puzzelen.

Overigens is er tot nu toe geen Linux-specialist geweest die mij heeft kunnen uitleggen waarom zoiets veel gevraagds als het zichtbaar maken van netwerkfolders onder Linux zo idioot moeilijk gemaakt is. Op dit vlak is Windows toch echt wel superieur.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Je maakt het zelf moeilijker dan het echt is.

Commandline FTW | Tweakt met mate


  • Corrigan
  • Registratie: juni 2016
  • Niet online
Videopac schreef op zaterdag 13 januari 2018 @ 14:37:
[...]

Dank voor je hulp. Ik ze nu de hoofdmappen van de NAS wel, maar niet de inhoud als ik er op klik.
Ik blijf nog even door puzzelen.

Overigens is er tot nu toe geen Linux-specialist geweest die mij heeft kunnen uitleggen waarom zoiets veel gevraagds als het zichtbaar maken van netwerkfolders onder Linux zo idioot moeilijk gemaakt is. Op dit vlak is Windows toch echt wel superieur.
Check de machtigingen van de mappen en de gebruikers.

Je NAS is ook Linux dus is het logischer om ook NFS te gebruiken. Samba gebruik je alleen als je nog moet verbinden met Windows shares. De handleiding van Synology geeft voor een Linux desktop NFS als de standaard aan.

Als je het eenmaal door hebt is het allemaal best logisch. Het zijn bijna dezelfde stappen als met Windows.

[Voor 3% gewijzigd door Corrigan op 13-01-2018 18:04]


  • DJMaze
  • Registratie: juni 2002
  • Niet online
Videopac schreef op zaterdag 13 januari 2018 @ 14:37:
[Overigens is er tot nu toe geen Linux-specialist geweest die mij heeft kunnen uitleggen waarom zoiets veel gevraagds als het zichtbaar maken van netwerkfolders onder Linux zo idioot moeilijk gemaakt is. Op dit vlak is Windows toch echt wel superieur.
Alles draait om beveiliging en we weten hoe het zit met de beveiliging van Samba vs NFS 🙊
Als Windows zo superieur is, ga jij dan eens proberen de beveiliging in Samba in te stellen :+

[Voor 9% gewijzigd door DJMaze op 13-01-2018 18:30]

Maak je niet druk, dat doet de compressor maar


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op zaterdag 13 januari 2018 @ 15:02:
Je maakt het zelf moeilijker dan het echt is.
Waar doe ik moeilijk / wat doe ik verkeerd?
Ik snap/zie niet wat ik fout doe, vandaar de frustraties.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
DJMaze schreef op zaterdag 13 januari 2018 @ 18:29:
[...]

Alles draait om beveiliging en we weten hoe het zit met de beveiliging van Samba vs NFS 🙊
Als Windows zo superieur is, ga jij dan eens proberen de beveiliging in Samba in te stellen :+
Geen idee. Het enige dat ik weet is dat ik in Windows gewoon de gebruikersnaam en wachtwoord van een Synology account op kon geven. De rechten die je onder Windows op de share hebt zijn dezelfde als die van het Synology account. Ik zie niet wat daar onveilig aan is. Onder Linux is dit kennelijk een extreem complexe zaak, gezien de vele verschillende, deels tegenstrijdige suggesties die ik hier krijg. Op zich dank daarvoor, maar duidelijker wordt het er niet van.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Videopac schreef op zaterdag 13 januari 2018 @ 22:05:
[...]

Waar doe ik moeilijk / wat doe ik verkeerd?
Ik snap/zie niet wat ik fout doe, vandaar de frustraties.
De laatste tip die je hier hebt gevolgd gaat over NFS. Dat kan fantastisch werken, maar het kan je ook bijten als je gebruiker op je PC niet hetzelfde UID heeft als de gebruiker waarmee de rest van je data beschikbaar wordt gesteld via SMB. Dan krijg je zaken als iets niet kunnen schrijven of überhaupt lezen. Is het overal hetzelfde, dan is het prettiger werken dan via SMB.

Dat laatste, SMB, had je aan de praat en werkte prima, maar 'opeens' werkte het niet meer en gaf je geen verdere informatie waar dat mogelijk aan kon liggen (zoals m'n voorgestelde mount commando).

Commandline FTW | Tweakt met mate


  • DJMaze
  • Registratie: juni 2002
  • Niet online
Onder linux is het niet moeilijk als je kio of gvfs gebruikt

smb://192.168.1.10/
nfs://192.168.1.10/

Je moet wel het verschil weten tussen SMB en NFS. Het zijn twee compleet verschillende dingen.
Je moet "nfs://192.168.1.10/" zien als een SSD/HDD/USB met naam en wachtwoord, terwijl SMB zoiets is als FTP.

Maak je niet druk, dat doet de compressor maar


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op zaterdag 13 januari 2018 @ 23:42:
[...]

De laatste tip die je hier hebt gevolgd gaat over NFS. Dat kan fantastisch werken, maar het kan je ook bijten als je gebruiker op je PC niet hetzelfde UID heeft als de gebruiker waarmee de rest van je data beschikbaar wordt gesteld via SMB. Dan krijg je zaken als iets niet kunnen schrijven of überhaupt lezen. Is het overal hetzelfde, dan is het prettiger werken dan via SMB.

Dat laatste, SMB, had je aan de praat en werkte prima, maar 'opeens' werkte het niet meer en gaf je geen verdere informatie waar dat mogelijk aan kon liggen (zoals m'n voorgestelde mount commando).
Uitkomst mount commando: "mount: /media/nas: Bestand of map bestaat niet".
M.b.t. UID: begrijp ik dat het UID van de lokale Linuxgebruiker hetzelfde moet zijn als het UID van de gebruiker op de (Synology)NAS?

Edit: heb nu even geen tijd meer. Zal er later vandaag wat uitgebreider naar kijken.

[Voor 4% gewijzigd door Videopac op 14-01-2018 08:35]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Videopac schreef op zondag 14 januari 2018 @ 08:05:
[...]

Uitkomst mount commando: "mount: /media/nas: Bestand of map bestaat niet".
Je moet de locatie gebruiken die in je fstab staat natuurlijk. ;) En als dat de map is die er staat, moet je natuurlijk wel zorgen dat die bestaat, Linux kan niets mounten op een niet-bestaande locatie. Als ik iets op /pietje/puk beschikbaar wil maken, moet /pietje/puk wel bestaan. Met alleen /pietje gaat dat niet.
M.b.t. UID: begrijp ik dat het UID van de lokale Linuxgebruiker hetzelfde moet zijn als het UID van de gebruiker op de (Synology)NAS?
Dat is niet strikt noodzakelijk, maar als je de map ook via SMB aanbied wel. Het is daarom verstandig om je bij 1 manier van delen te houden. Als je namelijk met SMB een map deelt, zal er geschreven worden met de gebruiker op de NAS, daar authenticeer je uiteindelijk mee. Op je PC kan je dan een heel ander UID hebben voor je gebruiker en de map met de mount opties daarop vastzetten, dat heeft dan geen gevolgen voor wat er aan de kant van de NAS gebeurt.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Update: weer een aantal dingen geprobeerd, zonder succes helaas.

Mijn huidige fstab:
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# 192.168.1.23:/volume1 /mnt/nas nfs noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0
/dev/mapper/mint--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=f72aba5f-9a48-43f0-9e3b-7639dd5b47e3 /boot           ext2    defaults        0       2
# /boot/efi was on /dev/sda1 during installation
UUID=604C-E5F8  /boot/efi       vfat    umask=0077      0       1
# hieronder een suggestie uit Tweakerstopic die niet werkte.
# /dev/mapper/mint--vg-swap_1 none            swap    sw              0       0
# hieronder een suggestie uit Tweakerstopic die ooit werkte.
# //[IP-adresNAS]/[folder_op_NAS] [folder_op_Linux_Mint] cifs username=<username>,password=<password>,noperm,dir_mode=0666,file_mode=0666,iocharset=utf8,_netdev 0 0
# hieronder de suggestie waar ik nu mee aan het prutsen ben
//192.168.1.23/volume1/books /home/XXXX cifs username=XXXX,password=YYYY,noperm,dir_mode=0775,file_mode=0666,iocharset=utf8,_netdev 0 0 x-systemd.device-timout=30
# //ip.synology/nasshare    /media/nas    cifs    username=<user>,password=<pass>,uid=1000,gid=1000    0 0

NB: Met /media/nas i.p.v. /home/user kreeg ik de melding dat alleen root dat kon mounten.

De laatste keer kreeg ik tijdens het editen de volgende foutmelding:
code:
1
(gedit:2659): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

De voorlaatste keer kreeg ik tijdens het editen de volgende foutmeldingen:
code:
1
2
3
4
5
6
7
(gedit:2722): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:2722): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-spell-enabled is niet mogelijk

** (gedit:2722): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-encoding is niet mogelijk

** (gedit:2722): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-position is niet mogelijk


Nogmaals: dank voor de hulp zover, maar ik krijg het nog niet voor elkaar.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Waarom op /home/[user] mounten? Dat is je home map. Daar wil je helemaal geen SMB share mounten. Ook niet als 'roaming' locatie. SMB is niet POSIX compliant, dus je gaat een hoop gezeik krijgen van programma's e.d. die niet meer functioneren, omdat de rechten niet goed staan.

Zet je onderste regel eens aan, zorg dat er een map /media/nas is en pas de <user> en <pass> aan naar wat je erboven hebt en doe dan 'sudo mount /media/nas'. Uiteraard de regel dat je op /home/XXXXX mount even uitzetten.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op maandag 15 januari 2018 @ 12:59:
Waarom op /home/[user] mounten? Dat is je home map. Daar wil je helemaal geen SMB share mounten. Ook niet als 'roaming' locatie. SMB is niet POSIX compliant, dus je gaat een hoop gezeik krijgen van programma's e.d. die niet meer functioneren, omdat de rechten niet goed staan.

Zet je onderste regel eens aan, zorg dat er een map /media/nas is en pas de <user> en <pass> aan naar wat je erboven hebt en doe dan 'sudo mount /media/nas'. Uiteraard de regel dat je op /home/XXXXX mount even uitzetten.
Dank. Die 'sudo mount /media/nas': als laatste regel in fstab of op de command prompt?
Edit: SMB = samba? Ik 'moest' toch via NFS connectie maken?

[Voor 4% gewijzigd door Videopac op 15-01-2018 13:10]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online
@Videopac wat staat er in je /etc/auto.master ?
Staat die op
code:
1
/net    -hosts

Zo ja, wat gebeurt er met
code:
1
$ cd /net/192.168.1.11/

Maak je niet druk, dat doet de compressor maar


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
DJMaze schreef op maandag 15 januari 2018 @ 13:11:
@Videopac wat staat er in je /etc/auto.master ?
Staat die op
code:
1
/net    -hosts

Zo ja, wat gebeurt er met
code:
1
$ cd /net/192.168.1.11/
Ehm: ik heb geen auto.master bestand in /etc?

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online

Maak je niet druk, dat doet de compressor maar


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

@DJMaze, dat heeft hij niet geconfigureerd. En waarom wel eigenlijk? Het is niet direct nodig voor thuisgebruik. NFS is aardig, maar je zit ook met de punten die ik aangaf mbt UID op de systemen. Dat maakt het wat complexer. SMB werkte en nu opeens niet meer, al is niet duidelijk waarom. Laten we dan hier even op blijven focussen. :)

@Videopac, je fixt eerst fstab zoals ik aangaf, daarna voer je dat commando uit. Of je herstart, maar als het niet werkt krijg je geen duidelijke feedback en moet je alsnog het commando draaien om meer te weten. ;)

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op maandag 15 januari 2018 @ 13:18:
@DJMaze, dat heeft hij niet geconfigureerd. En waarom wel eigenlijk? Het is niet direct nodig voor thuisgebruik. NFS is aardig, maar je zit ook met de punten die ik aangaf mbt UID op de systemen. Dat maakt het wat complexer. SMB werkte en nu opeens niet meer, al is niet duidelijk waarom. Laten we dan hier even op blijven focussen. :)

@Videopac, je fixt eerst fstab zoals ik aangaf, daarna voer je dat commando uit. Of je herstart, maar als het niet werkt krijg je geen duidelijke feedback en moet je alsnog het commando draaien om meer te weten. ;)
Ik krijg de volgende foutmelding:

mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online
@Hero of Time autofs kan ook met samba hoor. Je hebt inderdaad wel een punt.
https://forums.linuxmint.com/viewtopic.php?t=144997

Maak je niet druk, dat doet de compressor maar


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Even voor de duidelijkheid: het hoeft niet via Samba: ik heb NFS geconfigueerd op mijn NAS.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Videopac schreef op maandag 15 januari 2018 @ 13:22:
[...]

Ik krijg de volgende foutmelding:

mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
Dus, je hebt staan wat ik aangaf, wat ook in je eerder gemarkeerde 'beste antwoord' staat en een mount werkt niet? De regel van fstab kan je ook handmatig uitvoeren, misschien dat dat wat makkelijker is.
code:
1
mount -v -t cifs -o username=<user>,password=<pass>,uid=1000,gid=1000 //192.168.1.23/volume1/books /media/nas


Plak hier de uitvoer ervan. Let even op of er geen gevoelige informatie zoals wachtwoorden worden weergegeven, die dan even weghalen.

Iets wat heel goed mogelijk is, is dat je een submap aanroept. Ik weet niet of dat ondersteund wordt door SMB.

Om NFS te mounten, wat op dezelfde manier shared is, kan je dit doen:
code:
1
mount -v -t nfs 192.168.1.23:/volume1/books /media/nas

Dat werkt wel met de submap.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op maandag 15 januari 2018 @ 13:36:
[...]

Dus, je hebt staan wat ik aangaf, wat ook in je eerder gemarkeerde 'beste antwoord' staat en een mount werkt niet? De regel van fstab kan je ook handmatig uitvoeren, misschien dat dat wat makkelijker is.
code:
1
mount -v -t cifs -o username=<user>,password=<pass>,uid=1000,gid=1000 //192.168.1.23/volume1/books /media/nas


Plak hier de uitvoer ervan. Let even op of er geen gevoelige informatie zoals wachtwoorden worden weergegeven, die dan even weghalen.

Iets wat heel goed mogelijk is, is dat je een submap aanroept. Ik weet niet of dat ondersteund wordt door SMB.

Om NFS te mounten, wat op dezelfde manier shared is, kan je dit doen:
code:
1
mount -v -t nfs 192.168.1.23:/volume1/books /media/nas

Dat werkt wel met de submap.
Zonder in detail te treden: ik heb een uitroepteken in mijn wachtwoord en daar breekt hij op af:

bash: !<restvanwachtwoord>,uid=1000,gid=1000: event not found

Ik ga even het NFS commando proberen.
Edit: foutmelding NFS commando:

mount.nfs: timeout set for Mon Jan 15 13:53:38 2018
mount.nfs: trying text-based options 'vers=4,addr=192.168.1.23,clientaddr=192.168.1.118'
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting 192.168.1.23:/volume1/books

Edit 2: op de NAS de squash setting op geen toewijzing gezet (stond op toewijzen aan admin): maakte geen verschil: zelfde foutmelding.

Edit 3: alle pogingen tot het mounten van de NAS verwijderd uit fstab, opnieuw opgestart en ik zie nog steeds een NAS folder in mijn persoonlijke map.

Ik snap er helemaal niets (meer) van.

[Voor 23% gewijzigd door Videopac op 15-01-2018 14:17]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Hoezo is het vreemd dat je een NAS map ziet? Die is toch gewoon leeg of niet? Dat is dan normaal, want je hangt schijven en netwerklocaties aan een lege map.

Als je voor Samba een ! in je wachtwoord hebt, kan je ook een bestand maken met je inloggegevens en daar verwijs je dan weer naar met het commando (en uiteindelijk ook fstab). Ik had hierboven al eens aangegeven hoe dat eruit ziet, maar bij deze nog een keer.
code:
1
2
username=<user>
password=<pass>

Dit sla je op in een text bestand op een veilige locatie. Je zou als test gewoon je home map kunnen gebruiken, bijvoorbeeld /home/videopac/nasinlog.txt. Dan mount je met het volgende:
code:
1
mount -v -t cifs -o credentials=/home/videopac/nasinlog.txt,uid=1000,gid=1000 //192.168.1.23/volume1/books /media/nas


Voor NFS is er iets anders, je squash is niet het probleem. Dat ligt eerder aan de toegestane clients. Zie het plaatje bij Corrigan in "Synology folders in Linux Mint bestandbeheer", hier staat "Hostnaam of IP" op de eerste regel. Dat geeft aan welke systemen de NFS share mogen benaderen. Simpelweg '*' erin laat iedereen de NFS locatie benaderen.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op maandag 15 januari 2018 @ 14:39:
Hoezo is het vreemd dat je een NAS map ziet? Die is toch gewoon leeg of niet? Dat is dan normaal, want je hangt schijven en netwerklocaties aan een lege map.
Ik zie nog steeds een NAS map in mijn Persoonlijke map.
Volgens mij zit die daar sinds ik de suggestie van Corrigan opvolgde.
In die map zie ik wel de mappen van de NAS, maar als ik daarop klik zie ik niets. Ik krijg ook geen foutmelding.
Als je voor Samba een ! in je wachtwoord hebt, kan je ook een bestand maken met je inloggegevens en daar verwijs je dan weer naar met het commando (en uiteindelijk ook fstab). Ik had hierboven al eens aangegeven hoe dat eruit ziet, maar bij deze nog een keer.
code:
1
2
username=<user>
password=<pass>

Dit sla je op in een text bestand op een veilige locatie. Je zou als test gewoon je home map kunnen gebruiken, bijvoorbeeld /home/videopac/nasinlog.txt. Dan mount je met het volgende:
code:
1
mount -v -t cifs -o credentials=/home/videopac/nasinlog.txt,uid=1000,gid=1000 //192.168.1.23/volume1/books /media/nas


Voor NFS is er iets anders, je squash is niet het probleem. Dat ligt eerder aan de toegestane clients. Zie het plaatje bij Corrigan in "Synology folders in Linux Mint bestandbeheer", hier staat "Hostnaam of IP" op de eerste regel. Dat geeft aan welke systemen de NFS share mogen benaderen. Simpelweg '*' erin laat iedereen de NFS locatie benaderen.
* heb ik inmiddels er staan (had het al geprobeerd met 192.168.*.* en 192.168.1.*). Als ik "//192.168.1.23/volume1/books /media/NAS nfs" toevoeg aan fstab zie ik een NAS folder bij netwerk, maar als ik erop klik krijg ik deze foutmelding:
"mount: only root can mount //192.168.1.23/volume1/books on /media/NAS".

Wat gaat hier nou toch mis?

Edit: Samba verhaal probeer ik een andere keer wel. Klinkt als een 1993-issue, trouwens, dat afbreken na een !.

Wellicht dat ik morgen verder ga met deze marathon voor het toegang krijgen tot een simpele netwerkshare. Windows: < 5 minuten met net use, Linux: na dagen werkt het nog niet 8)7 Ik kan er niet bij...

Edit 2: superbedankt voor alle hulp!

[Voor 7% gewijzigd door Videopac op 15-01-2018 16:21]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Corrigan
  • Registratie: juni 2016
  • Niet online
Videopac schreef op maandag 15 januari 2018 @ 16:16:
[...]

Ik zie nog steeds een NAS map in mijn Persoonlijke map.
Volgens mij zit die daar sinds ik de suggestie van Corrigan opvolgde.
In die map zie ik wel de mappen van de NAS, maar als ik daarop klik zie ik niets. Ik krijg ook geen foutmelding.

[...]

* heb ik inmiddels er staan (had het al geprobeerd met 192.168.*.* en 192.168.1.*). Als ik "//192.168.1.23/volume1/books /media/NAS nfs" toevoeg aan fstab zie ik een NAS folder bij netwerk, maar als ik erop klik krijg ik deze foutmelding:
"mount: only root can mount //192.168.1.23/volume1/books on /media/NAS".

Wat gaat hier nou toch mis?

Edit: Samba verhaal probeer ik een andere keer wel. Klinkt als een 1993-issue, trouwens, dat afbreken na een !.

Wellicht dat ik morgen verder ga met deze marathon voor het toegang krijgen tot een simpele netwerkshare. Windows: < 5 minuten met net use, Linux: na dagen werkt het nog niet 8)7 Ik kan er niet bij...

Edit 2: superbedankt voor alle hulp!
Gebruik of SMB of NFS, niet door elkaar. In fstab staat cifs voor Samba.

Je bent nu in je laatste post met NFS bezig. Neem letterlijk mijn eerder geposte stappen door. Eentje vergeten of een hoofdletter verkeerd = No Glory.

Omdat je wel mappen ziet en geen inhoud heb je een machtigingen of rechten issue. Kijk op de Synology onder Gedeelde map of je wel alles goed hebt ingesteld zoals de screenshot. Bij Squash : Alle gebruikers aan root toewijzen en dezelfde vinken verder aanzetten.

Als je de Synology firewall gebruikt: zet NFS open voor je ip adres van de client.

Herstart daarna de Synology en je PC. De aanhouder wint. :)

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Videopac schreef op maandag 15 januari 2018 @ 16:16:
[...]

Ik zie nog steeds een NAS map in mijn Persoonlijke map.
Volgens mij zit die daar sinds ik de suggestie van Corrigan opvolgde.
In die map zie ik wel de mappen van de NAS, maar als ik daarop klik zie ik niets. Ik krijg ook geen foutmelding.
Dat kan. Heb al een paar keer meegemaakt dat een map in gaan kon, maar de inhoud zien niet mocht. In zo'n geval staat wel de execute bit aan, maar de read bit niet.
[...]

* heb ik inmiddels er staan (had het al geprobeerd met 192.168.*.* en 192.168.1.*). Als ik "//192.168.1.23/volume1/books /media/NAS nfs" toevoeg aan fstab zie ik een NAS folder bij netwerk, maar als ik erop klik krijg ik deze foutmelding:
"mount: only root can mount //192.168.1.23/volume1/books on /media/NAS".

Wat gaat hier nou toch mis?
Iets mounten en unmounten is normaal gesproken een actie dat alleen de beheerder doet. Root dus. Zo heel gek is dat dus niet. Dit is wel aan te passen, aldus de manpage van 'mount':
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
   Non-superuser mounts
       Normally, only the superuser can mount filesystems.  However, when fstab contains the user option on  a  line,  anybody
       can mount the corresponding filesystem.

       Thus, given a line

              /dev/cdrom  /cd  iso9660  ro,user,noauto,unhide

       any user can mount the iso9660 filesystem found on an inserted CDROM using the command:
              mount /cd

       Note  that  mount is very strict about non-root users and all paths specified on command line are verified before fstab
       is parsed or a helper program is executed. It's strongly recommended to use a valid mountpoint  to  specify  filesystem,
       otherwise mount may fail. For example it's bad idea to use NFS or CIFS source on command line.

       For  more  details, see fstab(5).  Only the user that mounted a filesystem can unmount it again.  If any user should be
       able to unmount it, then use users instead of user in the fstab line.  The owner option is similar to the user  option,
       with  the  restriction  that  the user must be the owner of the special file.  This may be useful e.g. for /dev/fd if a
       login script makes the console user owner of this device.  The group option is similar, with the restriction  that  the
       user must be member of the group of the special file.
Edit: Samba verhaal probeer ik een andere keer wel. Klinkt als een 1993-issue, trouwens, dat afbreken na een !.

Wellicht dat ik morgen verder ga met deze marathon voor het toegang krijgen tot een simpele netwerkshare. Windows: < 5 minuten met net use, Linux: na dagen werkt het nog niet 8)7 Ik kan er niet bij...

Edit 2: superbedankt voor alle hulp!
Een uitroepteken heeft een speciale betekenis op de shell. Ik was vergeten te melden dat als je de password= optie niet meegeeft, er interactief om een wachtwoord wordt gevraagd en het dan niet uitmaakt welke tekens je er allemaal in hebt staan. Het wordt overigens wel aangeraden om een credentials bestand te gebruiken. Dat is beter af te schermen en voorkomt dit soort rare fratsen door de shell omdat het zaken probeert te interpreteren.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Vanavond maar weer eens een uur aan deze soap besteden...
DJMaze schreef op zondag 14 januari 2018 @ 01:36:
Onder linux is het niet moeilijk als je kio of gvfs gebruikt

smb://192.168.1.10/
nfs://192.168.1.10/

Je moet wel het verschil weten tussen SMB en NFS. Het zijn twee compleet verschillende dingen.
Je moet "nfs://192.168.1.10/" zien als een SSD/HDD/USB met naam en wachtwoord, terwijl SMB zoiets is als FTP.
Wat is kio?
Wat is gvfs?
Hero of Time schreef op zondag 14 januari 2018 @ 12:16:

[...]

Dat is niet strikt noodzakelijk, maar als je de map ook via SMB aanbied wel. Het is daarom verstandig om je bij 1 manier van delen te houden. Als je namelijk met SMB een map deelt, zal er geschreven worden met de gebruiker op de NAS, daar authenticeer je uiteindelijk mee. Op je PC kan je dan een heel ander UID hebben voor je gebruiker en de map met de mount opties daarop vastzetten, dat heeft dan geen gevolgen voor wat er aan de kant van de NAS gebeurt.
Dit snap ik niet. Je geeft toch gewoon een username en password op voor een account op de NAS en dat is dan toch het NAS-account waarmee gelezen en geschreven wordt?
Hero of Time schreef op maandag 15 januari 2018 @ 19:29:
[...]

Dat kan. Heb al een paar keer meegemaakt dat een map in gaan kon, maar de inhoud zien niet mocht. In zo'n geval staat wel de execute bit aan, maar de read bit niet.
Dus ookal haal ik in fstab alle regels weg die iets met het benaderen van een netwerkshare te maken hebben weg en sla het op en herstart, dan kan er nog steeds ergens een verwijzing naar zo'n netwerkshare blijven staan? Ik vind dit niet logisch.

De vraag is nu: hoe kom ik van die lelijke, ongevraagde nep-map in mijn persoonlijke map af?

Of is dit veroorzaakt door de commando's van Corrigan:
- Installeer in Mint nfs-common: sudo apt install nfs-common
- maak een map om je nas te mounten: sudo mkdir /mnt/nas
[...]

Iets mounten en unmounten is normaal gesproken een actie dat alleen de beheerder doet. Root dus. Zo heel gek is dat dus niet. Dit is wel aan te passen, aldus de manpage van 'mount':
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
   Non-superuser mounts
       Normally, only the superuser can mount filesystems.  However, when fstab contains the user option on  a  line,  anybody
       can mount the corresponding filesystem.

       Thus, given a line

              /dev/cdrom  /cd  iso9660  ro,user,noauto,unhide

       any user can mount the iso9660 filesystem found on an inserted CDROM using the command:
              mount /cd

       Note  that  mount is very strict about non-root users and all paths specified on command line are verified before fstab
       is parsed or a helper program is executed. It's strongly recommended to use a valid mountpoint  to  specify  filesystem,
       otherwise mount may fail. For example it's bad idea to use NFS or CIFS source on command line.

       For  more  details, see fstab(5).  Only the user that mounted a filesystem can unmount it again.  If any user should be
       able to unmount it, then use users instead of user in the fstab line.  The owner option is similar to the user  option,
       with  the  restriction  that  the user must be the owner of the special file.  This may be useful e.g. for /dev/fd if a
       login script makes the console user owner of this device.  The group option is similar, with the restriction  that  the
       user must be member of the group of the special file.
Samengevat: ik kan beter geen NFS gebruiken?

Ik ben nu nogmaals de stappen van Corrigan aan het doorlopen. Wat me wel wederom opvalt zijn de fout(?)meldingen in de terminal:

(gedit:3361): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:3361): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-spell-enabled is niet mogelijk

** (gedit:3361): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-encoding is niet mogelijk

- Wat is dit en hoe los ik dit op.


Nu even herstarten en kijken hoe het er dan voor staat.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Corrigan schreef op maandag 15 januari 2018 @ 18:42:
[...]


Gebruik of SMB of NFS, niet door elkaar. In fstab staat cifs voor Samba.

Je bent nu in je laatste post met NFS bezig. Neem letterlijk mijn eerder geposte stappen door. Eentje vergeten of een hoofdletter verkeerd = No Glory.

Omdat je wel mappen ziet en geen inhoud heb je een machtigingen of rechten issue. Kijk op de Synology onder Gedeelde map of je wel alles goed hebt ingesteld zoals de screenshot. Bij Squash : Alle gebruikers aan root toewijzen en dezelfde vinken verder aanzetten.

Als je de Synology firewall gebruikt: zet NFS open voor je ip adres van de client.

Herstart daarna de Synology en je PC. De aanhouder wint. :)
Ik heb exact de aanwijzingen uit je eerdere post gevolgd, helaas zonder enig resultaat.
Geen zichtbare map onder netwerk, alleen nog steeds een NAS map in mijn persoonlijke folder waaronder wel de mappen van de NAS staan, maar als ik daarop klik zie ik geen bestanden. Bij het mapje van books staat er wel een zwart tekentje in het groene mapje, maar ook in die map zie ik niets.

NB: ik vind het nu echt niet grappig meer en ben de wanhoop nabij.
Is er werkelijk niemand die me kan helpen met deze eenvoudige vraag?

[Voor 5% gewijzigd door Videopac op 17-01-2018 23:30]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online
Videopac schreef op woensdag 17 januari 2018 @ 23:29:
Is er werkelijk niemand die me kan helpen met deze eenvoudige vraag?
Iedereen helpt, maar blijkbaar is er ergens een fout in je kennis en is de discussie troebel.


Begin even bij het begin en beantwoord de volgende simpele vragen:
  1. Welke distro gebruik je? (Fedora, Ubuntu, Mint, Slack, Suse, Kali, etc. etc.)
  2. Welke desktop omgeving? (GNOME, Unity, Cinnamon, MATE, KDE, Xfce, LXQT, etc.)
  3. Welke file browser gebruik je? (Dolphin, Konqueror, Nautilus, PCManFM, Nemo, Thunar, etc.)

Maak je niet druk, dat doet de compressor maar


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Videopac schreef op woensdag 17 januari 2018 @ 23:24:
Vanavond maar weer eens een uur aan deze soap besteden...

[...]

Wat is kio?
Wat is gvfs?
Dat zijn virtuele file systems van respectievelijk KDE en Gnome/GTK. Hiermee kan je via een file manager die het ondersteund naar locaties browsen zoals ftp://, smb:// e.d. zonder deze te moeten mounten. Dus iets als smb://<ip.van.nas/Volume1/books zou je je share moeten geven die je wilt. Alleen, je kan de bestanden daar mogelijk niet direct openen, omdat het programma dat eraan gekoppeld is ook die locatie moet ondersteunen en dat doen ze niet allemaal.
[...]

Dit snap ik niet. Je geeft toch gewoon een username en password op voor een account op de NAS en dat is dan toch het NAS-account waarmee gelezen en geschreven wordt?
Dat is precies wat er staat. Piet op je lokale machine logt in op de share van je nas als Klaas. Alles wat Piet schrijft, is van Klaas. Lokaal lijkt het echter alsnog van Piet te zijn, want dat geef je zo op bij de mount opties. Anders mag Piet niets volgens de lokale regels.
[...]

Dus ookal haal ik in fstab alle regels weg die iets met het benaderen van een netwerkshare te maken hebben weg en sla het op en herstart, dan kan er nog steeds ergens een verwijzing naar zo'n netwerkshare blijven staan? Ik vind dit niet logisch.
Dat is het ook niet en zou ook niet moeten gebeuren. Maar als je iets met autofs hebt gedaan zoals eerder aangegeven, dus iets in /etc/auto.master oid, wordt het ongeacht fstab toch beschikbaar. Had je daar nog iets mee gedaan?
De vraag is nu: hoe kom ik van die lelijke, ongevraagde nep-map in mijn persoonlijke map af?

Of is dit veroorzaakt door de commando's van Corrigan:
- Installeer in Mint nfs-common: sudo apt install nfs-common
- maak een map om je nas te mounten: sudo mkdir /mnt/nas
[...]

Samengevat: ik kan beter geen NFS gebruiken?
Als je verders helemaal niets met die locatie doet (met andere apparaten), dus ook niet met je NAS zelf kan je op zich prima NFS gebruiken. Je begon met Samba, dat werkte, het lijkt mij daarom logischer om dat weer aan de praat te krijgen dan iets geheel anders te doen wat mogelijk weer z'n eigen problemen heeft.
Ik ben nu nogmaals de stappen van Corrigan aan het doorlopen. Wat me wel wederom opvalt zijn de fout(?)meldingen in de terminal:

(gedit:3361): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:3361): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-spell-enabled is niet mogelijk

** (gedit:3361): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-encoding is niet mogelijk

- Wat is dit en hoe los ik dit op.
Dit zijn meldingen die je kan negeren. Deze komen van gedit en je krijgt die ongeacht welk bestand je opent. Draai 'm eens zonder bestand en sudo en je zal dezelfde meldingen zien.
Videopac schreef op woensdag 17 januari 2018 @ 23:29:
NB: ik vind het nu echt niet grappig meer en ben de wanhoop nabij.
Is er werkelijk niemand die me kan helpen met deze eenvoudige vraag?
Zoals hierboven al is geschreven door @DJMaze helpen we je waar we kunnen. Je vroeg zelfs dit:
Overigens is er tot nu toe geen Linux-specialist geweest die mij heeft kunnen uitleggen waarom zoiets veel gevraagds als het zichtbaar maken van netwerkfolders onder Linux zo idioot moeilijk gemaakt is.
Het is helemaal niet zo idioot moeilijk. In de basis is het gelijk aan Windows, daar rammel je \\ip.van.nas\share in de adresbalk van Verkenner en gaan. Dat is bij Linux net zo, alleen is de syntax van de URI iets anders, namelijk smb://. Het mappen naar een directe map is alleen wat anders.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
DJMaze schreef op donderdag 18 januari 2018 @ 02:11:
[...]

Iedereen helpt, maar blijkbaar is er ergens een fout in je kennis en is de discussie troebel.


Begin even bij het begin en beantwoord de volgende simpele vragen:
  1. Welke distro gebruik je? (Fedora, Ubuntu, Mint, Slack, Suse, Kali, etc. etc.)
  2. Welke desktop omgeving? (GNOME, Unity, Cinnamon, MATE, KDE, Xfce, LXQT, etc.)
  3. Welke file browser gebruik je? (Dolphin, Konqueror, Nautilus, PCManFM, Nemo, Thunar, etc.)
System: Host: bla-Latitude-5580 Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm Distro: Linux Mint 18.2 Sonya
Machine: System: Dell (portable) product: Latitude 5580 Chassis: type: 10
Mobo: Dell model: 0CMYFT v: A00 Bios: Dell v: 1.4.3 date: 05/11/2017
CPU: Dual core Intel Core i5-7300U (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848
clock speeds: min/max: 400/3500 MHz 1: 2700 MHz 2: 2700 MHz 3: 2700 MHz 4: 2700 MHz
Graphics: Card: Intel Device 5916 bus-ID: 00:02.0 chip-ID: 8086:5916
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz
GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio: Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:9d71
Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network: Card-1: Intel Ethernet Connection (4) I219-LM
driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6 chip-ID: 8086:15d7
IF: enp0s31f6 state: down mac: <filter>
Card-2: Intel Device 24fd driver: iwlwifi bus-ID: 02:00.0 chip-ID: 8086:24fd
IF: wlp2s0 state: up speed: N/A duplex: N/A mac: <filter>
Drives: HDD Total Size: 512.1GB (13.9% used)
ID-1: /dev/sda model: Micron_1100_SATA size: 512.1GB serial: 1723175A66C4
Partition: ID-1: / size: 453G used: 66G (16%) fs: ext4 dev: /dev/dm-1
ID-2: /boot size: 473M used: 257M (58%) fs: ext2 dev: /dev/sda2
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 40.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list.d/nathan-renniewaldock-flux-xenial.list
deb http: //ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu xenial main
deb-src http: //ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http: //mintlinux.mirror.wearetriple.com/packages sonya main upstream import backport
deb http: //mirror.netcologne.de/ubuntu xenial main restricted universe multiverse
deb http: //mirror.netcologne.de/ubuntu xenial-updates main restricted universe multiverse
deb http: //mirror.netcologne.de/ubuntu xenial-backports main restricted universe multiverse
deb http: //security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http: //archive.canonical.com/ubuntu/ xenial partner
Active apt sources in file: /etc/apt/sources.list.d/stebbins-handbrake-releases-xenial.list
deb http: //ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
deb-src http: //ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/vivaldi.list
deb http: //repo.vivaldi.com/stable/deb/ stable main
Info: Processes: 227 Uptime: 2 min Memory: 634.6/15903.3MB
Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
Client: Unknown python2.7 client inxi: 2.2.35

--

Ik zit er sterk over te denken Linux Mint gewoon opnieuw te installeren. Dat was erg weinig werk en dan ben ik van de erfenis van mijn gepruts tot nu toe af.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online
Videopac schreef op donderdag 18 januari 2018 @ 15:49:
Distro: Linux Mint 18.2 Sonya
Desktop: Cinnamon 3.4.6
FM: Nemo
Open een terminal venster in Cinnamon en doe eens het volgende:
code:
1
nemo smb://NASGEBRUIKERSNAAM@IP_VAN_NAS

Vervang NASGEBRUIKERSNAAM en IP_VAN_NAS met die van jou natuurlijk.

Wat is het resultaat?

Maak je niet druk, dat doet de compressor maar


  • Corrigan
  • Registratie: juni 2016
  • Niet online
Videopac schreef op donderdag 18 januari 2018 @ 15:49:
[...]

Ik zit er sterk over te denken Linux Mint gewoon opnieuw te installeren. Dat was erg weinig werk en dan ben ik van de erfenis van mijn gepruts tot nu toe af.
Opnieuw Mint installeren zal waarschijnlijk weinig nut hebben. Je geeft immers aan dat je je Nas mappen nu kunt zien met NFS, alleen kun je niet de inhoud zien. Dat icoon teken in 1 map zal waarschijnlijk een melding zijn dat alleen de root /admin user deze mag benaderen. Klinkt dat je alleen nog een rechtenissue hebt op je Synology en die moet je instellen op je NAS.

Het is allemaal niet moeilijk, alleen moet je zorgvuldig zijn met het instellen. En ook proberen te begrijpen wat je aan het doen bent, want alleen commando's overkloppen gaat vaak mis wanneer het bij jou net iets anders is.

Maar je bent niet de eerste die hier mee aan het worstelen bent. :)

Zie deze link met instellingen voor de rechten op je Synology:
https://robferguson.org/b...nfs-on-your-synology-nas/

Meer info over NFS of SMB is te vinden op de Wiki van Arch. Een van de best gedocumenteerde online Linux bronnen, ook voor als je geen Arch Linux gebruikt. https://wiki.archlinux.org/index.php/NFS

[Voor 10% gewijzigd door Corrigan op 18-01-2018 18:03]


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
DJMaze schreef op donderdag 18 januari 2018 @ 15:58:
[...]


Open een terminal venster in Cinnamon en doe eens het volgende:
code:
1
nemo smb://NASGEBRUIKERSNAAM@IP_VAN_NAS

Vervang NASGEBRUIKERSNAAM en IP_VAN_NAS met die van jou natuurlijk.

Wat is het resultaat?
Excuses voor de wat late reactie (druk met werk etc), maar: dit werkt! _/-\o_
Er wordt gevraagd om een wachtwoord en dan heb ik connectie en ik kan overal bij.
Alleen als ik vanuit een map terug wil naar het hoogste niveau werkt het niet, maar ik heb gemerkt dat je het commando ook met /<mapnaam> uit kunt voeren en dan ga je rechtstreeks naar die map.

Kan ik dit commando gewoon toevoegen aan fstab?

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Nee, want dat is een gvfs uri. Dat wat we eerder hadden voor je fstab zou gewoon moeten werken en is het equivalent voor wat je net uitvoerde.

Dit is vergelijkbaar, maar zorgt er voor dat je ook met andere programma's en je terminal erbij kan:
code:
1
sudo mount -t cifs -o username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000 //IPVANJENAS/sharenaam /media/nas

Uitgaande dat /media/nas bestaat op je PC, als het goed is nog wel.

Commandline FTW | Tweakt met mate


  • Corrigan
  • Registratie: juni 2016
  • Niet online
Alleen is het niet slim om je naam en password zomaar open in fstab te zetten.
Maak een apart bestandje aan, beveilig die en verwijs ernaar in fstab met credentials=.

credentials=/home/[je username zonder haken]/.smbcredentials

Zie verder onder Mount password protected network folders
https://wiki.ubuntu.com/MountWindowsSharesPermanently

[Voor 3% gewijzigd door Corrigan op 20-01-2018 12:53]


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Corrigan schreef op zaterdag 20 januari 2018 @ 12:52:
Alleen is het niet slim om je naam en password zomaar open in fstab te zetten.
Maak een apart bestandje aan, beveilig die en verwijs ernaar in fstab met credentials=.

credentials=/home/[je username zonder haken]/.smbcredentials

Zie verder onder Mount password protected network folders
https://wiki.ubuntu.com/MountWindowsSharesPermanently
:N Heb je het hele topic wel gelezen? Dat heb ik al meerdere keren genoemd. ;)

Commandline FTW | Tweakt met mate


  • Corrigan
  • Registratie: juni 2016
  • Niet online
Hero of Time schreef op zaterdag 20 januari 2018 @ 13:10:
[...]

:N Heb je het hele topic wel gelezen? Dat heb ik al meerdere keren genoemd. ;)
Klopt, maar het ging om je laatste post. Beter niet om ergens te adviseren om usernaam en password open en bloot in fstab te zetten. De TS zoekt een snelle oplossing en dan gaat het hup, zo in de fstab.

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Corrigan schreef op zaterdag 20 januari 2018 @ 13:28:
[...]

Klopt, maar het ging om je laatste post. Beter niet om ergens te adviseren om usernaam en password open en bloot in fstab te zetten. De TS zoekt een snelle oplossing en dan gaat het hup, zo in de fstab.
Lees het commando eens. Oh, he, een commando, geen entry in fstab. ;)

Commandline FTW | Tweakt met mate


  • DJMaze
  • Registratie: juni 2002
  • Niet online
@Videopac top dat het nemo commando werkt
Je weet nu dat SMB werkt met de juiste credentials.

Hero of Time geeft dan inderdaad de moeilijkere stap
Hero of Time in "Synology folders in Linux Mint bestandbeheer"

Zodra dit werkt kan je in fstab aan de gang

Maak je niet druk, dat doet de compressor maar


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op zaterdag 20 januari 2018 @ 12:48:
Nee, want dat is een gvfs uri. Dat wat we eerder hadden voor je fstab zou gewoon moeten werken en is het equivalent voor wat je net uitvoerde.

Dit is vergelijkbaar, maar zorgt er voor dat je ook met andere programma's en je terminal erbij kan:
code:
1
sudo mount -t cifs -o username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000 //IPVANJENAS/sharenaam /media/nas

Uitgaande dat /media/nas bestaat op je PC, als het goed is nog wel.
Wederom dank voor alle hulp. Ik krijg nu de volgende foutmelding:
"mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)"

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Videopac schreef op zondag 28 januari 2018 @ 09:18:
[...]

Wederom dank voor alle hulp. Ik krijg nu de volgende foutmelding:
"mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)"
Je hebt wel de zaken aangepast naar jouw omgeving neem ik aan. Het vreemde is ook nog eens dat het wel heeft gewerkt. Voor de zekerheid, je hebt cifs-utils nog steeds als package geïnstalleerd staan?

Even snel gegoogled op de foutmelding (mount cifs operation not supported) leert mij dat je nu blijkbaar wat extra opties mee moet geven bij het mounten. Probeer eens bij de -o regel 'vers=2.0' toe te voegen (eerste hits die ik lees hebben het over vers=1.0, zou je ook kunnen proberen maar heb ik minder vertrouwen in).

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op zondag 28 januari 2018 @ 11:19:
[...]

Je hebt wel de zaken aangepast naar jouw omgeving neem ik aan. Het vreemde is ook nog eens dat het wel heeft gewerkt. Voor de zekerheid, je hebt cifs-utils nog steeds als package geïnstalleerd staan?

Even snel gegoogled op de foutmelding (mount cifs operation not supported) leert mij dat je nu blijkbaar wat extra opties mee moet geven bij het mounten. Probeer eens bij de -o regel 'vers=2.0' toe te voegen (eerste hits die ik lees hebben het over vers=1.0, zou je ook kunnen proberen maar heb ik minder vertrouwen in).
ik heb cifs-utils nog steeds geïnstalleerd staan (heb een sudo apt-get install cifs-utils gedaan, omdat ik niet weet hoe ik anders kan controleren of cifs-utils geïnstalleerd zijn).

sudo mount -t cifs -o vers=2.0 username=...

werkt niet: ik krijg een opsomming van alle mogelijkheden van sudo mount, dus ik vermoed dat het geen geldige optie is.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Merethil
  • Registratie: december 2008
  • Laatst online: 22:51
Videopac schreef op zondag 28 januari 2018 @ 12:00:
[...]

ik heb cifs-utils nog steeds geïnstalleerd staan (heb een sudo apt-get install cifs-utils gedaan, omdat ik niet weet hoe ik anders kan controleren of cifs-utils geïnstalleerd zijn).

sudo mount -t cifs -o vers=2.0 username=...

werkt niet: ik krijg een opsomming van alle mogelijkheden van sudo mount, dus ik vermoed dat het geen geldige optie is.
Er staan komma's tussen de options die je moet meegeven, heb je die ook? Want anders ziet hij je vers=2.0 als optie voor de -o flag, en daarna gaat ie username proberen als nieuwe flag te parsen.

Kan je het volledige commando wat je net probeerde minus je user/pass (even obfusceren) posten?

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

En doe dan een -v bij zodat er meer informatie gegeven wordt over wat er gedaan wordt, dus dan zou het volledige commando dit moeten zijn:
sudo mount -v -t cifs -o username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0 //IPVANJENAS/sharenaam /media/nas


Ik las ook net nog dat je op de vorige pagina dezelfde foutmelding had (operation not permitted). Daar was ik helaas niet verder op in gegaan, had ik wel moeten doen. Dan hadden we mogelijk al verder geweest.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op zondag 28 januari 2018 @ 12:26:
En doe dan een -v bij zodat er meer informatie gegeven wordt over wat er gedaan wordt, dus dan zou het volledige commando dit moeten zijn:
sudo mount -v -t cifs -o username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0 //IPVANJENAS/sharenaam /media/nas


Ik las ook net nog dat je op de vorige pagina dezelfde foutmelding had (operation not permitted). Daar was ik helaas niet verder op in gegaan, had ik wel moeten doen. Dan hadden we mogelijk al verder geweest.
Dit werkt! Ik had die vers=2.0 niet met een , in het commando gezet.
Het gaat langzaamaan de goede kant op, dank voor jullie geduld!

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Mooi, dan is het tijd om dat in fstab te zetten. Als 't goed is heb je nog alles er staan van je eerdere pogingen. Enige wat je dan nog moet doen is de opties even matchen met het commando wat als laatste heeft gewerkt. Als je de enige gebruiker bent is het niet super belangrijk dat je een apart bestand hebt waar de inloggegevens van de share in staan, maar als je die al hebt, gebruik je die. Lees even terug in dit topic om te zien hoe dat ook alweer precies in z'n werk gaat. :)

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op zondag 28 januari 2018 @ 14:05:
Mooi, dan is het tijd om dat in fstab te zetten. Als 't goed is heb je nog alles er staan van je eerdere pogingen. Enige wat je dan nog moet doen is de opties even matchen met het commando wat als laatste heeft gewerkt. Als je de enige gebruiker bent is het niet super belangrijk dat je een apart bestand hebt waar de inloggegevens van de share in staan, maar als je die al hebt, gebruik je die. Lees even terug in dit topic om te zien hoe dat ook alweer precies in z'n werk gaat. :)
Aangezien dit simpele issue teveel frustraties opleverde heb ik het even geparkeerd.
Nu een nieuwe poging gewaagd.
"Dat" (sudo mount ... commando van hierboven) in fstab gezet, gereboot: nog steeds niks... :'(

NB: wat bedoel je met de enige gebruiker: ik ben de enige gebruiker op de laptop, op de NAS zijn uiteraard meerdere gebruikers aangemaakt.

Waarom is dit zo ontzettend verschrikkelijk moeilijk gemaakt in Linux???

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online
Videopac schreef op woensdag 21 februari 2018 @ 13:35:
Waarom is dit zo ontzettend verschrikkelijk moeilijk gemaakt in Linux???
Het is niet moeilijk als je weet wat je doet :)
Videopac schreef op woensdag 21 februari 2018 @ 13:35:
"Dat" (sudo mount ... commando van hierboven) in fstab gezet, gereboot: nog steeds niks... :'(
Dit doe je dus niet goed, je hebt namelijk al te horen gekregen dat "sudo mount" niet werkt in fstab ;)

Maak je niet druk, dat doet de compressor maar


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
DJMaze schreef op woensdag 21 februari 2018 @ 14:46:
[...]

Het is niet moeilijk als je weet wat je doet :)

[...]

Dit doe je dus niet goed, je hebt namelijk al te horen gekregen dat "sudo mount" niet werkt in fstab ;)
Sorry hoor, maar dit is gewoon wel moeilijk. Ik heb tot nu toe vele, zeer uiteenlopende adviezen gekregen die allemaal niet werken en het is niet duidelijk waarom niet. Mijn vraag is heel simpel en waarschijnlijk al veel vaker gesteld. Als het allemaal zo simpel is zeg me dan exact wat ik wel moet doen. Met dit soort halve antwoorden kan ik niks. Sorry voor de frustraties maar ik wil gewoon bij mijn bestanden kunnen.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online
Terminal:
code:
1
sudo mount -v -t cifs -o username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0 //IPVANJENAS/sharenaam /media/nas


fstab:
code:
1
//IPVANJENAS/sharenaam /media/nas cifs username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0    0    0

Vervolgens testen in een terminal
code:
1
sudo mount /media/nas

Maak je niet druk, dat doet de compressor maar


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

@Videopac, op de eerste pagina van dit topic staan meerdere regels met voorbeelden hoe een fstab regel eruit ziet. Het is ook uitgelegd hoe je de 'vertaling' maakt van het commando naar een regel in het bestand. Door je redelijk beperkte geduld ben je zo snel gefrustreerd dat je dit blijkbaar niet meer kan zien.
Gelukkig heeft @DJMaze het hierboven prachtig gedemonstreerd hoe het precies zit.

Met "enige gebruiker" bedoelde ik idd je laptop. Als daar niemand anders op zit, maakt het niet echt meer uit of je nou de inloggegevens voor de share op je NAS direct in fstab zet of een apart bestand dat alleen door root is te lezen.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op woensdag 21 februari 2018 @ 20:09:
@Videopac, op de eerste pagina van dit topic staan meerdere regels met voorbeelden hoe een fstab regel eruit ziet. Het is ook uitgelegd hoe je de 'vertaling' maakt van het commando naar een regel in het bestand. Door je redelijk beperkte geduld ben je zo snel gefrustreerd dat je dit blijkbaar niet meer kan zien.
Gelukkig heeft @DJMaze het hierboven prachtig gedemonstreerd hoe het precies zit.

Met "enige gebruiker" bedoelde ik idd je laptop. Als daar niemand anders op zit, maakt het niet echt meer uit of je nou de inloggegevens voor de share op je NAS direct in fstab zet of een apart bestand dat alleen door root is te lezen.
Het enige dat ik zie is dat er continu beweerd wordt dat het wel makkelijk is als je maar weet hoe het werkt, worden er meerdere oplossingen aangedragen die niet werken, wordt er verwezen naar enorme lappen tekst en volgt er een discussie over welke lottogetallen er nu wel of niet achter moeten staan om de rechten goed in te kunnen stellen (de bedoeling was/is om gewoon de rechten van het useraccount op de NAS te gebruiken).

En dan ben ik degene die het niet snapt 8)7

Overigens: als ik nu met gedit fstab probeer te editen krijg ik op de command prompt allerlei (fout)meldingen:

(gedit:5531): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:5531): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-spell-enabled is niet mogelijk

** (gedit:5531): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-encoding is niet mogelijk

** (gedit:5531): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-spell-enabled is niet mogelijk

** (gedit:5531): WARNING **: Set document metadata failed: Instellen van attribuut metadata::gedit-encoding is niet mogelijk

Kan dit kwaad?

Edit: ik start even opnieuw op en probeer het dan opnieuw...

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
DJMaze schreef op woensdag 21 februari 2018 @ 17:17:
Terminal:
code:
1
sudo mount -v -t cifs -o username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0 //IPVANJENAS/sharenaam /media/nas


fstab:
code:
1
//IPVANJENAS/sharenaam /media/nas cifs username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0    0    0

Vervolgens testen in een terminal
code:
1
sudo mount /media/nas
Dank.

Even dat ik het snap: ik moet alle 3 regels 1 voor 1 uitvoeren?

En wat doen ze dan precies?
Zo'n sudo mount: die koppelt een externe share aan een lokale map, toch?
Wat doet dan fstab? Dat is geen batchbestand dat bij opstarten uitgevoerd wordt begrijp ik.

Ik wil het graag snappen maar het komt echt totaal niet aan. Heb echt het idee dat ik langzaam gek aan het worden ben. Des te harder er hier geroepen wordt dat het allemaal toch echt wel simpel is des te minder ik ervan snap.

[Voor 9% gewijzigd door Videopac op 21-02-2018 21:52]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Fstab staat voor file system table. Zoals de naam dus al aangeeft is het een tabel met de definities van file systems die gekoppeld moeten worden of kunnen worden aan specifieke locaties.

De drie regels die DJMaze heeft gepost laat de vertaling zien. Althans, de eerste twee. Je hebt een commando dat een werkt en bereikt wat je wilt. Het commando bevat een aantal 'velden'. Zet deze in de juiste volgorde in fstab en het werkt. Een paar neem je niet mee, zoals 'sudo', 'mount' en '-t'.

In Hero of Time in "Synology folders in Linux Mint bestandbeheer" geef ik je al bijna letterlijk wat je in fstab moet zetten. Er zijn maar 2 punten die je moet aanpassen en dat is de NAS locatie en de gebruikersnaam en wachtwoord om op de share te kunnen komen.

In je post Videopac in "Synology folders in Linux Mint bestandbeheer" vraag je al over die gedit meldingen en even later weer. Antwoord: niet boeiend.

Afrondend, in Videopac in "Synology folders in Linux Mint bestandbeheer" geef je aan dat het volgende werkt:
sudo mount -v -t cifs -o username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0 //IPVANJENAS/sharenaam /media/nas

Waarbij je uiteraard de zaken in hoofdletters hebt aangepast naar je omgeving. Dan is dit wat je in fstab zet, voorgekauwd en al:
code:
1
//IPVANJENAS/sharenaam    /media/nas    cifs    username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0

Zo heel moeilijk is het echt niet. Je doet alsof je iemand naar Mars moet sturen.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Hero of Time schreef op woensdag 21 februari 2018 @ 22:15:
Fstab staat voor file system table. Zoals de naam dus al aangeeft is het een tabel met de definities van file systems die gekoppeld moeten worden of kunnen worden aan specifieke locaties.

De drie regels die DJMaze heeft gepost laat de vertaling zien. Althans, de eerste twee. Je hebt een commando dat een werkt en bereikt wat je wilt. Het commando bevat een aantal 'velden'. Zet deze in de juiste volgorde in fstab en het werkt. Een paar neem je niet mee, zoals 'sudo', 'mount' en '-t'.

In Hero of Time in "Synology folders in Linux Mint bestandbeheer" geef ik je al bijna letterlijk wat je in fstab moet zetten. Er zijn maar 2 punten die je moet aanpassen en dat is de NAS locatie en de gebruikersnaam en wachtwoord om op de share te kunnen komen.

In je post Videopac in "Synology folders in Linux Mint bestandbeheer" vraag je al over die gedit meldingen en even later weer. Antwoord: niet boeiend.

Afrondend, in Videopac in "Synology folders in Linux Mint bestandbeheer" geef je aan dat het volgende werkt:
sudo mount -v -t cifs -o username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0 //IPVANJENAS/sharenaam /media/nas

Waarbij je uiteraard de zaken in hoofdletters hebt aangepast naar je omgeving. Dan is dit wat je in fstab zet, voorgekauwd en al:
code:
1
//IPVANJENAS/sharenaam    /media/nas    cifs    username=JOUWGEBRUIKER,password=JOUWWACHTWOORD,uid=1000,gid=1000,vers=2.0

Zo heel moeilijk is het echt niet. Je doet alsof je iemand naar Mars moet sturen.
Dank voor jullie geduld. Waarschijnlijk omdat het in mijn allergie terecht gekomen is lukt goed nadenken niet meer of zo.

In ieder geval: ik heb wat lopen aanpassen in fstab en vervolgens met mount -a gecontroleerd. En zowaar: het werkt _/-\o_ Het enige is dat hij nu gemount is onder mijn computer - mijn bestandssysteem - mnt - nas. Hoe krijg ik mijn NAS netwerkshares netjes onder netwerk te zien?

Edit: en ik heb in mijn Persoonlijke Map nog een map NAS waarin ik wel de directories op NAS kan zien maar niet de bestanden. Dat is waarschijnlijk een overblijfsel van een eerdere poging. In fstab staat er echter geen enkele verwijzing naar.

[Voor 5% gewijzigd door Videopac op 21-02-2018 22:36]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online
Videopac schreef op woensdag 21 februari 2018 @ 22:30:
Het enige is dat hij nu gemount is onder mijn computer - mijn bestandssysteem - mnt - nas. Hoe krijg ik mijn NAS netwerkshares netjes onder netwerk te zien?
Goh, als je dat nou direct vroeg hadden we 3 pagina's lang niet hoeven klooien met sudo en fstab.
Die hebben er namelijk niks mee te maken.
Dan is het enige wat je wilde, dat "nemo" commando zonder dat je dat hoeft typen.

Ik gebruik KDE Dolphin, en daar kan het out-of-the-box zo:

Een beetje op de windows manier dus.

Maak je niet druk, dat doet de compressor maar


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Alleen werkt het via het "netwerk" gedeelte niet met alle programma's en dan krijgen we daar weer een topic over. ;) Je wilt 'm dus eigenlijk niet onder "netwerk" zichtbaar hebben. Wil je snel toegang en staat 't niet in de linkerkant, dan sleep je de hoofdmap daar gewoon heen, wordt het automatisch een 'snelle toegang' keuze.

Commandline FTW | Tweakt met mate


  • DJMaze
  • Registratie: juni 2002
  • Niet online
Goed punt, dat is dan ook het enige wat beter werkt in Windows 🙊 ;)

Maak je niet druk, dat doet de compressor maar


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Aan de ene kant ben ik blij dat er nu iets werkt, maar begrijp ik nu goed dat ik mijn netwerkshare niet op het hoogste niveau in de verkenner zichtbaar kan maken, maar alleen als map in een submap?

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
DJMaze schreef op woensdag 21 februari 2018 @ 23:33:
[...]

Goh, als je dat nou direct vroeg hadden we 3 pagina's lang niet hoeven klooien met sudo en fstab.
Die hebben er namelijk niks mee te maken.
Dan is het enige wat je wilde, dat "nemo" commando zonder dat je dat hoeft typen.

Ik gebruik KDE Dolphin, en daar kan het out-of-the-box zo:
[afbeelding]
Een beetje op de windows manier dus.
Ik heb naar mijn mening vanaf het begin duidelijk proberen te maken dat ik het linux-alternatief voor net use zocht, zodat netwerkshares op de meest logische plek zichtbaar zijn, namelijk onder netwerk.

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800


  • DJMaze
  • Registratie: juni 2002
  • Niet online

Maak je niet druk, dat doet de compressor maar


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:47

Hero of Time

Moderator NOS

There is only one Legend

Videopac schreef op vrijdag 23 februari 2018 @ 23:42:
Aan de ene kant ben ik blij dat er nu iets werkt, maar begrijp ik nu goed dat ik mijn netwerkshare niet op het hoogste niveau in de verkenner zichtbaar kan maken, maar alleen als map in een submap?
Het allerhoogste niveau is /, daar kan je niet zomaar iets anders aan hangen. Je kan wel onder /netwerk of /ditiseenmapopdenasdiegedeeldis hangen. Je moet alleen zorgen dat die map eerst bestaat, dat is de enige vereiste.

Als je in je 'verkenner' een stukje links hebt genaamd "Places", dan kan je daar een map heen slepen en wordt het een snelkoppeling zodat je er makkelijk en snel heen kan.

Commandline FTW | Tweakt met mate


  • Videopac
  • Registratie: november 2000
  • Laatst online: 07:46
Het werkt nu naar mijn zin.
Dank voor alle hulp en geduld.

@Hero of Time d:)b _O_
@DJMaze d:)b _O_

Ik kan geen beste antwoord kiezen aangezien jullie me samen de weg gewezen hebben.

[Voor 3% gewijzigd door Videopac op 26-02-2018 23:03]

Opnsense (Odroid H2) DS918+ 4x8TB WD RED, SB Touch, Odroid C2, Netgear R7800

Pagina: 1


Apple iPhone SE (2020) Microsoft Xbox Series X LG CX Google Pixel 4a CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True