Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Intel integrated graphics screen tear

Pagina: 1
Acties:

  • headphoneguy
  • Registratie: mei 2013
  • Laatst online: 15:39
Beste tweakers,

Ubuntu 15.10 icm met gnome metacity
Mijn nuc5ppyh met 4gb ram en integrated hd graphics vertoont screen tearing.
Het probleem doet zich voor als op full screen hd video wordt afgespeeld.
Dit kan zijn via pipelight, html5 of een lokaal filmbestand.
Het volgende heb ik geprobeerd om het probleem te verhelpen.

- intel graphics installer zijn werk laten doen om de boel netjes te laten updaten
- /etc/X11/xorg.conf.d/20-intel.conf ziet er als volgt uit:
Section "Device"
Identifier "Intel Graphics"
Driver "Intel"
Option "AccelMethod" "sna"
Option "TearFree" "true"
Option "TripleBuffer" "true"
Option "MigrationHeuristic" "greedy"
Option "Tiling" "true"
Option "Pageflip" "true"
Option "ExaNoComposite" "false"
Option "Tiling" "true"
Option "Pageflip" "true"
EndSection

*Option "TearFree" "true" en Option "TripleBuffer" "true" heb ik er weer uit gehaald omdat die voor extra veel buffertijd bij streams zorgde bij pipelight streams.

Verder heb ik geprobeerd in compizconfig settings manager:
- check "Don't wait for video sync"
- check "Force Complete redraw on initial damage"
- check "Force full screen redraws (buffer swap) on repaint"

De fix in deze link verhelpt het ook niet: http://www.rottenrei.be/p...ing-on-intel-hd-graphics/

Deze package installeren zou voor vele mensen een fix zijn maar werkt bij mij niet : https://launchpad.net/ubu.../xserver-xorg-video-intel

Ik zie door de bomen het bos niet meer.
Kan iemand mij een zetje in de goeie richting geven?

[Voor 27% gewijzigd door headphoneguy op 11-12-2015 21:39]


  • Thralas
  • Registratie: december 2002
  • Laatst online: 17:16
En deze?

  • Loggedinasroot
  • Registratie: maart 2009
  • Laatst online: 30-10 19:24
Ik heb dit zelf ook icm de i5 4430-HD4600.
Het is bij mij alleen een probleem met een dual monitor set up. Als ik de andere monitor disable(software) dan verdwijnt de tearing. Ik weet niet of je dual monitor hebt maar het werkt in ieder geval voor mij.

  • headphoneguy
  • Registratie: mei 2013
  • Laatst online: 15:39
Bij jou is het probleem niet aanwezig bij een single monitor setup?
De nuc is aangesloten op de tv dus geen dual monitors hier..

Wat betreft Thralas z'n link, hij lost zijn flickering probleem op en niet zijn screen tearing voor zover ik weet. Ook vind ik geen duidelijke info wat betreft die i915.enable_ips=0 module. Wil ook niet al teveel spelen met die i915 settings aangezien ik al een flinke driver crash heb gehad. Zit nu op een iets minder zware Ubuntu, Xubuntu met xfce. Overall iets betere video performance maar nog steeds tearing.

Ik zal kijken of ik de tearing tot een acceptabel level kan krijgen. Dit heb ik in pipelight wel enigzins voor elkaar gekregen door hw acceleration aan te zetten. Die stond blijkbaar uit.

[Voor 17% gewijzigd door headphoneguy op 11-12-2015 21:37]


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 15:24

Hero of Time

Moderator NOS

There is only one Legend

Xfce heeft ook een compositor optie, zet die eens aan en kijk wat er dan gebeurt met je probleem.

Commandline FTW | Tweakt met mate


  • headphoneguy
  • Registratie: mei 2013
  • Laatst online: 15:39
De compositor staat standaard aan in xfce. Ik zal verder zoeken of ik een oplossing kan vinden

  • InflatableMouse
  • Registratie: december 2006
  • Laatst online: 24-10 11:04

InflatableMouse

Vinyl Bliss!

De compositor staat standaard niet aan, mischien "standaard" op Ubuntu, maar dat is dan door Ubuntu aangepast en dus niet standaard ;).

Draai zelf xfce4 met xfce compositor enabled en tearfree optie enabled in xorg.conf. Geen screen tearing maar dit is op Arch, geen Ubuntu :).

De standaard ubuntu is toch gebaseerd op gnome? Die zou geen screen tearing mogen hebben met de open source intel drivers. De Live CD hier doet het goed in ieder geval. Ook toen ik Gnome draaide (wederom op Arch :P) had ik met de intel drivers geen tearing.

Ik gebruik alleen deze opties:

code:
1
2
3
4
5
6
7
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"   "glamor"
    Option      "DRI"       "3"
    Option      "TearFree"  "true"
EndSection


PS. op m'n ouwe NUC (3de gen i5) had ik ook nooit last van tearing en op de 2 NUCjes die ik een maandje of wat terug voor m'n ouders heb geinstalleerd (nieuwe i3'tjes) met Arch+Gnome ook niet.

[Voor 11% gewijzigd door InflatableMouse op 12-12-2015 18:07]


  • headphoneguy
  • Registratie: mei 2013
  • Laatst online: 15:39
compositor stond al enabled bij (xfce settings -windows manager tweaks)

Ik heb nu ineens een andere intel conf gevonden bij /usr/share/X11/xorg.conf.d/20-intel.conf waarbij de option tearfree en triplebuffer de tearing had opgelost bij mijn asus305fa!
Ik probeer namelijk eerst op mn laptop de tearing te fixen en vervolgens de fix toe te passen op mijn nuc.

Straks maar eens kijken of dit ook werkt op mijn nuc. Triplebuffer schijnt zwaar te zijn voor minder krachtige cpu's dus ik zal kijken of deze option nodig is op mijn nuc.

Mag ik vragen waarom jij accelmethod glamor gebruikt? Deze is 2d toch?
En vanwaar de option DRI ¨3¨ ?

[Voor 19% gewijzigd door headphoneguy op 12-12-2015 18:52]


  • InflatableMouse
  • Registratie: december 2006
  • Laatst online: 24-10 11:04

InflatableMouse

Vinyl Bliss!

Ik heb gelogen trouwens, (let er niet meer zo op maar het is wel storend ja) maar op XFCE heb ik wel last van tearing. Bug in XFCE. De omschrijving is crap, maar het gaat erom dat xrender niet goed werkt. Je ziet het in filmpjes op het internet, youtube, html5, op Tweakers video reviews, maar ook simpel scrollen in en browser met smooth scrolling. Om dat op te lossen zul je over moeten stappen op een andere compositor, Compton of kwin bijvoorbeeld.
headphoneguy schreef op zaterdag 12 december 2015 @ 18:49:
Mag ik vragen waarom jij accelmethod glamor gebruikt? Deze is 2d toch?
Ja. Experimental middels OpenGL. Je kan het ook niet gebruiken dan heb je software rendering voor 2D.
Default is DRI 2 als je het niet specificeert.

  • headphoneguy
  • Registratie: mei 2013
  • Laatst online: 15:39
Hmm misschien dat je die conf die ik aangeef kan vinden? Wie weet lost het probleem bij jou ook zo op namelijk. Het is wel zo dat ik die oplossing nu alleen nog geprobeerd heb op gnome3. Moet nog een keer de nuc aanzetten en die oplossing proberen. Heb nu alleen ff geen zin na zo lang research, trial and error (and error and error)

Wat betreft die compositor, ik heb compton geinstalleerd via deze link > http://www.rottenrei.be/p...ing-on-intel-hd-graphics/
Start ook op boot!

Echter was het probleem helemaal verholpen na die 2e conf file gevonden en edited te hebben.
Moet wel zeggen dat het wel allemaal net iets vloeiender was met compton, of gevalletje placebo?

Ps. Je zegt om het probleem op te lossen in xfce een geval is van een andere compositor gebruiken.
Vanwaar gebruik je die dan niet? Of kijk je om de tearing heen haha.

[Voor 10% gewijzigd door headphoneguy op 12-12-2015 20:10]


  • InflatableMouse
  • Registratie: december 2006
  • Laatst online: 24-10 11:04

InflatableMouse

Vinyl Bliss!

headphoneguy schreef op zaterdag 12 december 2015 @ 20:08:
Hmm misschien dat je die conf die ik aangeef kan vinden?
Daar heb ik wel wat staan maar die settings die je noemt horen daar niet, vind ik. Daar heb je /etc/X11 voor. Als ze daarin niet werken dan werken ze ergens anders (als het daar al werkt) ook niet, volgens mij.
headphoneguy schreef op zaterdag 12 december 2015 @ 20:08:
Vanwaar gebruik je die dan niet? Of kijk je om de tearing heen haha.
Omdat ik mijn systeem pas een week heb draaien (nieuwe hardware) en te druk ben met andere dingen om dit nu te doen. Mischien vanavond, effe tussendoor zeg maar. Bovendien zoals ik m'n PC nu gebruik heb er niet zo veel last van, eigenlijk. Zit alleen maar in VM's en in terminals te kloppen op het moment.

  • headphoneguy
  • Registratie: mei 2013
  • Laatst online: 15:39
InflatableMouse schreef op zaterdag 12 december 2015 @ 20:22:
[...]


Daar heb ik wel wat staan maar die settings die je noemt horen daar niet, vind ik. Daar heb je /etc/X11 voor. Als ze daarin niet werken dan werken ze ergens anders (als het daar al werkt) ook niet, volgens mij.
Toch loste dat in 1 klap mijn tearing op.
Niet dat ik dat erg vind natuurlijk. O-)

Er is natuurlijk ook de kans dat op 1 of andere manier de settings van /etc/X11 toch bleven hangen en ineens gingen werken. Heb die namelijk niet aangepast meer. Maar wat die settings dan toch inzette blijft dan ook nog een raadsel.

[Voor 21% gewijzigd door headphoneguy op 12-12-2015 20:41]


  • InflatableMouse
  • Registratie: december 2006
  • Laatst online: 24-10 11:04

InflatableMouse

Vinyl Bliss!

Dat kan natuurlijk.

De bestanden in /usr/share/X11/xorg.conf.d/ zijn eigenlijk voor de defaults van de distro of leverancier, niet voor de eindgebruiker, daar is /etc/X11 voor.

Met andere woorden, wat je hebt gedaan kan wel en werkt, maar als je die setting in /etc/X11 had gezet had het hetzelfde effect gehad. Je geeft aan dat dit niet of niet goed werkte, dan is het mijns inziens beter uit te zoeken waarom dat niet werkt (conflicterende settings? Typo's?)

Probleem met /usr/share/X11 is dat wanneer de leverancier besluit dat er iets moet veranderen aan de door hun geleverde defaults, het jouw wijziging kan verwijderen.

Maanden later kan jij dus ineens weer een probleem hebben en zit je je nog wezenlozer te zoeken dan je nu al doet.

  • headphoneguy
  • Registratie: mei 2013
  • Laatst online: 15:39
Het zou heel goed kunnen dat settings bij mij conflicteren maar waarom zou ik je niet kunnen zeggen.
In mijn situatie is deze alternatieve conf aanpassen de enige oplossing. Mijn kennis reikt niet verder dan dat wat betreft linux. Ik ben op mijn nuc begonnen met een schone build dus ik zal kijken wat er zal gebeuren als ik nu de /etc/X11/intel-20.conf aanpas.

mijn nuc accepteert alles in /etc/X11/xorg.conf.d/intel-20.conf
screen tearing is gone en heb verder niet aan de andere conf gezeten.
Dit is volgens jou update proof toch?

Ik zal proberen te kijken of ik het probleem van mijn laptop kan vinden waarom die de settings niet accepteert. Kan me ook niet herinneren hoe die location "xorg.conf.d" en conf file zijn ontstaan op mijn laptop want op mijn nuc heb ik deze zelf aangemaakt via sudo mkdir en sudo touch.

Zal morgen op mn laptop hetzelfde proberen en die andere conf weer aanpassen naar wat het was.
Overigens gebruik ik op beide systemen compton.

[Voor 45% gewijzigd door headphoneguy op 13-12-2015 00:27]


  • InflatableMouse
  • Registratie: december 2006
  • Laatst online: 24-10 11:04

InflatableMouse

Vinyl Bliss!

Ja /etc/X11 is update proof.

Gisteren ook nog snel even Compton gecompileerd, werkt toch wel fijn met een goeie config.
Pagina: 1


Microsoft Xbox Series X LG CX Google Pixel 5 CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True