Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

  • Johan9711
  • Registratie: maart 2013
  • Laatst online: 24-05 11:59

Johan9711

Verslaaft aan Tweakers

Topicstarter
Beste medetweakers,

Ik zit met een vreemd probleem, waar ik niet uit kom.


Sinds versie 5 ondersteunt Virtual Box nested virtualisation, waardoor je een VM in een VM moet kunnen draaien. Nu ben ik voor mijn hobby bezig met een Xen Server, En ik wil daar in twee Windows 10 clients draaien. Echter als ik die clients wil starten, krijg ik de melding dat VT-x niet aan staat, terwijl die toch echt staat aangevinkt in de instellingen van de VM. Heeft iemand nog ideeen, of ben ik gewoon tegen een bug in Virtual Box aangelopen?

Wat ik zelf al heb geprobeerd:
- Googelen (niets relevants kunnen vinden)
- Host herstart (W10 education)
- Virtual Box herstart

Alvast bedankt!

Edit:
Na een aantal vragen het volgende ter verduidelijking:
- Melding in Xenserver is de melding die hier staat beschreven: http://support.citrix.com/article/CTX131386
- ESXi draait wel in VB (enkel 32 bit, maar het werkt, ik krijg wel de melding dat VT-x uit staat)

Johan9711 wijzigde deze reactie 03-11-2015 08:42 (16%)

Mijn tweakblog: http://johan9711.tweakblogs.net/


  • Xudonax
  • Registratie: november 2010
  • Laatst online: 24-05 14:20
Wat is de hardware waar je op draait? Als dit een oudere Intel of AMD chip is dan zal dit sowieso niet aanstaan, en anders moet je dit mogelijk in het BIOS nog inschakelen. Ik blijf me erover verbazen hoeveel apparaten er nog met dit soort features uit geleverd worden (ook zakelijk).

  • Johan9711
  • Registratie: maart 2013
  • Laatst online: 24-05 11:59

Johan9711

Verslaaft aan Tweakers

Topicstarter
Host is een i3-4160, VT-x staat aan in de BIOS.

Mijn tweakblog: http://johan9711.tweakblogs.net/


  • johnkeates
  • Registratie: februari 2008
  • Laatst online: 01:46
Ik weet niet welke Xen je draait, maar wat zegt dmesg en xl/xm/xe info? Daar kan je aan opmaken of VT-x gedetecteerd is.

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 24-05 23:41

Hero of Time

Moderator NOS/CSA

There is only one Legend

Hoe draai je VirtualBox? Als ik je goed begrijp heb je XenServer op je systeem geïnstalleerd en daarin Windows 10 draaien. Vervolgens wil je in die VM nog eens VirtualBox draaien en verwacht je dat VT-x beschikbaar is. Dat gaat niet werken, nested virtualisatie wil je hoe dan ook niet en nested VT-x gaat niet werken. VMWare heeft het maar dat is zo'n nare vieze hack, dat wil je eigenlijk ook niet.

Spekkies | Commandline FTW


  • Johan9711
  • Registratie: maart 2013
  • Laatst online: 24-05 11:59

Johan9711

Verslaaft aan Tweakers

Topicstarter
quote:
Hero of Time schreef op maandag 02 november 2015 @ 19:32:
Hoe draai je VirtualBox? Als ik je goed begrijp heb je XenServer op je systeem geïnstalleerd en daarin Windows 10 draaien. Vervolgens wil je in die VM nog eens VirtualBox draaien en verwacht je dat VT-x beschikbaar is. Dat gaat niet werken, nested virtualisatie wil je hoe dan ook niet en nested VT-x gaat niet werken. VMWare heeft het maar dat is zo'n nare vieze hack, dat wil je eigenlijk ook niet.
Nee, Windows 10 is host. Vervolgens heb ik daar in een VM Xen draaien.

Mijn tweakblog: http://johan9711.tweakblogs.net/


  • Xudonax
  • Registratie: november 2010
  • Laatst online: 24-05 14:20
Als ik het goed begrijp heb je een host, met daarop in Virtualbox dus Xen Server. Vervolgens wil je in Xen server weer twee Windows 10 VM's starten?

Volgens de Intel ARK doet je CPU inderdaad VT-x, dus so far so good. Als ik echter ga zoeken op Xen nested virtualisation dan vind ik dat je ook nog wat in de Xen configuratie moet aanpassen. Heb je dat ook gedaan?

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 24-05 23:41

Hero of Time

Moderator NOS/CSA

There is only one Legend

quote:
Johan9711 schreef op maandag 02 november 2015 @ 19:33:
[...]


Nee, Windows 10 is host. Vervolgens heb ik daar in een VM Xen draaien.
Dan zit je met hetzelfde probleem. VT-x is niet beschikbaar in een VM.

Kijk eens in het log van de VM wat voor melding daar staat als VB de foutmelding geeft. Daarnaast, heb je nog andere dingen geïnstalleerd staan, zoals Hyper-V in geval je Windows 10 Pro gebruikt?

Spekkies | Commandline FTW


  • zerox123
  • Registratie: mei 2009
  • Laatst online: 08:34
Ik heb onder VirtualBox ESXi 6 werkend gekregen. In ESXi had ik ook een virtueel systeem draaien.
Het is qua performance nutteloos, maar als test opstelling(ik wilde weten hoe ESXi werkte) prima mogelijk.
Ik zal eens probleren of dat XenServer ook werkt.

  • Johan9711
  • Registratie: maart 2013
  • Laatst online: 24-05 11:59

Johan9711

Verslaaft aan Tweakers

Topicstarter
quote:
zerox123 schreef op dinsdag 03 november 2015 @ 07:58:
Ik heb onder VirtualBox ESXi 6 werkend gekregen. In ESXi had ik ook een virtueel systeem draaien.
Het is qua performance nutteloos, maar als test opstelling(ik wilde weten hoe ESXi werkte) prima mogelijk.
Ik zal eens probleren of dat XenServer ook werkt.
Ik heb nu inderdaad esxi 5.5 ook draaien in virtual box, en die geeft geen problemen. wel een melding dat vt-x niet beschikbaar is, maar voor 32-bits besturingssystemen maakt dat niet uit. schijnbaar is het toch ergens instelling in xen.

Mijn tweakblog: http://johan9711.tweakblogs.net/


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 24-05 23:41

Hero of Time

Moderator NOS/CSA

There is only one Legend

quote:
Johan9711 schreef op dinsdag 03 november 2015 @ 08:19:
[...]


Ik heb nu inderdaad esxi 5.5 ook draaien in virtual box, en die geeft geen problemen. wel een melding dat vt-x niet beschikbaar is, maar voor 32-bits besturingssystemen maakt dat niet uit. schijnbaar is het toch ergens instelling in xen.
Waar krijg je nou die melding? Van VirtualBox of van XenServer?

Spekkies | Commandline FTW


  • Johan9711
  • Registratie: maart 2013
  • Laatst online: 24-05 11:59

Johan9711

Verslaaft aan Tweakers

Topicstarter

Mijn tweakblog: http://johan9711.tweakblogs.net/


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 24-05 23:41

Hero of Time

Moderator NOS/CSA

There is only one Legend

Maar dat heb ik toch al 2x gezegd? VT-x in een VB VM is niet beschikbaar.
quote:
Hero of Time schreef op maandag 02 november 2015 @ 19:32:
Hoe draai je VirtualBox? Als ik je goed begrijp heb je XenServer op je systeem geïnstalleerd en daarin Windows 10 draaien. Vervolgens wil je in die VM nog eens VirtualBox draaien en verwacht je dat VT-x beschikbaar is. Dat gaat niet werken, nested virtualisatie wil je hoe dan ook niet en nested VT-x gaat niet werken. VMWare heeft het maar dat is zo'n nare vieze hack, dat wil je eigenlijk ook niet.
quote:
Hero of Time schreef op maandag 02 november 2015 @ 19:35:
[...]

Dan zit je met hetzelfde probleem. VT-x is niet beschikbaar in een VM.
Dus wat je wilt doen gaat never nooit werken. VMware doet het met een hack (software emulatie) en heeft VT-x vziw niet als harde eis, daarom kan het ook in een VMWare workstation/server VM draaien.

Spekkies | Commandline FTW

Pagina: 1


OnePlus 7 Pro (8GB intern) Microsoft Xbox One S All-Digital Edition LG OLED C9 Google Pixel 3a XL FIFA 19 Samsung Galaxy S10 Sony PlayStation 5 Games

Tweakers vormt samen met Tweakers Elect, Hardware.Info, Autotrack, Nationale Vacaturebank, Intermediair en Independer de Persgroep Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True