Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

NFS en SMB op Synology

Pagina: 1
Acties:

Acties:
  • 0Henk 'm!

  • ScooBY_DoO
  • Registratie: november 2000
  • Laatst online: 08-09 13:55
Geachte lezer,

Ik heb 3 mediaplayers in mijn netwerk hangen.
1 Xtreamer MK1
1 Xtreamer sidewinder 3
1 Popcorn A210

Alle players worden ''gevoed'' door een Synology DS214Play.

Alle players werken via NFS.

Sinds kort krijg ik SMB niet meer aan de praat op de SW3, welke ik nodig heb om full 3D af te kunnen spelen.
Via NFS stottert en hapert elke full 3D film, via SMB werkt dit prima.

Probleem is nu dus, SMB is met geen mogelijkheid meer werkend te krijgen. (op de SW3)
De Popcorn heeft het nooit gedaan via SMB maar dat vind ik niet erg dus daar heb ik ook geen tijd in gestoken.
De MK1 doet het prima op zowel NFS als SMB..... :X

Vandaag een maatje langs gehad met zijn MED600X3D.
Ook die krijgt geen toegang via SMB, wel via NFS en het lijkt er sterk op dat die Mede8er wel zonder stotteren full 3D afspeelt.

Nou is het vrij eenvoudig om dus een andere player aan te gaan schaffen maar het heeft 100% gewerkt (paar maanden terug) en verder ben ik dik tevreden ermee dus sja... wellicht kan hier iemand wat pointers geven...?

Er is geen nieuwere fw voor de SW3, ik heb vandaag wel een eerdere fw erop gezet, dit maakte niets uit.

Ik heb in de Synology van alles geprobeerd te wijzigen (Sinds vandaag een update met SMB 3 geïmplementeerd) niets mag baten tot op heden.

Modem/router gereset alsmede meerdere keren de SW3 en MED600X3D gereset naar eerdere en laatste fw's....

Ik hoop dat iemand dit probleem herkent of me in de juiste richting kan helpen.

TIA

  • ShadowLord
  • Registratie: juli 2000
  • Laatst online: 22:11
Kun je met een Windows machine wel op de netwerk shares van je NAS (SMB is namelijk de Windows methode van netwerk shares)? Als je er met Windows ook niet bij kan heb je waarschijnlijk je shares niet goed geconfigureerd op de Synology.

Het makkelijkste om dit te testen is om met Windows Verkenner te gaan naar '\\aaa.bbb.ccc.ddd' waar je aaa.bbb.ccc.ddd vervangt door het IP van je NAS (bijvoorbeeld dus '\\19.168.0.123').

[Voor 34% gewijzigd door ShadowLord op 13-05-2015 10:33]

You see things; and you say, "Why?" But I dream things that never were; and I say, "Why not?"


  • ScooBY_DoO
  • Registratie: november 2000
  • Laatst online: 08-09 13:55
Dat werkt allemaal perfect.

De mk1 werkt zoals gezegd ook prima met smb.

  • jan99999
  • Registratie: augustus 2005
  • Laatst online: 28-09 02:23
Vertel wat je hebt ingesteld, heb je dit bij alle apparaten hetzelfde gedaan?

Ook je swich uitzetten als je zoiets ertussen hebt zitten, dus alle hardware eens uitzetten.

Vaker heb ik gezien dat de verbinding tot stand brengen langer duurt.
Probeer eens langer te wachten na opstarten,
probeer meerdere keren te vebinden, en steeds even wachten.

mk1 werkt wel,
dan bij de andere apparaten de instellingen nakijken,
heb je ook de toegangs rechten(wachtwoord en user) goed ingesteld?

  • Brahiewahiewa
  • Registratie: oktober 2001
  • Laatst online: 00:06

Brahiewahiewa

boelkloedig

ScooBY_DoO schreef op dinsdag 12 mei 2015 @ 21:36:
...Sinds kort krijg ik SMB niet meer aan de praat op de SW3,

Probleem is nu dus, SMB is met geen mogelijkheid meer werkend te krijgen. (op de SW3)
...
Je zult toch iets meer informatie moeten geven; hier kan niemand wat mee

QnJhaGlld2FoaWV3YQ==


  • ScooBY_DoO
  • Registratie: november 2000
  • Laatst online: 08-09 13:55
jan99999 schreef op woensdag 13 mei 2015 @ 11:48:
Vertel wat je hebt ingesteld, heb je dit bij alle apparaten hetzelfde gedaan?

Ook je swich uitzetten als je zoiets ertussen hebt zitten, dus alle hardware eens uitzetten.

Vaker heb ik gezien dat de verbinding tot stand brengen langer duurt.
Probeer eens langer te wachten na opstarten,
probeer meerdere keren te vebinden, en steeds even wachten.

mk1 werkt wel,
dan bij de andere apparaten de instellingen nakijken,
heb je ook de toegangs rechten(wachtwoord en user) goed ingesteld?
Er valt niet zo heel veel in te stellen in de mediaplayers, allen hebben een ip verkregen door dhcp (ik heb ook vaste ip's geprobeerd)

Ongeacht welke switch ik gebruik kom ik met zowel de Mede8er als de SW3 niet ingelogd via SMB (Login fail)
Toegangsrechten heb ik met een gebruiker geminimaliseerd tot 1 cijfer voor zowel login als pass.
Ook met het admin account kom ik er niet in.

Tot gisteren kon ik met elk account beschikbaar in de MK1 inloggen via SMB.
Zojuist ALLES nogmaals stroomloos gemaakt en nu kom ik ook met de MK1 niet meer in SMB, ook niet na een half uur wachten.
Wel via NFS.

Dit zou inderdaad een rechten-verhaal kunnen zijn maar waarom was die MK1 dan wel te gebruiken...?

Via NFS op de MK1 is de SW3 (interne HDD) zichtbaar.
Op de pc zijn de SW3 en de Synology zichtbaar in het netwerk en beide benaderbaar.

Alles zou uiteraard direct opgelost zijn als de SW3 via NFS zou doen wat ik wil, full3D afspelen.
Ik kan ook nergens een reden vinden waarom dit wel via SMB werkt en niet via NFS.

Als er nog aanvullende info nodig is hoor ik dat uiteraard graag.

  • ShadowLord
  • Registratie: juli 2000
  • Laatst online: 22:11
NFS heeft nogal wat opties om voor verschillende use cases te optimaliseren. Met welke opties de NFS gemount wordt kan dus impact hebben op het ophalen van de data door de mediaspeler. Ook hoe de mediaspeler de data leest en hoeveel CPU hij daar aan kwijt is kan hier invloed op hebben. Ik weet niet genoeg van NFS hoe je dit moet tweaken (en mogelijk kun je dit niet eens aanpassen in je mediaplayer).

Aangezien je andere apparaten ook niet meer bij de SMB share kunnen, vermoed ik toch dat er daar iets niet helemaal goed ingesteld is op je NAS. Wat dingen die je kan controleren:
  • Staat de Windows file service aan (Control Panel -> File Sharing -> File services, Win/Mac/NFS tab)?
  • In hetzelfde scherm, heb je daar onder 'advanced' settings zaken aan staan (ik zou hier niets aangevinkt verwachten)? Mogelijk kun je ook eens de 'Clear SMB cache' knop proberen.
  • Is de folder die je wilt delen wel gedeeld via SMB? Ga naar 'Control Panel -> File Sharing -> Shared Folders' en 'Edit' de folder die gedeeld zou moeten zijn via SMB. Onder de tab 'Permissions' zou de user die er bij moet kunnen in ieder geval leesrechten moeten hebben.
  • Controleer de effectieve permissies op de SMB share. Ga naar 'Control Panel -> File Sharing -> User' en 'Edit' de user die rechten zou moeten hebben. Onder de tab 'Permissions' is er voor iedere share een regel. Wat er in de 'Preview' kolom van de tabel staat is het recht dat de user heeft. De user die je gebruikt voor SMB moet voor de gewenste share(s) ie ieder geval leesrechten hebben.
Houd er rekening mee dat NFS en SMB (Windows file sharing) op een Synology niet aan elkaar gekoppeld zijn en geen rechten delen. Je instellingen voor NFS rechten hebben geen invloed op SMB en vice versa.

[Voor 6% gewijzigd door ShadowLord op 13-05-2015 16:33]

You see things; and you say, "Why?" But I dream things that never were; and I say, "Why not?"


  • ScooBY_DoO
  • Registratie: november 2000
  • Laatst online: 08-09 13:55
Ik kan echt al het bovenstaande positief beantwoorden.

Omdat na de reset ook de MK1 het niet meer deed via SMB en ik al een tijdje het idee heb dat mijn modem/router niet helemaal spoort heb ik een ander modem aangesloten.
Direct daarna deed de MK1 het weer, de rest met geen mogelijkheid in te loggen.
Omdat er nog oude port forwards etc in die modem stonden heb ik die een factory reset gegeven.
Nergens meer in te loggen.... 8)7

Modems weer uitgewisseld daar dat ''reserve'' modem problemen geeft met downloaden (ja het is hier af en toe een feest op netwerkgebied :9~ )

Alles is weer terug bij af.

Wat ik wel heb gevonden in de synology setup is dat de poorten voor windows bestandserver niet open gezet kunnen worden.
Zou dat dan nog e.e.a. verklaren?
Wat ik ook doe qua forceren etc, hij blijft mislukt aangeven.
Ook als ik portforward regels aanmaak in de modem/router zelf werkt het niet.

Om het feest compleet te maken.... ik heb een ip-cam hangen die ook gekoppeld is aan de Synology.
De poort die ik daar aan toe gewezen heb staat ook in de Synolog alszijnde Mislukt.
Ik had die poort uitgezet en vervolgens in de modem geforward, geen sjoege.
Nogmaals ingeschakeld in de Synology en ondanks dat hij blijft aangeven mislukt is de camera WEL zichtbaar extern......

Maarja... zoals gezegd, de MK1 heeft het gedaan, meermaals en ik had tot dan toe niets veranderd in de Synology.

LoL... wat een puinhoop eigenlijk }:O

  • Ben(V)
  • Registratie: december 2013
  • Laatst online: 20:50
Poort forwarden in je router heeft absoluut niets te maken met het verkeer op het lan, dat is alleen van belang als je vanaf het internet iets op je lan wilt bereike.

Kijk eens naar de firewall van je Nas, als die aanstaat moet daar wel de smb en/of nfs poorten voor je devices openzetten. Test eens met de Nas firewall helemaal uit.

Je kunt ook nog even controleren of er devices in de blocklist van je Nas staan.

Verder kun je even proberen om het guest account in je Nas aan te zetten en dat account rechten te geven op je video share.
Er zijn mediaplayers die allleen via dat account willen werken.

Denk er wel aan dat een guest account geen wachtwoord heeft.

All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.


  • ScooBY_DoO
  • Registratie: november 2000
  • Laatst online: 08-09 13:55
Check.

Firewall heb ik al geprobeerd aan/uit.

Blocklist is leeg.

Guest account ga ik zeker even proberen, dank!

  • ShadowLord
  • Registratie: juli 2000
  • Laatst online: 22:11
Je gebruikt wel het interne ip van de NAS toch? Anders moet je router NAT loopback doen en dat gaat niet altijd goed.

You see things; and you say, "Why?" But I dream things that never were; and I say, "Why not?"


  • ScooBY_DoO
  • Registratie: november 2000
  • Laatst online: 08-09 13:55
Waarvoor bedoel je?

  • ShadowLord
  • Registratie: juli 2000
  • Laatst online: 22:11
Om je NAS te benaderen vanuit je media speler dus :)
Zorg dus dat je het interne lan ip van de NAS gebruikt. Ook het gebruik van de hostname kan problemen geven als deze soms niet gevonden kan worden.

You see things; and you say, "Why?" But I dream things that never were; and I say, "Why not?"


  • ScooBY_DoO
  • Registratie: november 2000
  • Laatst online: 08-09 13:55
Ik heb geen keuze uit ip-adressen.

Via smb vind de mediaplayer het diskstation, mijn pc en zijn eigen interne hdd.

Heb ook upnp ingeschakeld, dit werkt ook.

Nfs werkt prima met intern Ip want dat laat hij zien.

Guest account werkt niet.

[Voor 6% gewijzigd door ScooBY_DoO op 14-05-2015 00:06]

Pagina: 1


Apple iPhone 12 Microsoft Xbox Series X LG CX Google Pixel 4a CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True