Toon posts:

SRV 2003 CHKDSK fout interne schijf door externe USB schijf

Pagina: 1
Acties:

  • MegaTronics
  • Registratie: januari 2004
  • Laatst online: 16-07-2018

MegaTronics

Chef WiFi Kabels

Topicstarter
Sinds gisteren heb ik een Western Digital My Book Essential 3.0 4TB aangesloten op mijn Windows Server 2003 als backup schijf. Bij het aansluiten kwam die nog met een ontbrekende driver voor de WD SES Driver, maar die was zo gedownload bij WD en daarna heb ik de schijf opnieuw geformateerd:


So far zo good en daarna bezig geweest met het backuppen van diverse data naar deze schijf (wat niet al te snel ging, aangezien er alleen maar USB2 poorten op mijn systeem zitten :P ). Dus alles zag er goed uit totdat vannacht de backup van de systeemschijf ging lopen (backup word op een andere interne disk geplaatst en zou later naar de externe schijf worden gekopieerd). Van Active@ Disk Image kreeg ik de volgende log binnen per mail:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
[09-Mar-2013 01:01:24] Information: Processing task 'Backup System (C:), Data (D:)', file: 76d87e0d-0f9e-48e6-a5ad-5005b8a1f59e.dit.
[09-Mar-2013 01:01:24] Information: Initializing VSS...
[09-Mar-2013 01:01:24] Information: Creating Snapshot set...
[09-Mar-2013 01:01:56] Information: Calculating image size...
[09-Mar-2013 01:01:56] Information: Opening volume \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy1
[09-Mar-2013 01:01:57] Information: Calculated image data size: 9425008720
[09-Mar-2013 01:01:57] Information: Opening volume \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2
[09-Mar-2013 01:01:58] Information: Calculated image data size: 2214856388
[09-Mar-2013 01:01:58] Information: Estimated image size: 11639909277
[09-Mar-2013 01:01:58] Information: Storage initialized
[09-Mar-2013 01:01:58] Information: Creating image of partition System (NTFS, 8.772 GB/20.00 GB, Disk 0, C:)
[09-Mar-2013 01:01:58] Information: Opening volume \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy1
[09-Mar-2013 01:02:08] Information: NTFS partition: opening volume...
[09-Mar-2013 01:02:08] Information: NTFS partition: reading structure...
[09-Mar-2013 01:02:10] Information: NTFS partition: saving data...
[09-Mar-2013 01:07:27] Information: Error reading disk: 2097152 bytes at sector 22366012, error=87.
[09-Mar-2013 01:07:27] Information: Error reading disk: 512 bytes at sector 22366012, error=87.
[09-Mar-2013 01:07:27] Error: Error reading cluster 5590991. MFT# 6, file: $Bitmap. Error = 87.
[09-Mar-2013 01:07:27] Information: Creating partition image completed. Retcode=2.
[09-Mar-2013 01:07:33] Error: Image creation failed. Elapsed time: 00:06:09.


Na controle bleek dat er in de Event Viewer ook wat meldingen stonden:


Screendump is van een later tijdsstip, maar om 1:07 stond deze melding er ook in.

Mijn eerste gedachte was dat de interne schijf stuk aan het gaan is en ik startte vanmorgen CHKDSK op voor deze disk. Deze gaf allerlei fouten over missende indexen en werd ook afgebroken op een undefined error. Daarna heb ik de server laten booten om tijdens de boot een CHKDSK te doen op die schijf, maar daar gaf die compleet geen fout en was alles goed. :?

Toen heb ik na de reboot onder Windows weer een CHKDSK gedraaid en die gaf weer dezelfde fouten. Ik heb toen de externe WD losgekoppeld en de CHKDSK die ik daarna gaf onder Windows gaf geen fouten meer. Dus de oorzaak van de fouten op de interne schijf worden veroorzaakt door de externe WD. 8)7 Ik heb de WD SES driver weer verwijderd om te kijken of die de oorzaak van het probleem zou zijn, maar na het aansluiten van de externe WD gaf CHKDSK weer fouten en als die weer was afgekoppeld niet.

Toen ben ik verder gaan onderzoeken en heb ik als test de NTFS partitie op de externe WD eens geformatteerd als exFAT (ik heb KB955704 geinstalleerd op de server voor exFAT ondersteuning) en daarna een CHKDSK laten draaien op de interne schijf en raar maar waar, nu geeft CHKDSK geen fouten. :? Ik heb de externe WD ook eens als MFT disk ingesteld en er een 2 TB NTFS partitie op aangemaakt (i.p.v. de GPT 4 TB) en dan geeft CHKDSK weer fouten op de interne schijf. Dus het lijkt erop dat het mis gaat als er op de externe schijf een NTFS partitie staat.

Als verdere test heb ik het systeem ook eens geboot vanaf de bootdisk van Active@ Disk Image (dat is een WinPE op basis van Windows 7) en daar via de console een CHKDSK laten doen op de interne schijf en die gaf ook geen fouten. Ook als ik de externe WD aansluit op mijn Windows 7 laptop geeft die ook nergens problemen. De problemen doen zich dus voor onder Windows Server 2003 en alleen als er een NTFS partitie op de externe WD staat.

Nu was ik benieuwd of er een van jullie eventueel weet waarom dit optreed? Ikzelf heb het vermoeden dat Windows Server 2003 moeite heeft met de nieuwere generatie schijven met 4 kb sectoren i.p.v. de oude 512 bytes sectoren, maar dat verklaard nog niet waarom het wel goed gaat met een exFAT partitie en waarom de interne schijf problemen geeft. Misschien heeft een van jullie nog een idee?

Vroeger, toen de Batavieren nog met zijn vijven waren.


  • larsiano
  • Registratie: september 2003
  • Laatst online: 20-08-2013

larsiano

-=XTRA=-

Het kan ook je mobo (BIOS) zijn probeer deze te updaten! Het lijkt me niet dat een OS problemen moet hebben met wat voor schijf grote dan ook omdat zeker server edit. gemaakt is voor systemen met schijven tot 100TB en groter.

2408WFP + 2x1908FP, i7 950 + EK Supreme, Asus Rampage III Black Edition, 3x2GB Corsair, GTX590, 2 x 120GB Vertex Turbo (RAID0 @ Higpoint3520), 850W Antec W.C.PSU, Termaltake Tenor, 2xZalman Reserator, Steelpad 4S + G5, AW-TaxtX, LG Blu/HD


  • MegaTronics
  • Registratie: januari 2004
  • Laatst online: 16-07-2018

MegaTronics

Chef WiFi Kabels

Topicstarter
Als ik het systeem boot vanaf de WinPE bootdisk geeft die geen fouten bij CHKDSK, dus het lijkt mij hardwarematig allemaal wel te werken. En de laatste BIOS versie staat er al op.

De externe WD is voorzien van de laatste firmware, de update bij WD geeft aan dat die versie al aanwezig is op het apparaat.

Maar het is toch vreemd dat een externe schijf een probleem veroorzaakt op een interne schijf?

Het maakt trouwens ook niet uit op welk systeem je de NTFS partitie maakt (Windows Server 2003 of Windows 7), het probleem blijft hetzelfde. Dacht in eerste instantie dat het kon liggen aan de alignment van de partitie maar dat maakt dus geen verschil.

[Voor 36% gewijzigd door MegaTronics op 09-03-2013 13:09]

Vroeger, toen de Batavieren nog met zijn vijven waren.


  • Turdie
  • Registratie: maart 2006
  • Laatst online: 00:06
Respect voor deze topicstart!

Dit is echt gissen wat er met de externe disk aan de hand is, heeft WD geen test tooltjes om de disk low-level te testen? Chkdisk checkt alleen het filesysteem wat op de disk staat, zou ook een low-level disk probleem kunnen zijn.

Maar het zo ook goed kunnen zijn dat Server 2003 moeite heeft met de nieuwere generatie filesysteem, Server 2003 is inmiddels ook al 10 jaar oud :), en zit inmiddels in de extended support fase (alleen security patches geen functionaliteit patches), en over 3 jaar verloopt de support op Windows Server 2003 helemaal. Ik zou deze server upgraden naar Windows Server 2008 R2 of Windows Server 2012.

[Voor 71% gewijzigd door Turdie op 09-03-2013 13:32]


  • MegaTronics
  • Registratie: januari 2004
  • Laatst online: 16-07-2018

MegaTronics

Chef WiFi Kabels

Topicstarter
Tja Windows Server 2003 is al wat ouder, maar voldoet nog voor wat ik er mee doe. Het systeem draait ook al sinds 9 juli 2009 :p. Grote kans dat het met een nieuwere Server OS wel allemaal foutloos werkt, maar ik blijf het vreemd vinden dat een externe schijf er voor kan zorgen dat de interne schijf problemen gaat geven als er op de externe schijf een NTFS partitie staat. Ik zal sowieso eens kijken naar een programma om de interne schijf op low-level te checken (als die daarvoor via een CD moet booten, zijn de plaatjes in de TS wel even weg :p).

Edit: De Hitachi check heeft niets gevonden op de interne schijf en geeft aan dat die 100% in orde is.

Edit2: Uit dit document haal ik dat >2TB schijven niet gesupport worden in Windows XP (en dus ook niet in Windows Server 2003). Maar volgens mij geld dat voor interne schijven, externe schijven worden bestuurd door de controller in de behuizing.

Edit3: Hier lees ik dat WD deze schijven ook niet support onder Windows Server 2003, dus ik hoef ook niet aan te kloppen bij WD.

Het lijkt er op dat deze externe schijf er een is met een gebruiksaanwijzing voor gebruik onder Windows Server 2003.

[Voor 50% gewijzigd door MegaTronics op 09-03-2013 18:58]

Vroeger, toen de Batavieren nog met zijn vijven waren.


Acties:
  • 0Henk 'm!

  • MegaTronics
  • Registratie: januari 2004
  • Laatst online: 16-07-2018

MegaTronics

Chef WiFi Kabels

Topicstarter
Een late kick, maar er is weer wat nieuws te melden. Ondertussen heb ik de volgende Intel NUC aangeschaft als vervanging van de Atom 330 server:

#Product
1Hitachi Travelstar 5K1500, 1.5TB
1Intel Next Unit of Computing (V3) (met 2.5" hdd space) Core i5-4250U
1Crucial CT102464BF160B
1Crucial M500 mSata 240GB

Op de NUC heb ik Server 2008 R2 geïnstalleerd (die licentie had ik nog liggen) en de WD aangekoppeld aan de NUC. Chkdsk geeft geen fouten, dus so far so good. Wat blijkt echter, zodra je een Image wilt maken met Active@ Disk Image (van de SSD naar de interne HDD) krijg je wederom een fout:

code:
1
CreateSnapshotSet() failed(Error during asynchronous operation. HRESULT = 0x8004230f (VSS_E_UNEXPECTED_PROVIDER_ERROR)), trying to lock volume(s)...


Oftewel, het gaat nog steeds fout op een moderne OS. Als ik Google op die foutcode, vind ik onder ander deze post met deze melding:

Check that all the disks have a Bytes/Sector value of 512. Due to a limitation of VSS, if a disk is attached with any other value, even if you are not imaging it,then VSS will fail with result code 0x8004230f.

De betreffende WD schijf heeft inderdaad een 4096 Bytes/Sector dus daar gaat het dus mis (waarschijnlijk is dit ook ondermeer de reden dat het mis gaat op Server 2003). Het maakt niet uit of je de disk wel of niet gebruikt om een back-up naar toe te schrijven, als er een 4096 Bytes/Sector schijf is aangekoppeld, gaat het mis.

Als ik verder Google kom ik uit op deze pagina van Microsoft, waarin staat dat Microsoft native 4096 Bytes/Sector schijven pas ondersteund vanaf Windows 8 / Server 2012. Voor versies vanaf Vista / Server 2008 ondersteund het wel de advanced format (512e) versie met een hotfix (die bij mij al geïnstalleerd was). Voor versies lager dan Vista / Server 2008 ondersteunen ze alleen het oude 512 Bytes/Sector systeem, waaronder dus ook het oude Server 2003 onder valt.

Verder kom ik op deze site wat oplossingen tegen (daar hebben ze problemen met het ingebouwde Windows Server Backup, welke ook VSS gebruikt):
  1. Upgrade to a later Version of Windows (Windows 8, Server 2012) , in those versions the issue do not exist (recommended)
  2. Simply backup to another Location that has another hard disk that does not have a 4096 Byte Sector Size (fastest solution)
  3. Reformat the Hard disk with a tool from the harddisk vendor (not recommended, because time-consuming and some vendors do not even have a tool for this)
Oplossing 1 is een dure oplossing, want een Server 2012 R2 licentie is duurder dan de complete NUC bij elkaar. Oplossing 2 is niet haalbaar, want de WD blijft toch geconnecteerd met de NUC. Dus eens kijken of oplossing 3 haalbaar is.

Via Google kwam ik uit op deze pagina van WD, waarna ik de drive via WD Quick Formatter heb geformatteerd als Most Compatible (Vista or later required). Als ik daarna via het commando 'Fsutil fsinfo ntfsinfo x:' de settings controleer krijg ik:

code:
1
2
3
4
Bytes Per Sector             :  512
Bytes Per Physical Sector    : <Not Supported>
Bytes Per Cluster            : 4096
Bytes Per FileRecord Segment : 1024


Voor de format was de uitvoer:
code:
1
2
3
4
Bytes Per Sector             : 4096
Bytes Per Physical Sector    : 4096
Bytes Per Cluster            : 4096
Bytes Per FileRecord Segment : 4096


De sectorgrootte is nu 512 Bytes/Sector, maar Physical geeft nu een not supported. Als ik echter een image maak van de SSD schijf naar de HDD gaat het nu gewoon goed met een aangekoppelde WD. Ook chkdsk geeft geen fouten, dus het lijkt nu allemaal te werken.

Vroeger, toen de Batavieren nog met zijn vijven waren.

Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee