Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Apache sub-domein verwijst niet naar eigen Doc Root

Pagina: 1
Acties:

  • TheMOD
  • Registratie: november 2008
  • Laatst online: 22-10 15:30
Waarschijnlijk is dit veel te makkelijk voor de doorgewinterde systeembeheerders hier, maar ik kom er niet uit: Ik wil een subdomein aanmaken voor m'n broer op themod.nl Nu moet dit kunnen via Apache (Virtual server). Ik gebruik Webmin en heb daar een virtual server toegevoegd met als document root /home/simon. De document root van de 'gewone' (themod.nl) is /var/www. Ik heb ook de DNS ingesteld en die verwijst keurig door.

Eigenlijk zou het gewoon moeten werken, behalve dat hij het niet doet. Als ik naar simon.themod.nl ga krijg ik de inhoud van /var/www. NIET /home/simon.

Ik heb al wat lopen klooien met de instellingen, maar dat helpt niets. Ik heb ook geprobeerd de virtual servers toe te voegen via httpd.conf, maar dit maakt geen verschil. Ik heb ook al veel rondgesneusd op Google, maar daar zitten eigenlijk alleen mensen bij wie het wel gewoon werkt...

Hier mijn DNS instellingen:

En hier mijn Webmin instellingen:

Kan iemand mij vertellen wat ik over het hoofd zie?

  • MrHarry
  • Registratie: oktober 2006
  • Laatst online: 15:14
als het goed is mag www-data niet lezen in /home/simon
daar verwijst die naar nu, terwijl de andere verwijzing naar de /var/www verwijst....

  • Razwer
  • Registratie: december 2000
  • Laatst online: 02-10 18:15

MCP - MCSA - MCSE (NT4/2012) - MCTS - MCITP:SA/EA/VA2008R2-Charter Member/EMA2010/LSA2010-Charter Member - Prince2 Foundation


  • borft
  • Registratie: januari 2002
  • Laatst online: 15:10
heb je apache al gerestart? ;) (anders laadt ie de nieuwe config niet)

En post anders ook even de apache config van de virtualhost

borft wijzigde deze reactie 22-08-2012 13:32 (31%)


  • TheMOD
  • Registratie: november 2008
  • Laatst online: 22-10 15:30
quote:
Error log:
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Wed Aug 22 13:02:58 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Wed Aug 22 13:02:58 2012] [warn] NameVirtualHost *:0 has no VirtualHosts
[Wed Aug 22 13:02:58 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Wed Aug 22 13:02:58 2012] [notice] Apache/2.2.17 (Ubuntu) configured -- resuming normal operations
[Wed Aug 22 13:03:04 2012] [error] [client 192.168.11.1] File does not exist: /etc/apache2/htdocs
[Wed Aug 22 13:03:04 2012] [error] [client 192.168.11.1] File does not exist: /etc/apache2/htdocs
[Wed Aug 22 13:06:12 2012] [notice] SIGUSR1 received.  Doing graceful restart
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Wed Aug 22 13:06:12 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Wed Aug 22 13:06:12 2012] [warn] NameVirtualHost *:0 has no VirtualHosts
[Wed Aug 22 13:06:12 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Wed Aug 22 13:06:12 2012] [notice] Apache/2.2.17 (Ubuntu) configured -- resuming normal operations
[Wed Aug 22 13:09:07 2012] [notice] SIGUSR1 received.  Doing graceful restart
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Wed Aug 22 13:09:07 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Wed Aug 22 13:09:07 2012] [warn] NameVirtualHost *:0 has no VirtualHosts
[Wed Aug 22 13:09:07 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Wed Aug 22 13:09:07 2012] [notice] Apache/2.2.17 (Ubuntu) configured -- resuming normal operations
[Wed Aug 22 13:11:36 2012] [notice] SIGUSR1 received.  Doing graceful restart
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Wed Aug 22 13:11:36 2012] [warn] NameVirtualHost *:0 has no VirtualHosts
[Wed Aug 22 13:11:36 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[Wed Aug 22 13:11:36 2012] [notice] Apache/2.2.17 (Ubuntu) configured -- resuming normal operations

In de Access log staat niets spannends.
quote:
MrHarry schreef op woensdag 22 augustus 2012 @ 13:26:
als het goed is mag www-data niet lezen in /home/simon
daar verwijst die naar nu, terwijl de andere verwijzing naar de /var/www verwijst....
Als ik de file permissions verander maakt dat geen verschil. Hij doet het ook niet als ik hem in /var/www/simon zet of alle folder permissions op 777 zet.
quote:
borft schreef op woensdag 22 augustus 2012 @ 13:31:
heb je apache al gerestart? ;) (anders laadt ie de nieuwe config niet)

En post anders ook even de apache config van de virtualhost
Tuurlijk :P Dit is de config:
code:
1
2
3
4
5
6
7
8
DocumentRoot /home/simon
<Files "/var/www/simon/index.html">
allow from all
Options +Indexes
</Files>
ServerAlias *.simon.themod.nl
<Directory /home/simon>
</Directory>

(Die Files in /var/www/simon was een experimentje, maakt verder niets uit of ik die toevoeg of weglaat)

  • Razwer
  • Registratie: december 2000
  • Laatst online: 02-10 18:15
probeer eens dit:
code:
1
2
3
4
5
6
7
8
9
10
<VirtualHost *:80>
    ServerAdmin simon@themod.nl
    DocumentRoot "/var/www/simon"
    allow from all
    Options +Indexes
    ServerName simon.themod.nl
    ServerAlias www.simon.themod.nl
    ErrorLog "logs/simon/error_log"
    CustomLog "logs/simon/access_log" common
</VirtualHost>

ook resultaat van: ls /etc/apache2/sites-enabled
even posten aub als dit bovenstaande niet werkt.

als je geen www.simon.themod.nl wilt hebben kan je deze weghalen of uit commenten (#ServerAlias www.simon.themod.nl).

wil je daarnaast pietje.themod.nl hosten maak je gewoon weer een stukje config aan zoals hierboven, vervang je alle simon met pietje.

Razwer wijzigde deze reactie 22-08-2012 17:06 (23%)

MCP - MCSA - MCSE (NT4/2012) - MCTS - MCITP:SA/EA/VA2008R2-Charter Member/EMA2010/LSA2010-Charter Member - Prince2 Foundation


  • TheMOD
  • Registratie: november 2008
  • Laatst online: 22-10 15:30
Dank voor je reactie. Helaas werkt het niet. De inhoud van ../../sites-enabled is:
code:
1
000-default  webmin.1345656458.conf

Als ik je configuratie toevoeg dan krijg ik deze foutmelding:
code:
1
2
3
4
5
6
* Starting web server apache2
Syntax error on line 12 of /etc/apache2/sites-enabled/webmin.1345656458.conf:
allow not allowed here
Action 'start' failed.
The Apache error log may have more information.
   ...fail!

(Apache start wel overigens, maar het subdomein werkt nog steeds niet)

Als ik 'allow' uitcomment krijg ik deze foutmelding:
code:
1
2
3
4
5
6
7
* Starting web server apache2
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Wed Aug 22 19:33:17 2012] [warn] NameVirtualHost 141.105.0.215:80 has no VirtualHosts
[Wed Aug 22 19:33:17 2012] [warn] NameVirtualHost *:0 has no VirtualHosts
Action 'start' failed.
The Apache error log may have more information.
   ...fail!

(Apache start wel gewoon)

Precies hetzelfde gebeurt als ik de config aan webmin.*.conf toevoeg of httpd.conf. Dit is trouwens de hele configuratie:
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
<VirtualHost *:80>
DocumentRoot "/var/www"
<Directory "/var/www">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerAdmin simon@themod.nl
DocumentRoot "/var/www/simon"
#allow from all
Options +Indexes
ServerName simon.themod.nl
ServerAlias www.simon.themod.nl
ErrorLog "logs/simon/error_log"
CustomLog "logs/simon/access_log" common
</VirtualHost>


  • TheMOD
  • Registratie: november 2008
  • Laatst online: 22-10 15:30
Nou ik snap er helemaal niets meer van... Ik heb nu nog meer zitten klooien. Heel veel verschillende instellingen geprobeerd, maar hij doet het gewoon niet. Ik heb hem nu dat hij alle subdomeinnamen doorverwijst naar themod.nl (Dus simon.themod.nl, hoi.themod.nl etc. gaan allemaal naar /var/www) Máár: als ik 'themod.nl' invoer in de browser doet ie het niet, er MOET een subdomein voor. :S Ik heb zelfs de hele boel al opnieuw geïnstalleerd; geen verschil.

  • Razwer
  • Registratie: december 2000
  • Laatst online: 02-10 18:15
fix voor je wilcard issue (alle opties die je er bij wilt er aan toe voegen zoals documentroot etc):
code:
1
2
3
4
<VirtualHost *:80>
     ServerName themod.nl
     ServerAlias *.themod.nl
</VirtualHost>

Als je extra sites gaat hosten (op subdomeinen etc) zou ik werken met aparte config files
alles wat je in /etc/apache2/sites-enabled zet voert ie door (ook hard links).
maak daar een simon.themod.nl.conf file oid en zet daar alle simon.themod.nl spul in en houd je standaard site apart.
000-default zou ik weg pleuren en lekker je eigen conf maken voor je default site. httpd.conf lekker afblijven.

Razwer wijzigde deze reactie 23-08-2012 19:54 (6%)

MCP - MCSA - MCSE (NT4/2012) - MCTS - MCITP:SA/EA/VA2008R2-Charter Member/EMA2010/LSA2010-Charter Member - Prince2 Foundation


  • TheMOD
  • Registratie: november 2008
  • Laatst online: 22-10 15:30
Oke, ik ben iets verder denk ik: allereerst werkt je wildcard fix helaas niet. Ik heb nu 2 bestandjes; themod.nl.conf en simon.themod.nl.conf. In de eerste staat:
code:
1
2
3
4
5
<VirtualHost *:80>
ServerName themod.nl
ServerAlias *.themod.nl
DocumentRoot "/var/www"
</VirtualHost>

In de tweede staat:
code:
1
2
3
4
5
<VirtualHost *:80>
ServerName simon.themod.nl
ServerAlias *.simon.themod.nl
DocumentRoot "/var/www/simon"
</VirtualHost>

Zowel 'themod.nl' als 'simon.themod.nl' doen het nog steeds niet. MAAR ik heb eens de DocumentRoot van themod.nl veranderd naar /var/www/simon en dan verwijst hij NOG STEEDS naar /var/www! Oftewel, Apache trekt zich geen hol aan van de DocumentRoot directive. Enig idee om dit op te lossen? (En themod.nl beschikbaar te maken i.p.v. www.themod.nl)

  • alt-92
  • Registratie: maart 2000
  • Niet online

alt-92

ye olde farte

Ik zou dit eerst eens even los testen van je DNS config bij je hoster, door bijvoorbeeld even een snelle setup op een machientje binnen je thuisomgeving (VMmetje is zo inelkaar getikt).
Dan kun je in je lokale hosts file ook die wildcard A record qua DNS meenemen in je testscenario's, en rustig klooien voordat je het live knalt op het Internet.

ik heb een 864 GB floppydrive! - certified prutser - the social skills of a thermonuclear device

Pagina: 1


Apple iPhone 11 Nintendo Switch Lite LG OLED C9 Google Pixel 4 FIFA 20 Samsung Galaxy S10 Sony PlayStation 5 Elektrische auto

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True