Toon posts:

Ziggo & het SIP-protocol (icm asterisk)

Pagina: 1
Acties:

Onderwerpen


  • sumac
  • Registratie: Maart 2008
  • Laatst online: 01-02 16:48
Wij hebben op het werk een asterisk-server voor VOIP telefonie. Hierbij wordt het SIP-protocol gebruikt. Nu willen we een telefoon bij iemand thuis aansluiten, die een abonnement bij Ziggo heeft. Het lijkt er echter op dat dit niet werkt.

Kan iemand dit bevestigen? Is er een workaround met port forwarding oid? Is er een andere manier om dit werkend te krijgen?

  • shure-fan
  • Registratie: Maart 2002
  • Laatst online: 04-02 18:04
ik had voip via ziggo (consumenten lijn) gewoon werkend..

Voip enthousiastelling, Liever een kabel dan wifi


  • RuntimeError
  • Registratie: Juni 2006
  • Laatst online: 03-02 12:53
Ik kreeg het alleen werkend via een DMZ naar de IP telefoon / PC

  • peponline
  • Registratie: Augustus 2003
  • Laatst online: 08-02 15:38
Ik vraag me dan toch af hoe jullie dit gedaan hebben, naar mijn idee wil Ziggo namelijk zijn instellingen voor het SIP account niet vrijgeven. Iemand meer informatie hierover?

  • John767
  • Registratie: Maart 2004
  • Laatst online: 08-02 22:54
Hier draaien 2 SIP account op een Ziggo consumentenlijn gewoon goed. Misschien moet je, in het geval van een modem/router/wlan combinatie, een portforward naar het IP van de telefoon doen.
Heb zelf niet zo'n combi modem, dus kan daar geen antwoord op geven. Wel heb ik in de router een portforward gedaan, en prio gegeven via QOS.

Zonder firewalls moet het geen problemen geven.

Acties:
  • +1Henk 'm!

  • magiel
  • Registratie: Januari 2005
  • Laatst online: 11:19
peponline schreef op maandag 12 maart 2012 @ 15:13:
Ik vraag me dan toch af hoe jullie dit gedaan hebben, naar mijn idee wil Ziggo namelijk zijn instellingen voor het SIP account niet vrijgeven. Iemand meer informatie hierover?
De TS wil dan ook niet aanmelden op de servers van Ziggo, maar op z'n eigen SIP (Asterisk) server.

@TS: je zal even moeten Googlen op SIP in combinatie met NAT.

Ik wil het er _niet_ over hebben.


Acties:
  • +1Henk 'm!

  • Demo
  • Registratie: Juni 2000
  • Laatst online: 11:17

Demo

Probleemschietende Tovenaar

peponline schreef op maandag 12 maart 2012 @ 15:13:
Ik vraag me dan toch af hoe jullie dit gedaan hebben, naar mijn idee wil Ziggo namelijk zijn instellingen voor het SIP account niet vrijgeven. Iemand meer informatie hierover?
Het gaat hier om het verbinden naar een externe SIP-server van de werkgever van de topicstarter. Verbinden met de VoIP-server van Ziggo is een heel ander verhaal, zij kunnen geen SIP-gegevens vrijgeven omdat ze geen SIP gebruiken, maar Packetcable oid. Jammer maar helaas, ik had ook graag mijn Ziggo account op een softphone of Asterisk-server gebruikt.

Unix doesn't prevent a user from doing stupid things, because that would necessarily prevent them from doing brilliant things.
while true ; do echo -n "bla" ; sleep 1 ; done


  • sumac
  • Registratie: Maart 2008
  • Laatst online: 01-02 16:48
Bedankt voor jullie reacties!

Zoals @ZDemoniac al aangeeft, het gaat hier niet om ziggo-telefonie, maar een telefoon die aangesloten wordt op een asterisk/voip-server die buiten het ziggo-netwerk draait, die niks met ziggo te maken heeft. Nu kan het zijn dat ziggo dit protocol blokkeert omdat het concurreert met hun eigen diensten (internet+bellen of hoe heet het).

@John767
Wil je zeggen dat jij het werkend hebt, of bedoel jij ook ziggo-telefonie?

[Voor 3% gewijzigd door sumac op 12-03-2012 15:34]


  • peponline
  • Registratie: Augustus 2003
  • Laatst online: 08-02 15:38
Bedankt voor de verduidelijking, ik had de TS inderdaad niet goed begrepen.

Mijn excuses!

  • TOYS
  • Registratie: November 2010
  • Laatst online: 03-02 14:25

TOYS

Zeg ik nie!!

Hoe maak je verbinding naar de server? is dit over het internet? is dit over een vpn?
Om te bellen moet je zorgen dat poort 5060 en RTP verkeer naar buiten kan... dus dat moet niet geblokkeerd worden op de firewall/router.

Bij IT-ers gaat alles automatisch, maar niets vanzelf.


  • CAPSLOCK2000
  • Registratie: Februari 2003
  • Nu online

CAPSLOCK2000

zie teletekst pagina 888

Ik kan me niet voorstellen dat Ziggo dit daadwerkelijk filter. VOIP blokkeren is/was iets voor mobiele providers. Als je nog weet hoe hard de mobiele providers hier op zijn aangepakt denk ik niet dat Ziggo het ook nog een keer gaat proberen.

This post is warranted for the full amount you paid me for it.


  • fridgeman
  • Registratie: September 2002
  • Laatst online: 11-09-2016

fridgeman

SomaFM Secret Agent

sumac schreef op maandag 12 maart 2012 @ 15:34:
Nu kan het zijn dat ziggo dit protocol blokkeert omdat het concurreert met hun eigen diensten (internet+bellen of hoe heet het).
Nee, dat doet Ziggo niet.

Wat heb je zelf al geprobeerd? Wel een erg magere OP.

Doet niet aan ontwikkelingssamenwerking.


  • laurens0619
  • Registratie: Mei 2002
  • Laatst online: 12:09
Los van ziggo, heb je wel al een aansluiting werkend bij iemand anders die achter nat zit?

CISSP! Drop your encryption keys!


Acties:
  • +1Henk 'm!

  • sumac
  • Registratie: Maart 2008
  • Laatst online: 01-02 16:48
@toys
De verbinding is via internet, niet via VPN.

@laurens0619
We hebben inmiddels meer dan 30 telefoons geinstalleerd, en die worden over de hele wereld gebruikt. Het werkt dus absoluut.

@fridgeman
Je zegt dat Ziggo dat niet doet. Ziggo bestaat uit het oude Casema, @home, en nog een paar andere providers geloof ik. Zijn die netwerken en alle instellingen daarvan inmiddels gelijk? Misschien dat het bij het oude Casema wel kan, en bij @home niet. Geen idee, maar ik sluit het niet uit. Dit probleem speelt overigens in Wassenaar, en ik weet niet welke oude provider daar zat.

Ik heb inmiddels geprobeerd via telnet een verbinding op te zetten. Als ik dat vanuit kantoor doe, dan krijg ik meteen de melding "connection refused", wat erop duidt dat er in ieder geval een verbinding opgezet wordt. Dat klinkt tegenstrijdig, maar er komt dus een foutmelding terug, en dus is er een verbinding. Als ik vanaf de computer van de collega telnet, krijg ik geen reactie. Ik zie dan alleen "trying 1.2.3.4...." en daarna een timeout.

Een kennis zit ook bij Ziggo, regio Utrecht, en die kan alleen uitgaand bellen. Inkomend belverkeer komt niet aan.

De router is een Netgear WNDR3300. Ik heb getracht de SPI firewall uit te zetten (zie http://www.phonepower.com...tion_with_the_Grandstream ). Dat schijnt weinig tot niks toe te voegen aan de veiligheid, aangezien de computer toch achter NAT zit. (zie http://www.dslreports.com/forum/remark,21791308 ) Dit lezend is NAT er voor inkomend verkeer, en de firewall voor uitgaand verkeer, en als er virussen of trojans aanwezig zijn, gebruiken die waarschijnlijk toch poort 80.

En wat gebeurt er: geen internet meer na een reboot. Het lukt wel nog om lokaal in te loggen op de router, dus heb ik de instellingen terug laten zetten (aanwijzingen gevend via de telefoon). Vervolgens weer een reboot, en dan doet ie niks meer, ook lokaal inloggen werkt niet meer. Dus maar een harde reset via het knopje op de achterkant, en ook dat helpt niet, ook niet na het herstarten van de computer...

Ik ben niet blij nu. Ik heb dus zonet de internetverbinding van een collega thuis vernaggelt, en die zit niet bepaald in de buurt. Straks komt er wel iemand daar langs die er iets meer verstand van heeft, dus ik hoop dat het snel opgelost is.

  • JMW761
  • Registratie: Oktober 2001
  • Laatst online: 11:17
sumac schreef op dinsdag 13 maart 2012 @ 12:53:


@fridgeman
Je zegt dat Ziggo dat niet doet. Ziggo bestaat uit het oude Casema, @home, en nog een paar andere providers geloof ik. Zijn die netwerken en alle instellingen daarvan inmiddels gelijk? Misschien dat het bij het oude Casema wel kan, en bij @home niet. Geen idee, maar ik sluit het niet uit. Dit probleem speelt overigens in Wassenaar, en ik weet niet welke oude provider daar zat.

Ik heb inmiddels geprobeerd via telnet een verbinding op te zetten. Als ik dat vanuit kantoor doe, dan krijg ik meteen de melding "connection refused", wat erop duidt dat er in ieder geval een verbinding opgezet wordt. Dat klinkt tegenstrijdig, maar er komt dus een foutmelding terug, en dus is er een verbinding. Als ik vanaf de computer van de collega telnet, krijg ik geen reactie. Ik zie dan alleen "trying 1.2.3.4...." en daarna een timeout.

Een kennis zit ook bij Ziggo, regio Utrecht, en die kan alleen uitgaand bellen. Inkomend belverkeer komt niet aan.

De router is een Netgear WNDR3300. Ik heb getracht de SPI firewall uit te zetten (zie http://www.phonepower.com...tion_with_the_Grandstream ). Dat schijnt weinig tot niks toe te voegen aan de veiligheid, aangezien de computer toch achter NAT zit. (zie http://www.dslreports.com/forum/remark,21791308 ) Dit lezend is NAT er voor inkomend verkeer, en de firewall voor uitgaand verkeer, en als er virussen of trojans aanwezig zijn, gebruiken die waarschijnlijk toch poort 80.

En wat gebeurt er: geen internet meer na een reboot. Het lukt wel nog om lokaal in te loggen op de router, dus heb ik de instellingen terug laten zetten (aanwijzingen gevend via de telefoon). Vervolgens weer een reboot, en dan doet ie niks meer, ook lokaal inloggen werkt niet meer. Dus maar een harde reset via het knopje op de achterkant, en ook dat helpt niet, ook niet na het herstarten van de computer...

Ik ben niet blij nu. Ik heb dus zonet de internetverbinding van een collega thuis vernaggelt, en die zit niet bepaald in de buurt. Straks komt er wel iemand daar langs die er iets meer verstand van heeft, dus ik hoop dat het snel opgelost is.
Ik zat op Ziggo (voorheen @home) in Leiderdorp en daar werkte het altijd prima; nu zit ik ergens anders, maar heb ik zo'n Netgear en werkt het ook; SIP naar een Asterisk machine.

Ik zou het niet in de verbinding zoeken maar in de instellingen van de router OF van Asterisk.
ik geef altijd een
code:
1
2
nat=yes
host=dynamic


mee in sip.conf

  • sumac
  • Registratie: Maart 2008
  • Laatst online: 01-02 16:48
Internet werkt weer, bleek een losse kabel te zijn...

We hebben de router ertussenuit gehaald, en de computer direct op het modem aangesloten. Vervolgens een telnet-test gedaan, en daar kreeg ik wel respons. Dus het zit in de router.
JMW761 schreef op dinsdag 13 maart 2012 @ 13:00:
Ik zat op Ziggo (voorheen @home) in Leiderdorp en daar werkte het altijd prima; nu zit ik ergens anders, maar heb ik zo'n Netgear en werkt het ook; SIP naar een Asterisk machine.

Ik zou het niet in de verbinding zoeken maar in de instellingen van de router OF van Asterisk.
ik geef altijd een
code:
1
2
nat=yes
host=dynamic


mee in sip.conf
Sip.conf staat goed, met nat en host.

Als we bij WAN-setup de SPI firewall uitzetten, en Disable SIP ALG aanvinken, en die wijzigingen opslaan, dan lijkt ie een reboot uit te voeren. Je ziet een balkje lopen, wat waarschijnlijk niks zegt, en alleen als timer dient. Ik zie dat Teamviewer de verbinding heel even kwijt lijkt te zijn, maar dat is zo kort dat de verbinding wel in stand blijft. Maar het verandert niks. Dus dan doen we maar een harde reboot, stroom eraf, en wat gebeurt er dan: geen internet meer. Je kunt nog wel op de router inloggen, maar verder niks. (En daarbij starten we de computer voor de zekerheid ook opnieuw op.) Die wijzigingen terugzetten met een harde reboot herstelt de verbinding niet. Dus volgt weer een harde reset, en ben je terug bij af.

We gaan nu een nieuwe router regelen, ander merk, en dan kijken of dat werkt.

  • Uberprutser
  • Registratie: Januari 2000
  • Laatst online: 12:06
Best ontopic maar Leiderdorp had GEEN @Home maar Casema (wat nu Ziggo is). :)
Ik kan overigens ook gewoon SIP bellen via Ziggo en had ook een Cisco Call Manager erachter aan de praat.

As you may already have guessed, following the instructions may break your system and you are on your own to fix it again.


  • sumac
  • Registratie: Maart 2008
  • Laatst online: 01-02 16:48
Een ding wat ik gemist had is dat de telefoon wel de configuratie ophaalt als ie aangesloten is op de router, maar dat gebeurt over poort 80, dus dat dat werkt is niet heel vreemd.

Er is een andere router gehaald, een Sitecom. Helaas blijft het probleem bestaan. De telefoon rechtstreeks op het modem aansluiten werkt niet. Er gebeurt dan niks, en er wordt dan ook geen configuratie opgehaald, terwijl dat bij aansluiting op het modem wel gebeurt. Dat vind ik vreemd. Als je de computer rechtstreeks op het modem aansluit is er wel internet, en werkt telnet naar poort 5060 ook.

Ik vermoed dat het modem alleen een gateway is, zelf geen IP-adressen uitgeeft. Waarom werkt het dan niet met de telefoon? Komt dat doordat er misschien een speciaal protocol gebruikt moet worden (zoals bv PPTP) wat de computer (Mac OSX) wel automatisch doet, en de telefoon niet? Of is hier een andere verklaring voor?

Een mogelijke verklaring is de volgende: (1) telefoon is niet slim genoeg om rechtstreeks op modem verbinding op te zetten, (2) telefoon achter router kan wel configuratie ophalen, en (3) er is toch iets kapot in de telefoon zodat er geen verbinding opgezet kan worden met de server. Dit is op zich eenvoudig te testen, maar ook veel gedoe met het ter plekke krijgen van de nieuwe telefoon. Ik ga kijken of het gaat lukken de telefoon bij de buren of elders aan te laten sluiten, en te kijken of het dan wel lukt.

  • JMW761
  • Registratie: Oktober 2001
  • Laatst online: 11:17
Ballebek schreef op dinsdag 13 maart 2012 @ 22:09:
Best ontopic maar Leiderdorp had GEEN @Home maar Casema (wat nu Ziggo is). :)
Ik kan overigens ook gewoon SIP bellen via Ziggo en had ook een Cisco Call Manager erachter aan de praat.
mijn nederige excuses, u heeft natuurlijk gelijk :)

  • autostatic
  • Registratie: April 2004
  • Laatst online: 24-11-2022
Beetje laat, maar wat voor modem heeft die Ziggo gebruiker? VoIP geeft namelijk problemen met de Ubee modem/router. Dat werkte in mijn geval pas goed nadat ik de Ubee in bridged mode had laten zetten door de Ziggo servicedesk.
Pagina: 1


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee