Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

NOD32 failed to start because side-by-side-configuration...

Pagina: 1
Acties:

  • Kid Jansen
  • Registratie: oktober 2005
  • Niet online
Ik heb een probleem met ESET NOD32 Antivirus 4.2 x64. Het viel me vanmiddag op dat het icoontje van NOD32 in het systeemvak weg was, toen ik vervolgens probeerde om NOD32 handmatig op te starten via die snelkoppeling in het startmenu kreeg ik de foutmelding:

C:\Program Files\ESET\ESET NOD32 Antivirus\egui.exe

The application failed to start because side-by-side-configuration is incorrect. Please see the application event log or use the command-line sxstrance.exe tool for more detail.


Vervolgens ben ik gaan zoeken naar een oplossing en toen vond ik dat het probleem aan Microsoft Visual C++ 2005 redistributable en Microsoft Visual C++ 2008 redistributable zou moeten liggen. Die zouden corrupt kunnen worden en dan werken programma's geschreven in C++ niet meer, als ik het goed begrepen heb.

Dat leek me niet zo ingewikkeld, gewoon die dingen verwijderen en opnieuw installeren. Dus ik heb alle 8 van die dingen die in het programma-onderdeel van het configuratiescherm gedeïnstalleerd.

En vervolgens heb ik Microsoft Visual C++ 2005 redistributable SP1 (x64) en Microsoft Visual C++ 2008 redistributable SP1 (x64) geïnstalleerd.

Daarna kwamen er via Windows Update voor beide nog update, dus die heb ik ook maar geïnstalleerd. Vervolgens opnieuw opgestart: geen resultaat! NOD32 start nog steeds niet met Windows mee en als ik handmatig via het startmenu probeer op te starten krijg ik nog steeds die foutmelding.

Het frappante is dat ik me bedacht dat ik laatst met Solidworks 2010 SP4.0 (Educational edition 2010-2011) precies dezelfde foutmelding kreeg. Ik had toen alleen echt geen tijd om dat op te gaan lossen, dus toen heb ik het maar op m'n laptop gedaan. Maar ik zie nu net dat Solidworks nu wel weer werkt.

Specs van de PC waar het om gaat. Deze draait op Windows 7 Professional UK x64, alle updates geïnstalleerd.

Wat ik ook raar vind is dat ik het probleem op m'n laptop niet heb, terwijl ik daar dezelfde Windows versie op heb staan, ook alle updates op heb geïnstalleerd en waar ook vrijwel dezelfde programma's op staan.

Weet iemand hoe ik dit probleem op kan lossen? Ik zou het namelijk wel fijn vinden als m'n virusscanner het weer gewoon doet.

EDIT: was vergeten te vermelden dat ik was begonnen met NOD32 verwijderen en opnieuw installeren, aangezien dat niet werkte ben ik toen gaan Googlen naar een oplossing en daardoor kwam ik op dat "Microsoft Visual C++ 200x redistributable"-verhaal uit.

Kid Jansen wijzigde deze reactie 20-02-2011 20:36 (7%)


  • Kid Jansen
  • Registratie: oktober 2005
  • Niet online
Om terug te komen op dat gezeur met Solidworks, dat zal 9 februari geweest zij. Als ik namelijk in de Windows Application logs kijk zie ik daar 3123x errors staan in één minuut tijd (van 18:03:01 tot 18:03:58), dat zijn vrijwel allemaal deze error:

Activation context generation failed for "C:\Program Files\SolidWorks Corp\SolidWorks\sldcoreu.dll".Error in manifest or policy file "C:\Windows\WinSxS\manifests\amd64_microsoft.vc80.mfc_1fc8b3b9a1e18e3b_8.0.50727.4053_none_8444db7d32915e4c.manifest" on line 0. Invalid Xml syntax.

Maar er zit ook een paar keer deze tussen:

.NET Runtime Optimization Service (clr_optimization_v4.0.30319_64) - Failed to compile C:\Program Files\SolidWorks Corp\SolidWorks\annotationcplu.dll because of the following error: The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail. (Exception from HRESULT: 0x800736B1).

Er staan echt achterlijk veel side-by-side errors in die log files, in totaal 3811. De eerste zijn van toen ik m'n PC net had geïnstalleerd (blijkbaar nog nooit die log leeg gehaald). Van 28 juli t/m 20 januari zijn er 105 side-by-side errors, allemaal van programma's waar ik nooit problemen mee heb gehad, of die ik nooit heb gebruikt (onderdeel van een suite waar ik dan blijkbaar meer onderdelen van heb geïnstalleerd dan ik nodig heb).

Op 21 januari zie ik de eerste side-by-side errors van NOD32:

Activation context generation failed for "C:\Program Files\ESET\ESET NOD32 Antivirus\egui.exe".Error in manifest or policy file "C:\Windows\WinSxS\manifests\amd64_microsoft.vc80.mfc_1fc8b3b9a1e18e3b_8.0.50727.4053_none_8444db7d32915e4c.manifest" on line 0. Invalid Xml syntax.

Blijkbaar doet m'n virusscanner het dus al een maand niet meer (lekker wakker Kid...) Overigens is ekrn.exe wel actief als ik in taakbeheer kijk.

  • CoolGamer
  • Registratie: mei 2005
  • Laatst online: 16-06 21:12

CoolGamer

What is it? Dragons?

Als je
sfc /scannow
draait, worden dan fouten aangegeven? Het lijkt erop dat de bestanden die voor SxS zorgen beschadigd zijn.

¸.·´¯`·.¸.·´¯`·.¸><(((º>¸.·´¯`·.¸><(((º>¸.·´¯`·.¸.·´¯`·.¸.·´¯`·.¸<º)))><¸.·´¯`·.¸.·´¯`·.¸.·´¯`·.¸


  • Kid Jansen
  • Registratie: oktober 2005
  • Niet online
Ja, ik krijg het volgende resultaat:

"Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.log..."

Die CBS.log is overigens bijna 1 MB, dus die tekst kan ik hier niet posten. Het viel me op dat bij zo'n driekwart van de alinea's weer 9 februari als datum staat (de log begint ook pas bij die datum), alleen dan een paar uur eerder dan al die side-by-side errors waar ik het over had in m'n vorige post, hier is het namelijk van 12:05:55 tot 14:39:08 (er zijn er daarna nog een aantal van 19:22:49 tot 19:34:29, maar dat zijn er in verhouding heel weinig).

  • CoolGamer
  • Registratie: mei 2005
  • Laatst online: 16-06 21:12

CoolGamer

What is it? Dragons?

Windows Update logt ook naar dat bestand. Dus dat levert nogal wat regels op. Hier staat uitgelegd hoe je alleen de regels eruit haalt die betrekking hebben tot sfc: How to analyze the log file entries that the Microsoft Windows Resource Checker (SFC.exe) program generates in Windows Vista

¸.·´¯`·.¸.·´¯`·.¸><(((º>¸.·´¯`·.¸><(((º>¸.·´¯`·.¸.·´¯`·.¸.·´¯`·.¸<º)))><¸.·´¯`·.¸.·´¯`·.¸.·´¯`·.¸


  • Kid Jansen
  • Registratie: oktober 2005
  • Niet online
Ik heb die filter techniek even toegepast en alle regels die anders waren dan de standaard regel hieronder neergezet. Wat moet ik nu doen?

2011-02-20 19:17:50, Info CSI 0000018b [SR] Cannot verify component files for Microsoft.VC80.MFC, Version = 8.0.50727.4053, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:10{5}]"win32", TypeName neutral, PublicKey neutral, manifest is damaged (TRUE)

...

2011-02-20 19:20:52, Info CSI 000002fc [SR] Cannot verify component files for Microsoft.VC80.MFC, Version = 8.0.50727.4053, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:10{5}]"win32", TypeName neutral, PublicKey neutral, manifest is damaged (TRUE)

...

2011-02-20 19:20:52, Info CSI 00000307 [SR] Verify and Repair Transaction completed. All files and registry keys listed in this transaction have been successfully repaired

...

2011-02-20 22:20:48, Info CSI 0000018b [SR] Cannot verify component files for Microsoft.VC80.MFC, Version = 8.0.50727.4053, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:10{5}]"win32", TypeName neutral, PublicKey neutral, manifest is damaged (TRUE)

...

2011-02-20 22:23:35, Info CSI 000002f7 [SR] Verify complete
2011-02-20 22:23:35, Info CSI 000002f8 [SR] Repairing 1 components
2011-02-20 22:23:35, Info CSI 000002f9 [SR] Beginning Verify and Repair transaction
2011-02-20 22:23:35, Info CSI 000002fc [SR] Cannot verify component files for Microsoft.VC80.MFC, Version = 8.0.50727.4053, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:10{5}]"win32", TypeName neutral, PublicKey neutral, manifest is damaged (TRUE)
2011-02-20 22:23:35, Info CSI 000002fe [SR] Repair complete
2011-02-20 22:23:35, Info CSI 00000303 [SR] Committing transaction
2011-02-20 22:23:35, Info CSI 00000307 [SR] Verify and Repair Transaction completed. All files and registry keys listed in this transaction have been successfully repaired

  • Kid Jansen
  • Registratie: oktober 2005
  • Niet online
Weet iemand hoe ik nu verder moet? (of alleen al waar ik op zou moeten zoeken?)

Ik heb overigens vandaag ook SP1 geïnstalleerd, ik weet niet of dat nog uit maakt, maar NOD32 werkt in ieder geval nog niet.

  • Kid Jansen
  • Registratie: oktober 2005
  • Niet online
Alle onderdelen van Nero Multimedia Suite 10 werken nu ook niet meer.

Verder krijg ik de afgelopen dagen af en toe een BSOD:

The computer has rebooted from a bugcheck. The bugcheck was: 0x0000007f (0x0000000000000008, 0x0000000080050031, 0x00000000000006f8, 0xfffff88004d36a6d). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 022611-19983-01.

En nog een paar keer met iets andere foutcodes:

0x0000007f (0x0000000000000008, 0x0000000080050031, 0x00000000000006f8, 0xfffff88004b992ce)

0x0000007f (0x0000000000000008, 0x0000000080050031, 0x00000000000006f8, 0xfffff88004da13cc)

0x0000007f (0x0000000000000008, 0x0000000080050031, 0x00000000000006f8, 0xfffff88004778120)

0x0000007f (0x0000000000000008, 0x0000000080050031, 0x00000000000006f8, 0xfffff88004bee7a9)


Verder zie ik heel vaak deze error voorbij komen:

A device with IP address '130.89.167.114' failed to register itself for protected content retrieval due to unknown error '0xc00d278f'.

(130.89.x.x is de campus van Universiteit Twente, waar ik woon, alle PC's vormen daar één groot LAN netwerk)

En ik zag ook nog een aantal keer deze fout voorbij komen:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{9BA05972-F6A8-11CF-A442-00A0C90A8F39}
and APPID
{9BA05972-F6A8-11CF-A442-00A0C90A8F39}
to the user Washington2\Kid Jansen SID (S-1-5-21-1966288450-1375190039-514584504-1000) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.


Ook heb ik vrij vaak een system hang, zomaar uit het niets: browsen, serie kijken, idlen (dat er niks aan staat, scherm even uit, loop weg, kom terug en dan hangt hij weer :(). Maakt echt helemaal niks uit wat ik doe, het maakt ook niet uit hoeveel geheugen of processorkracht er gebruikt wordt. Daar zijn overigens geen foutcodes van terug te vinden in de log files, alleen dat het systeem onverwacht en incorrect is afgesloten.

Ik ga nu even Memtest86+ 4.10 draaien, kijken wat daar uit komt.

  • Kid Jansen
  • Registratie: oktober 2005
  • Niet online
Ik kon vanochtend rond 9:00 niet kijken hoe het gegaan was, want er was of iets mis gegaan met Memtest86+, of m'n U2711 wilde gewoon geen beeld geven.

Ik denk eerlijk gezegd dat laatste, de U2711 heeft af en toe moeite om weer beeld op het scherm te krijgen als hij uit is geweest buiten Windows. Geen idee of dat aan de U2711 of m'n ATI FirePro v4800 ligt, maar het is dus zo dat als je bijvoorbeeld tijdens de BIOS splash het scherm uit zet tijdens het opstarten, dat je dan pas weer beeld krijgt bij het login scherm van Windows. Als je in het BIOS zit en je zet het scherm uit, krijg je daarna meestal ook geen beeld meer na het opnieuw aanzetten.

Anyway, ik moest dus de resetknop gebruiken en Memtest86+ opnieuw starten, wel jammer, want hij had waarschijnlijk wel al bijna 10 cycli gehad. Hij zit nu weer op 3 cycli (heb m'n U2711 nu gewoon niet uit gezet), duurt een kleine 53 minuten per cyclus gemiddeld. Tot nu toe geen fouten, maar hij mag denk ik nog wel een paar cycli draaien.

Ik ben bang dat het een kwestie wordt van Windows opnieuw installeren...

  • Kid Jansen
  • Registratie: oktober 2005
  • Niet online
Ik heb 6 volledige cycli laten draaien, dat duurde 5:48 uur, dus toen vond ik het wel weer een keer mooi geweest. Allemaal zonder fouten, dus ik denk dat het geheugen wel goed is.

Zou het misschien de hardeschijf kunnen zijn?
Pagina: 1


OnePlus 7 Pro (8GB intern) Microsoft Xbox One S All-Digital Edition LG OLED C9 Google Pixel 3a XL FIFA 19 Samsung Galaxy S10 Sony PlayStation 5 Games

Tweakers vormt samen met Tweakers Elect, Hardware.Info, Autotrack, Nationale Vacaturebank, Intermediair en Independer de Persgroep Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True