• verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
Ik ben een beginner met Fedora en ik probeer Samba aan het werk te krijgen.
Alleen als ik met mijn Windowsclient probeer in te loggen dan krijg ik het volgende te zien:

Mygroup is niet toegangkelijk. U hebt mogelijk niet de juiste machtingen voor deze net workbron.
Kan het netwerkpad niet vinden.
Ik heb het vogelgende instesteld voor Samba:

smbpasswd -a loek
smbpasswd -e loek

Heeft iemand een idee waarom ik niet kan inloggen onder loek ?

[global]
workgroup = MYGROUP
netbios name = MYNETWORK
server string = Samba Server Version %v
log file = /var/log/samba/log.%m
max log size = 50
hosts allow = 192.168.0.0
cups options = raw

[homes]
comment = Home Directories
path = /home/%u/share
valid users = %S
read only = No
create mask = 0664
directory mask = 0775
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

  • DiedX
  • Registratie: december 2000
  • Laatst online: 13:48
Je hebt nog niet echt een share gemaakt, behalve je homedirectory. Was dat ook je bedoeling?

  • martijnvanegdom
  • Registratie: januari 2004
  • Laatst online: 06-09 09:50
Heb je geprobeerd op server ip te connecten via Windows? (dus //hier.het.ip/loek ? Mijn ervaring is dat browsen door het netwerk met samba niet altijd goed gaat terwijl de server wel degelijk beschikbaar is.

  • Vinzz
  • Registratie: november 2002
  • Laatst online: 16:30
Controleer de logfiles altijd als eerste:

log file = /var/log/samba/log.%m

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
DiedX schreef op zaterdag 06 november 2010 @ 13:52:
Je hebt nog niet echt een share gemaakt, behalve je homedirectory. Was dat ook je bedoeling?
Het is een voorbeeld uit het Fedoraboek en ik heb met mkdir een share gemaakt in de homedirectory.

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
martijnvanegdom schreef op zaterdag 06 november 2010 @ 13:52:
Heb je geprobeerd op server ip te connecten via Windows? (dus //hier.het.ip/loek ? Mijn ervaring is dat browsen door het netwerk met samba niet altijd goed gaat terwijl de server wel degelijk beschikbaar is.
ik heb vanuit mijn windowsclient kunnen pingen naar de linuxserver 192.168.1.2

  • borft
  • Registratie: januari 2002
  • Laatst online: 16:44
pingen zegt niet zoveel, behalve dat je windows machine de samba server over het netwerk kan vinden. Moet je sowieso niet de security option in samba ergens op instellen?

dus bv:
security = user

in je smb.conf knallen.

overigens, wat gebeurt er als je

start -> run -> \\192.168.1.2 doet?

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
borft schreef op zaterdag 06 november 2010 @ 14:34:
pingen zegt niet zoveel, behalve dat je windows machine de samba server over het netwerk kan vinden. Moet je sowieso niet de security option in samba ergens op instellen?

dus bv:
security = user

in je smb.conf knallen.

overigens, wat gebeurt er als je

start -> run -> \\192.168.1.2 doet?
Ik heb security = user teogevoegd in de Global section.
Maar op welke machine moet ik start > run > \\192.168.1.2 doen ?

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
Vinzz schreef op zaterdag 06 november 2010 @ 13:53:
Controleer de logfiles altijd als eerste:

log file = /var/log/samba/log.%m
dit is de log van 127.0.0.1:

[2010/11/05 18:33:59.164811, 0] lib/access.c:410(check_access)
Denied connection from (::ffff:127.0.0.1)
[2010/11/05 18:33:59.165111, 1] smbd/process.c:2295(smbd_process)
Connection denied from ::ffff:127.0.0.1

en dit is de log van 192.168.1.2

[2010/11/06 15:12:08.729261, 0] lib/access.c:410(check_access)
Denied connection from (::ffff:192.168.1.2)
[2010/11/06 15:12:08.729550, 1] smbd/process.c:2295(smbd_process)
Connection denied from ::ffff:192.168.1.2

  • Caelorum
  • Registratie: april 2005
  • Nu online
Ik zou even in de firewall van fedora kijken. Standaard staat die geloof ik zo ingesteld dat smb verkeer wordt geblokkeerd.

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
Caelorum schreef op zaterdag 06 november 2010 @ 16:35:
Ik zou even in de firewall van fedora kijken. Standaard staat die geloof ik zo ingesteld dat smb verkeer wordt geblokkeerd.
Ik heb de firewall uitgezet

  • DiedX
  • Registratie: december 2000
  • Laatst online: 13:48
Begin maar met je hosts allow aan te passen in je smb.conf:

hosts allow = 192.168.0.0

Terwijl je vanaf 192.168.1.0/24 komt...

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
DiedX schreef op zaterdag 06 november 2010 @ 18:38:
Begin maar met je hosts allow aan te passen in je smb.conf:

hosts allow = 192.168.0.0

Terwijl je vanaf 192.168.1.0/24 komt...
oke ik heb nu mijn host allow op 192.168.1.3 en ik kan nu de mappen printers en faxapparaten en loek zien.
maar nog geen optie share.

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
verbatim schreef op zaterdag 06 november 2010 @ 19:48:
[...]


oke ik heb nu mijn host allow op 192.168.1.3 en ik kan nu de mappen printers en faxapparaten en loek zien.
maar nog geen optie share.
Ik heb nu browseble = yes gezet en ik kan nu de map homes zien maar ik krijg geen acces op home.

  • DiedX
  • Registratie: december 2000
  • Laatst online: 13:48
Verbatim, je weet ondertussen waar het logboek zit. Maak daar gebruik van, we hebben het allemaal eens moeten leren.

Voor nu: hoe staan de userrights op de directory die je wil benaderen?

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
DiedX schreef op maandag 08 november 2010 @ 00:06:
Verbatim, je weet ondertussen waar het logboek zit. Maak daar gebruik van, we hebben het allemaal eens moeten leren.

Voor nu: hoe staan de userrights op de directory die je wil benaderen?
Ik had ook nog een chmod 777 gedaan op /home/loek/sahre.
bedoel je dit :
-rw-rw-r--. 1 loek loek 0 nov 6 15:14 \192.168.1.2

  • DiedX
  • Registratie: december 2000
  • Laatst online: 13:48
Ik weet niet welk pad jij nu de verkeerde rechten geeft?

Terug naar af:

met welke user log jij nu in op je Samba-share? Is dat de user loek?

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
DiedX schreef op dinsdag 09 november 2010 @ 11:31:
Ik weet niet welk pad jij nu de verkeerde rechten geeft?

Terug naar af:

met welke user log jij nu in op je Samba-share? Is dat de user loek?
Ja ik log in met user loek.

  • DiedX
  • Registratie: december 2000
  • Laatst online: 13:48
verbatim schreef op dinsdag 09 november 2010 @ 11:34:
[...]


Ja ik log in met user loek.
En kan je eens:

code:
1
ls -l /home


en
code:
1
ls -l /home/loek


doen?

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
DiedX schreef op dinsdag 09 november 2010 @ 13:11:
[...]

En kan je eens:

code:
1
ls -l /home


en
code:
1
ls -l /home/loek


doen?
-rw-rw-r--. 1 loek loek 0 nov 6 15:14 \192.168.1.2
drwxr-xr-x. 2 loek loek 4096 nov 5 14:53 Afbeeldingen
drwxr-xr-x. 2 loek loek 4096 nov 5 14:53 Bureaublad
drwxr-xr-x. 2 loek loek 4096 nov 5 14:53 Documenten
drwxr-xr-x. 2 loek loek 4096 nov 5 15:10 Downloads
drwxr-xr-x. 2 loek loek 4096 nov 5 14:53 Muziek
drwxr-xr-x. 2 loek loek 4096 nov 5 14:53 Openbaar
-rw-rw-r--. 1 loek loek 0 nov 6 15:14 run
drwxrwxrwx. 2 root root 4096 nov 5 17:04 share
drwxr-xr-x. 2 loek loek 4096 nov 5 14:53 Sjablonen
drwxr-xr-x. 2 loek loek 4096 nov 5 14:53 Video's

  • DiedX
  • Registratie: december 2000
  • Laatst online: 13:48
En heb jij die directories daar neergezet? Of stonden die daar al?

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
DiedX schreef op dinsdag 09 november 2010 @ 15:29:
En heb jij die directories daar neergezet? Of stonden die daar al?
Ik heb gisteren geloof ik een chmod 777 uitgevoerd op /home/loek/share.

  • DiedX
  • Registratie: december 2000
  • Laatst online: 13:48
maar doe dat even op /home/loek

dus:

chown loek:loek /home/loek
chmod 777 /home/loek

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
DiedX schreef op dinsdag 09 november 2010 @ 15:55:
maar doe dat even op /home/loek

dus:

chown loek:loek /home/loek
chmod 777 /home/loek
Heb ik gedaan. Nu heb ik twee mappen een met homes en een met loek. En ik krijg op allebei acces denied.

  • DiedX
  • Registratie: december 2000
  • Laatst online: 13:48
Wat geven je logfiles ondertussen aan?

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
DiedX schreef op dinsdag 09 november 2010 @ 17:57:
Wat geven je logfiles ondertussen aan?
[2010/11/07 17:02:46.392411, 0] lib/access.c:410(check_access)
Denied connection from (::ffff:192.168.1.2)
[2010/11/07 17:02:46.392693, 1] smbd/process.c:2295(smbd_process)
Connection denied from ::ffff:192.168.1.2

[2010/11/07 16:37:09.929800, 0] lib/access.c:410(check_access)
Denied connection from (::ffff:127.0.0.1)
[2010/11/07 16:37:09.930089, 1] smbd/process.c:2295(smbd_process)
Connection denied from ::ffff:127.0.0.1

  • Big Mama
  • Registratie: mei 2000
  • Laatst online: 16:46
Connection denied, lijkt me duidelijk. Heeft niets met rechten op een directory te maken, maar wordt gelijk al geblokkeerd door samba.

Oorzaak zit waarschijnlijk in 'hosts_allow' (in smb.conf), die staat bij jou als:
hosts allow = 192.168.1.3

terwijl je van 192.168.1.2 lijkt te komen.

Verander hem eens in:
hosts allow = 192.168.1.0/24

Computers follow your orders, not your intentions.


  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
Big Mama schreef op dinsdag 09 november 2010 @ 19:55:
Connection denied, lijkt me duidelijk. Heeft niets met rechten op een directory te maken, maar wordt gelijk al geblokkeerd door samba.

Oorzaak zit waarschijnlijk in 'hosts_allow' (in smb.conf), die staat bij jou als:
hosts allow = 192.168.1.3

terwijl je van 192.168.1.2 lijkt te komen.

Verander hem eens in:
hosts allow = 192.168.1.0/24
Heb ik gedaan maar nog steeds connection denied.
Maar ik heb er wel twee logbestanden bij. Namelijjk nmbd en smbd.

  • jbhc
  • Registratie: juli 2007
  • Laatst online: 19-09 12:44
ik zou hosts allow veranderen in 192.168.1.2
Ook was het bij mij zo dat de username en het wachtwoord van samba exact het zelfde moesten zijn als die van windows.

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
jbhc schreef op dinsdag 09 november 2010 @ 21:43:
ik zou hosts allow veranderen in 192.168.1.2
Ook was het bij mij zo dat de username en het wachtwoord van samba exact het zelfde moesten zijn als die van windows.
Ik heb het veranderd maar nu krijg ik op windowsclient: Mygroup is niet toegankelijk.U hebt mogelijk niet de juiste machtigingen voor deze netwerkbron.
En op windows heb ik geen wachtwoord.

  • jbhc
  • Registratie: juli 2007
  • Laatst online: 19-09 12:44
kun je eens op de windows pc het volgende doen:
(windows-nl) start -->uitvoeren -->cmd
(of windows-eng) start -->run -->cmd
ipconfig /all

en daar de output van geven?

[Voor 17% gewijzigd door jbhc op 09-11-2010 22:46]


  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
Ik ga nu slapen. Morgen maar weer verder als het kan.
Nog bedankt tot zover.

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
jbhc schreef op dinsdag 09 november 2010 @ 22:45:
kun je eens op de windows pc het volgende doen:
(windows-nl) start -->uitvoeren -->cmd
(of windows-eng) start -->run -->cmd
ipconfig /all

en daar de output van geven?
Microsoft Windows XP [versie 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

start -->uitvoeren--cmd lukt niet.

C:\Documents and Settings\loek>ipconfig /all

Windows IP-configuratie

Host-naam . . . . . . . . . . . .: dompeling
Primair DNS-achtervoegsel. . . . .:
Knooppunttype: . . . . . . . . . .: onbekend
IP-routering ingeschakeld. . . . .: nee
WINS-proxy ingeschakeld . . . . . : nee

Ethernet-adapter LAN-verbinding:

Verbindingsspec. DNS-achtervoegsel:
Beschrijving . . . . . . . . . . .:
VIA Compatable Fast Ethernet Adapter
Fysiek adres. . . . . . . . . . . : 00-11-2F-E5-6B-A9
DHCP ingeshakeld. . . . . . . . . : ja
Autom. configuratie ingeschakeld. : ja
IP-adres. . . . . . . . . . . . . : 192.168.1.3
Subnetmasker. . . . . . . . . . . : 255.255.255.0
Standaardgateway. . . . . . . . . : 192.168.1.1
DHCP-server . . . . . . . . . . . : 192.168.1.1
DNS-servers . . . . . . . . . . . : 192.168.1.1
Lease verkregen . . . . . . . . . : woensdag 10 november 2010 8:11:08
Lease verlopen . . . . . . . . . : woensdag 10 november 2010 20:11:09

C:\Documents and Settings\loek>

  • jbhc
  • Registratie: juli 2007
  • Laatst online: 19-09 12:44
Ok,
1. Je windows pc heeft geen domein naam. Zorg dat deze het zelfde is als die van de Samba server (in jouw geval dus MYNETWORK) (Eventueel kun je dit in je router instellen)

2. Heeft je server een vast IP adres?

3. Het ip adres van de windows pc is 192.168.1.3 dus je kunt dat zo laten staan.
(Maar let op als je een dhcp server hebt draaien kan deze veranderen)

4. Volg eens deze tutorial omdat jouw windows pc geen wachtwoorden gebruikt.

  • Sosabowski
  • Registratie: juni 2003
  • Laatst online: 09-07 20:54
Je hebt dezelfde gebruiker op de windows bak en op de Fedora bak.Maar heb je die gebruiker ook aangemaakt in samba?

https://help.ubuntu.com/c...onfiguration%20-%20Manual
Add users who can access your shares with the 'smbpasswd' command.

The whole problem with the world is that fools and fanatics are always so certain of themselves, and wiser people so full of doubts. -- Bertrand Russell


  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
Sosabowski schreef op woensdag 10 november 2010 @ 20:53:
Je hebt dezelfde gebruiker op de windows bak en op de Fedora bak.Maar heb je die gebruiker ook aangemaakt in samba?

https://help.ubuntu.com/c...onfiguration%20-%20Manual

[...]
Bedankt voor je reactie en ik heb in windows mynetwork gezet.
Maar ik krijg nog steeds acces denied.
En bedankt voor de tutorial.

  • jbhc
  • Registratie: juli 2007
  • Laatst online: 19-09 12:44
@Sosabowski

Hij heeft geen wachtwoord op zijn xp :)
(misschien is het trouwens een idee om de samba user in ieder geval de zelfde gebruikersnaam te geven als de xp gebruiker ?)

  • machje
  • Registratie: juli 2003
  • Laatst online: 20-03-2014

machje

fedra

jbhc schreef op woensdag 10 november 2010 @ 22:03:
@Sosabowski

Hij heeft geen wachtwoord op zijn xp :)
(misschien is het trouwens een idee om de samba user in ieder geval de zelfde gebruikersnaam te geven als de xp gebruiker ?)
Volgens mij is dit ook gelijk het probleem!
Windows shares zijn niet benaderbaar zonder passwd. (zover ik weet)
Zet een passwd op je xp installatie, zorg dat je werkgroep overeen komt.
Je shares zouden nu benaderbaar moeten zijn.
Verander de rechten zodat niet iedere janzak (of jijzelf) kan uitvoeren maar alleen root, (om problemen te voorkomen)!!!

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
machje schreef op donderdag 11 november 2010 @ 10:40:
[...]


Volgens mij is dit ook gelijk het probleem!
Windows shares zijn niet benaderbaar zonder passwd. (zover ik weet)
Zet een passwd op je xp installatie, zorg dat je werkgroep overeen komt.
Je shares zouden nu benaderbaar moeten zijn.
Verander de rechten zodat niet iedere janzak (of jijzelf) kan uitvoeren maar alleen root, (om problemen te voorkomen)!!!
Ik weet niet hoe ik een password op mijn windows xp moet zetten.

  • machje
  • Registratie: juli 2003
  • Laatst online: 20-03-2014

machje

fedra

verbatim schreef op donderdag 11 november 2010 @ 11:13:
[...]


Ik weet niet hoe ik een password op mijn windows xp moet zetten.
Dit is wel heel basic verbatim... :(
Maar goed, open configuratiescherm, open users, voeg passwd voor user toe......klaar!

  • verbatim
  • Registratie: november 2010
  • Laatst online: 05-09 16:30
machje schreef op donderdag 11 november 2010 @ 13:49:
[...]


Dit is wel heel basic verbatim... :(
Maar goed, open configuratiescherm, open users, voeg passwd voor user toe......klaar!
Thanks
Als ik nu inlog krijg ik Acces denied on file \\Mynetwork\homes en As Administrator.
Als ik As Administrator inlog is loek en password dan gebeurt er niks.
Hij blijft op de map homes staan.

  • machje
  • Registratie: juli 2003
  • Laatst online: 20-03-2014

machje

fedra

verbatim schreef op donderdag 11 november 2010 @ 15:27:
[...]

Thanks
Als ik nu inlog krijg ik Acces denied on file \\Mynetwork\homes en As Administrator.
Als ik As Administrator inlog is loek en password dan gebeurt er niks.
Hij blijft op de map homes staan.
Maak eens in windows een user aan die al een unix user is,
(die van fedora in jouw geval dus) en probeer het dan nog eens!
Volgens mij is dit nodig voor samba!

  • Sosabowski
  • Registratie: juni 2003
  • Laatst online: 09-07 20:54
machje schreef op donderdag 11 november 2010 @ 19:47:
[...]

Maak eens in windows een user aan die al een unix user is,
(die van fedora in jouw geval dus) en probeer het dan nog eens!
Volgens mij is dit nodig voor samba!
Bijna.
Zorg dat er een linux users is die ook bij samba bekend is.

Als jij vanuit je windows bak verbinding maakt naar je linux bak zal windowds gebruikersnaam en password doorgeven aan samba. Als deze niet overeenkomen krijg je een melding geen toegang. Is de gebruiker die windows doorgeeft aan samba niet bekend bij samab dan zou je een pop-up moeten krijgen die vraagt om username en password.

Kortom. Het makkelijkste testen is als je een gebruiker hebt met dezelfde username en password in zowel linux. samba als windows.

succes

The whole problem with the world is that fools and fanatics are always so certain of themselves, and wiser people so full of doubts. -- Bertrand Russell


  • jbhc
  • Registratie: juli 2007
  • Laatst online: 19-09 12:44
Verbatim,

Je moet dus in windows een user loek aanmaken die het zelfde wachtwoord heeft als de user loek in samba.

  • chrisO
  • Registratie: mei 2003
  • Laatst online: 15:24
in je smb.conf staat:
hosts allow = 192.168.0.0

en je probeert te connecten van 192.168.1.2 ?

misschien even je hosts allow in je [global] aanpassen naar:
hosts allow = 192.168.1.
Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee