Toon posts:

HP procurve switch en Cisco router (geen communicatie)

Pagina: 1
Acties:

Onderwerpen


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
Ik heb een Hp switch aan een cisco router hangen. aan de switch staat wat apparatuur die kan elkaar pingen. Op de router kan ik naar buiten pingen (interface 0/0)
Ik kan alleen niet naar binnen pingen (interface 0/1)

Op de switch kan ik ook niet naar de router pingen. Er is geen verkeer tussen. De straightkabel is wel getest. en beide apparaten vertonen indicatielampjes dat er connectie is.

Op de switch staat trunking aan wegens 2 vlans.

Cisco router config:
Building configuration...

Current configuration : 1920 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 3600
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$HIwC$tQg1X16ChGVczCf.zz9IY1
enable password xxxxxx
!
no aaa new-model
no ip routing
!
no ip cef
!
!ip name-server 192.168.2.1
!!
voice-card 0
no dspfarm
!
interface FastEthernet0/0
description WAN Connection
ip address 10.6.98.185 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0.1
description Production Vlan
encapsulation dot1Q 1 native
ip address 172.22.2.1 255.255.255.0
ip helper-address 172.22.2.2
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
ip address 172.22.2.88 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1.99
description Sub-Interface VLAN 99
encapsulation dot1Q 99
ip address 10.99.99.1 255.255.255.0
ip helper-address 172.22.2.2
ip nat inside
ip virtual-reassembly
no ip route-cache
!
interface Serial0/0/0
ip address 172.22.2.10 255.255.255.0
no ip route-cache
clock rate 2000000
!
ip default-gateway 10.6.98.250
ip route 0.0.0.0 0.0.0.0 10.6.98.250
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 172.22.2.0 0.0.0.225
access-list 1 permit 10.99.99.0 0.0.0.255
snmp-server community public RO
!
control-plane
!
line con 0
line aux 0
line vty 0 4
password xxxxxxx
login
!
scheduler allocate 20000 1000
!
end



Wat the bleep gaat er fout ?

  • Bloodshot
  • Registratie: maart 2006
  • Laatst online: 22-09 16:27
Matcht aan beide zijden het native (untagged) VLAN wel?
Ik zou de base-config van de ethernet-if afhalen, een native vlan van 999 gebruiken zodat alles getagged wordt en per VLAN een subinterface aanmaken.

  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
De native vlan aan beide kanten is 1. Dat is de standaard als ik het goed zeg.

Ik heb als het goed is per vlan een inteface gemaakt met 0/1.1 en 0/1.99

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Hoe heb je op de switch trunking aangezet? In HP-land is een trunk namelijk een port aggregation (etherchannel in Cisco-taal), ofwel het samenvoegen van twee ports voor een hogere bandbreedte EN redundantie.

Ofwel: pleur de switchconfig er ook eens bij?

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
; J9147A Configuration Editor; Created on release #W.14.49

hostname "ProCurve 2910al-48G Switch"
module 1 type J9147A
module 3 type J9008A
mirror-port 10
trunk 1 Trk1 Trunk
ip default-gateway 172.22.2.2
vlan 1
name "Poduction Vlan"
untagged 2-48,B1-B2,Trk1
ip address 172.22.2.4 255.255.255.0
exit
vlan 99
name "Quarantaine VLAN"
ip address 10.99.99.2 255.255.255.0
exit
interface 2
monitor
exit
gvrp
radius-server host 172.22.2.99 key "procurve"
ip authorized-managers 172.22.2.88 255.255.255.0 access manager
ip dns server-address priority 2 192.168.2.1
snmp-server community "public" unrestricted
aaa authentication port-access eap-radius
aaa port-access authenticator 13-24
aaa port-access authenticator 13 client-limit 4
aaa port-access authenticator 14 client-limit 4
aaa port-access authenticator 15 client-limit 4
aaa port-access authenticator 16 client-limit 4
aaa port-access authenticator 17 client-limit 4
aaa port-access authenticator 18 client-limit 4
aaa port-access authenticator 19 client-limit 4
aaa port-access authenticator 20 client-limit 4
aaa port-access authenticator 21 client-limit 4
aaa port-access authenticator 22 client-limit 4
aaa port-access authenticator 23 client-limit 4
aaa port-access authenticator 24 client-limit 4
aaa port-access authenticator active
spanning-tree Trk1 priority 4

  • MrFX
  • Registratie: maart 2010
  • Laatst online: 26-09 08:15
interface FastEthernet0/0.1
description Production Vlan
encapsulation dot1Q 1 native
ip address 172.22.2.1 255.255.255.0
ip helper-address 172.22.2.2
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
ip address 172.22.2.88 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto

Als je FA 0/1 nu geen ip adres geeft werkt het dan wel?

Money and sex, storage and bandwidth: Only too much is ever enough.


  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Daar was ik al bang voor: je hebt poort 1 nu als trunk ingesteld. Trunk in HP-land is zoals ik al zei een port aggregation, niet een link waarover je meerdere VLANs kan transporteren.

Om poort 1 te laten 'trunken' zoals bij Cisco, moet je hem TAGGED in alle VLANs gooien die je wilt gebruiken. Dus:

vlan 1
tagged 1

vlan 99
tagged 1

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
That and a little mistake i made fixed it.

1 vraagje

Op het interne netwerk heb ik een dns server. die forward zijn request door naar een dns buiten mijn netwerk. maar als ik op de server ping naar die dns dan doet die dat niet (intern is 172.22.2.2 en extern is 192.168.2.1)

Het moet in de router geforward worden. hoe doe ik dit ?

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Hmm ik zie in ieder geval dat je een nulroute hebt naar je WAN-verbinding dus dat lijkt in orde. Ik zie echter ook dat er een default-gateway staat ingesteld. Ik weet niet of dat samenkan, normaal gesproken stel je maar 1 van de 2 in.

edit: ofwel post je routetabel eens met sh ip route?

[Voor 10% gewijzigd door Vicarious op 05-11-2010 11:34]

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
Uhmmm die is leeg......

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Dan gaat het sowieso niet werken. Misschien nog even het globale commando ip routing invoeren om te zorgen dat het apparaat gaat routeren?

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
3600#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.6.98.250 to network 0.0.0.0

172.22.0.0/24 is subnetted, 1 subnets
C 172.22.2.0 is directly connected, FastEthernet0/1.1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.99.99.0/24 is directly connected, FastEthernet0/1.99
C 10.6.98.0/24 is directly connected, FastEthernet0/0
S 10.6.98.250/32 [254/0] via 10.6.98.250, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 10.6.98.250

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Hmm je routes lijken te kloppen, dus ik ben even naar je NAT gaan kijken en die klopt volgens mij niet. Bovendien begrijp ik niet helemaal hoe je productie-vlan nu op dezelfde fysieke interface kan zitten als je WAN connectie. Ik zou eerst eens een netwerktekeningetje maken over hoe je het nou wilt hebben.

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
router had tijd nodig om alles te zien denk. kan nu wel van binnen naar buiten

  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
Ik krijg wel een IP uit vlan1 maar niet uit vlan 99. Moet ik hier iets speciaals voor doen ?
3600#show run
Building router configuration...

Current configuration : 1472 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 3600
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$y1PD$kfiTNLkhYSVe1vKBENEY/.
enable password
!
no aaa new-model
!
!
ip cef
!
voice-card 0
no dspfarm
!
!
!
interface FastEthernet0/0
description WAN
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
Interface FastEthernet0/1
no ip address
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1.1
description Vlan 1
encapsulation dot1Q 1 native
ip address 172.22.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.99
description Vlan 99
encapsulation dot1Q 99
ip address 10.99.99.1 255.255.255.0
ip helper-address 172.22.2.2
ip nat inside
ip virtual-reassembly
!
interface Serial0/0/0
ip address 172.22.2.10 255.255.255.0
clock rate 2000000
!
ip default-gateway 10.6.98.250
ip route 0.0.0.0 0.0.0.0 10.6.98.250
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 172.22.2.0 0.0.0.255
access-list 1 permit 10.99.99.0 0.0.0.255
snmp-server community public RO
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password
login
!
scheduler allocate 20000 1000
!
end


Running configuration:

; J9147A Configuration Editor; Created on release #W.14.49

hostname "ProCurve 2910al-48G Switch"
module 1 type J9147A
module 3 type J9008A
mirror-port 10
ip default-gateway 172.22.2.1
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged 1-48,B1-B2
ip address 172.22.2.4 255.255.255.0
exit
vlan 99
name "Quarantaine"
forbid 3,27
no ip address
exit
interface 1-2
monitor
exit
gvrp
radius-server host 172.22.2.99 key "procurve"
ip dns server-address priority 1 192.168.2.2
ip route 10.99.99.0 255.255.255.0 10.99.99.1
snmp-server community "public" unrestricted
aaa authentication port-access eap-radius
aaa port-access authenticator 13-14
aaa port-access authenticator active

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Als je een computer in VLAN 99 wil hebben moet je die switchport UNTAGGED in dat VLAN zetten.

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
Ja heb ik gedaan. maar er is geen dhcp request.

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Swennienl schreef op dinsdag 09 november 2010 @ 13:24:
Ja heb ik gedaan. maar er is geen dhcp request.
Je hebt op dat VLAN een ander IP helper adres staan. Is dat bewust (ofwel: heb je 2 dhcp servers) of is dat een typfout? Verder heb ik al eerder gezegd dat ik je netwerk niet helemaal snap, een overzichtelijk tekeningetje erbij zou helpen.

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Je cisco router heeft ook nog een serial0/0/0 interface die in 172.2.2.0/24 zit. Hoe weet de router nu of hij de DHCP request uit moet sturen via die serial interface of via je ethernet interface?

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
Ik heb de serial interface uitgeschakeld.

Het probleem zit hem in de switch denk ik, het tagged untagged en gvrs verhaal.

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

gvrp bedoel je? Waarom staat dat aan dan?

Verder: als je de huidige config van je vlans geeft en aangeeft welke poort je in VLAN 99 wilt hebben kan ik even kijken of daar nog wat misgaat.

Vicariously I live while the whole world dies


  • Swennienl
  • Registratie: december 2009
  • Laatst online: 07-04 16:33
Probleem is opgelost.
Thnx

  • Vicarious
  • Registratie: juni 2008
  • Laatst online: 01-10-2020

Vicarious

☑Rekt | ☐ Not rekt

Ok, wat was er mis dan? Wel zo handig als iemand anders naar een vergelijkbaar probleem zoekt.

[Voor 6% gewijzigd door Vicarious op 11-11-2010 20:30]

Vicariously I live while the whole world dies

Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee