Toon posts:

Geen gateway bij Cisco VPN

Pagina: 1
Acties:

Onderwerpen


  • Kosovo
  • Registratie: september 2010
  • Laatst online: 17-12-2010
Hallo Tweakers,

Ik ben zojuist al een tijdje bezig met cisco routers voor me stage. Ik heb er niet echt verstand van, maar ik doe mijn best.

Heb een probleempje, als ik een VPN verbinding maak naar me router krijg ik geen gateway toegewezen. Heeft iemand enig idee waar dat kan liggen, of wat er mist in me configuratie.

Mijn config file:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
Building configuration...



Current configuration : 9636 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname CISCO-Hajdarpasha

!

boot-start-marker

boot-end-marker

!

logging buffered 51200

logging console critical

enable secret 5 $1$JzF2$I7IS7UCfhjBUoCbzP7KBs1

!

aaa new-model

!

!

aaa group server radius SDM_DOT1X_RAD_GRP

 server 192.168.62.254 auth-port 1645 acct-port 1646

!

aaa authentication login default local

aaa authentication login ciscocp_vpn_xauth_ml_1 local

aaa authentication login ciscocp_vpn_xauth_ml_2 local

aaa authentication dot1x default group SDM_DOT1X_RAD_GRP

aaa authorization exec default local 

!

!

aaa session-id common

clock timezone PCTime 1

clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00

!

dot11 syslog

no ip source-route

ip cef

ip dhcp smart-relay

no ip dhcp use vrf connected

ip dhcp bootp ignore

ip dhcp excluded-address 192.168.62.1 192.168.62.49

ip dhcp excluded-address 192.168.62.56 192.168.62.254

!

ip dhcp pool ccp-pool1

   import all

   network 192.168.62.0 255.255.255.0

   dns-server 212.21.244.66 217.21.244.7 

   default-router 192.168.62.254 

!

ip dhcp pool SDM_UNTRUSTED_POOL1

   network 192.168.5.0 255.255.255.0

   dns-server 212.21.244.66 217.21.244.7 

   default-router 192.168.5.1 

!

!

no ip bootp server

ip name-server 8.8.8.8

ip name-server 8.8.4.4

!

vpdn enable

!

vpdn-group 1

! Default PPTP VPDN group

 accept-dialin

  protocol pptp

  virtual-template 1

!

dot1x system-auth-control

identity profile dot1x

 auth-type not-authorize policy SDM_DOT1X_POLICY_1

identity policy SDM_DOT1X_POLICY_1

 template Virtual-Template2

!

!

username admin privilege 15 secret 5 $1$3qjp$d4vgj0F5SzlhpI7netk8o/

username Hajdarpasha privilege 15 secret 5 $1$CWFY$JboIxNCyn8QLGAzz6nwB30

username cisco password 7 060506324F41584B56

username cisco12 password 7 110A1016141D5A5E

! 

!

crypto isakmp policy 1

 hash md5

 authentication pre-share

 lifetime 28800

!

crypto isakmp policy 2

 hash md5

 authentication pre-share

 lifetime 3600

crypto isakmp key ********* address 78.***.1*1.61 255.255.255.248

crypto isakmp aggressive-mode disable

!

crypto ipsec security-association lifetime kilobytes 100000

crypto ipsec security-association lifetime seconds 28800

!

crypto ipsec transform-set Peja_TSET esp-des esp-md5-hmac 

crypto ipsec df-bit clear

!

crypto ipsec profile profielPeja

 set security-association idle-time 3600

 set transform-set Peja_TSET 

 set pfs group1

!

!

crypto map SDM_CMAP_1 1 ipsec-isakmp 

 description Tunnel to78.***.1*1.61

 set peer 78.***.1*1.61

 set security-association idle-time 3600

 set transform-set Peja_TSET 

 set pfs group1

 match address 100

!

crypto map SDM_CMAP_2 1 ipsec-isakmp 

 description Tunnel to78.***.1*1.61

 set peer 78.***.1*1.61

 set security-association idle-time 3600

 set transform-set Peja_TSET 

 set pfs group1

 match address 104

!

archive

 log config

  hidekeys

!

!

ip tcp mss 1300

ip tcp synwait-time 10

ip ssh time-out 60

ip ssh authentication-retries 2

ip ssh version 2

!

class-map type inspect match-any SDM_AH

 match access-group name SDM_AH

class-map type inspect match-any ccp-skinny-inspect

 match protocol skinny

class-map type inspect match-any SDM_ESP

 match access-group name SDM_ESP

class-map type inspect match-any SDM_SSH

 match access-group name SDM_SSH

class-map type inspect match-any SDM_HTTPS

 match access-group name SDM_HTTPS

class-map type inspect match-any SDM_SHELL

 match access-group name SDM_SHELL

class-map type inspect match-any ccp-sip-inspect

 match protocol sip

!

!

!

!

interface FastEthernet0

 switchport mode trunk

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

 description $ES_WAN$$ETH-WAN$$FW_OUTSIDE$

 ip address 78.***.1*1.58 255.255.255.248

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 ip mtu 1300

 ip nat outside

 ip virtual-reassembly

 ip route-cache flow

 ip tcp adjust-mss 1300

 duplex auto

 speed auto

 crypto map SDM_CMAP_2

 crypto ipsec df-bit clear

!

interface Virtual-Template1 

 ip unnumbered Vlan1

 peer default ip address pool test

 no keepalive

 ppp encrypt mppe auto

 ppp authentication pap chap ms-chap

!

interface Vlan1

 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$

 ip address 192.168.62.254 255.255.255.0

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 ip nat inside

 ip virtual-reassembly

 ip route-cache flow

 ip tcp adjust-mss 1300

 crypto ipsec df-bit clear

!

ip local pool test 192.168.62.1 192.168.62.250

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 78.***.1*1.62

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip dns server

ip nat inside source static tcp 10.27.13.4 3389 interface Vlan1 3389

ip nat inside source route-map SDM_RMAP_1 interface FastEthernet4 overload

ip nat inside source route-map SDM_RMAP_2 interface FastEthernet4 overload

!

ip access-list extended SDM_AH

 remark CCP_ACL Category=1

 permit ahp any any

ip access-list extended SDM_ESP

 remark CCP_ACL Category=1

 permit esp any any

ip access-list extended SDM_HTTPS

 remark CCP_ACL Category=1

 permit tcp any any eq 443

ip access-list extended SDM_SHELL

 remark CCP_ACL Category=1

 permit tcp any any eq cmd

ip access-list extended SDM_SSH

 remark CCP_ACL Category=1

 permit tcp any any eq 22

!

logging trap debugging

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 192.168.62.0 0.0.0.255

access-list 2 remark CCP_ACL Category=2

access-list 2 permit 192.168.5.0 0.0.0.255

access-list 100 remark CCP_ACL Category=4

access-list 100 remark IPSec Rule

access-list 100 permit ip 192.168.62.0 0.0.0.255 192.168.5.0 0.0.0.255

access-list 101 remark CCP_ACL Category=2

access-list 101 remark IPSec Rule

access-list 101 deny   ip 192.168.62.0 0.0.0.255 192.168.5.0 0.0.0.255

access-list 101 permit ip 192.168.62.0 0.0.0.255 any

access-list 102 remark CCP_ACL Category=4

access-list 102 remark IPSec Rule

access-list 102 permit ip 192.168.62.0 0.0.0.255 192.168.5.0 0.0.0.255

access-list 103 remark CCP_ACL Category=2

access-list 103 remark IPSec Rule

access-list 103 deny   ip 192.168.62.0 0.0.0.255 192.168.5.0 0.0.0.255

access-list 103 permit ip 192.168.5.0 0.0.0.255 any

access-list 104 remark CCP_ACL Category=4

access-list 104 remark IPSec Rule

access-list 104 permit ip 192.168.62.0 0.0.0.255 192.168.5.0 0.0.0.255

no cdp run

!

!

route-map SDM_RMAP_1 permit 1

 match ip address 101

!

route-map SDM_RMAP_2 permit 1

 match ip address 103

!

radius-server host 192.168.62.254 auth-port 1645 acct-port 1646

radius-server vsa send authentication

!

control-plane

!

banner exec ^C

% Password expiration warning.

-----------------------------------------------------------------------

 

Cisco Configuration Professional (Cisco CP) is installed on this device 

and it provides the default username "cisco" for  one-time use. If you have 

already used the username "cisco" to login to the router and your IOS image 

supports the "one-time" user option, then this username has already expired. 

You will not be able to login to the router with this username after you exit 

this session.

 

It is strongly suggested that you create a new username with a privilege level 

of 15 using the following command.

 

username <myuser> privilege 15 secret 0 <mypassword>

 

Replace <myuser> and <mypassword> with the username and password you 

want to use.

 

-----------------------------------------------------------------------

^C

banner login ^CAuthorized access only!

 Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

 no modem enable

 transport output telnet

line aux 0

 transport output telnet

line vty 0 4

 transport input telnet ssh

!

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

end


Alvast bedankt !

  • TrailBlazer
  • Registratie: oktober 2000
  • Laatst online: 22:20

TrailBlazer

Karnemelk FTW

code:
1
2
3
4
5
6
interface Virtual-Template1 
 ip unnumbered Vlan1
 peer default ip address dhcp
!
ip dhcp-server 192.168.62.254 
ip bootp server

probeer dit eens. Je gebruikt nu geen dhcp maar die pool en in die pool zit geen default gateway.

Vrouwen kunnen twee dingen tegelijk.... zeuren en iets anders.


  • Kosovo
  • Registratie: september 2010
  • Laatst online: 17-12-2010
Hij krijgt nu wel een IP van zijn DHCP reeks. Alleen zijn standaard gateway krijgt hij nu nog steeds niet.

Wat ik er nu in hebs taan is:
code:
1
2
3
4
5
6
interface Virtual-Template1
 ip unnumbered Vlan1
 peer default ip address dhcp
 no keepalive
 ppp encrypt mppe auto
 ppp authentication pap chap ms-chap


Ik krijg ip bootp server er niet in verwerkt, komt dat misschien omdat ip dhcp bootp ignore erinstaat ?

off-topic: IDD Sigur Ros FTW!! er is geen betere band dan Sigur Ros, het is gewoon kunst !

  • Kosovo
  • Registratie: september 2010
  • Laatst online: 17-12-2010
ik heb er zojuist ip nat inside bij interface Virtual-Template1 toegevoegd. Ik krijg wel internettoegang, maar pingen naar het interne netwerk werkt niet. Alsnog krijgt die geen standaard gateway.

  • TrailBlazer
  • Registratie: oktober 2000
  • Laatst online: 22:20

TrailBlazer

Karnemelk FTW

Als je kan internetten lijkt het me dat je default-gateway werkt. Je interne netwerk is ook vlan1 (192.168.62.0/24) neem ik aan. Waarom zet je niet gewoon een hard ip adres uit een ander subnet op je virtual template (kan dat weinig ervaring met dit soort dial meuk) en maak je een aparte DHCP scope aan voor je VPN gebruikers.

Vrouwen kunnen twee dingen tegelijk.... zeuren en iets anders.


  • Kosovo
  • Registratie: september 2010
  • Laatst online: 17-12-2010
Nope, vlan1 is bij mij 192.168.62.254/24

  • TrailBlazer
  • Registratie: oktober 2000
  • Laatst online: 22:20

TrailBlazer

Karnemelk FTW

Zet gewoon hard een ip adres op je virtual template uit een ander subnet 192.168.63.0/24 ofzo en maak daar ook een DHCP pool voor aan. Je clients krijgen nu een ip adres uit dezelfde reeks als je lokale lan. Ik weet niet of dat helemaal lekker werkt namelijk.

Vrouwen kunnen twee dingen tegelijk.... zeuren en iets anders.


  • Kosovo
  • Registratie: september 2010
  • Laatst online: 17-12-2010
Oke, ik zal het ff uitvogelen hoe dat moet. Als ik er niet uitkom dan klop ik hier nog eventjes aan.

  • Equator
  • Registratie: april 2001
  • Laatst online: 21:53

Equator

Crew Council

Bowmore & Laphroaig fan

Doe dat dan maar wel in Netwerken want een stageopdracht hoort niet in PNS :)

Moved..

Verder zou ik het in het vervolg op prijs stellen dat je slechts het deel van je config plaatst waar het om gaat. Want om nou gewoon je config te dumpen in de hoop dat iemand je wel helpt is wel erg makkelijk :)

[Voor 50% gewijzigd door Equator op 03-11-2010 15:44]

Vragen/opmerkingen
Privacy is something you can sell, but you can't buy back!


  • kokkel
  • Registratie: september 2000
  • Laatst online: 16-08 11:19
Ik zou het structureel aanpakken.
- DSL / Externe int configgen zoals het hoord.
- Intern vlan 1
- NAT
- Testen
- Dicht timmeren firewall (indien nodig)
- Bv met ip inspect
- Dan VPN configureren
- Zou split tunneling doen (gaat alleen verkeer over de vpn wat daar moet wezen en niet alles)
- Testen
Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee