Toon posts:

[Excel 2010] Importeren CSV, decimaal herkenning

Pagina: 1
Acties:

Onderwerpen


  • Keiichi
  • Registratie: juni 2005
  • Laatst online: 09:28
Van de week heb ik een PC omgeschakeld van Office 2003 naar Office 2010.

Een van de dingen die hiermee gedaan wordt, is het importeren van een CSV naar excel. Een echt mooi CSV bestand is het niet, de kolommen zijn met vaste lengte gescheiden, voor decimalen word een '.' gebruikt en bij een waarde '0', komt deze naar voren als '.0000000000'

Bij het importeren, worden bij de geadvanceerde instellingen ingesteld dat de '.' als decimaal seperator gebruikt moet worden.

Bij 2010, worden de getalen '.0000000000' niet meer als cijfer herkend, maar als plaintext. Excel 2003 wist dit nog wel gewoon te doen.

'Oplossingen' die op het internet te vinden zijn, maken allen gebruik van een macro, hier ben ik alleen niet zo'n grote fan van. Is deze bug nog op andere manieren op te lossen of te omzeilen?

Solar @ Dongen: http://solar.searchy.net/ - Penpal International: http://ppi.searchy.net/


  • sanfranjake
  • Registratie: april 2003
  • Niet online

sanfranjake

Computers can do that?

(overleden)
Ik draai CVS in de titel dan nog even de letters om zodat er daadwerkelijk staat wat je bedoelt :)

Mijn spoorwegfotografie
Somda - Voor en door treinenspotters


  • pedorus
  • Registratie: januari 2008
  • Niet online
Heb je al geprobeerd de systeeminstellingen op de Engelse te zetten en 'use system settings' te gebruiken? Of wil je daar juist Nederlandse instellingen?

Ik kan dit met 2007 met Engelse systeeminstellingen iig niet reproduceren.

Vitamine D tekorten in Nederland | Middelen tegen corona


  • svertue
  • Registratie: november 2010
  • Laatst online: 30-08 11:02
Hier getest met office 2010 op XP sp3: de enige manier om office 2010 de waarde .00000000 als getal 0 te laten herkennen is je landinstellingen in het configuratiescherm aan te passen naar bv. Engels (verenigde staten). De waarden die je zelf opgeeft in Excel 2010 bij de geavanceerde instellingen tijdens het importeren worden gewoon genegeerd.

Afgekeken van Tiago Maymone's reactie op:
http://www.howtogeek.com/...ort-text-into-excel-2007/

Met een beetje tweaken kun je bij de landinstellingen je eigen voorkeur opgeven: het gaat erom dat je het de punt als decimaalscheidingsteken instelt, en de komma als cijfergroeperingssymbool.


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee