Toon posts:

Boot.ini kapot? [Windows XP}

Pagina: 1
Acties:

Onderwerpen


  • Marnixzzz
  • Registratie: februari 2009
  • Laatst online: 19-09 20:14
Ik heb hier een EEE PC 901 staan met bootproblemen. De laptop heeft 2 SSD's: 1 van 3.7 GB en 1 van 7 GB(vraag me niet waarom zo belachelijk klein). Ik heb windows XP op de schijf van 7 GB geínstalleerd.
Het probleem is dat van welke schijf ik ook boot, ik kan niet doorstarten. Ik krijg iedere keer een andere foutmelding.
Als ik echter van mijn usb stick start met daarop de installatie van windows XP (gemaakt met Novicorp WinToFlash) heb ik (door WinToFlash) meerdere opties:
1. Installatie van Xp starten
2. Doorstarten van 1e harde schijf
3. Debug opstarten vanaf schijf 0, partitie 1 (de schijf van 3GB is schijf 0)
4. Debug opstarten vanaf schijf 0, partitie 2
5. Debug opstarten vanaf schijf 1, partitie 1 (De schijf van 7GB is schijf 1)
6. Debug opstarten vanaf schijf 1, partitie 2

Als ik voor nummer 5 kies start Xp gewoon netjes op. Er zit dus iets fout in de boot.ini als ik dat zo bekijk. Ik heb al verschillende dingen geprobeerd in de herstelconsole.:
1. Bootcfg /rebuild
2.fixboot c:
3. fixboot d:
4. fixmbr c:
5. fixmbr d:

Ik krijg de volgende foutmeldingen:

1.Windows kan niet worden gestart vanwege een schijfconfiguratieprobleem in de computer.
Kan de geselecteerde opstartdiskette niet lezen

2.Windows kan niet worden gestart omdat het volgende bestand is beschadigd of niet kan worden gevonden:
<windows-hoofdmap>system32\hal.dll
Installeer het bovenstaande bestand opnieuw.


Deze 2 meldingen komen dus niet bij opstarten vanaf de usb stick met optie 5.

Ik dacht dus slim te zijn een aangepaste boot.ini erin te zetten via de herstelconsole. Op beide schijven staat nu deze boot.ini:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn

Ik krijg nu 2 opties tijdens het opstarten : Xp professional of ''leeg''(dit komt door bootcfg /rebuild, waarin ik aangeef dat de installatie ''leeg'' moet heten)

Nu mijn simpele vraag: Wat nu? :P

  • Dramatic
  • Registratie: juli 2010
  • Laatst online: 15-09 18:57
nvm..

[Voor 96% gewijzigd door Dramatic op 24-10-2010 00:03. Reden: & zal wel 7 betekenen]


  • wagenveld
  • Registratie: februari 2002
  • Niet online
Is het 1 SSD met 2 partities of 2 aparte SSDs? Wat waarschijnlijk het probleem is, is dat disk0 automatisch actief wordt gezet en dus de bootsector krijgt. Handigst lijkt mij om in het geval van 2 aparte SSDs de eerste er tijdelijk uit te halen en dan met de herstelconsole nogmaals fixboot en fixmbr te doen, en met fdisk de active vlag te zetten. Zie hier voor uitleg:
The computer does not start after you change the active partition by using the Disk Management tool

  • Marnixzzz
  • Registratie: februari 2009
  • Laatst online: 19-09 20:14
Was inderdaad ook al in me opgekomen, op het active zetten na dan. Ik ga het vanmiddag proberen!

Het zijn overigens 2 aparte SSD's

[Voor 16% gewijzigd door Marnixzzz op 24-10-2010 09:12]


  • Marnixzzz
  • Registratie: februari 2009
  • Laatst online: 19-09 20:14
Na de partitie actief te hebben gemaakt gaf hij de melding ntldr missing. Ik heb die van de cd af geplukt en naar de root gekopieerd, nog een keer de goeie schijf geselecteerd in het bios en: succes.

Bedankt


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee