Toon posts:

[MythBuntu] Hauppage WinTV (bt878) niet goed herkend

Pagina: 1
Acties:

  • NjitsSs
  • Registratie: oktober 2007
  • Laatst online: 22:23
Goedendag allen,

Ik heb volgend computersysteem voorzien van een verse MythBuntu 10.10 installatie: Pentium 4 2.4GHz, 256MB ram, ATI Radeon 9250, Hauppage WinTV (bt878).
Het probleem is nu dat de tvkaart niet goed herkend wordt door de computer. Xawtv crasht de eerste keer dat ik het programma start, de 2e keer start het wel goed op en geeft het enkel een groen beeld. Op de line-out van de tvkaart hoor ik echter wel het juiste geluid dat bij het afgestemde kanaal hoort.
Als xawtv de eerste keer crasht komt er in de console een melding dat hij een framebuffer adres niet juist kan vinden.

Output van dmesg:
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
stijn@mythTV:~$ dmesg | egrep '(bttv|bt87?|tveeprom)'
[    5.951701] bttv: driver version 0.9.18 loaded
[    5.951707] bttv: using 8 buffers with 2080k (520 pages) each for capture
[    5.952980] bttv: Bt8xx card found (0).
[    5.953011] bttv 0000:02:07.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[    5.953027] bttv0: Bt878 (rev 17) at 0000:02:07.0, irq: 18, latency: 132, mmio: 0xc0500000
[    5.953071] bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
[    5.953076] bttv0: using: Hauppauge (bt878) [card=10,autodetected]
[    5.953121] bttv0: gpio: en=00000000, out=00000000 in=00ffffdb [init]
[    5.955602] bttv0: Hauppauge/Voodoo msp34xx: reset line init [5]
[    5.986340] tveeprom 0-0050: Hauppauge model 44004, rev C108, serial# 2271273
[    5.986346] tveeprom 0-0050: tuner model is Philips FI1216 MK2 (idx 8, type 5)
[    5.986350] tveeprom 0-0050: TV standards PAL(B/G) (eeprom 0x04)
[    5.986354] tveeprom 0-0050: audio processor is None (idx 0)
[    5.986357] tveeprom 0-0050: has no radio
[    5.986360] bttv0: Hauppauge eeprom indicates model#44004
[    5.986364] bttv0: tuner type=5
[    6.741890] bttv0: audio absent, no audio device found!
[    7.121831] tuner 0-0061: chip found @ 0xc2 (bt878 #0 [sw])
[    7.968586] bttv0: registered device video0
[    7.968755] bttv0: registered device vbi0
[    7.968779] bttv0: PLL: 28636363 => 35468950 .. ok
[    8.005120] bt87x0: Using board 1, analog, digital (rate 32000 Hz)
[  305.876086] bttv0: PLL can sleep, using XTAL (28636363).


Bij het openen van xawtv:
code:
1
2
3
4
5
6
7
8
9
stijn@mythTV:~$ xawtv
This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.35-22-generic)
xinerama 0: 1440x900+0+0
WARNING: couldn't find framebuffer base address, try manual
         configuration ("v4l-conf -a <addr>")
v4l2: WARNING: framebuffer base address mismatch
v4l2: me=(nil) v4l=(nil)
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
game over



Iemand enig idee om die tvkaart werkend te krijgen? Ze heeft op een oude versie van MythBuntu ooit gewerkt, maar dat was in een andere computer...

Edit: Ik dacht dat het misschien aan de videokaart zou kunnen liggen... Die heb ik vervangen door een FX5200 (en het systeem opnieuw geinstalleerd), maar het probleem blijft.

[Voor 3% gewijzigd door NjitsSs op 13-10-2010 16:52]


  • NjitsSs
  • Registratie: oktober 2007
  • Laatst online: 22:23
Ik heb me vandaag nog wat bezig gehouden om de TV kaart werkend te krijgen.
Na het invoeren van volgende commando's kan ik TV kijken in xawtv:
sudo v4l-conf -a 0xF0000000
v4l-conf -1

Het framebuffer base adres wordt daardoor ingesteld, en er wordt gewerkt met v4l versie 1.
Ik moet dan wel in xawtv capture instellen op grabdisplay. Als ik dat niet doe dan krijg ik een zwart beeld.
Spijtig genoeg krijg ik nog steeds geen beeld in MythTV. MythTV kan ook geen kanalen vinden bij het automatisch scannen.
Iemand een idee?

  • lamko
  • Registratie: december 2001
  • Laatst online: 12-09 23:01
Ondersteund Mythtv uberhaupt dit oude spul nog wel bt878 met v4l v 1 ? Misschien probeer je wel iets wat helemaal wel niet meer kan werken.

And this !! Is to go even further beyond!!!


  • NjitsSs
  • Registratie: oktober 2007
  • Laatst online: 22:23
Overal op internet is te vinden dat een bt878 goed ondersteund wordt in MythTV... Ik zie niet in waarom ze opeens de ondersteuning zouden stoppen voor die hardware?


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee