Toon posts:

[APACHE] Javascript code corrupt

Pagina: 1
Acties:

  • DaRKie
  • Registratie: december 2001
  • Laatst online: 15:25
Ik heb sinds vandaag een zeer bizar probleem met mijn apache installatie:
Win 2003 SP 1
Apache 2.0.59
PHP 5.2.10

Het probleem:
Apache geeft mijn Javascript code/files verkeerd door.
Als ik de source bekijk, dan zie ik halverwege de file dat deze stopt en dan terug opnieuw het begin van de source file laat zien. Ik heb de source ook eens in eens TXT file geplaatst maar ook deze file heeft dit probleem. Als ik de files rechtstreeks op de server open doen, is alles OK.
De file die ik download is exact even groot in bytes als de file op de server.

Ik heb ook al eens een cleane Apache 2.2 geïnstalleerd --> zelfde probleem.

Ik heb op mijn server ook Kerio Connect draaien (die intern ook een webserver heeft) en als ik de JS file daar zet en online bekijk, dan is de file OK.

Heb al heel de morgen gezocht maar ik vind niets, als iemand een hint/tip heeft in welke richting ik moet zoeken...

Update: blijkbaar worden images ook maar half getoond

[Voor 3% gewijzigd door DaRKie op 11-10-2010 10:08]


  • NielsNL
  • Registratie: januari 2002
  • Laatst online: 13:53

NielsNL

DigiCow

Probeer het eens met een nieuwe config ini en even restarten uiteraard.
Vaag probleem btw...
Worden ze niet door de php molen gehaald? probeer eens met
PHP:
1
echo "foo";
in een bestand te zetten.

[Voor 36% gewijzigd door NielsNL op 11-10-2010 10:14]

M'n Oma is een site aan het haken.


  • DaRKie
  • Registratie: december 2001
  • Laatst online: 15:25
NielsNL schreef op maandag 11 oktober 2010 @ 10:13:
Probeer het eens met een nieuwe config ini en even restarten uiteraard.
Helpt niet, zelfs een volledig nieuwe cleane Apache install heeft het probleem.
Vaag probleem btw...
Worden ze niet door de php molen gehaald? probeer eens met
PHP:
1
echo "foo";
in een bestand te zetten.
Ik heb de code in een txt file gezet maar krijg gewoon de code te zien via de browser, dus php zit er niet tussen.

  • chrashoverraid
  • Registratie: augustus 2006
  • Laatst online: 26-09-2016

chrashoverraid

koekiemonster

DaRKie, hoe controleer jij dat de javascript verkeert is overgekomen?
Als je dat controleert met FireBug, dan ligt dat waarschijnlijk daaraan, want daar heb ik het ook heel erg vaak.

  • DaRKie
  • Registratie: december 2001
  • Laatst online: 15:25
Door naar de source te gaan kijken, zowel rechtstreeks in Firefox of de file eerst downloaden en dan met notepad kijken. En bij images is het probleem dus ook,hij toont deze half en de rest blijft grijs.

  • Skinkie
  • Registratie: juni 2001
  • Laatst online: 09-06-2020

Skinkie

Op naar de 500

Doet apache aan filecaching terwijl jij je bestanden al hebt veranderd terwijl ze zijn gecached?

Steun Elkaar, Kopieer Nederlands Waar!


  • mkleinman
  • Registratie: oktober 2001
  • Laatst online: 17:12

mkleinman

4.5kWp, 8.4GJ Zb/CV, WTW, ELGA

Heb je al geprobeerd om lokaal je cache leeg te gooien , browser afsluiten en opnieuw starten en dan nogmaals controleren?

Misschien worden de bestanden lokaal verkeerd gecached?

Installeer anders eens een netwerksniffer om te kijken wat er over het netwerk gaat. Dan kan je achterhalen of het probleem op je server ligt of dat het toch lokaal mis gaat.

Duurzame nerd. Veel comfort en weinig verbruiken. Zuinig aan doen voor de toekomst.


  • DaRKie
  • Registratie: december 2001
  • Laatst online: 15:25
Voor zover ik kan vinden, staat er geen caching op de apache install.
Browser cache is het probleem niet (meerdere pc's getest als ook een online proxy).

En blijkbaar zijn het dus gewoon alle files die dit probleem hebben ... heb net een text file genomen en er een heel lange text in gezet, als ik dan de eerste regel opzoek, dan zie ik de file 5x opnieuw beginnen en het bizarre is dat er steeds op een andere regel afgebroken wordt voor er opnieuw begonnen wordt.

De filesize is wel exact aan deze op de server.

  • DaRKie
  • Registratie: december 2001
  • Laatst online: 15:25
Na heel lang prutsen en zoeken per ongeluk op de volgende Apache settings gestoten:

code:
1
2
3
4
5
6
7
8
9
EnableSendfile Off 
<Directory "/path-to-nfs-files">
EnableSendfile Off
</Directory> 

EnableMMAP Off 
<Directory "/path-to-nfs-files">
EnableMMAP Off
</Directory>


http://httpd.apache.org/d.../core.html#enablesendfile
http://httpd.apache.org/docs/2.2/mod/core.html#enablemmap

En problem solved :)
Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee