Toon posts:

[win7] executables blijven draaien maar zijn er niet*

Pagina: 1
Acties:

Onderwerpen


  • Ventieldopje
  • Registratie: december 2005
  • Laatst online: 16:25

Ventieldopje

I'm not your pal, mate!

Topicstarter
Nee dit gaat niet om Norton Ghost!, ook niet over geesten .. Nee beste menschen. Ik heb last van heuze spook executables, even een kleine uitleg.

Ik werk als programmeur hele dagen met visual studio en bouw dan vaak een programma om het daarna te debuggen, programma weer te stoppen en verder te gaan met schrijven. Nou gaat dit normaal gesproken goed alleen heb ik op deze laptop het probleem dat ik na het stoppen van het programma voor een minuut of 5 geen schrijf rechten heb op het bestand en het ook niet kan verwijderen. Nou is dit niet alleen met programma's die ik zelf geschreven heb, ook met alle andere executables van andere programma's heb ik daar last van (alleen .exe voor zover ik weet).

Nu is dit zeer frustrerend omdat er bij het bouwen van een programma dus de melding komt dat hij de executable niet kan weg schrijven dus kan ik eerst koffie gaan pakken, mijn zegje op de wc gaan doen en weer nieuwe koffie gaan pakken voordat ik weer schrijf rechten heb op het bestand.

Wat ik al heb gedaan:
- Gekeken met een process explorer of de executable nog draaide -> niet het geval :/
- Virus scanner uitgeschakelt (Avast Free Antivirus 5) -> geen verschil :/
- Windows defender uitgeschakelt (inclusief de complete service) -> geen verschil :/
- Gekeken met een 'file in use' scanner, die gaf aan dat de executable in gebruik was door 'System Process' -> Nee daar hebben we wat aan :F
- 8)7 -> Was ook geen success :'(
- FUUUUUUUU -> keken me collega's wat raar van op :/

Conclusie tot nu toe :/
- Het ligt niet aan visual studio
- Het gebeurt met ALLE executables, op welke plek dan ook
- Het ligt niet aan de beruchte vshost processen
- Het ligt niet aan de search indexer, die staat uit
- Het ligt niet aan de virus scanner
- Virus scan tijdens boot leverde niks op
- Herstelpunt staat uit

OPGELOST!!
Application experience service aangezet, nu geen problemen meer gehad!

Help? Ik zal u rijkelijk belonen :>

[Voor 14% gewijzigd door Ventieldopje op 11-11-2010 12:33. Reden: Opgelost!]

www.maartendeboer.net
Mijn sig is te klein :+


  • Bergen
  • Registratie: maart 2001
  • Laatst online: 21-09 16:17

Bergen

Spellingscontroleur

Probeer het gratis Unlocker eens: http://www.filehippo.com/download_unlocker/

Dat programma draait in de achtergrond en merkt het als je iets niet kunt verwijderen... en fixt het dan. Is freeware, ik gebruik het al heel lang naar volle tevredenheid.

[Voor 22% gewijzigd door Bergen op 06-10-2010 13:56]


  • Ventieldopje
  • Registratie: december 2005
  • Laatst online: 16:25

Ventieldopje

I'm not your pal, mate!

Topicstarter
Dank :D Ik ga het eens even proberen!

Het leuke is ook, dat had ik er niet bij vermeld is dat ik de bestanden wel kan verwijderen maar dat ze gewoon vrolijk weer terug gezet worden ... dus ze uiteindelijk toch niet kan verwijderen :9

Maargoed misschien kan dit programma dat verhelpen 8)

www.maartendeboer.net
Mijn sig is te klein :+


  • Mavamaarten
  • Registratie: september 2009
  • Nu online

Mavamaarten

Omdat het kan!

Al geprobeerd met task manager het "<Appname>.vshost" process te beeindigen ? Dit is de debugger, die kan misschien iets met het probleem te maken hebben.

Als dat niets uitmaakt, probeer dan eens heel snel je project op te slaan, te sluiten, en opnieuw te openen met Visual Studio. Kijk dan of je write access hebt, zodat je weet of het probleem daar ligt, of buiten Visual Studio.

Het eerste waar ik aan dacht was ook Unlocker, maar Bergen was me voor :+

Android developer & dürüm-liefhebber


  • alt-92
  • Registratie: maart 2000
  • Niet online
Over welke Windows variant hebben we het trouwens?
Scheelt in preventie, dan hoef je niet gelijk met een kanon op een mug te schieten ;)

ik heb een 864 GB floppydrive! - certified prutser - the social skills of a thermonuclear device


  • Ventieldopje
  • Registratie: december 2005
  • Laatst online: 16:25

Ventieldopje

I'm not your pal, mate!

Topicstarter
Zoals ik ook al zei, misschien niet duidelijk genoeg ligt het probleem niet aan visual studio. Wat ik net gedaan heb:

1. 2 executables kopiëren naar mijn Downloads map genaamd A.exe en B.exe.
2. A.exe verwijderen
3. B.exe hernoemen naar A.exe

Nu kreeg ik een foutmelding dat A.exe al bestaat en dat B.exe daarom niet hernoemd kan worden. Druk ik op F5 zie ik dat A.exe gewoon doodleuk weer bestaat, zonder schrijf rechten!

Verwijder ik hierna A.exe komt hij doodleuk weer terug, ik liet het er niet bij zitten, ik dacht hah nou heb ik je >:) en besloot Unlocker te gebruiken maar die kon op A.exe geen lock handle vinden en vond dus dat er niks aan de hand was en me raar aan keek en vroeg of ik soms geesten zag }:O Echter was hij wel zo aardig om nogmaals te proberen het bestand te verwijderen maar kwam met de melding dat dat niet ging en of ik het wou proberen bij de volgende keer opstarten.

Kortom, zelfs unlocker bied geen soelaas. Ook een terminal als administrator opstarten en het bestand verwijderen resulteert in een vrolijke wedergeboorte van A.exe :D

Waarom ik! :X

@ Alt-F4 ehh .. Alt-92
Windows 7 32bit Professional

[Voor 6% gewijzigd door Ventieldopje op 06-10-2010 14:39]

www.maartendeboer.net
Mijn sig is te klein :+


  • Ventieldopje
  • Registratie: december 2005
  • Laatst online: 16:25

Ventieldopje

I'm not your pal, mate!

Topicstarter
Iemand enig idee? *bump*

www.maartendeboer.net
Mijn sig is te klein :+


  • Ventieldopje
  • Registratie: december 2005
  • Laatst online: 16:25

Ventieldopje

I'm not your pal, mate!

Topicstarter
Ik bump dit topic nog een keer omdat ik hier nog steeds last van heb en er nog steeds geen oplossing voor heb :( Helaas is het voor mij niet makkelijk om een complete reinstall te doen omdat hier veel programmeer werk op staat wat gekoppelt zit met SourceSafe van Microsoft (kreng van een pakket), allemaal library's op geinstalleerd staan en dergelijken, dit zal me meer dan een dag kosten en die tijd heb ik op moment niet.

Ik heb gisteren met Avast antivirus een complete boot time scan gedaan, ruim een uur mee bezig maar heeft niks gevonden. Diverse unlock programma's helpen ook niet ...

www.maartendeboer.net
Mijn sig is te klein :+


  • Sebazzz
  • Registratie: september 2006
  • Laatst online: 15:45
Ik kan mij voorstellen dat het erg vervelend is. Heb je het ook als je je applicatie build, VS afsluit, applicatie draait, afsluit? Kan je dan de executable ook niet verwijderen. Heb je het ook met andere executables, draai bijvoorbeeld iets kleins zoals GPU-Z en probeer direct na het sluiten van GPU-Z de executable te verwijderen.

[Website en online portfolio] [Return: realtime retrospective tool] [PokerTime planning poker]


  • Ventieldopje
  • Registratie: december 2005
  • Laatst online: 16:25

Ventieldopje

I'm not your pal, mate!

Topicstarter
Zie mijn posts hier boven, ook al geprobeert. Het is dus niet de vshost / visual studio executable maar echt met alle executables van wat voor programma op wat voor locatie dan ook ;)

[Voor 8% gewijzigd door Ventieldopje op 10-11-2010 10:20]

www.maartendeboer.net
Mijn sig is te klein :+


  • diabolofan
  • Registratie: mei 2009
  • Laatst online: 14:18
Visual Studio opnieuw installeren.. :) Of heb je dat al gedaan? Misschien doet hij het dan opeens wel goed, allicht het proberen waard?!

  • ResuCigam
  • Registratie: maart 2005
  • Nu online
Je zegt dat je geen tijd hebt om alles opnieuw te installeren maar misschien kun je een image van je schijf maken, er een kale windows + studio opzetten en testen? Dan kan je meteen weer terug naar je image. En mocht het probleem verholpen zijn met de kale installatie dan maak je daar eerst een image van voor je terug gaat en dan kan je daar later weer mee verder zodra je tijd hebt.

We do what we must because we can.


  • Ventieldopje
  • Registratie: december 2005
  • Laatst online: 16:25

Ventieldopje

I'm not your pal, mate!

Topicstarter
Heb de orginele post aangepast met conclusies tot nu toe :)
ResuCigam schreef op woensdag 10 november 2010 @ 10:23:
Je zegt dat je geen tijd hebt om alles opnieuw te installeren maar misschien kun je een image van je schijf maken, er een kale windows + studio opzetten en testen? Dan kan je meteen weer terug naar je image. En mocht het probleem verholpen zijn met de kale installatie dan maak je daar eerst een image van voor je terug gaat en dan kan je daar later weer mee verder zodra je tijd hebt.
Dat is misschien nog wel een optie, alhoewel ik daar dan vandaag de hele dag ook nog wel mee bezig ben denk ik, niet dat ik zo traag ben maar meer dat deze laptop niet al te snel is vaak ;)

[Voor 85% gewijzigd door Ventieldopje op 10-11-2010 10:25]

www.maartendeboer.net
Mijn sig is te klein :+


  • alt-92
  • Registratie: maart 2000
  • Niet online
Laat VS even buiten beschouwing? Lees het topic even door, dan wordt vanzelf duidelijk dat dat blindstaren op VS geen zin heeft.


Ik zou eerder gaan kijken of je niet per ongeluk die lokaties in je indexering hebt zitten of (indien dat op het netwerk staat) via Offline files..

ik heb een 864 GB floppydrive! - certified prutser - the social skills of a thermonuclear device


  • Ventieldopje
  • Registratie: december 2005
  • Laatst online: 16:25

Ventieldopje

I'm not your pal, mate!

Topicstarter
Een collega van mij is waarschijnlijk met de oplossing gekomen na een paar minuten googlen :F Zeker weten doe ik het nog niet, tot nu toe gaat alles goed in ieder geval dus daar kom ik nog op terug.

Het gaat waarschijnlijk om de "Application Experience" service, die stond bij mij uit wat dus in houd dat windows bij het verwijderen in zijn application cache gaat zitten roeren en het verwijderen in de war gooit. Door die service aan te zetten zal hij zijn cache niet meer aan roepen maar andere vage dingen gaan doen, maar dan zonder de boel in de war te gooien :X

edit:
Het probleem is al opgelost, topic kan op slot, oplossing staat in de orginele post ;)

[Voor 8% gewijzigd door Ventieldopje op 11-11-2010 12:34]

www.maartendeboer.net
Mijn sig is te klein :+

Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee