Toon posts:

Problemen met site ! heel vaag !

Pagina: 1
Acties:
  • 493 views

  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011
Hoi heren

Ik ben bezig met een site voor een vriend van mij. Veel kaas hebben we er niet van gegeten, maar in dreamweaver is het ons toch gelukt het 1 en ander voor elkaar te krijgen.

www.*weg*.nl is de site.

Als snel kwamen we erachter dat onze lightbox2 script niet werkte zodra we hem online hadden gezet.

Zoeken zoeken op het internet, en toen kwamen we erachter dat linux tenopzichte van windows case sensitive is....

Dus wij de site weer offline gehaald, en zijn nu bezig alle paden in kleine letters te veranden.

Maar hier komt het vage ! zodra we de nieuwe code uploaden, voert ie het niet door ! De oude code blijft erin staan.

Op de pc staat bijv: blabla/foto1.jpg

op de site staat ie weer vrolijk als blabla/Foto1.JPG

de paden kloppen dus weer niet...

Ik heb alle cache en cookies verwijderd van me browser, maar probleem blijft....

Hoe kan dit toch, het huilen staat me nader dan het lachen atm :(

[Voor 1% gewijzigd door RobIII op 06-10-2010 13:52]


  • stp_4
  • Registratie: maart 2003
  • Laatst online: 12-09 10:19
bij mij staan de plaatjes in kleine letters

* edit, inderdaad niet in het fotoboek

[Voor 32% gewijzigd door stp_4 op 06-10-2010 13:20]

stp - PSN ID: stp_4


  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011
stp_4 schreef op woensdag 06 oktober 2010 @ 13:19:
bij mij staan de plaatjes in kleine letters
werkt het lightbox2 script ook bij jouw dan ? (klikken op foto is grotere foto krijgen) ?

http://www.*weg*.nl/links/Fotoboek1.html


het gaat om die link

[Voor 16% gewijzigd door RobIII op 06-10-2010 13:53]


  • CherandarGuard
  • Registratie: oktober 2001
  • Laatst online: 09-08 12:30
Heb je je browser cache al geleegd?

  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011
volgens mij wel ik zal het nog eens voor de zekerheid proberen.

  • Notna
  • Registratie: november 2002
  • Laatst online: 13:00

Notna

Where are you?®

Om mee te beginnen is dit lang niet gek hoor wat je doet, maar heb je al eens nagedacht een dergelijke site te maken met behulpt vabn Wordpress en een hele schare aan themes die je kan krijgen + customizen? Dat is dan wel php en geen html, maar het is letterlijk in 5 minuten te installeren en je kan knallen.

Ontopic: Ik zie dat hele lightbox script niet in je site hangen?

Edit: ah nu wel, maar het lijkt mij dat hij gewoon niets ermee doet. De foto's zijn iig in kleine letters neergezet, maar ik geloof niet dat je het JS goed aanroept. Ik zie in Firebug namelijk bar weinig gebeuren

[Voor 22% gewijzigd door Notna op 06-10-2010 13:26]

DIY Klus Topic + DIY gereedschapstopic || Xbox Live ID:Notna8310


  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011
hoi Notna, waar kijk jij precies dan ?

de script staat in een folder in me root,

in de code word ie zo aangeroepen:


<a href="../Images/fotoboekcanyoning/thumbscanyoning/thumb1groot.jpg" [b]rel="lightbox " >

<img src="../Images/fotoboekcanyoning/thumbscanyoning/thumb1.jpg" width="200" height="133" /></a>


In dreamweaver werkt alles perfect, online niet... volgens mij dus omdat ik de bestandsnamen door elkaar had met soms een hoofdletter soms een kleine letter. dat zou het probleem moeten zijn...


Op een bepaald punt had ik het ook een beetje gefixed, later alles fout gegaan... De hele boel gedeleted en me backup gepakt... nu ben ik weer terug bij af.

Namelijk dat die broncode niet veranderd


pagina bron in dreamweaver:

<a href="../Images/fotoboekcanyoning/thumbscanyoning/thumb1groot.jpg" rel="lightbox [b]" ><img src="../Images/fotoboekcanyoning/thumbscanyoning/thumb1.jpg" width="200" height="133" /></a>


en online ziet ie er zo uit


<a href="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb1groot.JPG" rel="lightbox [b]" ><img src="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb1.JPG" width="200" height="150" /></a>

Edit:

zoals je ziet, zitten er dus ineens hoofdletters waar ze niet moeten zitten !

[Voor 3% gewijzigd door JanDijkstra op 06-10-2010 13:28]


  • danslo
  • Registratie: januari 2003
  • Laatst online: 11:50
Op URL:
http://www.*weg*.nl/links/Fotoboek1.html

Wijst naar plaatjes die niet bestaan:
http://www.*weg*.nl/Images/Fotoboekcanyoning/thumbscanyoning/Thumb1groot.JPG

Overigens bestaat css/lightbox.css ook niet op je server.

Een simpele blik in firebug laat dit zien :)

[Voor 23% gewijzigd door RobIII op 06-10-2010 13:53]


  • Notna
  • Registratie: november 2002
  • Laatst online: 13:00

Notna

Where are you?®

Overigens roep je de ligthbox.css aan vanaf een andere locatie. Ik zou die hoe dan ook even zelf hosten ;)

Als ik zo op de site van de plugin kijk, snap ik al uberhaubt niet waarom je rel=lightbox [b] gebruikt als dat niet zo aangegeven is. En zoals mijn bovenbuurman aangeeeft, verwijs je naar plaatsje die niet bestaan

DIY Klus Topic + DIY gereedschapstopic || Xbox Live ID:Notna8310


  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011
En hier komt het aller raarste... mijn zojuist geuploade file naar me root (fotoboek1.html)

heb ik vervolgens terug gedownload naar c:\test


geopend ----> ik kijk in de broncode... EN WEER IS HET VERANDERD !$()!($


wtf !?!??!?!

  • Notna
  • Registratie: november 2002
  • Laatst online: 13:00

Notna

Where are you?®

Je weet dat je code een relatief pad heeft en daarom naar andere dingen verwijst?

Nofi, maar het lijkt erop alsof je even de plank mis slaat met het eea. Ik zou eerst eens je inlezen over wat je aan het doen bent alvorens je zelf een site gaat bouwen en scriptjes van 2 jaar oud gaat gebruiken.

[Voor 66% gewijzigd door Notna op 06-10-2010 13:35]

DIY Klus Topic + DIY gereedschapstopic || Xbox Live ID:Notna8310


  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011
ik snap er niks meer van...


alle code is geupdated...


alles is gewoon geuploaded...


ik zie alle bestanden gewoon staan in me root...


en toch krijg ik dit gelul :(

  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011
cls schreef op woensdag 06 oktober 2010 @ 13:31:
Op URL:
http://www.*weg*.nl/links/Fotoboek1.html

Wijst naar plaatjes die niet bestaan:
http://www.*weg*.nl/Images/Fotoboekcanyoning/thumbscanyoning/Thumb1groot.JPG

Overigens bestaat css/lightbox.css ook niet op je server.

Een simpele blik in firebug laat dit zien :)

[afbeelding]
edit dus nogmaals :


pagina bron in dreamweaver:

<a href="../Images/fotoboekcanyoning/thumbscanyoning/thumb1groot.jpg" rel="lightbox [b]" ><img src="../Images/fotoboekcanyoning/thumbscanyoning/thumb1.jpg" width="200" height="133" /></a>


en online ziet ie er zo uit


<a href="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb1groot.JPG" rel="lightbox [b]" ><img src="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb1.JPG" width="200" height="150" /></a>


zoals je ziet, zitten er dus ineens hoofdletters waar ze niet moeten zitten !

die plaatjes bestaan wel !!! alleen zijn ze in kleine letters geschreven nu !


vervolgens update ik in dreamweaver de paden, zodat ze allemaal in de broncode als kleine lettertjes staan, vervolgens UPLOAD ik dat naar me ROOT FOLDER OP DE SERVER


en vervolgens staat de oude code er weer in


WTF

[Voor 28% gewijzigd door RobIII op 06-10-2010 13:54]


  • Notna
  • Registratie: november 2002
  • Laatst online: 13:00

Notna

Where are you?®

Weet je zeker dat je de plaatjes overwrite/ de code overwrite? Daarnaast is dat the least of your worries, gezien het javascript gewoon niet werkt

[Voor 58% gewijzigd door Notna op 06-10-2010 13:39]

DIY Klus Topic + DIY gereedschapstopic || Xbox Live ID:Notna8310


  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011
heren wacht even, want nu gaat alles fout


Ik zeg al de hele tijd, het probleem is het feit dat zodra ik mijn broncode offline verander.... dat vervolgens upload, hij de oude broncode blijft gebruiken om 1 of andere vage reden..


daarom geeft firebug aan dat er geen fotos zijn

OMDAT HET PAD NIET MEER KLOPT


fix ik het pad en upload ik het


GEBRUIKT IE HET OUDE PAD


dat probeer ik duidelijk te maken :D

  • JanDijkstra
  • Registratie: maart 2006
  • Laatst online: 05-01-2011



DE CODE OFFLINE !!!


DEZELFDE CODE ONLINE


div class="style4" id="Balkje"><strong> <FONT COLOR="#FFFFFF"> Home --> Fotoboek Canyoning </FONT></strong></div>
<div id="bodyArea">

<div class="fotoboek">


<a href="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb1groot.JPG" rel="lightbox [b]" ><img src="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb1.JPG" width="200" height="150" /></a>

<a href="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb2groot.JPG"rel="lightbox [b]"><img src="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb2.JPG" width="200" height="150" /></a>

<a href="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb3groot.JPG"rel="lightbox [b]"><img src="../Images/Fotoboekcanyoning/thumbscanyoning/Thumb3.JPG" width="200" height="150" /></a>


zoals je dus ziet !!! HOOFDLETTERS IN DE PADEN


wat ik zojuist allemaal kleine letters heb gemaakt, heb gesafed, en heb geuploaded, is online weer gewoon deze sheisse !! :)

[Voor 8% gewijzigd door JanDijkstra op 06-10-2010 13:41]


  • danslo
  • Registratie: januari 2003
  • Laatst online: 11:50
Haal je posts even door een spellchecker en stop met het plaatsen van 3 enters na elke zinnetje, het zijn geen alineas. Ook het overmatig gebruik van hoofdletters en uitroeptekens is behoorlijk storend.

On-topic:
Open het aangepaste bestand in een (andere) teksteditor nadat je de paden hebt aangepast:

1) Je image paden zijn lowercase:
-> Er gaat iets mis bij het uploaden.

2) Je image paden kloppen niet:
-> Er gaat iets mis bij dreamweaver.

[Voor 10% gewijzigd door danslo op 06-10-2010 13:42]


  • Notna
  • Registratie: november 2002
  • Laatst online: 13:00

Notna

Where are you?®

JanDijkstra schreef op woensdag 06 oktober 2010 @ 13:38:
heren wacht even, want nu gaat alles fout


Ik zeg al de hele tijd, het probleem is het feit dat zodra ik mijn broncode offline verander.... dat vervolgens upload, hij de oude broncode blijft gebruiken om 1 of andere vage reden..


daarom geeft firebug aan dat er geen fotos zijn

OMDAT HET PAD NIET MEER KLOPT


fix ik het pad en upload ik het


GEBRUIKT IE HET OUDE PAD


dat probeer ik duidelijk te maken :D
Ok even wat dingen op een rij:

• Wij snappen jou wel, maar jij snapt mij/ons niet. Mijn vraag is: weet je zeker dat je de code, zodra je die upload, wel overschrijft op je server? Krijg je CHMOD (ervanuitgaande dat je het middels een ftp upload doet) meldingen dat het gelukt is of dat het eea geblocked is
• Je javascript werkt en dat is al je eerste probleem. Als alleen je plaatjes een probleem waren, zou het script tenminste werken maar zou je de plaatjes gewoon niet zien

DIY Klus Topic + DIY gereedschapstopic || Xbox Live ID:Notna8310


  • Herko_ter_Horst
  • Registratie: november 2002
  • Niet online
Is dat een nieuwe manier om het werkend te krijgen? Hard schreeuwen?

Die plaatjes bestaan dus niet, want grote letters zijn iets anders dan kleine letters.

Ik gok dat Dreamweaver je hier in de weg zit. Waarschijnlijk past die de paden automatisch weer aan wat je lokaal hebt staan. Pas het bestand anders eens buiten DW aan (met Notepad of zo) en upload dan eens met een simpel FTP programma.

"Any sufficiently advanced technology is indistinguishable from magic."


  • Mad Marty
  • Registratie: juni 2003
  • Laatst online: 08:25

Mad Marty

Je bent slimmer als je denkt!

Ja, dat is allemaal wel duidelijk. De conclusie die je hieruit kan trekken is dat er iets fout gaat bij het uploaden. Ga daar dan ook even naar kijken, ipv hier te lopen schreeuwen tegen iedereen. Sommige dingen zul je echt zelf moeten doen, hoor.

Rail Away!


  • NMe
  • Registratie: februari 2004
  • Laatst online: 11:56

NMe

Quia Ego Sic Dico.

Kerel, serieus. Je posts zijn amper te lezen en er is amper een touw vast te knopen aan je gerant. Het lijkt erop dat je "gewoon" iets verkeerd doet bij het uploaden (zoals bijvoorbeeld het niet overschrijven van bestanden die al bestaan) maar met code heeft dit sowieso niets te maken. Probeer voor de lol eens een andere FTP-client of controleer of je wel naar het juiste domein en de juiste folder aan het uploaden bent. Als de bestanden niet bestaand of niet gewijzigd worden dan zijn ze domweg niet geüpload, wat je ook zegt.

We hebben je verder al vaker gewezen op het feit dat je zelf even mag nadenken en wat inzet mag tonen. Wederom ontbreekt het in dit topic aan eigen inzet en de manier waarop je je posts schreeuwerig en onduidelijk opzet helpt ook niet mee. We blijven niet bezig, ook dit topic gaat dicht. Zie je mail.

'E's fighting in there!' he stuttered, grabbing the captain's arm.
'All by himself?' said the captain.
'No, with everyone!' shouted Nobby, hopping from one foot to the other.

Pagina: 1

Dit topic is gesloten.



Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee