Toon posts:

Windows 7 DNS probleem

Pagina: 1
Acties:

Onderwerpen


  • UltraSub
  • Registratie: mei 2003
  • Laatst online: 21-09 20:32
Heb al tijden een irritant probleem met DNS op mijn Windows 7 clients in een 2008 AD.
Tot nu toe loste ik dat altijd op door de belangrijkste hosts in mijn netwerk in de host file te zetten, maar eigenlijk slaat dat natuurlijk nergens op en moet ik het gewoon oplossen. Vandaag dus maar weer eens aan het Googlen geslagen, maar ik kom er niet uit. Misschien kan iemand hier me helpen.

Het probleem:
Mijn DC is een 2008 R2 die ook DNS/DHCP doet.
Dcdiags vanaf andere R2's in het domein zien er super uit. Op Windows 7 clients falen echter van tijd tot tijd de DNS lookups. Start ik dan nslookup, wordt automatisch de goede DNS gekozen, en slagen alle hosts die normaal falen:

C:\Users\robert.xxxxxx>ping slider
^C
C:\Users\robert.xxxxxx>ping slider.xxxxxx.nl
Ping request could not find host slider.xxxxxx.nl. Please check the name and try again.

C:\Users\robert.xxxxxx>nslookup
Default Server: charlie.xxxxxx.nl
Address: 192.168.0.2

> slider
Server: charlie.xxxxxx.nl
Address: 192.168.0.2

Name: slider.xxxxxx.nl
Address: 192.168.0.4

> quit

C:\Users\robert.xxxxxx>ipconfig /all
Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : xxxxxx.nl
Description . . . . . . . . . . . : Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller(NDIS6.20)
Physical Address. . . . . . . . . : 00-23-54-37-61-51
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::1070:c358:3856:8746%11(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.151(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : dinsdag 28 september 2010 7:36:39
Lease Expires . . . . . . . . . . : woensdag 6 oktober 2010 7:36:37
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.2
DHCPv6 IAID . . . . . . . . . . . : 234890068
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-31-4E-39-00-23-54-37-61-51

DNS Servers . . . . . . . . . . . : 192.168.0.2
192.168.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Alles lijkt er dus goed uit te zien, en meestal werkt het ook. Maar dan ineens falen de lookups, maar als ik dus zelf middels nslookup vanaf diezelfde host probeer, werkt het gewoon. Ik kan werkelijk niks vinden waarom van tijd tot tijd de boel faalt. Als ik IPv6 disable, heb ik gewoon van tijd tot tijd hetzelfde probleem.

Iemand die me kan helpen, of een zetje in de juiste richting kan geven?

  • lier
  • Registratie: januari 2004
  • Laatst online: 14:41

lier

MikroTik nerd

Ik verwacht dat de 192.168.0.1 je modem/router is. Volgens mij is het al opgelost door deze uit je DHCP scope te halen. Dan weet je namelijk zeker dat alle DNS calls via je server lopen.

Eerst het probleem, dan de oplossing


  • Pascal
  • Registratie: januari 2001
  • Laatst online: 02:37
Wat lier zegt

doe eens ping slider.xxxxxx.nl. <-- Ja met PUNT erachter

[Voor 21% gewijzigd door Pascal op 28-09-2010 09:50]


  • Craven
  • Registratie: februari 2007
  • Laatst online: 13:49
0.1 is je router en 0.2 is dus je dc die dhcp en dns doet.

Ik zou 0.1 uit je lijst met dns server adressen halen in de dhcp. En ik zou als ik jou was een andere server ook dns laten doen. Ik weet niet of je al een 2e dc hebt ergens? Zo niet dan zou ik dat ding ook direct creeren.

Ik heb het wel vaker zien gebeuren dat clients de 1e dns server in de lijst overslaan en direct aan de gang gaan met de tweede. Waarom weet ik niet.

edit: spuit 11

  • UltraSub
  • Registratie: mei 2003
  • Laatst online: 21-09 20:32
Gheh! Dat lijkt inderdaad te werken so far jongens!
De reden van de .0.1 in de DNS is dat het bedoeld was als een fallback als ik de DC reboot. De gateway is een Debian bak die een DNS server draait, welke forward lookups bij de Google DNS's doet als hij ze zelf niet kent. En inderdaad, die kent een hoop van die Windows servers in mijn domein niet. Maar wel erg raar dat de 1e in de rij gewoon wordt overgeslagen dan!

Over 2de DC. Heb ik bewust niet. Ik draai al zat VM's ;)
Een tweede DC draaien maakt de boel moeilijker met snapshotting als backup. Als je er maar een hebt, kun je vrij gemakkelijk terug snappen mocht er iets mis gaan.

Nu even kijken of het probleem ook opgelost blijft. Bedankt mannen!


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee