Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

[Kubuntu 10.4/PHP/PGSQL] "block type is not 01"

Pagina: 1
Acties:

  • storeman
  • Registratie: april 2004
  • Laatst online: 09:58
Ik probeer met mijn webapplicatie verbinding te maken met een remote database server (postgresl op ubuntu server 9.10).

Bij het verbinden krijg ik de volgende melding:"SSL error: block type is not 01"

Echer als ik boot in windows, wordt de verbinding wel opgezet. Ik heb dus het vermoeden dat het een probleem met Kubuntu is. Overigens kan ik met PGAdmin3 wel verbinding maken met de databaseserver.

Het betekend dus:
- Firewall is open
- SSL (van PGSQL) op server staat uit (eerst maar eens zonder)

Ik heb ook een problemen met verbinden op DNS-naam. Als ik mbv putty verbinding probeer te maken werkt dit niet op DNS naam maar wel op IP (in windows werkt beide).

Wat kan ik doen om dit te onderzoeken of is iemand hiermee bekend?

"Chaos kan niet uit de hand lopen"


  • storeman
  • Registratie: april 2004
  • Laatst online: 09:58
Ik ben de libs gaan vergelijken, maar lijkt me sterk dat het daaraan kan liggen:

Ubuntu server:
openssl 0.9.8g-16ubuntu3.1
libssl0.9.8 0.9.8g-16ubuntu3.1

Kubuntu client:
libssl0.9.8k-7ubuntu8
openssl0.9.8k-7ubuntu8

Wat betekenen die achtervoegsels? (7ubuntu8?)

"Chaos kan niet uit de hand lopen"


  • Onno
  • Registratie: juni 1999
  • Niet online
quote:
storeman schreef op maandag 14 juni 2010 @ 15:28:
Bij het verbinden krijg ik de volgende melding:"SSL error: block type is not 01"

[...]

- SSL (van PGSQL) op server staat uit (eerst maar eens zonder)
Als SSL uitstaat op de server zou je client ook niets met SSL moeten doen, en dus niet zo'n foutmelding moeten geven. Gebruik je expliciet een of andere SSL-optie bij het verbinden met de databaseserver vanuit je script?
quote:
Ik heb ook een problemen met verbinden op DNS-naam. Als ik mbv putty verbinding probeer te maken werkt dit niet op DNS naam maar wel op IP (in windows werkt beide).

Wat kan ik doen om dit te onderzoeken of is iemand hiermee bekend?
Gebruik je in Linux en Windows dezelfde DNS-server? Als dat zo is, geeft "host <hostnaam>" (of dig, nslookup, enz.) wel het juiste IP-adres terug?

  • storeman
  • Registratie: april 2004
  • Laatst online: 09:58
SSL:

Ik heb dit nu werkend, bleek toch nog een foutje in het config bestandje te staan (ik haal putty en konsole wel eens door elkaar :S). Ik ga nog een beetje experimenteren met de ssl instellingen, daar zal het wel mee te maken hebben.

DNS:

Ik heb meerdere dns entries:

combiserver.dyndns.info
gwsystems.dyndns.info

Putty wil mbv van eerste niet connecten (ik heb het idee dat ie teruggaat naar zichzelf) en met de tweede wel. Op IP werkt het ook. Het IP adres klopt. als ik het controleer met ping of host

"Chaos kan niet uit de hand lopen"



Apple iPhone 11 Microsoft Xbox Series X LG OLED C9 Google Pixel 4 CES 2020 Samsung Galaxy S20 Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True