Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

[Ubuntu 10.04 [PostgreSQL] Krijg postgresql niet verwijderd

Pagina: 1
Acties:

Onderwerpen


  • Afvalzak
  • Registratie: oktober 2008
  • Laatst online: 24-02 22:44

Afvalzak

Zet jij mij even buiten?

Topicstarter
Ik probeer mijn PostgreSQL 8.4 volledig te verwijderen om opnieuw te beginnen aangezien er wat problemen zijn ontstaan (probeer een OpenStreetMap server op te starten).
Maar op de een of andere manier krijg ik telkens een foutmelding:
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
After this operation, 13.7MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 234370 files and directories currently installed.)
Removing postgresql-8.4 ...
Stopping PostgreSQL 8.4: 
pg_ctl: PID file "/opt/PostgreSQL/8.4/data/postmaster.pid" does not exist
Is server running?
invoke-rc.d: initscript postgresql-8.4, action "stop" failed.
dpkg: error processing postgresql-8.4 (--remove):
 subprocess installed pre-removal script returned error exit status 1
update-rc.d: warning: /etc/init.d/postgresql-8.4 missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
Starting PostgreSQL 8.4: 
waiting for server to start...sh: cannot create /opt/PostgreSQL/8.4/data/pg_log/startup.log: Directory nonexistent
............................................................could not start server
PostgreSQL 8.4 did not start in a timely fashion, please see /opt/PostgreSQL/8.4/data/pg_log/startup.log for details
invoke-rc.d: initscript postgresql-8.4, action "start" failed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 postgresql-8.4
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dit gebeurt ook in synaptic, of als ik het probeer met purge.

is er misschien een andere manier om het te deïnstalleren, of weet iemand wat er fout gaat/wat ik fout doe?

De /opt/PostgreSQL/8.4/data/pg_log/startup.log lijkt niet eens te bestaan.

Last.fm | Code Talks


  • DeKaerften
  • Registratie: december 2007
  • Niet online
Dat betekent dat Postgre niet meer draait / de lockfile verwijderd is / nooit gedraaid heeft / al gedeeltelijk verwijderd is.

Wat gebeurt er als je
code:
1
#apt-get install -f

doet?

  • Afvalzak
  • Registratie: oktober 2008
  • Laatst online: 24-02 22:44

Afvalzak

Zet jij mij even buiten?

Topicstarter
Dan krijg ik dezelfde foutmelding.

Last.fm | Code Talks


  • eghie
  • Registratie: februari 2002
  • Niet online

eghie

Spoken words!

voeg in het bestand /etc/init.d/postgresql-8.4, de volgende regel toe aan het begin (net na #!/bin/sh):
code:
1
exit 0

en draai dat commando nog maar eens.

- I Am Second - Rebels Guide to Joy - Werkelijke Christendom


  • Afvalzak
  • Registratie: oktober 2008
  • Laatst online: 24-02 22:44

Afvalzak

Zet jij mij even buiten?

Topicstarter
Super dat werkt:) Tnx!

Last.fm | Code Talks



Apple iPhone 11 Microsoft Xbox Series X LG OLED C9 Google Pixel 4 CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True