Toon posts:

GPRS verbinding Ubuntu

Pagina: 1
Acties:
  • 1.522 views sinds 30-01-2008
  • Reageer

Onderwerpen


  • mcb1
  • Registratie: Januari 2003
  • Laatst online: 26-06 23:43
Ik heb de volgende vraag.....

hoe krijg je het in Ubuntu voor elkaar om een GPRS verbinding te maken via een mobiele telefoon? Ik wil namelijk graag onderweg gebruik maken van mijn GPRS verbinding i.c.m. mijn laptop. In windows xp was dit geen probleem maar in Ubuntu krijg ik het niet voor elkaar.
GPRS easy connect, via PPP verbinding, via Terminal instellingen, uren gezocht op het net etc etc. het lukt gewoon niet!!

volgens mij zijn het maar twee dingen die moeten kloppen namelijk:
- seriele verbinding tussen GSM en laptop (via bluetooth of USB verbinding maakt mij niet uit)
- juist instellen van een modem verbinding

mijn gegevens:
Laptop voorzien van Ubuntu 7.04 (Feisty Fawn)
Gsm Mio A701 met t-mobile PIT
Bluetooth Sitecom CN-512
of de USB kabel naar de Mio

Let wel, ik ben net in staat wat simpele dingen via terminal uit te voeren dus absoluut geen expert in Linux. (maar doe mijn best dat te worden, is de reden dat mijn laptop nu is voorzien van Ubuntu)

mcb1


Anoniem: 63780

Hierover is genoeg te vinden op internet, gewoon ff op google zoeken.

Acties:
  • 0Henk 'm!

  • Harm
  • Registratie: Mei 2002
  • Niet online
Gezien de opmerking 'uren gezocht op het net' wil ff op Google zoeken niet zo... het zou handig zijn als zowel de TS als KoeNijn dan aangeven waarmee gezocht is dan wel gezocht moet worden. Daar heeft iedereen wat aan :) .

Acties:
  • 0Henk 'm!

  • Drgn
  • Registratie: Februari 2004
  • Niet online
Aldus deze post op het ubuntuforums moet je eens kijken naar WvDial.

Leave the gun, get the canoli


Acties:
  • 0Henk 'm!

Anoniem: 63780

zoek eens op: grps linux

Eerste Tweede resultaat op google.

[Voor 12% gewijzigd door Anoniem: 63780 op 18-05-2007 17:11]


Acties:
  • 0Henk 'm!

  • mcb1
  • Registratie: Januari 2003
  • Laatst online: 26-06 23:43
http://www-128.ibm.com/developerworks/library/wi-enable.html

http://wiki.clug.org.za/wiki/GPRS_Internet_over_Bluetooth

http://www.howtoforge.com...e_via_bluetooth_gsm_phone

enkele voorbeelden in bovenstaande links welke ik heb gebruikt.

iedere keer volg ik een Howto ......?

probleem iedere keer nu:
Laptop ziet GSM, GSM ziet niet de laptop.
Ik krijg het dus niet voor elkaar om de laptop en GSM aan elkaar te verbinden. Als ik dus met de GSM de laptop probeer te zoeken en te pairen dan ziet de GSM de laptop dus niet. (hoe het andersom kan weet ik niet, misschien iemand een tip?)
Ik denk dat als ik maar voor elkaar krijg de GSM en Laptop te verbinden de rest wel lukt!

Ga het morgen nog eens met mijn oude GSM proberen, misschien meer geluk.

- er is genoeg te vinden over gprs en linux, probleem is alleen wat moet je gebruiken. Had gehoopt dat er iemand is die het al heeft gebruikt in mijn combinatie van hardware en software. (zelf het wiel uitvinden is leuk maar zonde van de tijdI
- wvdail begrijp ik niet helemaal, maar zal er nog eens naar kijken.

mcb1


Acties:
  • 0Henk 'm!

Anoniem: 63780

mcb1 schreef op zondag 20 mei 2007 @ 03:41:
http://www-128.ibm.com/developerworks/library/wi-enable.html

http://wiki.clug.org.za/wiki/GPRS_Internet_over_Bluetooth

http://www.howtoforge.com...e_via_bluetooth_gsm_phone

enkele voorbeelden in bovenstaande links welke ik heb gebruikt.

iedere keer volg ik een Howto ......?

probleem iedere keer nu:
Laptop ziet GSM, GSM ziet niet de laptop.
Ik krijg het dus niet voor elkaar om de laptop en GSM aan elkaar te verbinden. Als ik dus met de GSM de laptop probeer te zoeken en te pairen dan ziet de GSM de laptop dus niet. (hoe het andersom kan weet ik niet, misschien iemand een tip?)
[...]
Op deze pagina staat hoe je moet paren vanuit linux/pc. Iets naar beneden scrollen. Gevonden door te zoeken op 'pair bluetooth linux'.

Acties:
  • 0Henk 'm!

  • mcb1
  • Registratie: Januari 2003
  • Laatst online: 26-06 23:43
@ KoeNijn --> Het werkt mijn telefoon is nu verbonden aan de laptop via Bluetooth.

Nu ga ik verder om de modem in te stellen, dus weer even kijken hoe dat moet.

hieronder instructies vanaf de website hoe je telefoon te pairen met de laptop:

Connecting a bluetooth (Jabra BT250V) handset to a linux box (Scientific linux)

If you want to use a bluetooth headset with linux, I recommend that you read:

* http://bluetooth-alsa.sourceforge.net/
* http://www.linux.ie/articles/bluetoothheadset.php

A few pitfalls to avoid:

* When you try to pair your computer check that bluetooth is enable and that the deamon has been started (this is not done by default on some distros)
If you get a message like:
>hcitool scan
Device is not available: Success
You should try to start bluetooth again:
/etc/init.d/bluetooth start

Once bluetooth is started, to find the hardware address of your device (in pairing mode) use:
>hcitool scan
It should return:
Scanning ...
00:07:A4:23:XX:XX Jabra BT 250v

Then you can pair it by typing:
>hcitool cc 00:07:A4:23:XX:XX
* The next step is to install btsco and the kernel module snd_bt_sco.
o When you download the sources of btsco (At: http://sourceforge.net/pr...les.php?group_id=116589), check the kernel version. If the compilation of the kernel module fails witout explanation, it might be that the module requires a more recent kernel than yours.
o After compiling and installing the module, you need to refresh your modules list by typing:
>depmod -ae
>modprobe snd_bt_sco

If the compilation/installation is successful but you get the error:
>modprobe snd_bt_sco
FATAL: Module snd_bt_sco not found.
It probably means that you forgot to type:
>depmod -ae

Once this is done you can start btsco:
>btsco -v 00:07:A4:23:XX:XX
(and then start skype in another terminal)
o Summary (once everything is installed):
+ To connect your handset type (in pairing mode):
>/etc/init.d/bluetooth start
>hcitool scan
>hcitool cc 00:07:A4:23:XX:XX
>btsco -v 00:07:A4:23:XX:XX
You are ready to use your handset...

mcb1


Acties:
  • 0Henk 'm!

  • mcb1
  • Registratie: Januari 2003
  • Laatst online: 26-06 23:43
Ik ben er bijna denk ik, maar gaat nog even iets niet helemaal goed met de instellingen.

Ik heb de volgende link gebruikt voor modem in te stellen:

http://wiki.clug.org.za/w...r_Bluetooth#Configure_PPP

Van de website van t-mobile:
(DNS heb ik aangepast, *99# heb ik ingevuld werkte in windows ook zo neem aan dat dit voor Ubuntu niet anders is, is het enige wat ik zie en zelf weet aan te passen)


Welke gegevens heb ik nodig als ik handmatig mijn GPRS instellingen op de computer configureer?
Om je laptop of pda handmatig in te stellen voor T-Mobile GPRS Internet, heb je de volgende gegevens nodig:


APN: internet (Let op kleine letters)
IP-adres: Door server toegewezen IP-adres
DNS: Door server toegewezen DNS-adres

In geval dat DNS-adressen toch nodig blijken te zijn
Primair DNS: 193.79.237.39
Secundair DNS: 193.79.242.39

Advanced connection settings:
+CGDCONT=1,"IP", "internet","",0,0 (Voor Motorola telefoons:+CGDCONT=1,"IP","internet")

Inbelnummer voor GPRS
Voor Siemens en Motorola telefoons: *99***1#
Voor Samsung telefoons: *99**1*1#
Alle andere telefoons: *99#

Deze instellingen gelden voor alle abonnementen en tariefplannen.

Automatische verbinding maken met T-Mobile GPRS kan via GPRS Connect software.

Onderstaand wat ik te zien krijg als log, onderaan staat "connect script failed" er zal dus ergens wel een instelling niet goed zijn alleen weet ik niet wat.

Als er iemand is die t-mobile PIT aan de gang heeft gekregen in Ubuntu of een andere distributie post a.u.b. even je instellingen!


root@mcb-laptop:/home/mcb# pon GPRS
root@mcb-laptop:/home/mcb# tail -f /var/log/syslog
May 20 22:15:26 mcb-laptop chat[7867]: ATZ^M^M
May 20 22:15:26 mcb-laptop chat[7867]: OK^M
May 20 22:15:27 mcb-laptop chat[7867]: ATDT*99#^M^M
May 20 22:15:27 mcb-laptop chat[7867]: CONNECT
May 20 22:15:27 mcb-laptop chat[7867]: -- got it
May 20 22:15:27 mcb-laptop chat[7867]: send (^M)
May 20 22:15:28 mcb-laptop chat[7867]: expect (ogin:)
May 20 22:15:28 mcb-laptop chat[7867]: ^M
May 20 22:15:32 mcb-laptop chat[7867]: ~^?}#@!}!} } }2}!}$}%\}"}&} }*} } }#}$@#kZ~~^?}#@!}!}!} }2}!}$}%\}"}&} }*} } }#}$@
May 20 22:15:40 mcb-laptop chat[7867]: #dJ~~^?}#@!}!}"} }2}!}$}%\}"}&} }*} } }#}$@#uz~~^?}#@!}!}#} }2}!}$}%\}"}&} }*} } }
May 20 22:15:49 mcb-laptop chat[7867]: #}$@#zj~~^?}#@!}!}$} }2}!}$}%\}"}&} }*} } }#}$@#W}:~~^?}#@!}!}%} }2}!}$}%\}"}&} }*
May 20 22:15:58 mcb-laptop chat[7867]: } } }#}$@#X}*~~^?}#@!}!}&} }2}!}$}%\}"}&} }*} } }#}$@#I:~~^?}#@!}!}'} }2}!}$}%\}"}
May 20 22:16:06 mcb-laptop dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
May 20 22:16:06 mcb-laptop chat[7867]: &} }*} } }#}$@#F*~~^?}#@!}!}(} }2}!}$}%\}"}&} }*} } }#}$@#}3Z~~^?}#@!}!})} }2}!}$}
May 20 22:16:13 mcb-laptop dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
May 20 22:16:13 mcb-laptop chat[7867]: alarm
May 20 22:16:13 mcb-laptop chat[7867]: Failed
May 20 22:16:13 mcb-laptop pppd[7864]: Connect script failed
May 20 22:16:14 mcb-laptop pppd[7864]: Exit.
May 20 22:16:31 mcb-laptop dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
^[[B^[[B^[[B^[[A^[[AMay 20 22:16:37 mcb-laptop dhclient: No DHCPOFFERS received.
May 20 22:16:37 mcb-laptop dhclient: No working leases in persistent database - sleeping.

mcb1


Acties:
  • 0Henk 'm!

  • mcb1
  • Registratie: Januari 2003
  • Laatst online: 26-06 23:43
Ik heb de verbinding nog steeds niet helaas...

ik heb de deze link gevonden:

http://www.teaparty.net/technotes/blue-gprs.html

heb de handleiding gevolgd en van het chat-gprs het volgende gemaakt:

OK 'AT&F'
OK 'ATV1E0S0=0&D2&C1'
OK AT+CMEE=1
OK 'AT+CGDCONT=1,"IP", "internet","",0,0
OK-AT-OK ATD*99#
CONNECT ""

After a short delay, pppd logs the following to syslog:

en dan volgt er dus niets!

of mijn instellingen kloppen niet of er iets anders aan de hand.


Onderstaande is mij niet helemaal duidelijk

ik krijg geen error, dus moet ik de patch toepassen? (heeft iets te maken met seriele verbinding, op mijn telefoon kan ik hiervoor normaal kiezen als ik pair maar deze optie verschijnt niet)




Talking to the 'phone
Now, we have to talk to the 'phone's onboard modem. I tried
# rfcomm bind 0 00:02:EE:60:97:6E 1

and got this error at the prompt

Can't open RFCOMM control socket: No such file or directory

and syslog immediately complained

modprobe: Can't locate module bt-proto-3

Digging on the net found www.holtmann.org/linux/kernel/ , which outlined how 2.4.20 (stock) kernel doesn't contain the rfcomm code. Downloaded thence the latest Marcel Holtmann rfcomm patch, being 2.4.20-mh4. Applied to kernel source

# cd /usr/src
# patch -p0 < /tmp/patch-2.4.20-mh4

went to kernel source dir, menuconfig'ged, and lo, the RFCOMM options appeared. Turned on RFCOMM and BNEP, and all associated checkboxes, did

# make dep
# make bzImage && make modules && make modules_install

Booted from new kernel (2.4.20-mh4), did

# rfcomm bind 0 00:02:EE:60:97:6E 1

got nothing at prompt, but syslog shows

kernel: BlueZ RFCOMM ver 0.4
kernel: Copyright (C) 2002 Maxim Krasnyansky
kernel: Copyright (C) 2002 Marcel Holtmann

as the driver is force-loaded, and i can also do

# rfcomm show
rfcomm0: 00:02:EE:60:97:6E channel 1 clean

But I could find no device to attach minicom to, for testing. Digging revealed that the device special files are major number 216, so after I did

mknod /dev/rfcomm0 c 216 0

I was able to use minicom to initiate a connection to the phone on device /dev/rfcomm0, at 9600 baud, with software flow control. My 'phone immediately asked me if I wanted to pair with my laptop (I said yes), and then asked me for a PIN before immediately giving me a disconnect message

mcb1


  • dot_crazy
  • Registratie: Februari 2003
  • Laatst online: 29-12-2019
Ik zit met hetzelfde probleem, ik ben er wel achter gekomen dat voor mij persoonlijk "wvdial" de ideale applicatie/hulpje is.

Als ik wvdial verzoek gprs verbinding te maken, gaat mijn telefoon aan de gang en belt *99# zoals volgens wat zoekwerk voor T-mobile de instelling voor een Nokia 6280 moet zijn.

Maar dan de speaker in de telefoon klapt hem er vervolgens gewoon uit en laat een ingesprek of bestaat niet toon horen. Vervolgens krijg ik deze uitput.

ralph@ralph-laptop:~$ wvdial gprs
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATM0
ATM0
OK
--> Modem initialized.
--> Sending: ATDTATD*99#
--> Waiting for carrier.
ATDTATD*99#
NO CARRIER
--> No Carrier! Trying again.

Mijn wvdial.conf ziet er zo uit:

$ cat /etc/wvdial.conf
[Modem0]
Modem = /dev/rfcomm0
Dial Command = ATDT
Init1 = ATZ
Init2 = ATM0
FlowControl = None

[Dialer GPRS]
Username = (empty)
Password = (empty)
Phone = ATD*99#1
Stupid Mode = 1
Inherits = Modem0


Nu begrijp ik niet of dit gewoon een fout van mijn telefoon is of iets met de instellingen die worden meegestuurd door wvdial. Ik heb gelezen dat je voor T-mobile als APN : internet moet instellen en als username : tmobile. Alleen zou ik niet weten of dat in mijn config ook gespecificeerd moet worden en zoja hoe.

  • dot_crazy
  • Registratie: Februari 2003
  • Laatst online: 29-12-2019
Ik heb het aan de praat via "wvdial"

Zie http://www.bless.li/articles/bluetooth-gprs/
om je telefoon te paren.

Volg stap 1,2 & 3

Vervolgens pas je de wvdial.conf aan naar :

----

[Modem0]
Modem = /dev/rfcomm0
Dial Command = ATDT
Init1 = AT+CGDCONT=1,"IP","internet"
FlowControl = None


[Dialer GPRS]
Username = tmobile
Password = (empty)
Phone = *99#
Stupid Mode = 1
Inherits = Modem0

-----

LET OP!! : de init1 string is voor T-Mobile PIT (en volgens mij alle data van T-Mo) en werkt voor mijn Nokia 6280 en N73, wellicht dat dit voor andere telefoons/providers anders is.

$ wvdial gprs

En tadadadadada verbinding.

Vervolgens kun je stap 5 nog verder afmaken.

[Voor 6% gewijzigd door dot_crazy op 30-05-2007 23:24]


  • mcb1
  • Registratie: Januari 2003
  • Laatst online: 26-06 23:43
dus het werkt wel!

Ik heb er even geen tijd voor gehad, maar ga het eens proberen met wvdial. Inmiddels ubuntu opnieuw geinstalleerd i.v.m. vervanging van grotere hdd dus kan fris van start!

Als ik mijn mijn mio aan de gang heb laat ik het nog wel even weten!

mcb1


Anoniem: 257710

Helaas, ik krijg het met wvdial nog steeds niet aan de praat.

Ik ben niet helemaal zeker van "Password = (empty)" Van de helpdesk van tmobile heb ik begrepen dat zowel paswoord als user name "tmobile" zouden moeten zijn. Maar goed, misschien is het paswoord inderdaad wel niet van belang. Ik lijk ongeacht het paswoord dezelfde output te krijgen.

Ik heb Google helemaal afgezocht, maar met ik kom niets verder dan:

$sudo cat /etc/wvdial.conf
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
#Init3 = AT+CGDCONT=1,"IP","internet" # veroorzaakt: "Bad init string"
#Init3 = AT+CGDCONT=1,"IP","internet","0.0.0.0",0 0 # veroorzaakt: "Bad init string"
FlowControl = None
Stupid Mode = 1
Modem Type = USB Modem
ISDN = 0
Phone = *99#
New PPPD = yes
Modem = /dev/ttyACM0
Username = tmobile
Password = (empty) # geeft hetzelfde resultaat als: "Password = tmobile"
Baud = 460800

kom ik niet verder dan:

$ sudo wvdial
WvDial<*1>: WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot get information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: ATZ
WvDial Modem<*1>: OK
WvDial<*1>: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: OK
WvDial<*1>: Modem initialized.
WvDial<*1>: Sending: ATDT*99#
WvDial<*1>: Waiting for carrier.
WvDial Modem<*1>: ATDT*99#
WvDial Modem<*1>: CONNECT
WvDial Modem<*1>: ~[7f]}#@!}!}!} }8}#}$@#}(}"}'}"}"}&} } } } }%}&n[14]H[13]}4S~
WvDial<*1>: Carrier detected. Starting PPP immediately.
WvDial<Notice>: Starting pppd at Wed Apr 16 00:08:23 2008
WvDial<Notice>: Pid of pppd: 27219
WvDial<*1>: Using interface ppp0
WvDial<*1>: pppd: H�[06][08]��[06][08]
WvDial<*1>: pppd: H�[06][08]��[06][08]
WvDial<*1>: pppd: H�[06][08]��[06][08]
WvDial<*1>: pppd: H�[06][08]��[06][08]
WvDial<*1>: pppd: H�[06][08]��[06][08]
WvDial<*1>: pppd: H�[06][08]��[06][08]
WvDial<*1>: pppd: H�[06][08]��[06][08]
WvDial<*1>: Disconnecting at Wed Apr 16 00:08:24 2008
WvDial<*1>: The PPP daemon has died: A modem hung up the phone (exit code = 16)
WvDial<*1>: man pppd explains pppd error codes in more detail.
WvDial<Notice>: Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.

En:

$ tail /var/log/messages
Apr 15 23:00:30 feisty-laptop pppd[7193]: Using interface ppp0
Apr 15 23:00:30 feisty-laptop pppd[7193]: Connect: ppp0 <--> /dev/ttyACM0
Apr 15 23:00:30 feisty-laptop pppd[7193]: Remote message: Congratulations!
Apr 15 23:00:30 feisty-laptop pppd[7193]: PAP authentication succeeded
Apr 15 23:00:30 feisty-laptop kernel: [ 2651.184000] PPP BSD Compression module registered
Apr 15 23:00:30 feisty-laptop kernel: [ 2651.248000] PPP Deflate Compression module registered
Apr 15 23:00:31 feisty-laptop pppd[7193]: LCP terminated by peer
Apr 15 23:00:31 feisty-laptop pppd[7193]: Modem hangup
Apr 15 23:00:31 feisty-laptop pppd[7193]: Connection terminated.
Apr 15 23:00:31 feisty-laptop pppd[7193]: Exit.

Op de een of andere manier wordt de verbinding verbroken. Heeft iemand enig idee wat er bij mij aan de hand is.

Alvast bedankt!

Gusteen

P.S. Ik gebruik een (sim-lock vrije) SonyEricsson K320i via de datakabel. Via bluetooth heb ik het met dit toestel ook geprobeerd, maar dat leidt tot dezelfde foutmelding.

[Voor 51% gewijzigd door Anoniem: 257710 op 16-04-2008 00:13]


  • cherwin
  • Registratie: Maart 2006
  • Niet online
Het gebruikersnaam en wachtwoord moeten weldegelijk tmobile zijn. Waarom probeer je het niet even met gnome-ppp dan?

Tell me your problem, not the solution you think I should build for you.


Anoniem: 257710

Bedankt voor je tip. Ik kende gnome-ppp niet. Het is een heel handig programma.

Maar helaas: ik heb "tmobile" als user name en paswoord opgegeven en krijg na "sudo gnome-ppp" de volgende output:

/root/.wvdial.conf<Warn>: Ignoring malformed input line: ";Do NOT edit this file by hand!"
WvDial<*1>: WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot get information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: ATZ
WvDial Modem<*1>: OK
WvDial<*1>: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: OK
WvDial<*1>: Modem initialized.
WvDial<*1>: Sending: ATM1L3DT*99#
WvDial<*1>: Waiting for carrier.
WvDial Modem<*1>: ATM1L3DT*99#
WvDial Modem<*1>: CONNECT
WvDial Modem<*1>: ~[7f]}#@!}!}!} }8}#}$@#}(}"}'}"}"}&} } } } }%}&|__S[06]}8~
WvDial<*1>: Carrier detected. Starting PPP immediately.
WvDial<Notice>: Starting pppd at Wed Apr 16 08:05:01 2008
WvDial<Notice>: Pid of pppd: 1185
WvDial<*1>: Using interface ppp0
WvDial<*1>: Disconnecting at Wed Apr 16 08:05:02 2008
WvDial<*1>: The PPP daemon has died: A modem hung up the phone (exit code = 16)
WvDial<*1>: man pppd explains pppd error codes in more detail.
WvDial<Notice>: Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.

$tail /var/log/messages geeft:
Apr 16 08:05:01 feisty-laptop pppd[1185]: pppd 2.4.4 started by root, uid 0
Apr 16 08:05:01 feisty-laptop pppd[1185]: Using interface ppp0
Apr 16 08:05:01 feisty-laptop pppd[1185]: Connect: ppp0 <--> /dev/ttyACM0
Apr 16 08:05:01 feisty-laptop pppd[1185]: Remote message: Congratulations!
Apr 16 08:05:01 feisty-laptop pppd[1185]: PAP authentication succeeded
Apr 16 08:05:02 feisty-laptop pppd[1185]: LCP terminated by peer
Apr 16 08:05:02 feisty-laptop pppd[1185]: Modem hangup
Apr 16 08:05:02 feisty-laptop pppd[1185]: Connection terminated.
Apr 16 08:05:02 feisty-laptop pppd[1185]: Exit.

Ik gebruik Ubuntu Gutsy, maar ik heb het ook geprobeerd met Knoppix 5.3. Verder heb ik het ook geprobeerd op een Nokia telefoon. Maar ik blijf last houden van "LCP terminated by peer"

Als iemand verder nog tips heeft houd ik me aanbevolen. Ik denk dat ik het ook eens met een vodafone prepaid kaart ga proberen.

Bedankt!

Gusteen

Anoniem: 257710

Het werkt nog steeds niet...

Het lijkt aan die "bad init string" te liggen.

Ik heb het nu ook direct met pppd / chat geprobeerd. Maar dan krijg ik als melding dat het met het chat script niet gelukt is ("Connect script failed"):

$tail /var/log/messages
Apr 16 23:30:21 feisty-laptop chat[13351]: -- got it
Apr 16 23:30:21 feisty-laptop chat[13351]: send (AT+CGDCONT=1,"IP","live.vodafone.nl","0.0.0.0",0,0^M)
Apr 16 23:30:22 feisty-laptop chat[13351]: timeout set to 30 seconds
Apr 16 23:30:22 feisty-laptop chat[13351]: expect (OK)
Apr 16 23:30:22 feisty-laptop chat[13351]: ^M
Apr 16 23:30:22 feisty-laptop chat[13351]: AT+CGDCONT=1,"IP","live.vodafone.nl","0.0.0.0",0,0^M^M
Apr 16 23:30:22 feisty-laptop chat[13351]: ERROR^M
Apr 16 23:30:22 feisty-laptop chat[13351]: -- failed
Apr 16 23:30:22 feisty-laptop chat[13351]: Failed ( ERROR^M)
Apr 16 23:30:22 feisty-laptop pppd[13349]: Exit.

$sudo cat /etc/ppp/vodafone.chat
ECHO ON
ABORT '\nERROR\r'
ABORT '\nNO ANSWER\r'
'' \rAT
OK-+++\c-OK ATZ
OK 'ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0'
OK 'AT+CGDCONT=1,"IP","live.vodafone.nl","0.0.0.0",0,0'
TIMEOUT 30
OK ATD*99#
CONNECT ""

Gusteen

[Voor 15% gewijzigd door Anoniem: 257710 op 16-04-2008 23:58]


Anoniem: 257710

Ondertussen ben ik erachter dat de 1ste "data account" van mijn telefoon geblokkeerd was. Voor mij moest de juiste init string als volgt zijn:

"OK 'AT+CGDCONT=3,"IP","live.vodafone.nl","0.0.0.0",0,0' "

Met het volgende chat script kom ik door de inlogprocedure

# chat script for vodafone
TIMEOUT 5
ECHO ON
ABORT '\nBUSY\r'
ABORT '\nERROR\r'
ABORT '\nNO ANSWER\r'
ABORT '\nNO CARRIER\r'
ABORT '\nNO DIALTONE\r'
ABORT '\nRINGING\r\n\r\nRINGING\r'
'' \rATZ
OK 'ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0'
OK 'AT+CGDCONT=3,"IP","live.vodafone.com"'
OK 'AT+CGATT=1'
OK 'ATD*99#'
TIMEOUT 10
CONNECT ""

Maar helaas, ik blijf stuiten op de melding "LCP terminated by peer"

$ sudo pppd call vodafone
ATZ
OK
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
AT+CGDCONT=3,"IP","live.vodafone.com"
OK
AT+CGATT=1
OK
ATD*99#
CONNECT
Serial connection established.
using channel 16
Using interface ppp0
Connect: ppp0 <--> /dev/ttyACM0
sent [LCP ConfReq id=0x1 <asyncmap 0xa0000> <magic 0xf7074e0e>]
rcvd [LCP ConfReq id=0x2 <auth pap> <accomp> <pcomp> <asyncmap 0x0> <magic 0x38dfc450>]
sent [LCP ConfRej id=0x2 <accomp> <pcomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0xa0000> <magic 0xf7074e0e>]
rcvd [LCP ConfReq id=0x3 <auth pap> <asyncmap 0x0> <magic 0x38dfc450>]
sent [LCP ConfAck id=0x3 <auth pap> <asyncmap 0x0> <magic 0x38dfc450>]
sent [LCP EchoReq id=0x0 magic=0xf7074e0e]
sent [PAP AuthReq id=0x1 user="vodafone" password="vodafone"]
rcvd [LCP EchoRep id=0x0 magic=0x38dfc450]
rcvd [PAP AuthAck id=0x1 "Congratulations!"]
Remote message: Congratulations!
PAP authentication succeeded
sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
rcvd [LCP ProtRej id=0x1 80 fd 01 01 00 0c 1a 04 78 00 18 04 78 00]
Protocol-Reject for 'Compression Control Protocol' (0x80fd) received
rcvd [LCP TermReq id=0x1]
LCP terminated by peer
sent [LCP TermAck id=0x1]
Connection terminated.
Modem hangup

Het lijkt erop dat vodafone het "compressie control protocol" niet wil gebruiken. Maar op het internet lees ik dat dat niet uit zou moeten maken. M.a.w. ik weet niet precies waarom dat de reden is dat de verbinding verbroken wordt...

Tweakers, als jullie hier verstand van hebben, please help me!!

Gusteen

Anoniem: 257710

Gelukkig, het werkt eindelijk:

Zoals gezegd waren op mijn GSM blijkbaar de eerste en de tweede data account gelockt. Dus moet ik gebuik maken van een andere. Ik heb gekozen voor de derde data account. Dat kun je aangeven met "OK 'AT+CGDCONT=3,"IP","live.vodafone.com"'" EN "OK 'ATD*99***3#'". En daarna werkt het gewoon!

$ cat /etc/ppp/vodafone.chat
TIMEOUT 5
ECHO ON
ABORT '\nBUSY\r'
ABORT '\nERROR\r'
ABORT '\nNO ANSWER\r'
ABORT '\nNO CARRIER\r'
ABORT '\nNO DIALTONE\r'
ABORT '\nRINGING\r\n\r\nRINGING\r'
'' \rATZ
OK 'ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0'
OK 'AT+CGDCONT=3,"IP","live.vodafone.com"'
OK 'AT+CGATT=1'
OK 'ATD*99***3#'
TIMEOUT 10
CONNECT ""

~$ sudo pon vodafone
OK
ATZ
OK
V1 E1 S0=0 &C1 &D2 +FCLASS=0AT+CGDCONT=3,"IP","live.vodafone.com"
OK
AT+CGATT=1
OK
ATD*99***3#
CONNECT
Serial connection established.
using channel 4
Using interface ppp0
Connect: ppp0 <--> /dev/ttyACM0
sent [LCP ConfReq id=0x1 <asyncmap 0xa0000> <magic 0x662fdd6f>]
rcvd [LCP ConfReq id=0x2 <auth pap> <accomp> <pcomp> <asyncmap 0x0> <magic 0x7c25ee5e>]
sent [LCP ConfRej id=0x2 <accomp> <pcomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0xa0000> <magic 0x662fdd6f>]
rcvd [LCP ConfReq id=0x3 <auth pap> <asyncmap 0x0> <magic 0x7c25ee5e>]
sent [LCP ConfAck id=0x3 <auth pap> <asyncmap 0x0> <magic 0x7c25ee5e>]
sent [LCP EchoReq id=0x0 magic=0x662fdd6f]
sent [PAP AuthReq id=0x1 user="vodafone" password="vodafone"]
rcvd [LCP EchoRep id=0x0 magic=0x7c25ee5e]
rcvd [PAP AuthAck id=0x1 "Congratulations!"]
Remote message: Congratulations!
PAP authentication succeeded
sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
rcvd [LCP ProtRej id=0x1 80 fd 01 01 00 0c 1a 04 78 00 18 04 78 00]
Protocol-Reject for 'Compression Control Protocol' (0x80fd) received
rcvd [IPCP ConfReq id=0x1]
sent [IPCP ConfNak id=0x1 <addr 10.0.0.1>]
rcvd [IPCP ConfNak id=0x1 <addr 10.22.102.61> <ms-dns1 62.140.138.237> <ms-dns3 62.140.140.250>]
sent [IPCP ConfReq id=0x2 <addr 10.22.102.61> <ms-dns1 62.140.138.237> <ms-dns3 62.140.140.250>]
rcvd [IPCP ConfReq id=0x2]
sent [IPCP ConfAck id=0x2]
rcvd [IPCP ConfAck id=0x2 <addr 10.22.102.61> <ms-dns1 62.140.138.237> <ms-dns3 62.140.140.250>]
Cannot determine ethernet address for proxy ARP
local IP address 10.22.102.61
remote IP address 10.0.0.1
primary DNS address 62.140.138.237
secondary DNS address 62.140.140.250
Script /etc/ppp/ip-up started (pid 26962)
Script /etc/ppp/ip-up finished (pid 26962), status = 0x0

Bedankt voor de tips!

Gusteen
Pagina: 1



Nintendo Switch (OLED model) Apple iPhone SE (2022) LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S22 Garmin fēnix 7 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee