Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

[Ubuntu 6.06] wel internet verbinding maar kan niet browsen

Pagina: 1
Acties:

Onderwerpen


  • hilgo
  • Registratie: maart 2000
  • Laatst online: 19:58

hilgo

Clear your mind of can't.

Topicstarter
Ik heb ubuntu 6.06 naast winxp geïnstalleerd en heb een raar probleem. Als ik met firefox bijvoorbeeld de site van tweakers of planet (mijn isp) wil bezoeken lukt dit niet. Daarentegen google/gmail wordt zonder problemen op het scherm getoverd. De pc zit via een utp kabel aan mijn modem/router verbonden en als ik naar planet ping krijg ik keurig netjes een reply terug.
Ook kan ik met gaim msn-en. Kortom: de internet verbinding lijkt up & running.
Ik vermoed een dns probleem en heb het volgende gedaan:
Bij de netwerk kaart (eth0) de dns servers van planet internet ingevuld (195.121.1.34 en 195.121.1.66) maar die verdwenen na een reboot dus die heb ik nu aan de dhclient.conf toegevoegd (had ik op het ubuntu forum gelezen).
Verder heb ik ipv6 in firefox uitgezet aangezien dat ook als mogelijk probleem werd genoemd.
Daarnaast heb ik in /etc/modprobe.d/aliases de regel alias net-pf-10 ipv6 aangepast naar alias net-pf-10 ipv6 off en later naar #alias net-pf-10 ipv6.
Helaas heeft dit alles niet geholpen, ik kan haast geen enkele site bezoeken en ik hoop dat jullie me verder kunnen helpen.

Mijn ifconfig info:

eth0 Link encap:Ethernet HWaddr 00:13:D3:C7:05:29
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::213:d3ff:fec7:529/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:74 errors:37 dropped:0 overruns:0 frame:37
TX packets:97 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:11027 (10.7 KiB) TX bytes:10646 (10.3 KiB)
Interrupt:233 Base address:0xdead

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:11 errors:0 dropped:0 overruns:0 frame:0
TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:572 (572.0 b) TX bytes:572 (572.0 b)

Discogs


  • Dutchmega
  • Registratie: september 2001
  • Niet online
Ik neem aan dat onder Windows alles goed werkt?

De regel in /etc/modprobe.d/aliases moet zijn:
code:
1
alias net-pf-10 off


Daarna moet je eventjes je netwerk opnieuw opstarten:
code:
1
sudo /etc/init.d/networking restart


Wat voor router heb je trouwens?

  • hilgo
  • Registratie: maart 2000
  • Laatst online: 19:58

hilgo

Clear your mind of can't.

Topicstarter
Dutchmega schreef op zondag 11 februari 2007 @ 20:45:
Ik neem aan dat onder Windows alles goed werkt?

De regel in /etc/modprobe.d/aliases moet zijn:
code:
1
alias net-pf-10 off


Daarna moet je eventjes je netwerk opnieuw opstarten:
code:
1
sudo /etc/init.d/networking restart


Wat voor router heb je trouwens?
Onder windows werkt het inderdaad ok. Modem/router is een e-tech adwg02. Zal de genoemde regel direct gaan proberen :)

Edit: helaas, alias net-pf-10 off is ook niet de oplossing. Het gekke is dat op deze machine het al eens 'out of the box' gedraaid heeft maar door een hd crash is nu alles opnieuw geinstalleerd (zowel xp als ubuntu).

[Voor 17% gewijzigd door hilgo op 11-02-2007 21:02]

Discogs


  • wzzrd
  • Registratie: februari 2000
  • Laatst online: 28-09-2020
Als je die planet site pingt, zie je dan wel een IP adres en krijg je dan een time-out of krijg je meteen een time-out?
Wat is de output van route?

[Voor 25% gewijzigd door wzzrd op 11-02-2007 23:16]


  • hilgo
  • Registratie: maart 2000
  • Laatst online: 19:58

hilgo

Clear your mind of can't.

Topicstarter
Als ik de site van planet ping krijg ik een ip terug en gewoon een reply. En dat is raar want in firefox kan ik wachten tot ik een ons weet. Output van route (ik neem aan dat je traceroute bedoelt) zal ik vanavond wel even posten (zit nu op werk).

Discogs


  • wzzrd
  • Registratie: februari 2000
  • Laatst online: 28-09-2020
Nee, ik bedoel route. Daarmee kun je een tabel weergeven met je default gateway en dergelijke. Gewoon route typen in een console. Toch moet je mogelijk ook even in Firefox in Prefs, Advanved je netwerksettings checken.

  • hilgo
  • Registratie: maart 2000
  • Laatst online: 19:58

hilgo

Clear your mind of can't.

Topicstarter
Het resultaat van route:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

Firefox staat ingesteld op 'Direct connection to the internet'

[Voor 10% gewijzigd door hilgo op 12-02-2007 19:51]

Discogs


  • wzzrd
  • Registratie: februari 2000
  • Laatst online: 28-09-2020
Doe eens opera of epiphany proberen? Dan sluiten we daarmee even uit dat het eventueel om firefox gaat. route ziet er goed uit. Ik heb dit ook wel eens gehad, maar ik het geen idee hoe ik dit gefixt heb. Hoe ziet je /etc/resolv.conf eruit?

  • hilgo
  • Registratie: maart 2000
  • Laatst online: 19:58

hilgo

Clear your mind of can't.

Topicstarter
resolv.conf:
nameserver 195.121.1.34
nameserver 195.121.1.66
nameserver 192.168.1.1

Die onderste heb ik al eens verwijderd maar komt vanzelf weer terug. Zou op zich denk ik ook geen kwaad kunnen aangezien hij de bovenste eerst pakt (als ik het goed onthouden heb).
Zal eens een van de genoemde browsers proberen te installeren.

Discogs


  • Jungian
  • Registratie: juni 2006
  • Laatst online: 20:56
De onderste is sowieso de enige die je nodig hebt. Je kunt ook even iets wgetten of links (cli-browser) gebruiken om te checken of alles werkt (lijkt mij wel als je kunt chatten etc.). Het viel me trouwens ook op dat je geen local loopback hebt draaien (lijkt me ook niet relevant, maar ik vind het wel bizar).
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
loopback        *               255.0.0.0       U     0      0        0 lo

Heb je trouwens ook al even je modem een schop gegeven ?

[Voor 113% gewijzigd door Jungian op 12-02-2007 21:52]

0.0


  • NoBody
  • Registratie: juni 2001
  • Laatst online: 17-02 23:03

NoBody

www.gentoo.org

Aan je DNS zal het niet liggen want anders kon je ook niet pingen...

Wat je wel ff kunt proberen is om ff het betreffende IP, die je met ping dus te zien krijgt (je kunt m ook opvragen met 'host <adres>'), in je firefox adresbalk te mikken. Helpt dat ook niet, vermeld dan eens wat er zich allemaal in je firefox statusbalk onderaan afspeelt vanaf het moment dat je op enter drukt, totaan het moment dat je het opgeeft..

En, zoals eerder gezegd, idd ff 1 of 2 andere browsers proberen. Kijken wat dat oplevert :)

Hoi


  • hilgo
  • Registratie: maart 2000
  • Laatst online: 19:58

hilgo

Clear your mind of can't.

Topicstarter
andere browser installeren wordt moeilijk.. epiphany mist iets en als ik met synapsis repositories toe voeg en op reload druk gebeurd er niets.
Modem had ik reeds een schop gegeven. ip adres in firefox gooien gaf ook geen resultaat maar ik zal eens noteren wat er gebeurd.

Edit:

ping www.planet.nl
PING netapp.kpn-is.nl (213.75.12.42) 56(84) bytes of data.
64 bytes from content79.wxs.nl (213.75.12.42): icmp_seq=1 ttl=250 time=8.32 ms
64 bytes from content79.wxs.nl (213.75.12.42): icmp_seq=2 ttl=250 time=8.84 ms
64 bytes from content79.wxs.nl (213.75.12.42): icmp_seq=3 ttl=250 time=8.53 ms

ip 213.75.12.42 in firefox ingevoerd. Onderin verschijnt 'Waiting for
213.75.12.42'


wget geeft een soort gelijk iets:
wget http://en.wikipedia.org
--22:43:07-- http://en.wikipedia.org/
=> `index.html'
Resolving en.wikipedia.org... 145.97.39.155
Connecting to en.wikipedia.org|145.97.39.155|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://en.wikipedia.org/wiki/Main_Page [following]
--22:43:07-- http://en.wikipedia.org/wiki/Main_Page
=> `Main_Page'
Connecting to en.wikipedia.org|145.97.39.155|:80... connected.
HTTP request sent, awaiting response...

In beide gevallen voor mijn gevoel uren gewacht (okay, 1 a 2 minuten) maar geen resultaat. En dan te bedenken dat de google site (en gmail site) gewoon vliegt.. echt raar :?

[Voor 67% gewijzigd door hilgo op 12-02-2007 22:55]

Discogs


  • hilgo
  • Registratie: maart 2000
  • Laatst online: 19:58

hilgo

Clear your mind of can't.

Topicstarter
Na lang prullen ubuntu er af gehaald en opensuse geinstalleerd. Na het uitschakelen van ipv6 werkt dit nu perfect. Geen idee waar of wat de verschillen zijn maar ik ben weer een happy trooper met een werkende linux omgeving :)

Discogs

Pagina: 1


Apple iPhone 12 Microsoft Xbox Series X LG CX Google Pixel 5 Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True