Vraag


  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Hoi,

Omdat we een tijdje een WD NAS hebben en ik deze wil bereiken met een VPN heb ik een Raspberry pi gekocht en hier OpenVPN op geïnstalleerd. Ik heb alles aan de praat gekregen en het werkt... behalve op mijn werk.
Wat mij opvalt is dat het IP adres van mijn modem thuis 192.168.178.1 is en dit is op mijn werk het zelfde IP op hun modem. Heb ik hier al het probleem gevonden dan of moet dat geen probleem zijn? En als dit het probleem is kan ik dit dan makkelijk oplossen door mijn modem IP te veranderen naar bijvoorbeeld 192.168.123.1? Of heb ik hier te veel werk aan en ga ik dan tegen andere problemen lopen?
Verder had ik al gevonden dat het probleem kon zijn dat het poort dat ik gebruik geblokkeerd is op mijn werk, daarom heb ik verschillende andere poorten geprobeerd zonder resultaat.
Wel valt me op dat ik wel bijvoorbeeld een losse router die op 192.168.178.10 zit kan bereiken via de VPN. Maar mijn NAS en mijn eigen modem weer niet. Ook via de verkenner krijg ik geen toegang tot de NAS.

Ik hoop dat dit makkelijk op te lossen is. niet perse voor op mijn werk maar vooral om problemen in de toekomst te vermeiden.

Hoor graag van jullie.

Mvg Brian :)

Beste antwoord (via Brian07 op 20-04-2021 19:30)


  • Minitrooper
  • Registratie: december 2013
  • Laatst online: 23-12-2021
Dag Brian!
Heel kort door de bocht: als jij met jouw pc via het internet connecteert op jou PI, gebeuren er veel maar vooral 2 belangrijke dingen:
1. je krijgt een VPN-intern-adres (typisch 10.0.0.2 bv)
2. je VPN server haakt dat naar een lokaal lan adres (dus 192.168.178.x iets)

Wat er nu gebeurt is dat jouw pc 2x eenzelfde ip range onder zijn voeten heeft: eentje via jouw (werk) netwerk (LAN kant) en eentje via de VPN tunnel (VPN-jouw-thuis-LAN kant).

Vermoedelijk ga jij de subnetten/gateways/.. op jouw werk niet makkelijk kunnen veranderen, dus ik stel voor van iets zeer atypisch te gebruiken bij jouw thuis (192.168.251.x bv). Maar voor je daaraan begint, ga je bést eerst al jouw devices met een static adres (de PI, jouw WD NAS, domotica, ?.... ?) langs en duw daar eerst een nieuw statisch adres in. Als laatste verander je jouw router subnet en reboot je deze.

Dan zou je VPN setup moeten werken.

Succes!

PS: die 192.168.178.10, ben je zeker dat dat een router bij jou thuis op de LAN was of op jouw werk LAN?

Alle reacties


  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Hoi.

Bedankt voor je snelle antwoord.
Mijn vermoeden is inderdaad juist dus. Wel wordt het nog een gedoe om met mijn kennis alles soepel over te zetten. Als ik het goed begrijp zet ik alleen alle apparaten die een statisch ip hebben zelf over en op het einde mijn modem. Andere apparaten worden vanzelf overgezet, na een eventuele reboot ga ik vanuit?
Ik ga hier in het weekend waarschijnlijk mee verder.

De router op 192.168.178.10 is 100% zeker die bij mij thuis. Deze heeft een statisch ip adres. En bovendien kan ik er gewoon op inloggen met mijn inlog gegevens. Verder staat op mijn werk niet meer dan alleen het modem en die staat al op 192.168.178.1, netzo als mijn modem thuis die ik dus via de vpn niet kan bereiken als ik op mijn werk ben.

Groet Brian
Minitrooper schreef op donderdag 15 april 2021 @ 23:07:
Dag Brian!
Heel kort door de bocht: als jij met jouw pc via het internet connecteert op jou PI, gebeuren er veel maar vooral 2 belangrijke dingen:
1. je krijgt een VPN-intern-adres (typisch 10.0.0.2 bv)
2. je VPN server haakt dat naar een lokaal lan adres (dus 192.168.178.x iets)

Wat er nu gebeurt is dat jouw pc 2x eenzelfde ip range onder zijn voeten heeft: eentje via jouw (werk) netwerk (LAN kant) en eentje via de VPN tunnel (VPN-jouw-thuis-LAN kant).

Vermoedelijk ga jij de subnetten/gateways/.. op jouw werk niet makkelijk kunnen veranderen, dus ik stel voor van iets zeer atypisch te gebruiken bij jouw thuis (192.168.251.x bv). Maar voor je daaraan begint, ga je bést eerst al jouw devices met een static adres (de PI, jouw WD NAS, domotica, ?.... ?) langs en duw daar eerst een nieuw statisch adres in. Als laatste verander je jouw router subnet en reboot je deze.

Dan zou je VPN setup moeten werken.

Succes!

PS: die 192.168.178.10, ben je zeker dat dat een router bij jou thuis op de LAN was of op jouw werk LAN?

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Hoi @FreshMaker

Bedankt voor je antwoord.
Ik heb er zelf nog niet al te veel verstand van maar ik denk dat wat jij verteld dat dit een stapje terug is? Het open zetten van de poort en doorverwijzen naar mijn raspberry heb ik al gedaan en dit werkt prima. Behalve op het netwerk bij mijn werk, dat is het probleem.

Los van of mijn werk het een probleem vind wil ik dit probleem oplossen om problemen in de toekomst op andere netwerken te voorkomen.

Groet Brian
FreshMaker schreef op donderdag 15 april 2021 @ 23:50:
Euhmmmm nee,
@minitrooper heeft het geheel bij het verkeerde eind ...

IPadressen met 192.168.x.x zijn alleen bereikbaar via het interne ( eigen ) netwerk.
Deze worden nooit doorgezet naar een algemeen extern netwerk.
Dus het aanpassen van het eigen interne IPadres naar een ander subnet zal niets uithalen

Als jij jouw eigen netwerk wilt bereiken, zal je dit moeten doen door de poort (1194 ) open te zetten in jouw router, en deze verwijzen naar de r-pi ( het 192.168.x.x adres)

Daar zijn best veel tutorials over te vinden, maar ik zou aanraden om eerst in te lezen wat de risico's zijn, en of jouw werkgever het wel zo prettig vindt dat je jouw netwerk, aan het zijne 'knoopt'

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
@FreshMaker

Klopt, de OpenVPN client verwijst inderdaad naar het externe adres. En de vpn verbinding werkt ook prima, ook vanuit andere netwerken dan bij mij thuis(zoals mijn 4G van mijn mobiel).
Het probleem zou dus kunnen zijn dat mijn interne ip en het ip van mijn werk het zelfde zijn. Daar probeer ik achter te komen door middel van deze post. Ook heb ik als optie open dat het gewoon geblokkeerd word op mijn werk. Maar wat ik zelf al vermoeden heeft @Minitrooper bevestigd. Ik hoop dat dit inderdaad klopt zodat ik zo het probleem opgelost krijg.
FreshMaker schreef op vrijdag 16 april 2021 @ 00:02:
Intern zal het inderdaad prima werken, daar worden de ipadressen gerouteerd.

Maar als jij van buiten naar binnen wilt, zal je dus de openvpn-client naar het externe adres moeten laten verwijzen ( niet de 192.168.xx )


[...]


Op veel zakelijke netwerken worden dat soort dingen actief geblokkeerd, ivm veiligheidsrisico's en datalekken

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
FreshMaker schreef op vrijdag 16 april 2021 @ 00:02:


Verder heb jij het over een router op 192.168.178.10 en een modem op 192.168.178.1
Hoe heb je dat ingericht dan, is het modem in bridge gezet ?

Er mist nog wat relevante informatie namelijk
Het modem (van ziggo) staat op .1 en deze staat niet in bridge en deelt alle ip adressen uit naar alle apparaten. Vervolgens heb ik aan de andere kant van de woonkamer een snellere router met een statisch ip op .10 en in de garage nog een router met statisch ip .20. Verder heeft de nas .31 en de raspberry pi .25. Allemaal statisch. De rest van de Ip adressen deelt het modem uit naar alle apparaten..

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
FreshMaker schreef op vrijdag 16 april 2021 @ 00:13:
Welk ipadres krijg je dan als je via 4G inlogt.

Ook dat is in openVPN gewoon in te stellen natuurlijk.

https://serverfault.com/q...-take-the-same-ip-address
Weet ik zo even niet, in ieder geval iets heel anders als mijn ip van de router thuis

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Will_M schreef op vrijdag 16 april 2021 @ 00:32:
Hide NAT, of is dat niet iets?
Hoi @Will_M
Ik als leek zou me even moeten gaan inlezen wat dat precies is. Tenzij jij me simpel kunt uitleggen wat het is en wat je er mee kunt.

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Het overnummeren van mijn eigen netwerk klinkt voor mij nu de beste optie, ik zou bij alle andere opties weer eerst veel kennis moeten op doen terwijl de IP adressen veranderen mij niet heel moeilijk lijkt.
Thralas schreef op vrijdag 16 april 2021 @ 08:49:

Dit spreekt de rest van je (verder logische) verhaal overigens wel tegen. Hoe ziet de routetabel eruit?
Ik ben met je eens dat het niet logisch klinkt vandaar ook dat ik zei dat het me op valt (het was voor mij meer een bevestiging dat de verbinding er wel degelijk is).
Mijn netwerk zit als volgt in elkaar:
Als eerste mijn modem van ziggo(staat niet in bridge modes) deze heeft achteraan het IP .1 en hier zit via de internet kabel een router op aangesloten die .10 heeft. Op deze router zit mijn pc, de nas, de raspberry pi, een klik aan klik uit kastje en nog een 2e losse router aangesloten. De pc, pi en nas zitten via een switch. De 2e losse router zit op .20 en hier zit nog een beveilingscamera op aangesloten.

Misschien dat ik de router met .10 wel kan bereiken omdat de pi op hem zit aangesloten?

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Minitrooper schreef op vrijdag 16 april 2021 @ 11:22:
Brian, maak je eens een tekening met jouw verschillende netwerklagen inclusief subnetmasks en gateways, want jouw ziggo (router) heeft een .1, maar is dat dan 192.168.178.1? En op welk adres draait bv jouw raspberry pi?
Ongeacht blijf ik bij mijn mening dat de ip ranges te veranderen het snelst en eenvoudigste is.
Ik zal dat binnenkort even tekenen, heb je daar een goed voorbeeld van die ik kan gebruiken?

Verder zijn alle adressen 192.168.178.x waar de x dus het getal is in mijn vorige bericht. Het ziggo modem zit dus op 192.168.178.1 en de pi op 192.168.178.25 enzovoort...

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Minitrooper schreef op vrijdag 16 april 2021 @ 16:58:
[...]


Van mij mag je het zelfs in Excel oplijsten :-)

Maar hier een voorbeeldje bruutweg van internet geplukt:
[Afbeelding]


Maar uit bovenstaande uitleg haal ik dat jouw 192.168.178.10 router TUSSEN jouw ziggo modem (op 192.168.178.1) en de pi (op 192.168.178.25) zit? Gebruik jij die als router of als "switch"? Uit jouw verhaal haal ik dat het een router is, maar ik vermoed dat ie simpelweg switch speelt ;-)

Vandaar mijn vraag voor een oplijsting (grafisch of tabulair) van hoe jouw netwerk eruit ziet :-)
Heb me even kort ingelezen en ik heb inderdaad de router ingesteld als switch. Al een tijdje terug. Puur omdat het modem niet in bridge kan omdat we meer dan 1 internet poort nodig hebben vanuit het modem en als de switch dan als router staat ingesteld stoort alles op elkaar. Voor mij is het gewoon een router haha, onder die naam heb ik hem ook gekocht bovendien. Maar indd de router (switch) op 192.168.178.10 hangt tussen mijn modem en de raspberry pi.

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
@Minitrooper
Lijkt dit een beetje op wat je van me vroeg of ben ik dingen vergeten er bij te zetten?


  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Frogmen schreef op vrijdag 16 april 2021 @ 21:11:
Meest simpele oplossing is wel dat je thuis een ander subnet instelt liefst een niet veel gebruikt. Simpel gezegd je kan geen VPN maken naar een zelfde subnet want dan weet je PC niet meer hoe te routeren.
Hartelijk bedankt voor je reactie, ik ga dit binnenkort proberen. Misschien zondag al.
Heb je eventueel een subnet als voorbeeld waar ik waarschijnlijk geen problemen mee krijg? Ik weet niet wat wel en wat niet veel voor komt.

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Frogmen schreef op vrijdag 16 april 2021 @ 21:18:
Zolang je begint met 192.168.xxx.0 mag je ieder getal kiezen 1, 2, 178 zijn heel veel gebruikt.
Oke bedankt, dan gaat het vast goed komen :)

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
@Minitrooper
Thanks voor je uitleg. De klik aan klik uit en het alarm systeem heb ik nooit een statisch ip gegeven, maar ik snap dat ze wel een ip hebben. Gaan deze vanzelf over als ik deze uiteindelijk gewoon opnieuw opstart?
Ook mijn pc heeft geen statisch ip. Is het handig omdat wel te doen dan op het einde of werkt opnieuw opstarten van de pc ook? Gaat de pc dan vanzelf in de juiste range?
Als dat zo is dan neem ik zelf niet het risico dat ik iets verkeerd invul maar veranderd het automatisch na dat ik het modem ip heb aangepast samen met alle andere apparaten die geen statisch ip hebben.

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
FreakNL schreef op zaterdag 17 april 2021 @ 05:15:
Je eigen subnet wijzigen is op zich wel handig, zodat als je op je werk zit je zowel het subnet van het werk 192.168.178.x als je (nieuwe) subnet thuis (bijv 192.168.135.x) kunt benaderen als je verbonden bent met VPN. Doe je dat niet is het afhankelijk van de instellingen van je VPN welk subnet benaderbaar is.. Dat staat ook duidelijk in de post van @Thralas;
Thralas in "OpenVPN werkt niet op alle netwerken"

Maar in jouw geval zou ik inderdaad gewoon je eigen subnet omnummeren naar iets weinig voorkomends zoals 192.168.135.x of 192.168.215.x

Buiten dat nog een pro-tip:
Draai je VPN op TCP/443 (als die poort thuis nog niet bezet is). Ik ben nog geen hotel tegengekomen waar het NIET werkte. En ik kom op wat plekken. Zit nu in Jakarta en ik kan prima met thuis verbinden.
ThinkPadd in "Raspberry Pi server"

Iets dichter bij huis; vriendin had vroeger slaapdiensten op haar werk en daar stond alles ook dicht op de WiFi. Met een OpenVPN cliënt op haar iPad kon ze in ieder geval Plex en Ziggo kijken. Ook daar werkte OpenVPN alleen op 443/TCP.


Dat je op jouw werk niet kan verbinden zal eerder aan een firewall/blokkade op het werk liggen dan aan overlappende subnets. Als je namelijk overlappende subnets hebt wordt de verbinding (volgens mij) WEL opgezet maar gaat het daarna pas “mis”..
Hey, bedankt voor je antwoord. Met die pro tip wil je zeggen dat ik al pro ben? :P
Ik heb inderdaad mijn VPN al op TCP 443 staan, nauwelijks trager dus vond ik dit zelf ook al een betere keuze.
Maar ook andere poorten had ik al geprobeerd op mijn werk waardoor ik eigelijk al wist dat het niet daar aan lag, of ze zouden echt alles op slot moeten hebben staan, waar ik niet vanuit ga.
De VPN maakt ook gewoon verbinding en het lijkt me ook indd dat het daarna pas mis gaat.

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Ik ga het vandaag proberen om alles over te zetten. Ik zal laten weten hoe het is gegaan.

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Het is veel sneller gegaan dan ik had verwacht. Alles werkt al weer. Ik ben van 192.168.178.x naar 192.168.215.x gegaan.
Enige wat niet goed was gegaan was het statische IP van de Raspberry pi omzetten maar is dat nu net een computer waar ik gewoon mijn monitor en toetsenbord en muis op kan aansluiten. Dus ook die heb ik achteraf alsnog goed ingesteld gekregen.
Ook de VPN werkt al weer.
Alleen dinsdag of woensdag nog kijken op werk of het daar nu ook werkt en dan weet ik zeker dat mijn vraag/probleem is opgelost!

Allemaal heel erg bedankt voor jullie hulp, ik laat jullie aankomende week weten of daadwerkelijk het probleem ook verholpen is.

Groet Brian

Acties:
  • +1Henk 'm!

  • Brian07
  • Registratie: maart 2021
  • Laatst online: 17-01 11:52
Yes alles werkt. Ook op mijn werk kan ik de VPN nu gebruiken doordat ik thuis mijn IP range heb aangepast.

Allemaal nogmaals erg bedankt voor jullie hulp! :)
Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee