Toon posts:

cel vervangen op basis van inhoud van twee andere cellen

Pagina: 1
Acties:

Onderwerpen

Vraag


  • granitk7
  • Registratie: Augustus 2014
  • Laatst online: 24-11 09:56
Mijn vraag

Een bepaalde formule die ik wil gebruiken om een derde cel te vervangen als twee andere cellen met elkaar overeenkomen werkt niet.

De situatie is momenteel zo:


Blad2..............Blad 2.............Blad 2 ..........Blad 2..................Blad 3..............................Lijst................Lijst

Kolom A..........Kolom B.........Kolom C.......Kolom D ..............Kolom A(=blad2!$C).......Kolom B..........kolom C

Voornaam........Achternaam...Adres...........Waar/Onwaar..... Adres...............................Achternaam.....Adres


Als een bepaald persoon x in blad 2 voorkomt dan moet zijn adres worden opgezocht in een speciale lijst. Komt deze naam niet voor dan moet de volgende standaard actie worden uitgevoerd in kolom C: VERSCHUIVING(Blad1!E$1;(RIJ()-1)*2;0)&" "&VERSCHUIVING(Blad1!E$1;((RIJ()-1)*2)+1;0).

Als persoon x wel voorkomt in deze lijst dan moet de volgende actie worden uitgevoerd in kolom C

VERT.ZOEKEN(B2;lijst!B2:C44;2;0) (De achternaam in kolom B wordt dus gezocht in de lijst en het adres in de lijst wordt overgenomen en zou in kolom C van blad1 moeten komen.

Kolom D gebruik is als hulpmiddel om te bepalen om te kunnen bepalen of een persoon wel of niet in de lijst voorkomt. Als de persoon in de lijst voorkomt dan is de waarde waar en zo niet dan is de waarde onwaar. Dus daar heb ik deze formule in gezet: =ALS(Blad3!A1="ADRES X"; WAAR; ONWAAR)

Het volgende heb ik dus gebruikt in blad2 kolom C:

=ALS(D2=WAAR;VERT.ZOEKEN(B2;lijst!B2:C44;2;0);ALS(D2=ONWAAR;VERSCHUIVING(Blad1!E$1;(RIJ()-1)*2;0)&" "&VERSCHUIVING(Blad1!E$1;((RIJ()-1)*2)+1;0);""))

Helaas werkt dit niet. Ik krijg alleen de ingetypte formule te zien in plaats van een adres.

Relevante software en hardware die ik gebruik
Excel

Wat ik al gevonden of geprobeerd heb

Ik dacht eerst de fout te hebben gevonden, omdat ik blad3!$A niet had aangemaakt in het begin. Ik besefte eerst niet dat je dan een paradox zou krijgen. Het was namelijk eerst zo ingesteld dat er in blad2 kolom C iets zou moeten worden gedetecteerd en vervolgens gewijzigd, maar zodra de inhoud wordt gewijzigd zou daardoor de waarde van blad2 kolom D veranderen enz.

Dat heb ik dus veranderd, maar het werkt nog steeds niet en ik weet echt niet waar het probleem zou kunnen liggen. Misschien een lang verhaal maar ik waardeer alle hulp

[Voor 9% gewijzigd door granitk7 op 01-07-2020 01:51]

Beste antwoord (via granitk7 op 01-07-2020 11:13)


  • g0tanks
  • Registratie: Oktober 2008
  • Laatst online: 02:23

g0tanks

Moderator CSA
granitk7 schreef op woensdag 1 juli 2020 @ 01:44:
Helaas werkt dit niet. Ik krijg alleen de ingetypte formule te zien in plaats van een adres.
Je krijgt dus geen foutmelding? Staat de opmaak van de cel toevallig op tekst in plaats van algemeen? Of staat formule weergeven aan?

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW

Alle reacties




Google Pixel 7 Sony WH-1000XM5 Apple iPhone 14 Samsung Galaxy Watch5, 44mm Sonic Frontiers Samsung Galaxy Z Fold4 Insta360 X3 Nintendo Switch Lite

Tweakers is samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer onderdeel van DPG Media B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee