Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

TPLink Archer T9UH + Experiabox V10 veel trager dan verwacht

Pagina: 1
Acties:

Acties:
  • +1Henk 'm!

  • dion_b
  • Registratie: september 2000
  • Laatst online: 15:14

dion_b

Moderator Harde Waren

say Baah

De Experiabox v10 doet 3x3 MIMO in beide banden, met iirc een Broadcom BCM4360, zelfde chip als in o.a. Netgear R7000. Dat zou op papier dus een stuk sneller moeten kunnen.

Doe eens op je Windows-bak netsh wlan show interface, uitdraai daarvan geeft veel relevante info.

En mbt iPerf, hebben we het over de oude (onbetrouwbare) iPerf2 of over iPerf3? En welke settings doe je exact? Om goed hogere snelheden te meten moet je meer concurrent TCP streams gebruiken, dus -P 5 ofzo. Dat is meestal voor 400-600Mbps genoeg. Wil je daarboven meten, dan moet het aantal omhoog.

Soittakaa Paranoid!


Acties:
  • +2Henk 'm!

  • dion_b
  • Registratie: september 2000
  • Laatst online: 15:14

dion_b

Moderator Harde Waren

say Baah

Razor_ schreef op vrijdag 19 juni 2020 @ 09:29:
netsh wlan show interface geeft:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
There is 1 interface on the system:

    Name                   : Wi-Fi
    Description            : TP-Link Wireless USB Adapter
    GUID                   : 23521ae4-774c-478b-a016-38ed6b005601
    Physical address       : 7c:8b:ca:11:d6:b3
    State                  : connected
    SSID                   : H369A261DFE
    BSSID                  : 74:b5:7e:26:1d:ff
    Network type           : Infrastructure
    Radio type             : 802.11ac
    Authentication         : WPA2-Personal
    Cipher                 : CCMP
    Connection mode        : Auto Connect
    Channel                : 108
    Receive rate (Mbps)    : 650
    Transmit rate (Mbps)   : 650
    Signal                 : 92%
    Profile                : H369A261DFE

    Hosted network status  : Not available
OK, hier zien we een paar dingen:
- je bent verbonden met iets dat inderdaad op een Experiabox v10 lijkt.
- je zit idd op 5GHz, op kanaal 108.
- security en encryption gooit geen roet in het eten
- "92%" signal komt neer op -54dBm RSSI - dat zou meer dan goed genoeg moeten zijn voor een snelle verbinding.
- link rates zijn wel opvallend. 650Mbps betekent namelijk bij 80MHz kanaalbreedte dat je niet 3 maar 2 streams gebruikt, en dat je maar op 64QAM zit en niet 256QAM. Aantal streams kan verschillende oorzaken hebben, maar bij -54dBm RSSI zou ik volle 256QAM (en dus 866Mbps link rate bij 2 streams) verwachten. Lijkt alsof er mogelijk aardig wat verstoring in de lucht zit.
Ik gebruik de laatste iperf 3.1.3-win64 en op de Mac iperf 3.7 (cJSON 1.5.2) (via Homebrew geïnstalleerd).

De MacBook zit met een 2 meter Cat5e kabel direct in de Experiabox en heeft een 1Gbit interface. Hier host ik de iperf server op als:

code:
1
2
iperf3 -s
Server listening on 5201


Op Windows run ik dan:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
E:\Other\iperf-3.1.3-win64>iperf3.exe -c 192.168.2.16
Connecting to host 192.168.2.16, port 5201
[  4] local 192.168.2.8 port 50600 connected to 192.168.2.16 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  26.1 MBytes   219 Mbits/sec
[  4]   1.00-2.00   sec  26.9 MBytes   225 Mbits/sec
[  4]   2.00-3.00   sec  26.5 MBytes   222 Mbits/sec
[  4]   3.00-4.00   sec  23.0 MBytes   193 Mbits/sec
[  4]   4.00-5.00   sec  26.2 MBytes   220 Mbits/sec
[  4]   5.00-6.00   sec  25.5 MBytes   214 Mbits/sec
[  4]   6.00-7.00   sec  25.5 MBytes   214 Mbits/sec
[  4]   7.00-8.00   sec  25.1 MBytes   211 Mbits/sec
[  4]   8.00-9.00   sec  24.6 MBytes   206 Mbits/sec
[  4]   9.00-10.00  sec  25.5 MBytes   214 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   255 MBytes   214 Mbits/sec                  sender
[  4]   0.00-10.00  sec   255 MBytes   214 Mbits/sec                  receiver

iperf Done.


Met -P 5 zoals je aangaf krijg ik als ik na ongeveer 10 seconden cancel deze output:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec  66.2 MBytes  55.6 Mbits/sec                  sender
[  4]   0.00-10.00  sec  66.2 MBytes  55.6 Mbits/sec                  receiver
[  6]   0.00-10.00  sec  65.5 MBytes  54.9 Mbits/sec                  sender
[  6]   0.00-10.00  sec  65.5 MBytes  54.9 Mbits/sec                  receiver
[  8]   0.00-10.00  sec  65.0 MBytes  54.5 Mbits/sec                  sender
[  8]   0.00-10.00  sec  65.0 MBytes  54.5 Mbits/sec                  receiver
[ 10]   0.00-10.00  sec  64.4 MBytes  54.0 Mbits/sec                  sender
[ 10]   0.00-10.00  sec  64.4 MBytes  54.0 Mbits/sec                  receiver
[ 12]   0.00-10.00  sec  62.4 MBytes  52.3 Mbits/sec                  sender
[ 12]   0.00-10.00  sec  62.4 MBytes  52.3 Mbits/sec                  receiver
[SUM]   0.00-10.00  sec   324 MBytes   271 Mbits/sec                  sender
[SUM]   0.00-10.00  sec   324 MBytes   271 Mbits/sec                  receiver

iperf Done.
OK, iPerf is een goede versie. -P 5 maakt inderdaad wat uit, maar je probleem zit overduidelijk niet in iPerf. 271Mbps vind ik overigens ook opvallend laag bij 650Mbps link rate. Je verwacht ongeveer 2/3 van de bruto link rate aan nettocapaciteit te houden, dus ik zou hier meer dan 400Mbps netto verwachten - tenzij er andere apparaten in hetzelfde kanaal bezig zijn.

Even een check: ik heb ook een T9UH verbonden met een 3x3 MIMO AP. Ik ga eens uitlezen wat ik daar zie...

Soittakaa Paranoid!


Acties:
  • +1Henk 'm!

  • dion_b
  • Registratie: september 2000
  • Laatst online: 15:14

dion_b

Moderator Harde Waren

say Baah

Razor_ schreef op vrijdag 19 juni 2020 @ 14:33:
Bedankt voor alle duidelijke info! Kwam er net achter dat er toch nog een Ziggo AP op 108 zit. Helaas is de channel keuze Auto 100~112. Ik heb even refreshed en zit nu weer solo op kanaal 100. Weer getest, maar lijkt niet echt veel uit te maken in de iPerf results.
Probleem met tools die kijken naar andere netwerken is dat ze twee erg belangrijke zaken niet kunnen waarnemen:
- hoe druk een netwerk is
- hoeveel non-WiFi ruis er op een kanaal is.

Drukte is erg relevant. Het gaat om airtime (hoe lang de zendtijd in een kanaal bezet is). Een netwerk in 5GHz waar geen verkeer overheen gaat zal zelfs met slechtste instellingen 0.5% van zendtijd in beslag nemen, dus je houdt 99.5% van capaciteit. Moge duidelijk zijn dat je daar weinig last van gaat hebben, ongeacht signaalsterkte. Ruis in het kanaal staat los van WiFi en levert een lagere SNR op, wat weer een lagere link rate oplevert.

Als ik zie dat je maar 650Mbps haalt bij -54dBm denk ik dat er flink wat (non-WiFi) ruis aanwezig is. Ik heb ondertussen de mijne uitgelezen en ik zit op -57dBm (3dB slechter dan bij jou) en haal volle 1300Mbps (max link rate WiFi-ac in drie streams tegelijk).
Je verneemt wel dat de TP Link antenne plaat vrij gevoelig is. Ik zit nu op 94% strength, als ik hem maar iets wegbeweeg van de directe richting van de router is er direct een drop naar 84%.
Ja, dat is by design, het is een redelijk high-gain antenne om maximale ontvangst te hebben als het goed georienteerd is. Keerzijde is slechter ontvangst bij slechte orientatie. Goed dat je dit geprobeerd hebt, je weet nu dat je het optimaal hebt staan.
Er lijkt verder ook niet echt iets te zijn wat serieuze obstructie geeft tussen het pad van de TP Link en de router (zit een klein muurtje tussen), maar signaal is wel sterk. Verder staat de TP Link een halve meter hoger dan het bureau (op de mini ATX kast) en er staat een PS4, nog een MacBook Pro en kleine waaier in de buurt. En heb nog een bluetooth koptelefoon. Heb net al die apparaten ver uit de buurt gehaald van de TP Link en nogmaals getest maar geen merkbaar verschil t.o.v. de voorgaande test-results.
Macbook Pro... welk jaar? En wat haal je daarmee? De 2015-2017 MBP's hebben dezelfde BCM4360 als in de Experiabox v10 en hebben ook erg goede antennes. Dat is echt best-case scenario. Ben benieuwd welke link rate je haalt pal naast de T9UH.

In ieder geval is demping/te weinig signaal het probleem niet -54dBm is gewoon goed, alles boven de -65dBm is hoe dan ook uitstekend te noemen en daar zit je 11dB boven. Het is ofwel ruis in de lucht danwel ruis in de signaalverwerking van dat ding.

Soittakaa Paranoid!


Acties:
  • +1Henk 'm!

  • dion_b
  • Registratie: september 2000
  • Laatst online: 15:14

dion_b

Moderator Harde Waren

say Baah

Razor_ schreef op vrijdag 19 juni 2020 @ 15:02:
Ik woon aan de rand van een dorp, dus het is niet echt heel druk qua WiFi's. In de lijst staan een keer een stuk of 12, waarvan de meeste nog 2,4GHz zijn.
Wederom, dat zegt weinig over WiFi-drukte en helemaal niets over ruis. Ik heb acceptabele WiFi gehad in 2.4GHz op een locatie met 60 (!) netwerken in de 2.4GHz, en ik ken locaties met geen enkele detecteerbare netwerk waar WiFi op geen enkel kanaal werkt door non-WiFi interferentie.
De MacBook Pro is een Mid 2015 15". Ik gebruik de Thunderbolt ethernet (is gigabit en werkt zeker, want heb P2P met de Windows computer connected en daar is de iperf 940Mbit~1,10Gbit). De MacBook geld voor de test alleen als de iperf server.
Snap ik, maar het is ook een goede reference. Beter dan dat ga je het namelijk niet krijgen, en omdat chipset identiek is kun je compatibility uitsluiten/
De T9UH letterlijk naast de router zetten ga ik morgenvroeg even testen. Kom ik op terug!

Ik gebruik niet TP's eigen driver (laatste 2018-11-09). Is dat nog een potential gain?
Valt te proberen, maar als ik hieronder lees dat de MacBook ook lage link rates haalt, denk ik niet dat het probleem aan clientzijde zit.
In de netwerk adapter heb ik deze status:

Aangepast
Beamcap: van BEAMDisable naar VHT BEAM RX
EnableAdaptivity: van Auto naar Disabled
Prefered Band: van 1. No preference naar 3. 5G first
VHT 2.4G: van Enabled naar Disabled
Wireless Mode: van Auto naar 802.11a/n/ac

Niet aangeraakte settings
AdaptivityPara: is 0 (kan 0 of 1 zijn)
High Adhoc Mode: is Disable (kan Disable of Enable zijn)
HLDiffForAdaptivity: is 7 (kan 7 of 9 zijn)
L2HForAdaptivty: is Auto (kan E8, EB, ED, EF, F1, F3, F5 zijn)
LdpcCap: is VHT LDPC TX | HT LDPC TX (veel andere opties)
QoS Support: is Support QoS (kan Auto en Not support QoS zijn)
StbcCap: is VHT STBC TX|RX & HT (veel andere opties)
USB SF Mode: is Disable (kan Enable en Disable zijn)
USB Switch Mode: is Auto (kan USB Mode 1, 2, 3 zijn)

Helaas geven de aangepaste settings tot zover nog geen improvements op de iperf tests. Rare situatie dit :D
Klinkt allemaal goed, maar wederom, denk niet dat je het probleem daar moet zoeken.

Soittakaa Paranoid!


Acties:
  • +1Henk 'm!

  • dion_b
  • Registratie: september 2000
  • Laatst online: 15:14

dion_b

Moderator Harde Waren

say Baah

Razor_ schreef op vrijdag 19 juni 2020 @ 15:14:
Oh ja; zou nog een test met MacBook Pro doen.

Ik heb op de Raspberry Pi 3B+ iperf server aangezet (zit met 1 meter Cat5e kabel direct in de router). Dan krijg ik vanaf de MacBook met -P 5 maar 94,1MBit/s. Meerdere keren geprobeerd met laptop letterlijk boven/naast de router. En ook 1,2,3,4 meter er van af. Steeds hetzelfde resultaat. Met alt+klik op WiFi icon en heb dan deze info op de MacBook:

code:
1
2
3
4
5
6
7
8
9
Beveiliging: WPA2 - persoonlijk
Kanaal 100 (DFS, 5 GHz, 80MHz)
Landcode: BE
RSSI: -34dBm
Ruis: -94 dBm
Tx-snelheid: 176Mbps (super raar..)
PHY-modus: 802.11ac
MCS-index: 2
NSS: 2


Ligt het dan misschien toch aan de router? Heb helaas geen andere router o.i.d. bij de hand om verschil te testen.
Raspberry Pis staan niet bekend om hun hoge netwerkperformance, zou dus alle iPerf daarheen met korrel zout nemen. Deze waardes zijn echter opvallend: -34dBm is werkelijk perfecte signaalsterkte. Als daar vervolges maar 176Mbps link rate gehaald wordt, is er iets aan de hand. Implicatie is forse ruis, dat ofwel in de lucht danwel in de signaalverwerking zit. Het zit alvast niet in de MacBook, want de T9UH heeft er ook last van.

Soittakaa Paranoid!


Acties:
  • +1Henk 'm!

  • dion_b
  • Registratie: september 2000
  • Laatst online: 15:14

dion_b

Moderator Harde Waren

say Baah

Razor_ schreef op vrijdag 19 juni 2020 @ 15:32:
Zie nu ineens op de TP Link 96% en 780Mbps (niets aangepast, maar heb het idee dat de settings changes even geduurd hebben met doorvoeren).
Razor_ schreef op vrijdag 19 juni 2020 @ 15:46:
Het wordt steeds gekker. Nu heb ik de 2018 MacBook Pro (van 't werk geprobeerd). Als ik een tijdje bij de router in de buurt sta zie ik een schommeling tussen 866 en 1033 Mbps. Dat lijkt al veel beter dan de 2015 MacBook Pro. Enige verschil in de stats is Landcode: DE (ipv BE) en MCS-index: 9 (ipv 2). En toch is de iperf test weer maar 94~125Mbit's.. Zo raar dit. De router heb ik een week of 2 geleden nog ge-reset (voor de eerste keer in 1,5 jaar ofzo, dus ik verwacht ook geen oud zeer van lang draaien o.i.d.).
Doordat meerdere clients impacted zijn ligt het ofwel aan de AP, danwel aan iets in de lucht. Vuistregel is dat slechte hardware constant slecht is, terwijl zooi in de lucht continu verandert. Wat je hier beschrijft lijkt verdacht op een probleem dat allerminst constant is. Ik denk dat er forse verstoring is in de 5GHz-band van non-WiFi bronnen.

Soittakaa Paranoid!


Acties:
  • Beste antwoord
  • +1Henk 'm!

  • dion_b
  • Registratie: september 2000
  • Laatst online: 15:14

dion_b

Moderator Harde Waren

say Baah

Razor_ schreef op vrijdag 19 juni 2020 @ 16:11:
Er staat letterlijk een oude Philips DECT huistelefoon en de Ambilight TV vrij dicht naast de router. Kan dit een oorzaak zijn?
DECT wordt in de VS vaak genoemd omdat het daar in de 2.4GHz-band werkt, maar in EU zit het rond 1900MHz en zou niets moeten verstoren in WiFi, al helemaal niet in 5GHz-band.

TV... lijkt me niet. Maar het is eenvoudig uit te sluiten: maak de verdachte apparaten spanningsloos en kijk wat er gebeurt...

Overigens (gezien TV in de buurt): de Experiabox staat toch niet op een luidsprekerbox toevallig?
En anders is het mss een idee om zo'n radio-scanner te kopen/huren? Wat voor frequenties zou je dan moeten scannen/testen?
Kan. Je hebt een spectrum analyzer nodig die tussen 5GHz en 5.7GHz kan werken. Goedkoopste die ik ken kost ~ EUR 300. Als je (semi-)professioneel met WiFi aan de slag wilt een goede investering, zo niet allicht aan de prijs.

Voordat je ook maar iets uitgeeft: wat is je probleem eigenlijk? 146Mbps is meer dan voldoende voor iedere normale consumptieve toepassing. Gaat dit echt alleen om getalletje of werken dingen niet die je zou willen doen?

Soittakaa Paranoid!

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True