Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

VPN via L2TP/IPSec geeft een foutmelding

Pagina: 1
Acties:

Vraag


Acties:
  • 0Henk 'm!

  • Cryothic
  • Registratie: september 2001
  • Laatst online: 23-06 23:00
Ik heb momenteel mijn werk-pc thuis staan, en er zijn wat dingen binnen ons bedrijfsnetwerk veranderd dus er moest een nieuwe VPN verbinding ingevoerd worden.

Ik kreeg het in eerste instantie aan de praat op m'n werk-pc, maar niet op m'n prive-pc (staan fysiek naast elkaar, ik plug de UTP kabel gewoon om). Dus op dat moment kon het nog aan van alles liggen. Maar nadat ik de verbinding op m'n werk-pc ge-disabled/enabled heb, werkt het daar ook niet meer op, dus nu kan ik opeens een aantal dingen uitsluiten.

De situatie is als volgt:
Windows 10 machine, build 1909.
Ik maak verbinding met de VPN via L2TP/IPSec met een PreSharedKey.
Als ik die verbinding probeer te maken krijg ik na een tijdje de melding:



Na wat googlen kom je vooral fora tegen waar ze een regedit als oplossing aanbieden. En die heb ik ook allemaal wel geprobeerd, maar zonder succes.

Het vreemde is nu:
Als ik mijn werk-pc aan de WIFI hang kan ik verbinden met de VPN.
Als ik mijn werk-pc aan de UTP hang kan ik niet verbinden met de VPN en krijg ik dus bovenstaande melding.

Ik heb een ziggo modem, en nog nooit iets met poorten ofzo aangepast. De UTP gaat van de pc direct het modem in (dus zonder extra router ertussen). Een collega van mij heeft KPN, en kan ook niet verbinden. Maar in zijn geval lukt het niet met WIFI.

Zowel zijn, als mijn telefoon kunnen verbinding maken met de VPN over zowel WIFI als 4G. En zijn laptop kan de telefoon als hotspot gebruiken en dan heeft ie wel een VPN verbinding.

Het feit dat ik wel via WIFI maar niet via UTP kan verbinden lijkt mij aan te geven dat dingen als windows versie, updates, firewall, modem of eventueel het register in windows niet de oorzaak zijn.

Maar wat kan het nog wel zijn? Ik raak een beetje door m'n opties heen op dit moment. Ik doe m'n werk, maar de wifi op zolder (waar m'n pc staat) is niet echt denderend :P

Alle reacties


Acties:
  • 0Henk 'm!

  • Cryothic
  • Registratie: september 2001
  • Laatst online: 23-06 23:00
lier schreef op maandag 8 juni 2020 @ 15:26:
Kan je een ipconfig /all posten als je via kabel en als je via WiFi verbonden bent?
Dat kan ik wel even doen.
Is het via Wifi belangrijk dat ik dan ook de VPN aan heb staan?

Acties:
  • 0Henk 'm!

  • Cryothic
  • Registratie: september 2001
  • Laatst online: 23-06 23:00
Verbonden via Wifi (zonder VPN dus)
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
Windows IP Configuration

   Host Name . . . . . . . . . . . . : ******
   Primary Dns Suffix  . . . . . . . : ******.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ******.local

Wireless LAN adapter Local Area Connection* 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
   Physical Address. . . . . . . . . : 16-29-AF-40-59-83
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 5:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #3
   Physical Address. . . . . . . . . : 26-29-AF-40-59-83
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Dell Wireless 1705 802.11b/g/n (2.4GHZ)
   Physical Address. . . . . . . . . : 74-29-AF-40-59-83
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::38a0:bd85:8018:bdbd%9(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.178.44(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : maandag 8 juni 2020 13:00:28
   Lease Expires . . . . . . . . . . : donderdag 18 juni 2020 15:35:35
   Default Gateway . . . . . . . . . : 192.168.178.1
   DHCP Server . . . . . . . . . . . : 192.168.178.1
   DHCPv6 IAID . . . . . . . . . . . : 57944495
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-3C-BB-F5-B0-83-FE-73-AC-01
   DNS Servers . . . . . . . . . . . : 62.179.104.196
                                       213.46.228.196
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter vEthernet (Default Switch):

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter
   Physical Address. . . . . . . . . : 00-15-5D-CA-D9-42
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a8ad:640b:8557:abb1%26(Preferred)
   IPv4 Address. . . . . . . . . . . : 172.17.172.17(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.240
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 436213085
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-3C-BB-F5-B0-83-FE-73-AC-01
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled


Via UTP
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
Windows IP Configuration

   Host Name . . . . . . . . . . . . : ******
   Primary Dns Suffix  . . . . . . . : ******.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ******.local

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : B0-83-FE-73-AC-01
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : fd41:b0e9:4006:1:9052:9b18:d9fa:cee4(Preferred)
   Temporary IPv6 Address. . . . . . : fd41:b0e9:4006:1:7069:b67e:ac87:6462(Preferred)
   Link-local IPv6 Address . . . . . : fe80::9052:9b18:d9fa:cee4%13(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.178.43(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : maandag 8 juni 2020 15:41:35
   Lease Expires . . . . . . . . . . : donderdag 18 juni 2020 15:41:35
   Default Gateway . . . . . . . . . : 192.168.178.1
   DHCP Server . . . . . . . . . . . : 192.168.178.1
   DHCPv6 IAID . . . . . . . . . . . : 162563070
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-3C-BB-F5-B0-83-FE-73-AC-01
   DNS Servers . . . . . . . . . . . : 62.179.104.196
                                       213.46.228.196
   NetBIOS over Tcpip. . . . . . . . : Disabled

Ethernet adapter vEthernet (Default Switch):

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter
   Physical Address. . . . . . . . . : 00-15-5D-CA-D9-42
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a8ad:640b:8557:abb1%26(Preferred)
   IPv4 Address. . . . . . . . . . . : 172.17.172.17(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.240
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 436213085
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-3C-BB-F5-B0-83-FE-73-AC-01
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled


Overigens weet ik niet hoe ik die HyperV adapter weg krijg, maar als ik die disable, werkt het ook niet.
Al valt het me wel op dat als ik "Ethernet" enable, die HyperV adapter ook opeens "aan gaat" zeg maar.

Acties:
  • 0Henk 'm!

  • Cryothic
  • Registratie: september 2001
  • Laatst online: 23-06 23:00
Het adres zelf niet. Alle instellingen voor ipv6 staan op automatic.
Wat is precies het rare? Dat procentje bij link-local?

Acties:
  • 0Henk 'm!

  • Cryothic
  • Registratie: september 2001
  • Laatst online: 23-06 23:00
Brahiewahiewa schreef op maandag 8 juni 2020 @ 15:56:
Heb je zelf een idee hoe je aan dat ipv6 fd41:b0e9:4006:1:9052:9b18:d9fa:cee4 adres komt? Ziet er een beetje raar uit
Ik zou ook niet weten waar ik ipv6 voor gebruik, dus ik heb op m'n ethernet verbinding de ipv6-connection uitgevinkt. En nu werkt ie dus wel.

Acties:
  • 0Henk 'm!

  • Cryothic
  • Registratie: september 2001
  • Laatst online: 23-06 23:00
Brahiewahiewa schreef op dinsdag 9 juni 2020 @ 05:31:
[...]

Het rare is dat het met fd41 begint; als je van je isp een adres krijgt, begint het meestal met iets tussen de 2000 en 3000
Maar mooi dat het opgelost is
Geen idee wat dat rare ip-adres veroorzaakt dan. Ik gok HyperV? Ik zal eens kijken of m'n prive-pc ook zo'n raar adres krijgt.
Want die HyperV adapter is nu de enige op m'n werk-pc met IPv6 nog aan, en die heeft nog wel zo'n adres. (ooit iets met VM gedaan geloof ik, toen het nog een windows8 machine was. En ze stonden er op Win8 te upgraden naar Win10 ipv schone installatie. Daardoor waren er verbindingen ge-bridged en kon ik in eerste instantie uberhaubt geen enkele netwerkverbinding maken).

Door die IPv6 uit te zetten werkte het op m'n werk-pc en op m'n prive-pc.

Ik graptte gisteren nog tegen een collega dat ik eerst eens even moest zien dat het de volgende dag nog steeds werkt. Log m'n prive-pc uit (dacht dat m'n zoontje 's avonds nog wilde gamen), en voor ik naar bed ging logde ik nog even in, en wat denk je? Werkt het opeens niet meer.

Wat is dat nou voor onzin? :(

Acties:
  • 0Henk 'm!

  • Cryothic
  • Registratie: september 2001
  • Laatst online: 23-06 23:00
Dr Pro schreef op dinsdag 9 juni 2020 @ 08:19:
Probeer dit eens:

Set-NetIPInterface -InterfaceAlias "NAAM_ETHERNETPOORT" -InterfaceMetric 45

45 kan ook een hoger nummer zijn, als het maar het hoogste is.
Alleen na een reboot ben je de instellingen weer kwijt

Edit;
Bron: eigen ervaring met Windows 10 1909 en kantoor met een Always-On VPN
Helpt niet. Op m'n prive-pc is "Ethernet" sowieso de enige adapter.

De huidige situatie is dat ik dus gisteren na het uitzetten van IPv6 op m'n werk-pc op de VPN kon.
Eind van de middag werk-pc uit, UTP in prive-pc (die al aan stond), en toen werkte de VPN.
Prima, etenstijd, ik log uit.
Voor ik naar bed ga log ik nog even in, VPN doet het niet meer.

Vandaag: hele dag op m'n werk-pc gewerkt via de VPN.
Eind van de middag, ik sluit m'n werk-pc af, plug de UTP weer om (prive-pc stond wederom aan voor ik de UTP er in deed), en ik heb binnen no-time een VPN verbinding.
Ik log uit, ga eten.
Na het eten kom ik terug, log m'n prive-pc weer in en weer is er geen VPN verbinding te krijgen.

Het lijkt bijna alsof de server mijn prive-pc "accepteerd" als ik snel de kabel wissel, maar als ik wat langer uitgelogd ben dan reageert ie niet meer (aldus de melding "remote server not responding")

  • Cryothic
  • Registratie: september 2001
  • Laatst online: 23-06 23:00
Rensjuh schreef op woensdag 10 juni 2020 @ 09:12:
Controleer dat dan ook als de verbinding het doet, maar ook als hij het niet doet.
Dan weet je wat het moet zijn (als het werkt) en wat het is als het niet werkt.
Misschien zit daar een verschil in.

Of verbind je direct naar een IP?
Dan gaat dit verhaal niet op...
Nee, via de domeinnaam.

Ik ga eens even inventariseren.

edit:
Uitgerekend nu wil m'n prive-pc dus ook niet verbinden met de VPN nadat m'n werk-pc verbonden is. Dus dat is ook weer even geen garantie.

Als ik NSLookup doe op beide machines, komt er bij beide hetzelfde uit.
Zelfde lokale ip adres van ns01.upclive.nl, en hetzelfde ip adres van de VPN server.

Als ik tracert -d doe, is die ook identiek op beide machines.
Al vind ik het apart dat ie bij stap 14 het ip adres al heeft van de VPN server, en daarna gewoon door blijft gaan tot stap 30 met timeouts. Maar dat is misschien die -d flag?

edit 2:
Als ik na een dag werken op de werk-pc dus snel switch naar de prive pc wil die wel de verbinding opzetten, maar ik kan geen enkele server op het netwerk pingen, dus om nou te zeggen dat ik echt een VPN verbinding heb... nee.

[Voor 48% gewijzigd door Cryothic op 12-06-2020 20:15]

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True