Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie

Vraag


Acties:
  • +1Henk 'm!

  • ZFLaSH
  • Registratie: februari 2000
  • Laatst online: 14:43
Sinds 2 dagen heb ik T-mobile met een Zyxel modem / router, maar daar ben ik niet van gecharmeerd. Ik wil graag mijn eigen pfSense setup met mesh WiFi netwerk blijven gebruiken. Nu ben ik er van overtuigd dat dit geen enkel issue moet zijn aangezien er legio mensen zijn die dit al draaiende hebben, alleen krijg ik er grijze haren van (en zoveel heb ik er al niet meer).

Wat is het issue?

T-Mobile heeft het onderverdeeld in 3 VLAN's:

- 300 Internet (Die had ik binnen 3 minuten draaien)
- 640 IPTV (Het issue)
- 35 (?) VOIP (Ga ik niet gebruiken).

Aangezien ik redelijke ervaring in pfSense heb, dacht ik dat dit wel vrij snel zou werken maar ik loop tegen het issue aan dat ik de IPTV gewoonweg niet aan de praat krijg. Het onderstaande is wat ik tot nu toe heb ingesteld:

Ik heb 4 VLAN's gemaakt:



en deze koppel ik aan de betreffende interfaces:



Vervolgens maak ik een bridge van de WAN en de LAN 640 IPTV VLAN's



Daarna maak ik firewall rules aan om mijn IPTV verkeer te blokkeren richting mijn LAN en om het multicast verkeer toe te staan:

https://tweakers.net/ext/f/naD609riXquEwxojODM0FGJR/full.png

Verder heb ik op de Netgear GS108E een VLAN config aangemaakt voor VLAN 640 (op poort 2 hangt de Amino):



Overige settings:

Om alleen te filteren op de bridge interface:
- net.link.bridge.pfil_member=0
- net.link.bridge.pfil_bridge=1

- MTU van de bridge staat op 1594
- IGMP Snooping staat uit op de 108E

Symptomen

Het Amino TV kastje van TMobile lijkt gewoon totaal niet te kunnen communiceren met de server. Het beeld blijft na doorstarten zwart en geeft geen enkel beeld meer. Hang ik deze aan de Zyxel, dan werkt het gewoon dus het apparaat zelf is prima.

Wie heeft er enig idee waar ik dit in moet zoeken of heeft hier ervaring mee?

EDIT: De oplossing staat hieronder. Sinds we de Zyxel hebben moet de VLAN640 poort naar de Amino box UNTAGGED ipv TAGGED zijn. Dat is dus het grote verschil met de Huawei setup en waarom het in eerste instantie niet werkte. Hier zijn we achter gekomen dankzij @htn02 die hieronder de uitleg geeft.

[Voor 6% gewijzigd door ZFLaSH op 06-06-2019 09:15]

Beste antwoord (via ZFLaSH op 05-06-2019 20:20)


  • htn02
  • Registratie: december 2004
  • Nu online
alleen poort 2, poort 8 staat hij al goed

jou pfsense stuurt je IPTV verkeer uit met een speciale tag, die verteld dat het vlan 640 is. door op je switch die poort in dat vlan te taggen (de T dus) accepteerd jou switch dat vlan.

jou IPTV snapt dat allemaal niet.door poort 2 op untagged (de U dus) te zetten, zet jij het verkeer plat door, zonder speciale tag die verteld dat het een vlan is.

[Voor 81% gewijzigd door htn02 op 05-06-2019 20:17]

Alle reacties


Acties:
  • +1Henk 'm!

  • Seaborz
  • Registratie: mei 2005
  • Laatst online: 16:34
ZFLaSH schreef op woensdag 5 juni 2019 @ 18:39:
[...]


PVID heb ik ook op 640 voor poort 2. Het is de enige poort die in VLAN 640 hangt.
Hoe ziet de uplink naar je firewall er dan uit? Is dat een trunk? Anders moet je daar ook vlan 640 taggen.

Acties:
  • +1Henk 'm!

  • htn02
  • Registratie: december 2004
  • Nu online
ZFLaSH schreef op woensdag 5 juni 2019 @ 19:04:
[...]


Klopt. Dat is de pfSense firewall.

Ik heb net wat testjes gedaan:

- DHCP op de WAN_640 interface: IP van het IPTV segment
- DHCP op de Bridge: Ook een IPTV IP.
- Mac aan de Poort 2 van de switch. Geen IP.

Edit: vlan 1 weghaald poort 2.
en als je direct op de pfsense aansluit, en vlan 640 tagged op je laptop?

dan weten we of we het in de switch of de router moeten zoeken

https://www.aquantia.com/...-adapter-card-in-windows/

(niet vergeten er weer af te halen na afloop!)

Acties:
  • +1Henk 'm!

  • htn02
  • Registratie: december 2004
  • Nu online
ZFLaSH schreef op woensdag 5 juni 2019 @ 19:21:
[...]


Geniaal idee! Daar kreeg ik meteen op het VLAN een IPTV IP terug. Het zit dus in de switch, alleen wat moet ik dan daarin veranderen is de vraag.

Edit: Kabel in de switch, switch aan de laptop en het VLAN dat ik op de mac heb ingesteld krijgt ook gewoon IPTV IP. Hangt de TV box eraan: Geen beeld.
Kan je ergens in de switch een native vlan instellen voor de poort? als dat kan moet die ook op 640 komen te staan.

op dit moment geeft jou switch dus vlan 640 "tagged" door, maar hij moet dat "untagged" doen. helaas werk ik nooit met netgear, dus weet ik niet uit mijn hoofd hoe je dat instelt


EDIT: ik roep dit wel heel leuk, maar maak een kleine denkfout: kan je, als je de zyxel gebruikt, de IP tv in elke lan poort stoppen, of alleen in 1 specifieke?

[Voor 10% gewijzigd door htn02 op 05-06-2019 19:45]


Acties:
  • +1Henk 'm!

  • htn02
  • Registratie: december 2004
  • Nu online
ZFLaSH schreef op woensdag 5 juni 2019 @ 19:54:
[...]


Nou je het zegt. In 2 specifieke. Zouden ze daar iets mee gedaan hebben, want ik ben blijkbaar 1 van de eerste op het TMobile netwerk met deze router.
ja, uit die 2 poorten komt dus untagged het vlan 640. maak ik gelukkig geen denkfout :-)

staat er nog ergens in de switch iets over untagged of native vlan's?

Acties:
  • +1Henk 'm!

  • htn02
  • Registratie: december 2004
  • Nu online
onder vlan memberhip moet die T een U zijn. (bij poort 2)

die U is dus Untag(ged)

[Voor 32% gewijzigd door htn02 op 05-06-2019 20:13]


Acties:
  • Beste antwoord
  • +1Henk 'm!

  • htn02
  • Registratie: december 2004
  • Nu online
alleen poort 2, poort 8 staat hij al goed

jou pfsense stuurt je IPTV verkeer uit met een speciale tag, die verteld dat het vlan 640 is. door op je switch die poort in dat vlan te taggen (de T dus) accepteerd jou switch dat vlan.

jou IPTV snapt dat allemaal niet.door poort 2 op untagged (de U dus) te zetten, zet jij het verkeer plat door, zonder speciale tag die verteld dat het een vlan is.

[Voor 81% gewijzigd door htn02 op 05-06-2019 20:17]


Acties:
  • +1Henk 'm!

  • htn02
  • Registratie: december 2004
  • Nu online
Ik drink helaas geen bier, maar graag gedaan hoor :-) een leuke puzzel voor de woensdagavond!
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True