Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

[Ubiquiti & IPTV] Ervaringen & Discussie

Pagina: 1 2 3
Acties:

Onderwerpen


Acties:
  • +1Henk 'm!

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
xbeam schreef op zaterdag 4 januari 2020 @ 23:20:
[...]


Ik heb je link toegevoegd aan de start post.
Dank je wel! Ik het begin heb ik vooral de technische details gedeeld maar ik heb gemerkt dat "jong en oud" hier mee aan de slag gaat en soms ook behoefte heeft aan een wat meer uitgewerkt verhaal.
ppeterr schreef op zaterdag 4 januari 2020 @ 15:32:
[...]


Ik zie dat je het gereed hebt, mijn complimenten. _/-\o_

Zeer duidelijk en goed overzichtelijk. Ik zal binnenkort het eens aandachtig doornemen, en kijken of ik ergens punten zie waar ik tegen aanliep.

Ik heb wel gelijk 3 vragen, die mij opvallen die ik zelf wellicht fout deed. Misschien vind je het de moeite om toe te voegen. Of een soort faq te maken nog.

Waarom is jouw config goed voor de verschillende usg versies, en zijn er hier geen aanpassingen nodig voor in de Json ?

En, als je inlogt als admin op de usg en je bestanden gaat plaatsen in een "root" direcotory. Gaat dat dan wel met dat admin account via winscp ?

En klopt het dat de "default" site directory er niet staat als het nog nooit eerder is uitgevoerd. Ik moest de directory eerst aanmaken. (waarschijnlijk gewoon verkeerde dir)
Bedankt voor je compliment en nuttige vragen!
  • Mijn config is alleen geschikt voor de USG3 en niet USG4 Pro, ik heb dit aangepast in de handleiding :)
  • Met WinSCP en het admin account plaats je de bestanden in /config/scripts/postconfig.d/ welke beschrijfbaar is voor het admin account
  • Wanneer de map niet aanwezig is moet je deze aanmaken (zoals wij dat hebben gedaan); ik heb dat in de handleiding erbij vermeld
Volgende stap is om de troubleshooting en additionele info van dit forum ook naar de github page te kopiëren om alle informatie centraal te houden.

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Coolhva schreef op zondag 5 januari 2020 @ 21:13:
[...]


Dank je wel! Ik het begin heb ik vooral de technische details gedeeld maar ik heb gemerkt dat "jong en oud" hier mee aan de slag gaat en soms ook behoefte heeft aan een wat meer uitgewerkt verhaal.


[...]


Bedankt voor je compliment en nuttige vragen!
  • Mijn config is alleen geschikt voor de USG3 en niet USG4 Pro, ik heb dit aangepast in de handleiding :)
  • Met WinSCP en het admin account plaats je de bestanden in /config/scripts/postconfig.d/ welke beschrijfbaar is voor het admin account
  • Wanneer de map niet aanwezig is moet je deze aanmaken (zoals wij dat hebben gedaan); ik heb dat in de handleiding erbij vermeld
Volgende stap is om de troubleshooting en additionele info van dit forum ook naar de github page te kopiëren om alle informatie centraal te houden.
Als je het centraal wil houden mag je het ook in de start post uitwerken. Nu krijgen we 2 plekken met info. We zijn juist dit iptv topic begonnen Te Specialiseren en info te bundelen van alle providers. Zo dat het er in het grote ubnt topic niet steeds de zelfde vragen voor iptv komen.
Herman en ik kunnendoor tijd gebrek wel een 3e redacteur gebruiken :-)

xbeam wijzigde deze reactie 05-01-2020 21:34 (11%)


  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
djrednas schreef op maandag 6 januari 2020 @ 08:00:
[...]


Ik netjes de start post doorzoeken en google gebruiken, staat het ergens in het forum verstopt 8)7

Wellicht een goede om dit ook vast te zetten of in de start post op te nemen? :)
Ga het vanmiddag testen, ik laat het weten! :P
Dit is voor mij ook nieuw, ik kwam Hier dus vorrige week ook pas achter.

zal het van de week eens toevoegen

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Coolhva schreef op zondag 5 januari 2020 @ 21:13:
[...]


Dank je wel! Ik het begin heb ik vooral de technische details gedeeld maar ik heb gemerkt dat "jong en oud" hier mee aan de slag gaat en soms ook behoefte heeft aan een wat meer uitgewerkt verhaal.


[...]


Bedankt voor je compliment en nuttige vragen!
  • Mijn config is alleen geschikt voor de USG3 en niet USG4 Pro, ik heb dit aangepast in de handleiding :)
  • Met WinSCP en het admin account plaats je de bestanden in /config/scripts/postconfig.d/ welke beschrijfbaar is voor het admin account
  • Wanneer de map niet aanwezig is moet je deze aanmaken (zoals wij dat hebben gedaan); ik heb dat in de handleiding erbij vermeld
Volgende stap is om de troubleshooting en additionele info van dit forum ook naar de github page te kopiëren om alle informatie centraal te houden.
Als het goed is kan je nu de start post aanpassen.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
djrednas schreef op maandag 6 januari 2020 @ 21:08:
[...]


Zojuist geprobeerd en ruim een uur gewacht. Zelfs de settings laten bijwerken door de experiabox op de NTU aan te sluiten, te bellen, en daarna om te steken.
Hij haalt geen IP op via DHCP oid.
Ook is dit niet hard in te stellen op de experiabox.

Doe ik iets fout? moet ik hem factory resetten voor dit werkt? |:(
Volgens mij doe je niets fout en is telefonie van KPN nog steeds via VLAN7 (en niet direct via het internet). Omdat de NTU in het beheer is van KPN kunnen ze kwaliteit en voorrang (QOS) garanderen voor telefonie verkeer via een apart VLAN. Dit kan niet indien ze dat via het internet doen aangezien de klant een andere router er voor kan zetten.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
nero355 schreef op zaterdag 4 januari 2020 @ 14:35:
[...]

Als je de Search bovenaan gebruikt kom je twee dingen te weten :
- VoIP gebruikt regulier Internet tegenwoordig.
- De Experiabox kan je als een ATA kastje gebruiken, doordat je hem gewoon als Client van je normale netwerk aansluit! :)

Succes alvast! :w
Heb jij ergens documentatie / informatie over dat de Experiabox als netwerk client kan fungeren voor telefonie? Volgens mij is dat namelijk nog steeds alleen mogelijk via VLAN 7 aan de WAN kant.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
nero355 schreef op dinsdag 7 januari 2020 @ 17:32:
[...]

Zou zweren dat het gewoon zo in dit Topic stond :
- Hang de Experiabox een keer direkt aan je glasvezel, zodat die de Config ophaalt.
- Hang de Experiabox daarna gewoon aan je eigen LAN en dan kan je deze als ATA kastje gebruiken.

Je zou eens het Topic kunnen doorzoeken met de Search bovenaan :)


[...]

Zo zou er ook ergens in dit Topic moeten staan hoe je sub-interfaces met elkaar bridged en daarmee om de NAT Offload beperkingen heen werkt! :)

Er is trouwens ook nog kans dat we binnenkort van deze ellende af zijn : St00mwals in "Vrije router keuze - hulp van je provider obv besluit ACM" d:)b :*)


Ik heb zelf geen KPN PPPoE Glasvezel en volg dit Topic eigenlijk alleen maar vanwege de Ubiquiti hardware en de valse hoop om ooit nog eens weer lekker van een KPN verbinding te mogen genieten, maar dan via Glasvezel i.p.v. xDSL ;)
Ik kan zoeken maar dan is de vraag of de resultaten ook daadwerkelijk kloppen. In dit geval dien je dus nog steeds VLAN 7 tagged door te zetten naar de WAN poort van de experiabox; ofwel via een "software bridge" op de USG (niet aan te raden), of via een managed switch waarbij je de NTU aan de switch hangt met VLAN 4,6 en 7 tagged, de USG met vlan 4 en 6 tagged en de experiabox met VLAN 7 tagged. Hierna kan je je telefoon aan de experiabox hangen en werkt je telefonie.

Al ben ik het met je eens, en heb ik de hoop, dat we straks de gegevens krijgen en zelf kunnen bepalen hoe we SIP telefonie in ons eigen netwerk implementeren.

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Coolhva schreef op dinsdag 7 januari 2020 @ 13:04:
[...]


Volgens mij doe je niets fout en is telefonie van KPN nog steeds via VLAN7 (en niet direct via het internet). Omdat de NTU in het beheer is van KPN kunnen ze kwaliteit en voorrang (QOS) garanderen voor telefonie verkeer via een apart VLAN. Dit kan niet indien ze dat via het internet doen aangezien de klant een andere router er voor kan zetten.
Ja wat is het nu? Is het nu wel vlan7 of gaat voip over pppoe zoals Bij xs4all? Van de kreeg ik me kop 🙈dat ik start post moest aanpassen dat voip over pppoe ging 😂

xbeam wijzigde deze reactie 08-01-2020 06:55 (3%)


  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
c0rneel schreef op dinsdag 14 januari 2020 @ 10:14:
Dus als ik het goed begrijp is hetvolgende mogelijk (met dank aan het plaatje van Hs82H):
[Afbeelding: Vlan IPTV]


Bij schoonmoeder hebben we nu de situatie:
DSL > KPN modem + Router > USG > US 24 Switch > AP's
Daarop zijn een paar VLAN's geconfigureerd voor camera's / gasten / internet. plus een site-to-site vpn
Glasvezel laat nog even op zich wachten dus ik zit nog vast aan de kpn dsl modem / router. Niet heel optimaal.

Maar nu kwam ze met de vraag om ook via utp televisie te gaan kijken. Moet ik die buiten de USG omlussen en op de switch een paar poorten vlan only zetten zonder dhcp? Wat ik hier zo lees zou dat het stabielste moeten werken zonder grote aanpassingen aan de config van de USG.

Maar klopt mijn redenering hierin? Of eindig ik met uren aankloten op locatie? :?
Je redenering klopt. Maak een netwerk aan in de controller (VLAN only, geen DHCP) en configureer minimaal 2 poorten met dit netwerk / VLAN, daar gaat de experiabox en je tv setupbox op.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
xbeam schreef op woensdag 8 januari 2020 @ 01:21:
[...]


Ja wat is het nu? Is het nu wel vlan7 of gaat voip over pppoe zoals Bij xs4all? Van de kreeg ik me kop 🙈dat ik start post moest aanpassen dat voip over pppoe ging 😂
Het is nog steeds VLAN 7 zover ik kan zien. Er is enige spraakverwarring over de experiabox als cliënt in je netwerk, dit moet via VLAN 7.

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
TheGOoSTaD schreef op zaterdag 25 januari 2020 @ 15:21:
Oke, ik ben nu weer bezig om dit aan de praat te krijgen, maar eerlijk gezegd gaat de edgerouter mij echt boven de pet.
Is er een manier om tweak met tv te configureren via de webinterface? Of kan iemand mij uitleggen hoe ik de stukjes code in de router krijg? Want plakken in putty wil niet.
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
configure
 
delete interfaces ethernet eth0 address
 
set interfaces ethernet eth0 description " FTTH"
set interfaces ethernet eth0 duplex auto
set interfaces ethernet eth0 speed auto
set interfaces ethernet eth0 mtu 1512
 
set interfaces ethernet eth0 vif 6 description "Internet"
set interfaces ethernet eth0 vif 6 mtu 1508
set interfaces ethernet eth0 vif 6 pppoe 0  user-id kpn
set interfaces ethernet ethal0 vif 6 pppoe 0 password kpn
set interfaces ethernet eth0 vif 6 pppoe 0 default-route auto
set interfaces ethernet eth0 vif 6 pppoe 0 name-server auto
set interfaces ethernet eth0 vif 6 pppoe 0 idle-timeout 180
set interfaces ethernet eth0 vif 6 pppoe 0 mtu 1500
 
set interfaces ethernet eth0 vif 6 pppoe 0 firewall in name WAN_IN
set interfaces ethernet eth0 vif 6 pppoe 0 firewall local name WAN_LOCAL
 
set system name-server 8.8.8.8
set system name-server 8.8.4.4

set interfaces ethernet eth0 vif 4 address dhcp
set interfaces ethernet eth0 vif 4 description "eth10.4 - IPTV"
set interfaces ethernet eth0 vif 4 dhcp-options client-option "send vendor-class-identifier "IPTV_RG";"
set interfaces ethernet eth0 vif 4 dhcp-options client-option "request subnet-mask, routers, rfc3442-classless-static-routes;"
set interfaces ethernet eth0 vif 4 dhcp-options default-route no-update
set interfaces ethernet eth0 vif 4 dhcp-options default-route-distance 210

set service nat rule 5010 description "Internet"
set service nat rule 5010 log enable
set service nat rule 5010 outbound-interface pppoe0
set service nat rule 5010 protocol all
set service nat rule 5010 source address 192.168.2.0/24
set service nat rule 5010 type masquerade

set service nat rule 5000 description IPTV
set service nat rule 5000 log disable
set service nat rule 5000 outbound-interface eth0.4
set service nat rule 5000 protocol all
set service nat rule 5000 destination address 213.75.112.0/21
set service nat rule 5000 type masquerade
set protocols static route 213.75.112.0/21 next-hop (je next hob router adres) 

set service dhcp-server global-parameters "option vendor-class-identifier code 60 = string;"
set service dhcp-server global-parameters "option broadcast-address code 28 = ip-address;"
 
set protocols igmp-proxy interface eth0.4 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth0.4 role upstream
set protocols igmp-proxy interface eth0.4 threshold 1
set protocols igmp-proxy interface eth3 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth3 role downstream
set protocols igmp-proxy interface eth3 threshold 1
 

commit
save
exit

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
TheGOoSTaD schreef op zaterdag 25 januari 2020 @ 15:51:
[...]


Oke, super bedankt, dit herken ik.
Als ik het goed begrijp kan ik regel 12 en 13 verwijderen want ik heb geen kpn en geen username/ww voor mijn verbinding.

Wat moet ik bij regel 45 invullen als next hop router adres?
En ik hoef geen toegewezen ip van de iptv vlan in te vullen? Dat begreep ik uit het begin van dit topic.

EDIT:
Oke, ik probeer het stapje voor stapje te doen. Door de settings van de startpost via SSH in te stellen, het volgende snap ik en lukt:

configure

delete interfaces ethernet eth0 address

set interfaces ethernet eth0 description "WAN"
set interfaces ethernet eth0 duplex auto
set interfaces ethernet eth0 speed auto

set interfaces ethernet eth0 vif 34 address dhcp
set interfaces ethernet eth0 vif 34 description "WAN-Internet"

set interfaces ethernet eth0 vif 4 address dhcp
set interfaces ethernet eth0 vif 4 description "WAN-IPTV"

commit
save
exit

Ik zie op de webinterface ook dat ik twee ip adressen krijg, mooi, er is zelfs even internetverbinding en dan houd alles weer op.

Nu nog de STATIC route en IGMP instellen, mocht iemand weten hoe dit via SSH of de web interface gaat dan hoor ik dat graag.
Regel 13 zit type fout voor eth10 moet ook eth0 zijn.

En ik denk op te maken uit je vlan34 dat je Telfort hebt ? Dan moet je inderdaad vif vervangen voor vif 34 en worden alle eth0.6 dus eth0.34

Veder kan je volgens gewoon de zelfde igmp en nat settings gebruiken.

En bij regel 45 moet je het router adress invullen die terug krijgt uit de dhcp van Telfort op vlan 4

xbeam wijzigde deze reactie 25-01-2020 17:25 (8%)


  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Tweak icm Canal Digitaal TV
VLAN ID Functie verbindingstype
4 IP-tv DHCP
34 Internet (en Telefonie) DHCP
IGMP Snooping / Routing over VLAN 4
Static route naar 185.24.175.0/24 en 185.41.48.0/24 over het IP-TV Gateway (IP-adres verkregen op VLAN 4)
IGMP Proxy whitelist : 239.0.3.0/16 en 225.0.71.0/24 en 224.0.0.0/16

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
Playmaster schreef op maandag 27 januari 2020 @ 16:25:
Kun je met de custom configuratie zomaar je controller software upgraden? Of kan het zijn dat je dan problemen krijgt?
Ligt er aan welke custom configuratie je bedoeld. De gateway json en de post-config.d map worden ondersteund door ubiquity. Als je andere bestanden op de USG aanpast dan niet.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
Ewin schreef op zaterdag 25 januari 2020 @ 15:36:
Bedankt voor de heldere pagina met uitleg @Coolhva. Ik heb jouw config.json en bijbehorende .sh bestanden gedownload en zag dat dit niet 1 op 1 werkt voor een USG-PRO
Nu heb ik zelf een USG4/USG-PRO en derhalve 2 vragen:
  1. Werkt deze oplossing dan als ik de ETH poorten in de file aanpas naar de WAN/LAN poorten in mijn USG4?
  2. Ik moet nu elke keer als ik iets aanpas in de controller en mijn USG opnieuw provisioned mijn VPN instellingen opnieuw in de USG zetten via SSH. Ik zag in de repro van Coolvha dat ik dit ook aan de config.json kan toevoegen. Dit heb ik nu gedaan maar weet niet of het nu goed staat?
Zou iemand eventueel mijn aangepaste config.json en .sh files willen controleren op basis van bovenstaande aanpassingen? Dit zou mij enorm helpen! Dan kan ik het dit weekend testen of het werkt, en kan dit ook worden toegevoegd aan de informatie.
Via de mail ondertussen contact. De bestanden zien er goed uit, het zal waarschijnlijk met timing te maken hebben dat je foutmelding 561 krijgt van KPN.

De "quick fix" hier is als alles is ingesteld en provisioned:

1. herstart de USG via de controller en wacht totdat hij is gestart (en je internet hebt)
2. doe alles uit wat achter de USG hangt (switches, setup boxen)
3. doe alle switches eerst aan
4. doe daarna een setupbox aan en controlleer of je tv hebt
5. doe daarna andere setupboxen aan.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
mountain82 schreef op vrijdag 24 januari 2020 @ 19:50:
Dank voor dit helder topic ! Vraagje , in de instructie staat heel duidelijk aangeven waar je de json file voor de controller moet plaatsen. In mijn geval draai ik de controller op een RPI via Hassio-Addon (https://github.com/hassio-addons/addon-unifi). De aangegeven mapjes in de instructies kan ik niet terugvinden als ik via WinSCP connectie maak met mij HomeAssistant. Heeft iemand een idee waar ik deze map kan vinden ??
Zover ik het kan zien wordt het bestandssysteem niet vanuit buitenaf beschikbaar gemaakt door Hassio.

Wat je kan doen is de gateway.config.json op de hassio controller zetten in /tmp en dan met docker cp commando de map naar de juiste locatie zetten, controleer wel of de sites/default map bestaat!

(ik zie dat het ubuntu is waarop ze de unifi controller installeren, https://github.com/hassio...b/master/unifi/Dockerfile)

een voorbeeld van mijn unifi docker container op mijn nas, ik kijk eerst welke container ID deze heeft.
henk@HVASVR:~$ sudo docker ps
CONTAINER ID        IMAGE                       COMMAND                  CREATED             STATUS                  PORTS                     NAMES
e4b0883eecf9        jacobalberty/unifi:latest   "/usr/local/bin/dock…"   2 months ago        Up 2 months (healthy)                             unifi-controller


daarna ga ik er met een shell in (via docker exec -it) om te kijken of de map bestaat:
henk@HVASVR:~$ sudo docker exec -it e4b0883eecf9 /bin/bash
root@unifi-controller:/unifi# ls /usr/lib/unifi/
bin  data  dl  lib  logs  run  webapps
root@unifi-controller:/unifi# ls /usr/lib/unifi/data/
backup  db  firmware.json  keystore  sites  system.properties  system.properties.bk
root@unifi-controller:/unifi# ls /usr/lib/unifi/data/sites/
default
root@unifi-controller:/unifi# ls /usr/lib/unifi/data/sites/default/
config.gateway.json  map
root@unifi-controller:/unifi#exit
henk@HVASVR:~$


Zoals je ziet doe ik eerst ls op de hoofdmap en ga zo elke keer een niveau dieper. Als de map niet bestaat moet je hem maken:
root@unifi-controller:/unifi# mkdir -p /usr/lib/unifi/data/sites/default
root@unifi-controller:/unifi# chown unifi:unifi /usr/lib/unifi/data/sites/default


nu kan je met docker cp vanuit de hassie server de gateway.config.json in de juiste map zetten (verander wel het container id naar het id van jouw container:

# sudo docker cp /tmp/gateway.config.json e4b0883eecf9:/usr/lib/unifi/data/sites/default/gateway.config.json

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Old-Tweaker schreef op donderdag 30 januari 2020 @ 22:01:
[...]


Als ik bovenstaande JSON maak en gebruik dan blijft hij op provisionen hangen. Iemand enig idee waaraan dat kan liggen?

Wil graag ook zonder scripts werken en dan via de controller de next hop kunnen aanpassen. Dat is het makkelijkst.

Update:
Ik zie dit bij de foutmeldingen en heb inderdaad WAN 2 uitgeschakeld staan omdat die niet gebruikt werd. Moet ik die nu weer aanzetten?

Probleem met doorvoeren configuratie. Foutmelding: {"COMMIT":{"error":"[ interfaces ethernet eth2 vif 4 address dhcp ]\neth2.4 is disabled.\n\n0\nCommit failed\n","failure":"1","success":"1"},"DELETE":{"failure":"0","success":"1"},"SESSION_ID":"efb170374adf46856625b922f0","SET":{"failure":"0","success":"1"}} 21:51 30/01/2020

Probleem met doorvoeren configuratie. Foutmelding: {"COMMIT":{"error":"[ interfaces ethernet eth2 vif 4 address dhcp ]\neth2.4 is disabled.\n\n0\nCommit failed\n","failure":"1","success":"1"},"DELETE":{"failure":"0","success":"1"},"SESSION_ID":"68f53af10f5d40aea3f75e2d20","SET":{"failure":"0","success":"1"}} 21:43 30/01/2020

Probleem met doorvoeren configuratie. Foutmelding: {"COMMIT":{"error":"[ interfaces ethernet eth0 vif 4 address dhcp ]\nStopping DHCP client on eth0.4 ...\n\n1\n[ service nat rule 5000 outbound-interface eth2.4 ]\nNAT configuration warning: interface eth2.4 does not exist on this system\n\n1\n[ interfaces ethernet eth2 vif 4 address dhcp ]\neth2.4 is disabled.\n\n0\n[ protocols igmp-proxy ]\nStopping IGMP proxy\nStarting IGMP proxy service\n\n1\nCommit failed\n","failure":"1","success":"1"},"DELETE":{"failure":"0","success":"1"},"SESSION_ID":"68f53af10f5d40aea3f75e2d20","SET":{"failure":"0","success":"1"}} 21:33 30/01/2020
Welke USG heb je ?

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Duidelijk, dat verwachte ik al vanwege je fout omschrijving. De json is voor een USG4P

Hierdoor Komen de poort nummers niet overeen met jouw USG.

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Old-Tweaker schreef op zondag 2 februari 2020 @ 19:21:
[...]


Maar is er een.JSON voor een 3P? Want het instellen van de static vind ik geweldig.
Dus dat je het gewoon via de controller kan doen
Ja die is er, dat is een kwestie van de eth de juiste nummering geven ;-)

als je even je huidig config dumpt kan ik aangeven wat je moet aan passen.

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Old-Tweaker schreef op zondag 2 februari 2020 @ 21:22:
[...]


Dat is die van jouw ;-)

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
{ 
    "interfaces": {
        "ethernet": {
            "eth0": {
                "dhcp-options": {
                    "default-route": "no-update",
                    "default-route-distance": "1",
                    "name-server": "no-update"
                },
                "vif": {
                    "4": {
                        "address": [
                            "dhcp"
                        ],
                        "description": "WAN",
                        "dhcp-options": {
                            "client-option": [
                                "send vendor-class-identifier "IPTV_RG";",
                                "request subnet-mask, routers, rfc3442-classless-static-routes;"
                            ],
                            "default-route": "no-update",
                            "default-route-distance": "210",
                            "name-server": "no-update"
                        },
                        "ip": {
                            "source-validation": "loose"
                        }
  
                    },
                    "6": {
                        "description": "WAN",
                        "firewall": {
                            "in": {
                                "ipv6-name": "WANv6_IN",
                                "name": "WAN_IN"
                            },
                            "local": {
                                "ipv6-name": "WANv6_LOCAL",
                                "name": "WAN_LOCAL"
                            },
                            "out": {
                                "ipv6-name": "WANv6_OUT",
                                "name": "WAN_OUT"
                            }
                        },
                        "pppoe": {
                            "2": {
                                "default-route": "auto",
                                "firewall": {
                                    "in": {
                                        "ipv6-name": "WANv6_IN",
                                        "name": "WAN_IN"
                                    },
                                    "local": {
                                        "ipv6-name": "WANv6_LOCAL",
                                        "name": "WAN_LOCAL"
                                    },
                                    "out": {
                                        "ipv6-name": "WANv6_OUT",
                                        "name": "WAN_OUT"
                                    }
                                },
                                "name-server": "auto",
                                "password": "kpn",
                                "user-id": "kpn"
                            }
                        }
                    }
  
                }
            }
        }
    },
    "protocols": {
        "igmp-proxy": {
            "interface": {
                "eth0.4": {
                    "alt-subnet": [
                        "0.0.0.0/0"
                    ],
                    "role": "upstream",
                    "threshold": "1"
                },
                "eth1": {
                    "alt-subnet": [
                        "0.0.0.0/24"
                    ],
                    "role": "downstream",
                    "threshold": "1"
                }
            }
        },
        "static": {
            "route": {
                "213.75.112.0/21": {
                    "next-hop": {
                        "10.196.160.1": "''"
                    }
                }
            }
        }
    },
    "port-forward": {
        "wan-interface": "pppoe2"
    },
  
    "service": {
        "dns": {
            "forwarding": {
                "except-interface": [
                    "pppoe2"
                ]
            }
        },
        "nat": {
            "rule": {
                "5000": {
                    "description": "MASQ corporate_network to IPTV network",
                    "destination": {
                        "address": "213.75.112.0/21"
                    },
                    "log": "disable",
                    "outbound-interface": "eth0.4",
                    "protocol": "all",
                    "type": "masquerade"
                },
                "6001": {
                    "outbound-interface": "pppoe2"
                },
                "6002": {
                    "outbound-interface": "pppoe2"
                },
                "6003": {
                    "outbound-interface": "pppoe2"
                }
            }
        }
    }
}
Ah zo dit is niet je config dump ;-) maar de json die je nu gebruikt. Als je goed kijkt zie dat je hier eth0 gebruikt waar de json die je probeert te laden eth2 gebruikt.

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Old-Tweaker schreef op maandag 3 februari 2020 @ 16:44:
[...]


Dus als ik alles van eth2 aanpas naar eth0 dan zou dat het enige zijn?
En dat static instellen in de controller?
Yes, Daar komt ook je eth2 fout melding van vandaan. De json probeert instellingen te wijzigen die in jouw gateway niet bestaan.

xbeam wijzigde deze reactie 03-02-2020 16:59 (19%)


  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
Psvtje10 schreef op woensdag 12 februari 2020 @ 14:40:
@Coolhva Bedankt voor de duidelijke handleiding om KPN werkend te krijgen met de USG! Ik heb mij hier ~2 jaar geleden met Telfort aan gewaagd en dat was een drama dus ik heb tot vandaag gebruik gemaakt van bridged-IPTV. Ik ben overgestapt naar KPN en met jouw handleiding had ik alles binnen no-time werkend. Uiteraard ook een bedankje naar o.a. @xbeam en @hermanh want ik geloof dat jullie allemaal een hoop tijd in dit topic en het troubleshooten hebben gestoken!

Ik heb nog wel een vraag over de handleiding van Coolhva. IPv6 lijkt te werken maar IPv4 niet, in ieder geval niet volledig. Als ik bijvoorbeeld naar whatismyipaddress.com ga staat er dat er geen IPv4 address is gedetecteerd. Ook via de Unifi controller staat er bij de USG 0.0.0.0 als ik kijk naar de eigenschappen:

[Afbeelding]

Hierdoor werkt DDNS niet meer. Is dit een bekend probleem of weten jullie toevallig hoe ik dit op moet lossen? Voor mij is IPv6 niet noodzakelijk dus het zou geen probleem zijn als IPv6 helemaal niet werkt.

De USG Pro draait op firmware 4.4.44.5213871 en de controller op 5.12.35.
Als je inlogt met SSH op de USG en dan "show interfaces" doet, zou je bij PPPOE2 een IPv4 adres moeten zien. Je kan altijd nog een reboot uitvoeren om te kijken of dat helpt (of www.whoer.net testen).

In de GUI zie je inderdaad geen IPv4 adres, dat komt omdat er nu twee WAN interfaces zijn waardoor de GUI dat niet meer snapt.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
Psvtje10 schreef op woensdag 12 februari 2020 @ 21:03:
@Coolhva Via SSH laat de USG wel een IPv4 adres zien onder PPPoE2 dus ik neem aan dat 't gewoon werkt! Ik neem aan dat, doordat de GUI in de war raakt door de twee WAN interfaces, DDNS hierdoor niet meer werkt? Ik geloof dat DDNS ook via de config.gateway.json moet kunnen dus daar ga ik eens naar kijken.

Is er ook optie om heel IPv6 uit de configuratie te houden? Ik heb er nog geen behoefte aan en het maakt het een en ander wel ingewikkelder.
IPv6 kan eruit maar gaat je probleem niet oplossen. Waarom gebruik je DDNS, KPN IP is fixed.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
yniezink schreef op vrijdag 14 februari 2020 @ 10:08:
ik wil graag de KPN experiabox er tussenuit halen. Ik maak echter geen gebruik van IPTV.

Is dan het dan zo simpel om in mijn usg pro op de wan in te stellen

KPN
VLAN ID Functie verbindingstype
6 Internet pppoe

user kpn & wachtwoord kpn ?
Yup, IPv6 weet ik niet, zou je moeten proberen.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
Cartman! schreef op vrijdag 14 februari 2020 @ 09:01:
[...]

Ik heb 3 jaar geleden een brief gekregen met inloggegevens maar niet met een vast IP-adres erin. Dit wordt ook nergens beloofd door KPN, alleen zakelijk zover ik weet. In praktijk echter zal je IP-adres vast zijn maar zonder de garantie dat dit zo blijft. Heb zelf ook DDNS scriptje gemaakt; NAS stuurt elke 15min pingetje naar een endpoint die DNS records update wanneer nodig.
Je IP adres is gekoppeld aan je profiel bij KPN. Dat profiel is gekoppeld aan de switchpoort waar je glasvezel is in afgemonteerd in de DSLAM.

Als je gaat verhuizen of ze verplaatsen je aansluiting in de DSLAM dan kan je een ander IP adres krijgen. Ik ben in 2017 verhuisd, toen kreeg ik een ander IP, maar vanaf toen tot aan nu is hij gelijk gebleven.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
Old-Tweaker schreef op zaterdag 15 februari 2020 @ 16:05:
[...]

Heb het inmiddels werkend maar krijg weer die vervellende 561 melding.

Onderstaande stappen al gedaan.

De "quick fix" hier is als alles is ingesteld en provisioned:

1. herstart de USG via de controller en wacht totdat hij is gestart (en je internet hebt)
2. doe alles uit wat achter de USG hangt (switches, setup boxen)
3. doe alle switches eerst aan
4. doe daarna een setupbox aan en controlleer of je tv hebt
5. doe daarna andere setupboxen aan.

Maar loste het probleem niet op.

Heeft iemand nog een andere oplossing voor het 561 probleem?

Heb nu tijdelijk de Experia Box maar weer even terug gezet.
Wat me daar op valt is de tuners hier een vast IP krijgen.
Is de ook handig met de USG3P?
Misschien kan ik een keer (remote) troubleshooten? Lijkt me dat we het bij jou, net als iedereen, werkend moeten krijgen😏

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
💥BAM



!!!Probeer dit niet zelf. Hele grote kans dat er errors ontstaan en 100% kans dat je bestaande udm setup niet meer werkt. Daarnaast is het is niet zeker dat dit werkt en blijft werken ubnt wil dit namelijk niet. !!!

Het is wat uitzoek werk geweest en volledig buiten het boekje om het maar Lijkt te lukken om een udm-pro te laten informen naar een cloudkey of cloud controller.

Daarnaast weet ik inmiddels hoe je Root toegang krijgt tot In de unifi-os docker en daarmee ook tot de json.config en system.config locatie. Alleen of een json ook werkelijk geladen kan worden heb ik nog niet geprobeerd.

Morgen aan de slag om kijken de mogelijkheden zijn en of volledig te adopten is.

xbeam wijzigde deze reactie 16-02-2020 05:27 (178%)


  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
Psvtje10 schreef op zondag 16 februari 2020 @ 17:25:
@Cartman! Ik zie het inderdaad. Ik doelde echter op de andere handleiding van Coolhva. :) Wellicht dat 'ie het er bewust uit heeft gelaten om 't laagdrempelig te houden of misschien is 'ie het simpelweg vergeten. Voor mij was het in ieder geval belangrijke info. ;)
Ik kan het aan het einde van de handleiding wel toevoegen. Ik heb het expres niet toegevoegd om het laagdrempelig te houden, maar nu zie ik dat het wel handig is om toe te voegen.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
zekerpixels schreef op maandag 17 februari 2020 @ 16:03:
Ik ga het toch even hier vragen, de volgende opstelling;
KPN experia box -> UDM -> US-8-60W -> ITV
en ja, dat ding van KPN blijft staan.
Op de laatste pagina's staat het eigenlijk al, maar om te bevestigen, kan ik in de UDM dit weekend krijgen zonder echt te gaan rommelen.
Dit gaat zonder meer werken. Ik zou wel een vlan maken voor je iTV kastje(s) zodat deze direct aan de experiabox hangen vanwege de IGMP streams.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
misschien moet je fast interleave aanzetten (zie een aantal posts hiervoor hoe je dat doet).

  • xbeam
  • Registratie: maart 2002
  • Laatst online: 14:09
Tylen schreef op maandag 17 februari 2020 @ 22:32:
[...]


Ik zie geen post hoe je dit moet doen ;)

Maar ik gebruik geen USG of andere unifi router voor de igmp streams he. Alles is default van XS4ALL. Kan nergens settings vinden in de switch configuratie om "fast interleaved" aan te zetten. De switch is een Gen2 24 poorts poe. Daarin kan je ook niet meer naar de hidden telnet omgeving :(

Edit: https://community.ui.com/...35-47f9-92fd-923cb64aef53
Even testen.

Edit2: Nee dit maakt niets uit :(

Edit3:Header Validation uit maakt ook niets uit :(
config.system_cfg.1=switch.igmp.header_checking=false
config.system_cfg.2=switch.vlan.1.igmp_fastleave=true
Welke firmware gebruik je. Ik heb er bij een bekende in het verleden ook veel problemen mee gehad en toen bleek er igmp bug in de firmware te zitten.

  • Coolhva
  • Registratie: juni 2003
  • Laatst online: 21-02 09:10
Tylen schreef op dinsdag 18 februari 2020 @ 08:24:
Nieuwe versie natuurlijk ;) Het is een nieuwe switch uit de doos.

Maar het probleem met de Gen2 switches is dat je niet meer een telnet naar localhost kan doen om zo dieper in de config te komen. Dan kan je show igmpsnooping geven om de settings van je igmp snooping te bekijken. Maar dit kan niet meer :( Dus kan niet zien wat de huidige instelling is. Ik ga nog even verder erin duiken.
Mogelijke fix: https://community.ui.com/...-9334-71d12eab2e69?page=1

Nieuwe switches zijn veel minder flexibel inderdaad!

  • hermanh
  • Registratie: oktober 2005
  • Laatst online: 14:09
Tylen schreef op dinsdag 18 februari 2020 @ 08:56:
[...]


Leuke link ;) Die jeroen ben ik ;)

Heb zojuist van Chen een test firmware ontvangen die ik vanavond even ga testen.
Cool.. Dus eigenlijk bevestigd Chen dat de packets wel doorgezet worden, maar niet richting de Router een Membership update wordt gestuurd. Kans is dus groot dat dit niet alleen de nieuwe switches betreft, maar ook de huidige serie.
Pagina: 1 2 3


Apple iPhone 11 Microsoft Xbox Series X LG OLED C9 Google Pixel 4 CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True