Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

  • kroegtijger
  • Registratie: juli 2001
  • Laatst online: 23-05 13:26
Al enige tijd ben ik aan het stoeien met m’n TV Server setup, maar het wil nog niet helemaal naar wens verlopen.

M’n HTPC is voorzien van 2 DVB-C tuners met AlphaCrypt. Deze draaien netjes onder Windows 10 en via DVBViewer wordt dit aangeboden aan Kodi die op dezelfde machine draait.
Dit werkt prima, maar aangezien er ook een server in het netwerk draait wil ik dus die tuners verhuizen naar mijn server toe. Zodoende kan de HTPC dan gewoon uit als die niet gebruikt wordt, zonder dat het de dienstverlening op de rest van het netwerk verstoort.
De server draait op VMWare ESXi 5.5 met daarop Server 2012 geïnstalleerd. Daar vandaan wordt ook alle content (films, muziek etc) aangeboden, maar ook de diverse andere diensten die in het netwerk draaien worden vanaf deze ESX-host aangeboden.

Als proefopstelling heb ik 1 van de tuners uit de HTPC gehaald en in m’n server gepropt. In dit geval betreft het een Technisat CableStar HD2 (de andere tuner is een FireDTV; die zit nog in de HTPC). In VMWare heb ik deze netjes via device passthrough aan de server aangeboden die de tuner ook ziet. Drivers netjes toegevoegd en alles lijkt goed te staan, maar toch wordt de tuner niet zichtbaar in DVBViewer (of welke andere software dan ook). Na enig zoekwerk kwam ik erachter dat Server 2012, 2012r2 en 2008r2 niet over het BDA Driver Pack beschikken. Om zeker te zijn dat dit het probleem was heb ik daarom een VM met Windows 10 toegevoegd. Dat is nadrukkelijk een tijdelijke situatie, want Windows 10 (en elk client OS) is naar mijn mening totaal ongeschikt voor dit doeleinde, en dat hoort gewoon op een server te functioneren. Op de Windows 10 VM kreeg ik inderdaad netjes beeld van Ziggo op NPO1, 2 en 3 in HD, maar de encrypted zenders willen nog niet functioneren. (kennelijk een issue met de CAM?)
Daarmee lijkt het ontbreken van BDA-ondersteuning op Windows Server dus inderdaad een aannemelijke oorzaak. Inmiddels heb ik hier wel het nodige over terug kunnen vinden, (zie o.a. https://knowledge.zomers....e-with-DVBLogic-v4-5.aspx) en een BDA Driver Pack gevonden hiervoor. Deze geinstalleerd, Tuner opnieuw geinstalleerd en die wordt nu ook gedetecteerd door DVBViewer, echter wil scannen naar kanalen nog niet lukken. Transedit springt op Not responding bij een scan naar kanalen.

Zijn er mensen die een dergelijke setup al aan de praat hebben weten te krijgen? Of zijn er alternatieven te bedenken? Het hoeft niet strikt noodzakelijk onder Windows te draaien; een Linux (debian) is ook prima wat mij betreft, maar daarin schijnt de CAM nogal een issue te zijn. Ik heb het er in ieder geval nog niet werkend in gekregen. Een softcam (zoals osCAM) gebruik ik liever niet.
In het slechtste geval is overstappen naar een niet-gevirtualiseerde host (2012r2) een mogelijkheid, of overstappen naar HyperV zou ook kunnen, maar dat heeft nogal wat werk nodig om de data dan netjes verplaatst te krijgen dus ik heb een heel sterke voorkeur om dit onder VMWare aan de gang te slingeren.

It´s not a lie, if you believe it



OnePlus 7 Pro (8GB intern) Microsoft Xbox One S All-Digital Edition LG OLED C9 Google Pixel 3a XL FIFA 19 Samsung Galaxy S10 Sony PlayStation 5 Smartphones

Tweakers vormt samen met Tweakers Elect, Hardware.Info, Autotrack, Nationale Vacaturebank, Intermediair en Independer de Persgroep Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True