Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

  • CH4OS
  • Registratie: april 2002
  • Niet online
Mede-auteur:
  • Wiethoofd
  • Registratie: juli 2007
  • Laatst online: 22-09 13:48

Wiethoofd

Battlefield: Bad Company 2 - Problementopic
Inhoudsopgave
Introductie

Dit topic is bedoeld om problemen te bespreken rond de game 'Battlefield: Bad Company 2' van Electronic Arts / DICE. Het is ontstaan om de inhoudelijke discussies en discussies over problemen van elkaar te scheiden.
Systeemeisen PC

MinimaalAanbevolen
Processor2GHz DualcoreQuadcore
Geheugen2GB DDR2>2GB DDR2
Grafische kaartNvidia 7800GT | Ati X1900Nvidia GTX 260 | Ati 4870
BesturingssysteemWindows XPWindows Vista/7
Vrije schijfruimte15GB voor digitale | 10GB voor disc-versie

Uiteraard zijn deze gegevens van toepassing op de PC-versie van de game!
Veelgestelde vragen

Vraag: Help, ik krijg de melding "Failed to connect to EA Online", wat nu? :?
Antwoord: Elke Dinsdag om 11u heeft EA onderhoud aan de servers, wellicht dat je daarom niet kan spelen.

Vraag: Ik heb de game via Steam aangeschaft, is er een mogelijkheid een back-up te maken? :?
Antwoord: Ja, vanuit Steam kan je een back-up hiervan maken (howto)

Vraag: Ik heb mijn versie via de EA Store gekocht, maar waar kan ik nu mijn activeringscode vinden? :?
Antwoord: Zie ozziestroker1 in "[Multi] Battlefield: Bad Company 2 - deel 4"

Vraag: Ik heb een kickass PC, maar heb toch performance problemen, heb je tips? :?
Antwoord: Jazeker, je kan beginnen met v-sync uit te zetten en als dat niet voldoende helpt, kan je (eventueel) DX9 forceren. Dit is terug te vinden in een tweakguide. Bedankt voor de tip, riffey#4!

Vraag: Ik word met de PC-versie alleen maar gekicked, hoe kan dat? :?
Antwoord: Waarschijnlijk is jouw Punkbuster versie niet up-to-date, download en draai de updater.

Vraag: Ik heb last van (spawn)lag, hoe kan dat? :? (#1)
Antwoord: Probeer er voor te zorgen dat jouw Mijn Documenten folder lokaal op de PC staat, dat wil wel eens helpen. Ook kan het zijn, dat je jouw virusscanner even moet uitschakelen, danwel de BFBC2 mappen moet excluden bij jouw scanner, zodat hij deze overslaat.

Vraag: Ik heb zo'n last van (spawn)lag, is daar wat aan te doen? :? (#2)
Jazeker, het is niet officieel bevestigd of (op moment van schrijven) niet opgelost met een patch, maar je kan je BFBC2 folder toevoegen als uitzonderingen binnen je anti virus scanner. Er is meerdere malen bevestigd dat dit werkt, dus vooralsnog lijkt dit de enige oplossing te zijn.

Vraag: Ik heb last van (spawn)lag (en gebruik Windows 7), hoe kan dat? :? (#3)
Op het Steam-forum is een tip verschenen die wellicht uitkomst biedt.

Vraag: Ik krijg meldingen over PunkBuster, help!? :?
Je zou in ieder geval al kunnen beginnen met het updaten van PunkBuster.

Vraag: Is er wat te doen aan die lange laadtijden :?
Als je een AMD / ATi videokaart gebruikt, installeer dan de 10.4a Catalyst drivers.

Vraag: Ik heb de game nu pas, maar krijg geen verbinding, wat kan ik doen :?
Wat je kan doen is Ste7en in "[Multi] Battlefield: Bad Company 2 - Pro..." even doornemen

Missen jullie nog vragen en antwoorden, stuur CptChaos een DM.
Handige links
Missen jullie nog een handige link, stuur CptChaos een DM.
Met dank aan Wiethoofd is de UBB-code van de TS opgeschoond en hier en daar opgemaakt.

Regels

    
 
• Lees eerst de topicstart voordat je je probleem post
• Zoek of er al enige oplossingen voor zijn gevonden
• Geef een duidelijke omschrijving van het probleem
• Vermeld wat je zelf hebt geprobeerd
• Vermeld ook het platform waar het probleem over gaat
• Simpele vragen en problemen waar geen inzet worden getoond zijn uit den boze!
 
   

[ Steam ][ Diablo ][ CptChaos#2957 ]

Ik heb het vorige problemen topic niet de hele tijd gevolgd. Het kan zijn dat ik hierdoor een aantal vragen heb gemist, die daar al veelbesproken zijn. Ik wil jullie daarom vragen mij een DM te doen, als er een vraag is die daar veelbesproken is, maar die nog niet in de topicstart was vermeld, dan kan ik deze in deze nieuwe topicstart opnemen.

Laatste bericht in het vorige topic:
quote:
Compizfox schreef op dinsdag 28 december 2010 @ 17:54:
Ik krijg nu ook steeds een punkbuster kick!

Disallowed Program/Driver [125129].

Ik heb niets veranderd of zo... Eerst werkte het prima, maar sinds vandaag krijg ik dit bij elk potje, vaak al voordat ik tijd heb om te spawnen.

EDIT: Oh, het kwam door de Steam Overlay. Die heb ik wel pas aangezet en ik was dat vergeten. Zonder Steam werkt het, maar toch vreemd.
Wel vreemd trouwens, ik heb de game (en de DLC's) via Steam, maar word dan niet gekicked vanwege de overlay (die ik dus gewoon aan heb staan). Jij hebt de game toch retail (dus met doosje, boekje etc.)?

CH4OS wijzigde deze reactie 29-12-2010 00:00 (70%)

[ Steam ][ Diablo ][ CptChaos#2957 ]

quote:
Goner schreef op woensdag 29 december 2010 @ 10:40:
Even iets positiefs over Punkbuster/Evenbalance (uit vorige topic) :

Had een ticket ingeschoten bij EvenBalance, want ik kon echt niet meer spelen. Na een paar minuten spelen een PB kick met bovenstaande melding (meestal onmiddelijk na een death).
Gisteren antwoord ; opgelost !! Kan weer spelen !! (wel jammer dat ze niet even melden wat het nou was).
Dan zal het probleem in PunkBuster hebben gezeten. Naar ik altijd begrepen heb krijg je namelijk alléén support van Evenbalance als het probleem hem daadwerkelijk in Punkbuster zit, met meerdere meldingen erover. Als dat niet het geval is, is het voor hun een client-side probleem en doen ze dus nada.
quote:
Compizfox schreef op woensdag 29 december 2010 @ 11:13:
Ja, ik heb de game retail, boxed. Laatst wilde ik hem eens spelen met de Steam overlay aan, dat leek me wel handig. Maar dan kreeg ik dus steeds die kick.
En je weet 100% zeker dat PB up to date is? Ik kan me niet voorstellen dat de retail géén overlay aan mag hebben staan, maar de Steam versie wél. ;)

CH4OS wijzigde deze reactie 29-12-2010 11:36 (21%)

[ Steam ][ Diablo ][ CptChaos#2957 ]

quote:
Mastodon334 schreef op zaterdag 01 januari 2011 @ 20:31:
Hoi, ik heb sinds kort bad company gekocht via steam, het werkte eerst helemaal niet maar na een hoop gedoe en gezeik een manier gevonden om het werkende te krijgen. Dit door de onboard geluidskaart uit te zetten via bios en bij settings.ini de speakercount op 1 te zetten. Maar het blijft nog steeds wankel, ik kan alleen op 1024 x 768 resolutie spelen als ik de resolutie hoger zet crasht ie, als ik in multiplayer na het spelen op update statistics(of iets in die richting) crasht ie ook. Heb windows 7 opnieuw geinstalleerd en de drivers opnieuw geinstalleerd. Systeem specs zijn core 2 duo e8400 processor 4 gb geheugen en een ati 4870 met ati catalyst 10.12 drivers. Alle temperaturen zijn ook normaal, niet boven de 70 graden. Weet iemand nog een manier om het stabiel te laten lopen op hogere settings want volgens mij moet mijn pc dat gewoon aankunnen.
Ik had bijna dezelfde specs, alleen ik had een 4850, ook via Steam en draaide gewoon goed, met een resolutie van 1680x1050, zonder (FS)AA en AF. Wat kán helpen, is de game te verwijderen van de PC en vervolgens via Steam opnieuw te downloaden. Wellicht is er een bestand corrupt, waardoor het bij jou niet goed meer gaat. Heb ik ook ooit is gehad.

[ Steam ][ Diablo ][ CptChaos#2957 ]

quote:
Mastodon334 schreef op zondag 02 januari 2011 @ 17:18:
Ok thnx, ga ik dat es proberen. Kan het ook aan de videokaart drivers liggen? Oudere proberen? Of de direct x versie?
Dan zou je alleen in-game er veel last van moeten hebben. Dus als het daar al aan zou liggen, zou ik DirectX gokken. Als je andere drivers gaat proberen, ga dan niet lager dan versie 10.4a, anders hou je lange laadtijden over.

[ Steam ][ Diablo ][ CptChaos#2957 ]

quote:
Ste7en schreef op maandag 03 januari 2011 @ 18:42:
Ik kreeg vandaag Bad Company 2 retail binnen van amazon.co.uk. Na het spel geïnstalleerd te hebben met de dvd kan ik maar niet online. Ik start het spel op, kom in main menu, wil inloggen en dan als ik verbinding maak met EA om een account aan te maken, of ook maar iets wat online bevoegdheid nodig heeft dan blijft deze failen, melding "Failed to connect to EA online".

Wat ik heb geprobeerd:Leken mij een beetje de beginnersweb oplossingen, maar dit alles wil nog niet baten.
Je hebt de berichten gelezen dat er momenteel wat kleine problemen zijn, waardoor de stats niet altijd werken en dus ook het inloggen niet optimaal gaat?
quote:
Maar wat ik eigenlijk gewoon wil, cdkey registreren op steam, downloaden en spelen. Is dit eigenlijk wel mogelijk met de retail versie?
Voor zover ik weet is het niet mogelijk om met de retail versie de Steam-versie te krijgen, maar je kan het altijd proberen natuurlijk. Jouw key gaat er niet door verloren in ieder geval.

[ Steam ][ Diablo ][ CptChaos#2957 ]

BC2 is ook heel erg CPU afhankelijk. Ik ben van een E8400 met 4850 naar later een Q9550 met diezelfde 4850 (nu 6870) gegaan, maar de verandering van CPU verdubbelde mijn FPS!
quote:
Ste7en schreef op dinsdag 04 januari 2011 @ 14:02:
[...]

netsh int tcp set global ecncapability=disabled
in CMD does the trick. Kwam omdat ik eens TCP Optimizer had gebruikt voor WoW :)
Ga ik in de TS melden als oplossing! Staat inmiddels in de FAQ.

CH4OS wijzigde deze reactie 08-01-2011 00:10 (49%)

[ Steam ][ Diablo ][ CptChaos#2957 ]

quote:
Compizfox schreef op zondag 09 januari 2011 @ 16:37:
Ten eerste heb ik het hier over lag, en geen lage FPS. Dat zijn 2 verschillende dingen die niets met elkaar te maken hebben maar toch vaak door elkaar gehaald worden ;)

Ten tweede draai ik hem al op DX9 :P
Je kan Ste7en in "[Multi] Battlefield: Bad Company 2 - Pro..." proberen... :) Wellicht helpt dat ook.

Op de ping moet je eigenlijk niet zo letten en eigenlijk alleen uitgaan van de ping die je ziet bij de serverbrowser. Ingame zijn de ping waarden verdubbeld (of zoiets).

[ Steam ][ Diablo ][ CptChaos#2957 ]

Is dat alles wat je hebt geprobeerd, de geluidskaart uitschakelen in het BIOS? Als het geluid door gaat, wéét je toch dat het juist niet aan jouw geluidskaart ligt en dat je het probleem ergens anders moet zoeken? Als het steeds na dezelfde tijd van spelen is, dan zou je eens kunnen kijken naar de temperatuur van jouw videokaart. Begin dus eens met de drivers daarvan te updaten. Omdat wij nu de specificaties van jouw PC niet weten, kunnen we je (op dit moment) niet vertellen waar je deze kan downloaden.

[ Steam ][ Diablo ][ CptChaos#2957 ]

Pagina: 1


Apple iPhone 11 Nintendo Switch Lite LG OLED C9 Google Pixel 4 FIFA 20 Samsung Galaxy S10 Sony PlayStation 5 Auto

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True