Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Gnome: gemounte partities komen niet in het Computer verster

Pagina: 1
Acties:

  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
Hoi,

eerst even de mogelijke nodige info:

Gnome versie: 2.16.0
OS: Fedora Core 6

Plaatje op imageshack (popups!)

als je naar dat plaatje kijkt zie je dat ik on my gnome computer window de volgende items heb:

Floppy Drive
CD-RW/DVD±RW Drive
Filesystem
Network


Nu heb ik in me fstab nog 2 andere partieties er zelf bijgezet.. die regels zijn dit:

code:
1
/dev/sda1        /mnt/windows        ntfs-3g    defaults    0 0
/dev/hda1        /mnt/other-stuff    ntfs-3g    defaults    0 0

de hele fastab ziet er zo uit:
code:
1
2
3
4
5
6
7
8
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
/dev/sda1        /mnt/windows        ntfs-3g    defaults    0 0
/dev/hda1        /mnt/other-stuff    ntfs-3g    defaults    0 0



en ik had eigenlijk verwacht dat die 2 nu dus ook zelf in het computer venster zouden komen van gnome.. niet dus... heeft iemand misschien een idee waar ik moet zijn zodat dit wel in het computer venster komt?

o btw.. de mappen /mnt/windows en /mnt/other-stuff werken gewoon en ik er alles mee doen..

Alvast bedankt :)

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • woest85
  • Registratie: juli 2003
  • Niet online

woest85

[Ondertitel]

mount eens naar /media/ ?

dat werkt hier onder ubuntu 6.10 ook, en naar /mnt/ niet...

[Signature]


  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
geprobeert.. restart gegeven... en het heeft helaas niet geholpen.. :( en ik kan gewoon in de mappen komen.. de mount werkt dus (zoals het hoort) het komt alleen niet in het Computers windowtje te staan.

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • mithras
  • Registratie: maart 2003
  • Niet online

mithras

Ik blog over ZF

Wat ik weet van idd Ubuntu is dat onder /media ze wel als los component in "Computer" worden gezien, en onder /mnt niet te zien zijn.

Je kan het trouwens ook tijdelijk proberen (zonder restart om fstab te testen) met
sudo umount /dev/sda1
sudo mkdir /media/windows
sudo mount /dev/sda1 /media/windows
En ditzelfde geldt voor hda1. Als je terug naar de default instellingen zoals toen je je pc opstartte, moet je de volumes unmounten (met umount) en dan dit doen:
sudo mount -a
Dan is alles weer volgens fstab

  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
quote:
Mithras86 schreef op zondag 29 oktober 2006 @ 23:01:
Wat ik weet van idd Ubuntu is dat onder /media ze wel als los component in "Computer" worden gezien, en onder /mnt niet te zien zijn.

Je kan het trouwens ook tijdelijk proberen (zonder restart om fstab te testen) met
sudo umount /dev/sda1
sudo mkdir /media/windows
sudo mount /dev/sda1 /media/windows
En ditzelfde geldt voor hda1. Als je terug naar de default instellingen zoals toen je je pc opstartte, moet je de volumes unmounten (met umount) en dan dit doen:
sudo mount -a
Dan is alles weer volgens fstab


dat (alleen dan zonder sudo) heb ik ook al geprobeert in Fedora Core 6.. en ook dan komen ze niet in het Computer venster..

zou dit misschien een bug in fedora kunnen zijn?

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • Sir Isaac
  • Registratie: september 2002
  • Laatst online: 26-11 20:47
Volgens mij laat gnome partities alleen zien als ze user mountable zijn. Per slot van rekening staan / en /home ook niet in het overzicht. Het heeft geen zin om die partities weer te geven al de gebruiker ze toch niet zelf kan mounten. Als je in je fstab defaults,user als mount opties geeft zal het vermoedelijk wel werken.

  • Zerthis
  • Registratie: oktober 2006
  • Laatst online: 26-11 08:50
Laat hij ze wel zien als je het volgende doet?
code:
1
/etc/init.d/dbus restart

 MacBook Pro (13-inch Mid 2012)  iPad (4th gen) Wi-Fi  iPhone 5s  iPod shuffle (4th generation late 2012)  Apple TV (3rd generation Rev. A) 


  • H@rry
  • Registratie: maart 2001
  • Laatst online: 18-11 16:46
Volgens mij worden deze alleen zichtbaar op je desktop als de optie user, of auto word meegegeven. Jij heb alleen de optie defaults daar staan.

Maak dus van defaults bijv: defaults,auto of defaults,user

het is 1 van de twee, je zou het ff moeten proberen om te kijken wat werkt.

(ps: mount -a is alles mounten wat in je fstab staat)

GoT a clue? Specs


  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
sorry voor de wat late reply.

ik heb alle opties die hier nu zijn gegeven geprobeert (ook auto en user) en geen van de opties geeft mij die 2 partieties in me Computer venster.

BTW.. ik heb geen dbus.. kan dat het misschien zijn?

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • FrankTM
  • Registratie: januari 2002
  • Laatst online: 26-11 16:45

FrankTM

LowLow Army

gnome volume manager mount hier alles automatisch voor me :)
voor zover ik weet wordt deze automatisch gestart door gnome

anders te starten met gnome-volume-manager

Sometimes the same is different... But mostly it's the same...


  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
hehe ik dacht ook al aan volume manager.. alleen is gnome-volume-manager ook echt een volume-manager (voor geluid dus!! niet partities ;))

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • Oesermaatra0069
  • Registratie: november 2003
  • Laatst online: 23-08-2009
Heb je ook een usb-stick? Als je die mount moet je eens kijken in /etc/fstab.
Neem de code over van de usb waar normaal gesproken defaults staat en vervang defaults door die code van de usb. Ik denk dat het dan wel lukt, tenminste bij mij wel.

hmm nogwat~!


  • Blaasvis
  • Registratie: november 2001
  • Laatst online: 26-11 19:25

Blaasvis

Cidora \o/

quote:
markg85 schreef op woensdag 01 november 2006 @ 22:41:
hehe ik dacht ook al aan volume manager.. alleen is gnome-volume-manager ook echt een volume-manager (voor geluid dus!! niet partities ;))

fout

gnome-volume-control is voor geluid.
gnome-volume-manager is de automounter :P

Blaasvis wijzigde deze reactie 02-11-2006 13:46 (6%)

Freedom is everything you need ; <moto-moi|afk> ik verkloot het gewoon nooit :P


  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
hier staat ie toch echt voor geluid.. kijuk maar naar me gonme-volume-manager --help:
[mark@localhost ~]$ gnome-volume-manager --help
Usage: gnome-volume-manager [OPTION...]
  --load-modules=MODULE1,MODULE2,...     Dynamic modules to load

Help options
  -?, --help                             Show this help message
  --usage                                Display brief usage message

Application options
  -v, -version                           Print version and exit
  -d, -daemon=<yes|no>                   Run as a daemon
  -n, -no-daemon                         Don't run as a daemon
  -s, -secret-mode                       Run in secret mode

GTK+
  --gdk-debug=FLAGS                      Gdk debugging flags to set
  --gdk-no-debug=FLAGS                   Gdk debugging flags to unset
  --display=DISPLAY                      X display to use
  --screen=SCREEN                        X screen to use
  --sync                                 Make X calls synchronous
  --name=NAME                            Program name as used by the window
                                         manager
  --class=CLASS                          Program class as used by the window
                                         manager
  --gtk-debug=FLAGS                      Gtk+ debugging flags to set
  --gtk-no-debug=FLAGS                   Gtk+ debugging flags to unset
  --g-fatal-warnings                     Make all warnings fatal
  --gtk-module=MODULE                    Load an additional Gtk module

Bonobo activation Support
  --oaf-ior-fd=FD                        File descriptor to print IOR on
  --oaf-activate-iid=IID                 IID to activate
  --oaf-private                          Prevent registering of server with OAF

GNOME Library
  --disable-sound                        Disable sound server usage
  --enable-sound                         Enable sound server usage
  --espeaker=HOSTNAME:PORT               Host:port on which the sound server
                                         to use is running
  --version                              2.16.0

Session management
  --sm-client-id=ID                      Specify session management ID
  --sm-config-prefix=PREFIX              Specify prefix of saved configuration
  --sm-disable                           Disable connection to session manager

GNOME GUI Library
  --disable-crash-dialog                 Disable Crash Dialog
[mark@localhost ~]$ 

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • nextor
  • Registratie: januari 2002
  • Laatst online: 04-11 21:30

nextor

Ohw Ohw Ohwja

gconf-editor opstarten
apps-->nautilus-->desktop
vinkje plaatsen bij 'volumes_visible'

Ik vind persoonlijk deze manier niet zo fijn, het is allemaal niet configurabel omdat het door nautilus wordt beheert, daarom heb ik .desktop files op mn Desktop met deze inhoud:

code:
1
2
3
4
5
6
7
8
kay@dooie:~$ cat Desktop/WinSchijf.desktop
[Desktop Entry]
Encoding=UTF-8
Name=Windows Schijf
Type=FSDevice
Icon=gnome-dev-harddisk
URL=file:///media/WINDOWS
X-Gnome-Drive=1
kay@dooie:~$

En dat moeten echt drie slashes zijn achter file: (eerste twee voor de URI, en die laatste omdat het een pad is)

  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
die gconf setting staat al aan bij mij:
Plaatje op imageshack (popups!)

edit:://
ik ga maar eens een bug submitten op de fedora bugzilla... :( het lijkt er nu namelijk verdacht veel op dat dit gewoon een bug is.

markg85 wijzigde deze reactie 02-11-2006 22:45 (25%)

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • Zerthis
  • Registratie: oktober 2006
  • Laatst online: 26-11 08:50
quote:
markg85 schreef op donderdag 02 november 2006 @ 20:53:
hier staat ie toch echt voor geluid.. kijuk maar naar me gonme-volume-manager --help:
Tik dan eens in
code:
1
man gnome-volume-manager

 MacBook Pro (13-inch Mid 2012)  iPad (4th gen) Wi-Fi  iPhone 5s  iPod shuffle (4th generation late 2012)  Apple TV (3rd generation Rev. A) 


  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
quote:
Zerthis schreef op vrijdag 03 november 2006 @ 01:16:
[...]

Tik dan eens in

code:
1
man gnome-volume-manager

daar krijg ik dit op:
[mark@localhost ~]# man gnome-volume-manager 
No manual entry for gnome-volume-manager
[mark@localhost ~]# 


* met root heb ik hetzelfde resultaat
en ik heb toch echt geen kale installatie gedaan :) juist heel veel wel geinstalleerd.

markg85 wijzigde deze reactie 03-11-2006 13:57 (5%)

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • fabio-c
  • Registratie: januari 2003
  • Laatst online: 22-11 19:20
quote:
markg85 schreef op vrijdag 03 november 2006 @ 13:56:
[...]


daar krijg ik dit op:
[mark@localhost ~]# man gnome-volume-manager 
No manual entry for gnome-volume-manager
[mark@localhost ~]# 


* met root heb ik hetzelfde resultaat
en ik heb toch echt geen kale installatie gedaan :) juist heel veel wel geinstalleerd.
gnome-volume-manager heeft normaal ook helemaal geen manpage.
fabio@acetyl ~ $ man gnome-volume-manager
No manual entry for gnome-volume-manager
fabio@acetyl ~ $ gnome-volume-manager --usage
Usage: gnome-volume-manager [-?|--help] [--usage] [-v|-version]
        [-d|-daemon <yes|no>] [-n|-no-daemon] [-s|-secret-mode]
        [--gdk-debug=FLAGS] [--gdk-no-debug=FLAGS] [--display=DISPLAY]
        [--screen=SCREEN] [--sync] [--name=NAME] [--class=CLASS]
        [--gtk-debug=FLAGS] [--gtk-no-debug=FLAGS] [--g-fatal-warnings]
        [--gtk-module=MODULE] [--oaf-ior-fd=FD] [--oaf-activate-iid=IID]
        [--oaf-private] [--disable-sound] [--enable-sound]
        [--espeaker=HOSTNAME:PORT] [--version] [--sm-client-id=ID]
        [--sm-config-prefix=PREFIX] [--sm-disable] [--disable-crash-dialog]
        [--load-modules=MODULE1,MODULE2,...]
fabio@acetyl ~ $


En toch heeft de volume-manager niks met geluid te maken, maar alles met partities en drives.

fabio-c wijzigde deze reactie 03-11-2006 14:49 (3%)


  • Zerthis
  • Registratie: oktober 2006
  • Laatst online: 26-11 08:50
quote:
Hmm, ik zit hier juist met een vrij kale installatie (van Debian dan), ging er vanuit dat je hem ook wel zou hebben. Maarja, als je hem wel had gehad had je dit er in kunnen lezen:
quote:

DESCRIPTION
gnome-volume-manager is a GNOME daemon that acts as a policy agent in top of the kernel, udev, d-bus and HAL. It listens to HAL
events and reacts with user-configurable actions. Currently it supports automount of new media and hot-plugged devices, autorun,
autoplay for Cd’s and DVDs, and automatic camera management. It is expected to be simple and free of polling and other evil hacks.

 MacBook Pro (13-inch Mid 2012)  iPad (4th gen) Wi-Fi  iPhone 5s  iPod shuffle (4th generation late 2012)  Apple TV (3rd generation Rev. A) 


  • _JGC_
  • Registratie: juli 2000
  • Laatst online: 06:56
De reden waarom die partities niet in computer:/// komen is vrij simpel: hal toont sowieso al geen mountpoints die op FHS locaties gemount zijn, en daarnaast heeft hal op de meeste distro's een policy die hal verbiedt iets met harddisks te doen die niet removable zijn.

  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
quote:
_JGC_ schreef op vrijdag 03 november 2006 @ 23:29:
De reden waarom die partities niet in computer:/// komen is vrij simpel: hal toont sowieso al geen mountpoints die op FHS locaties gemount zijn, en daarnaast heeft hal op de meeste distro's een policy die hal verbiedt iets met harddisks te doen die niet removable zijn.


mijn hdd`s zijn geen usb dingen.. zitten echt in de kast met een IDE kabel..
en heb je misschien ook een oplossing?

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • _JGC_
  • Registratie: juli 2000
  • Laatst online: 06:56
Voor fedora kan je eens zoeken naar het bestandje 99-redhat-storage-policy-fixed-drives.fdi, als je deze verwijdert of aanpast zodat ie juist wel dingen toestaat zou je gewoon harddisk partities die niet op FHS-mountpoints gemount zijn moeten kunnen zien.

  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
geweldig :) ik heb dat bestandje eruit geknalt en daar zijn me partities dan (na een reboot) :)
alleen nu is er wel weer een ander klein probleempje.. ik wil me partieties alleen in me Computers window hebben staan.. nu staat het daar EN op me bureaublad.. op zich niet zo heel erg al hou ik me bureaublad liever schoon.. is daar ook nog een oplossing voor :D

edit:://
lol al gevonden..

quote:

gconf-editor opstarten
apps-->nautilus-->desktop
vinkje plaatsen bij 'volumes_visible'


dat werd eerder aangeraden.. dat laatste vinkje moet je nu dus weer weghalen en klaar is kees :)

ik vind het wel erg maf dat er vanuit fedora zelf niet ergens duidelijk gezegd word hoe je dit probleem met die partities op moet lossen.. :( en ik heb al behoorlijk wat lopen zoeken :P

markg85 wijzigde deze reactie 04-11-2006 03:09 (37%)

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • markg85
  • Registratie: februari 2003
  • Laatst online: 18-11 16:00
ehm nog een vraagje :)

Is het ook mogelijk om in het Computers window zelf een map toe te voegen? ik wil nu namelijk daar een map bij hebben die in 1x naar /var/www/subdomains gaat aangezien ik dat nogal vaak moet intypen :)

"We all know Linux is great...it does infinite loops in 5 seconds." (Linus Torvalds about the superiority of Linux on the Amterdam Linux Symposium)


  • ajvdvegt
  • Registratie: maart 2000
  • Laatst online: 29-09 21:07
Je kan 'm sowieso bij je 'lokaties' zetten (ofwel door te slepen binnen Nautilus, ofwel door in een open/save dialoog de juiste map te kiezen en op 'toevoegen' te klikken). Dan kan je er ook altijd makkelijk bij.

I don't kill flies, but I like to mess with their minds. I hold them above globes. They freak out and yell "Whooa, I'm *way* too high." -- Bruce Baum

Pagina: 1


Populair:Apple iPhone 6Samsung Galaxy Note 4Apple iPad Air 2FIFA 15Motorola Nexus 6Call of Duty: Advanced WarfareApple WatchWorld of Warcraft: Warlords of Draenor, PC (Windows)Microsoft Xbox One 500GBTablets

© 1998 - 2014 Tweakers.net B.V. Tweakers is onderdeel van De Persgroep en partner van Computable, Autotrack en Carsom.nl Hosting door True

Beste nieuwssite en prijsvergelijker van het jaar 2013